You are here: Tools > All Tools > Find Nearest

Find Nearest

Identify the shortest distance between spatial objects in one file and the objects in a second file.

Applications include finding the closest store locations to consumers in the customer file (both point files); identifying the closest cell towers (point files) to LATAs (polygon files); or selecting congressional districts (polygon files) within 50 miles of a major thoroughfare (line file).

A Universe input connection into this tool is optional (this file can be specified via an input path ), as indicated by the white input connection arrow .

Configuration Properties

The Find Nearest Point tool accepts two spatial inputs.

  1. Select the object to use for the Target input (for example, customers).
  2. Any object type can be chosen for the Target, but if it is a not a point type object, the centroid is used for analysis.

  3. Specify the Universe object. There are two choices:
  4. Specify how many nearest Universe objects to find for each Target.
  5. The Find Nearest tool can return more records than selected in the “How many nearest points to find?” field if there are multiple records in Universe the same distance from the Target object.

  6. Specify the maximum distance and units of measure these objects can be from the Target.
  7. If Drive time is to be calculated, the user can specify the dataset they wish to use to calculate this figure. If only one dataset is installed, you will not have the option to select another dataset.

    You can specify the default dataset from User Settings. Go to Options > User Settings > Edit User Settings and click the Dataset Defaults tab.

  8. Choose whether or not to Ignore 0 Distance Matches. When this box is checked, a point will never match itself.
  9. From the configuration properties, you can rename fields, reorder fields, sort ascending/descending, and select the fields needed from the inputs.
  10. See Options for more information.

TIP: If you are expecting the same number of input records as output records, ensure you do not have any duplicates in your data stream. You may find it necessary to add a Filter or Sort tool to assign a priority to duplicate records, and then link up a Unique tool before attaching the Find Nearest.

Click Apply to have the configurations accepted.

For information regarding Input, Output, Annotation and Error Properties, see Tool Properties.

Related Topics Link IconRelated Topics