You are here: Tools > All Tools > DataRobot Automodel

DataRobot Automodel Tool

Use the DataRobot Automodel tool to upload data to the DataRobot machine learning platform that creates predictive models. DataRobot creates and saves the predictive models which you can apply in Alteryx via the DataRobot Predict Tool.

To use this tool, you must subscribe to DataRobot services, and download the tool from the Alteryx Analytics Gallery.
This tool uses the R tool. To install R and the necessary packages, go to Options > Download Predictive Tools.

Input

Input an Alteryx data stream that includes a target field of interest along with one or more possible predictor fields.

Configuration Properties

  1. In Instance URL, type or paste your DataRobot URL.

    Unless you have a private DataRobot server, your URL is https://app.datarobot.com

  2. Log in to DataRobot using one of these methods:
  3. Click Connect.
  4. After you connect, type a unique name for the project in New Project Name.
  5. (Optional) Select Enable Autopilot Mode to select model settings in Alteryx.
    1. Click Select Target Variable and select a column in the data.

    2. In Number of Workers, type or select the number of workers to use in creating the model.

      The default number of workers is two. The number of workers available is set in DataRobot. If you select more workers than are available to you, the workflow will fail.

    3. (Optional) Select Enable Quick Mode to generate fewer predictive models, faster.

    If you do not select a model generation mode in Alteryx, after you run the workflow go to DataRobot to select model generation settings.

By default, Open DataRobot project in external browser window is selected so you can view or customize the model in DataRobot.

Output

Run the workflow to create the models. This tool does not create an output in Alteryx. To see the models created in DataRobot, copy and paste the output project URL in the Results window into your web browser.