You are here: Tools > Tool Categories > In/Out > Map Input

Map Input Tool

The Map Input tool allows the user to draw or select a desired map object to use as an input in a workflow.  The user can draw or select a point, line, or polygon from a map that is displaying a reference base map (such as TomTom or DigitalGlobe).

You can set a reference base map as a default and even set the default map bounds for the Map Input tool in User Settings. Go to Options > User Settings > Edit User Settings and click the Dataset Defaults tab.

Configuration Properties

  1. There are two options for configuring the Map Input tool: .

  2. Base Map display: Drop-down list to specify which set of reference layers to include within the map image. The list includes all mapfile/layersets currently installed.

  3. You can specify the default dataset from User Settings. Go to Options > User Settings > Edit User Settings and click the Dataset Defaults tab.

  4. Reference yxdb: Use the file browse to specify a yxdb with spatial objects to display on the map. The map will automatically zoom to the extent of this layer. Depending on the mode chosen, the user can select objects from this layer to pass through the tool or draw their own objects.

  5. If a user browses to a file on the Map Input tool which is on a mapped drive, then the file will not be found as it cannot exist in the persistence layer. In this instance, the file cannot be rendered, and only non-mapped files can be used.

  6. Label Field: Drop-down list of fields from the reference yxdb specified above. The user can pick a field to display on the map.