Report Map Tool

The Report Map tool enables the user to create a map image from the Alteryx workflow. The tool accepts multiple spatial inputs, allows for layering these inputs, and supports thematic map creation. Other cartographic features can be included such as a legend, scale and reference layers.

Maps are drawn in Spherical Mercator projection.

TIP: To include a header or footer to your Map, add a Report Text tool directly below the Map tool and configure by selecting the Radio Button: Attach Text to Existing Field and select Map.

Configuration Properties:

The Report Map tool has many configurable options. The interface for the tool is organized into two main sections: Map Preview and Map Configuration

Map Preview:

As layer styles are applied, the preview window will display the map with configured styles. The preview uses sample data before runtime. Simply run the workflow to see actual data and an accurate representation of what the resulting map will look like.

Map Preview Options:

Certain changes such as enabling grouping, applying a thematic, or changing the zoom will require a re-run of the workflow or a refresh of the preview window to see the changes.

Map Configuration:

The Map Configuration Setting is split into 4 tabs:

Settings
Data
Layers
Legend

Settings: The Settings tab includes the general specifications for the resulting map image.

  1. Map Size: Specify the map size in inches, default size is 8 inches wide x 6 inches high. The specified size includes the legend, if a map legend is specified. The rendered Map Size may differ slightly from this Map Size to fit on the outputted report, based on the Render tool specifications.
  2. Map size is limited to 30,000,000 pixels. Any size map that approaches this limit may cause Alteryx to run out of memory.

  3. Resolution: Specify the image resolution. Lower resolution creates a smaller file and is best for viewing on a monitor.  Higher resolution creates a larger file with much better print quality.
  4. Scale: Specify the units of measurement for the scalebar. The scalebar will appear in the lower left corner of the map image. Choices include:
  5. Reference Base Map: Drop down list to specify which set of reference layers to include within the map image. The list includes all mapfile/layersets currently installed.
  6. Note: You can specify the default dataset from User Settings. Go to Options > User Settings > Edit User Settings and click the Dataset Defaults tab.

  7. Background Color: Color picker that controls the background color of the map image. Default is a slight off-white to differentiate the image extent from the page.
  8. Add Drop Shadow: Drop down list to specify if the map gets styled with a drop shadow.
  9. Expand extent 10% w/ a Minimum Width of 0.5 miles. Expand or Contract the zoom level by entering in the number (representing a percentage: i.e. increase zoom level by 10 percent) to expand or contract by.

back to Map Configuration

 

Data: The Data tab includes specifications for handling the streams of data coming into the Map tool. There are 2 panes on this tab. The left side displays the incoming data connection. The right side displays the options for the selected data connection. To configure an incoming data connection,

  1. Click on the connection name to highlight the layer on the left and then edit the properties for that layer on the right. There are two types of connections:

  2. Connections can be managed by using the buttons located above the left side pane:

  3. For each data connection, configure the following options:

back to Map Configuration

Layers: The connections streaming into the Map tool are organized into layers. Layers are located in the left pane. The layers are listed by the Data Connection Name from the Data tab. The layers will draw on the map in the same order as the list. The map objects of the top layer of the list will appear on top of the resulting map.

      1. Click on a Layer name in the list on the left to reveal the following basic display options for the selected layer:

        • Layer Name: Specify the name for the layer to be displayed in the legend. If nothing is specified, the connection string name will be used. The Layer name will appear on the left panel in the layer control list.

        • Data Connection: Refers to the Data connection the layer is coming from. Dropdown list contains the Data Connection Names set on the Data tab.

        • Show in Legend: When checked the layer will be included in the map legend.

        • Zoom Map to Layer: When checked the map will zoom to the extent of the layer to ensure all objects are displayed in the resulting map.

        • Disable: When checked, this layer will not display on the final map.

      2. Click on the + to the left of the layer name to reveal the style parameters. Click on the individual parameters (Style, Label, Theme) to set them. Default styles are set for polygons, lines and points.  The user is able to edit all layer style settings explained in detail below.  

      3. Layer order and appearance can be controlled by using the buttons below:

        • reorders the selected layer up one position for each click.

        • reorders the selected layer down one position for each click.

        • adds a layer from an available connection. This is useful for stacking a duplicate layer on top of itself for styling purposes.

          • Points Layer: Displays available connections and will add a Points layer for the chosen connection.

          • Lines Layer: Displays available connections and will add a Lines layer for the chosen connection.

          • Polygons Layer: Displays available connections and will add a Polygons layer for the chosen connection.

        • deletes the selected layer from the layer control.

        • exposes multiple options to quickly reorder the selected layer. Choices include:

          • Move to Top: Moves the selected layer to the first position of the layer list.

          • Move to Bottom: Moves the selected layer to the last position of the layer list.

          • Move to Top of Group: Moves the selected layer to the first position of its group.

          • Move to Bottom of Group: Moves the selected layer to the last position of its group.

            • Groups are defined as Layer types (Points Lines and Polygons) and whether they are user layers or reference base map layers. The fundamental order of groups is this:

              1. User points

              2. Base layer points

              3. User lines

              4. Base layer lines

              5. User polygons

              6. Base layer polygons

    1. back to Map Configuration

    2. Legend: The Legend tab gives the user many configurable options to customize the legend that will accompany the map image.

back to Map Configuration

  1.  

  2. Layer Styles

    From the Layers tab, the following settings are available for configuration depending on the spatial object type within the selected layer. Base layers can be styled by clicking on the layer name and checking "Override Style." This will reveal a "Style option" below the layer.

    For a list of colors used in Alteryx Maps, see Map Colors.

    Style options will depend on the object type of the layer and are explained in detail below:

    Thematic
    Points
    Lines
    Polygons
    Label

Thematic: The word "Theme" appears nested below a layer name where a Thematic Field was chosen on the Data tab.

      1. Tile Method: Specify which Tile Method to use Smart Tile, Equal Tile Count, Equal Tile size or Unique value. Depending on the Tile method chosen, the following settings are available.

        • Smart Tile: Creates tiles based on the Standard Deviation of the values in the specified field. The tiles assigned indicate whether the record's value falls within the average range (=0), above the average (1) or below the average (-1), etc.

          • Options include: Use Custom Colors, Color specification

        • Equal Ranges: The minimum and maximum values of the tile field are determined. The range is split into equal sized sub-ranges and records are assigned to tiles based on these ranges.

          • Options include: Use Custom Colors, Color specification

        • Equal Records: Input records are sorted by the Thematic field and then divided into the specified amount of tiles so that each tile is assigned the same amount of records. This is based solely on the record's position in the input stream after it is sorted by the Thematic Field.

        • The number of records in the input may not be equally divisible by the number of tiles you specify.

          • Options include: Use Custom Colors, Color specification

        • Unique Value: For every unique value in a specified field or fields, a unique tile is assigned.

          • Options include: Use Custom Colors, Color specification

        • Manual Tile: The user can specify the cutoffs for the tiles by typing the lower value for each range on a separate line.

          • Manual Tiles: entering the values 2, 4, 6, 8 on separate lines creates 5 tiles:

            • Below 2

            • 2 to 4

            • 4 to 6

            • 6 to 8

            • Above 8

      2. Click on the Theme under the layer associated on the left panel to revel each theme band.

      3. Each Theme band can be edited individually.

      4. Expanding a theme band reveals the following Style options specific to the layer type.

Thematic styles will override object styles, so there is no need to specify an object style if there is a map theme on a layer. The user may, however, choose to label the map layer you are theming on.

back to Layers

    1. Points:  The points tab allows the user to edit styles for the points that are contained within a layer.  All points, unless a custom point is specified, are in the shape of the diamond.

      • Point Style: Specify the point style to use by selecting it from the drop down list. Choices include:

 

      • Custom Point: Specify if a custom point should be used by checking the box and browsing to the image (.png,.jpg and.gifs).  The image will be stored in the workflow.

      • Size: Specify the size of the point in pixels.  The default is 10.

      • Color:  Specify the color of the point. The default Blue.

      • Outline Color: Specify the outline color of the point. The default is none.

      • Outline Size: Specify the outline size of the point in pixels. The default is 1 pixel .

      • Opacity: Specify the opacity percentage for the point.  The default is 100%

      The user is also able to Reset the Defaults by clicking on the link in the upper right corner of each tab.

      back to Layers

Lines: The lines tab allows the user to edit the styles for the lines that are contained within a layer.

back to Layers

Polygons:  The polygons tab allows the user to edit styles for the polygons contained within a layer.

back to Layers

Label:  The label tab allows the user to edit styles for labels when a Label Field is chosen on the general tab.

  back to Layers

Because this tool includes an expression editor, an additional input anchor displays when the tool is used in an app or macro workflow. Use the Interface tools to connect to a Question anchor. See Interface Tools.