Main Menus

Version:
2021.3
Last modified: August 11, 2021

Access various windows and common actions from the main menu in Alteryx Designer.

Image showing the main menu in Alteryx Designer, including the File, Edit, View, Options, Help, and Localization menus.

 

File Menu

These options are specific to creating and working with workflows.

  • New Workflow (Ctrl+N): Creates a new workflow (*.yxmd).
  • Open Recent: Shows the most recently accessed and saved workflows.
  • Open Workflow: Opens a previously created workflow.
    • Browse: Open a workflow by browsing to the file location where the workflow was saved.
    • Private Gallery: Open a workflow from your company's Private Gallery. If you have connected to your company's private gallery, the connection is listed by the connection name.
    • Alteryx Gallery: Open a workflow from the Alteryx Public Gallery (gallery.alteryx.com). This option is pre-configured to connect to the Alteryx Public Gallery (gallery.alteryx.com), also known as the Alteryx Analytics Gallery. Credentials are required to sign in to the Gallery.
    • Add New Gallery: Provides the ability to create a connection to a private Gallery.
    • Open AutoRecovered Files: Opens a list of auto-saved files. Open files are automatically saved at regular intervals. The auto-save interval is enabled by default and can be modified in User Settings.
  • Open Workflow Group: Opens multiple workflows that have been saved into a workflow group. Visit Open a workflow group from a file directory for more details.
  • Save (Ctrl+S): Saves the active workflow.
  • Save As: Saves the active workflow to the selected location.
    • Browse: Browses to a file location and saves the workflow there.
    • Private Gallery
      • Existing connections to a Private Gallery are listed here.
      • Add New Gallery: Provides the ability to create a connection to a private Gallery and saves the workflow there.
    • Public Gallery (Alteryx Gallery): Saves the workflow to the Alteryx Public Gallery (gallery.alteryx.com). This option is pre-configured to connect to the Alteryx Public Gallery (gallery.alteryx.com), also known as the Alteryx Analytics Gallery. Credentials are required to sign in to the Gallery.
  • Create Workflow Group: Saves all open workflows, which previously were saved as individual workflows, as a workflow group. Visit Save workflow groups for more details.
  • Print: Offers a preview of what the workflow will look like when printed.
  • Print Settings: Offers settings for printing a workflow.
  • Exit: Closes Designer.

Edit Menu

These options are common editing functions.

  • Undo (Ctrl+Z): Automatically undoes the last action. Actions are recorded historically, so you can undo up to 32 actions.
  • Redo (Ctrl+Y): Redoes an action that you just undid.
  • Cut (Ctrl+X): Deletes an object and copies it to the clipboard for immediate pasting.
  • Copy (Ctrl+C): Copies an object to the clipboard.
  • Paste (Ctrl+V): Pastes a copied object.
  • Delete (Del): Deletes the selected object.
  • Find (Ctrl+F): Opens the Find tab of the Find and Replace window. Use the Find and Replace window to search for, find, and replace text within your workflow. Visit the Find and Replace documentation to learn more about this feature.
  • Replace (Ctrl+H): Opens the Replace tab of the Find and Replace window. Use the Find and Replace window to search for, find, and replace text within your workflow. Visit the Find and Replace documentation to learn more about this feature.

View Menu

Open or close these windows via the View menu:

  • Tool Palette (Ctrl+Alt+T): Displays the tool palette underneath the menu. Visit User Interface for more information about the Designer user interface.
  • Overview (Ctrl+Alt+V): Displays the Overview window docked in its last visible position.
  • Results (Ctrl+Alt+R): Displays the Results window docked in its last visible position.
  • Configuration (Ctrl+Alt+C): Displays the Configuration window docked in its last visible position.
  • Interface Designer (Ctrl+Alt+D): Displays the Interface Designer window docked in its last visible position. Visit Interface Designer and Interface Designer Window for more information.

Options Menu

These options provide access to workflow, scheduling, license functionality, as well as user settings.

  • Run Workflow: Runs the workflow. The Ctrl+R keyboard shortcut also runs the workflow. The icon changes to Stop Workflow while the workflow is running.
  • Schedule Workflow: Allows the user to schedule workflows to run at specific times and frequency. The Scheduler Service must be enabled as part of the Alteryx installation and the user must be licensed appropriately. The license should be installed by an Administrator to ensure all users are properly licensed and the service is properly configured. Visit Schedule Workflows for more information.
  • View Schedules: Allows the user to schedule workflows and applications, see the jobs in queue, and view information about completed jobs. The Scheduler Service must be enabled as part of the Alteryx installation and the user must be licensed appropriately. The license should be installed by an Administrator to ensure all users are properly licensed and the service is properly configured. Visit Manage Schedules for more information.
  • Run Analytic Apps: Opens the Choose Analytic App window that allows you to browse for apps and edit or run them. Visit Choose Analytic App for additional details.
  • Export Workflow: Opens the Export Workflow window which allows the user to take the active workflow and zip it up with all of its dependencies into a *.yxzp file. Visit Workflow Management for additional details.
  • Manage Licenses: Allows the user to view, add, and delete their Alteryx licenses via the License Manager.
  • Manage Connect Credentials: Opens the Connect Sign In window that allows you to access Connect. Visit Use Connect Assets for additional details.
  • Add Promote Connection: Opens the Promote Connection window that allows you to add connections to the Promote platform. To view all connections or delete a connection, access the Deploy tool or Score tool.
  • User Settings: Offers the ability to configure a workflow's appearance and to specify system resource usage to optimize the project's performance specific to the user. Visit User Settings for more information.
    • Edit User Settings: Visit User Settings for additional details.
    • Save Layout & Settings on Exit: Saves the GUI layout and user-specified settings upon exiting the program.
    • Save Layout & Settings Now: Saves the GUI layout and user-specified settings upon selecting this option.
    • Restore Defaults: Returns the GUI layout to its original orientation.
  • Advanced Options
    • Compare Workflows: Compare 2 workflows and quickly identify the differences via visual indicators. Visit Compare Workflows for instructions and additional information.
    • Lock Workflow: Saves a copy of a workflow so that it can be run, but cannot be opened and edited in Alteryx Designer. Visit Lock Your Workflow for instructions and additional information.
    • Manage Data Connections: Create and manage your data connections from a central location. View connections you created and connections shared with you, as well as add new connections. Visit Manage Data Connections for more information.
    • Manage In-DB Connections: Create and manage your in-database connections from a central location. View existing in-database connections and add new in-database connections. Visit Manage In-DB Connections for additional details.
    • Show HTML Developer Tools: Automatically opens the Alteryx HTML Developer Tools window when you select a tool or window that uses the Chromium Embedded Framework.
    • System Settings: Offers the ability to specify system resource usage to optimize the application's performance. System Settings require Administrator privileges to change. Visit System Settings for more information.
    • Workflow Dependencies: Controls the input and output paths associated with the workflow as well as specific datasets. Visit Workflow Dependencies for more information.
  • Download Predictive Tools: The predictive tools use the R programming language. Go to Options > Download Predictive Tools and sign in to the Alteryx Downloads and Licenses portal to install R and the packages used by the R tool.

Help Menu

These options provide quick access to help with Alteryx Designer.

  • Alteryx Help: Opens Designer Help. You can also access help via the F1 keyboard shortcut.
  • Tutorials: Opens tutorial workflows that provide an introduction to building workflows in Designer.
  • Sample Workflows: Opens the sample workflows that are available in Designer, including external installations such as Starter Kits. Visit Sample Workflows for more information.
  • Sample Datasets: Opens the sample datasets that are available in Designer.
  • Community: Links to the Alteryx Community site where you can find access to our user forums, support questions, workflow exchange, FAQs, and more.
  • What's New: Opens the What's New Help page for the current release version of Designer. This page highlights the new features and enhancements since the last official release. Visit What's New to see the latest features and enhancements.
  • Check for Updates: Designer checks to see if there is a newer version available than the current version. This feature requires an internet connection. Visit Version Updates for more information.
  • Generate Support File: Generate a tech support file that contains information that helps our team properly troubleshoot your issue. The file includes Runtime Settings and your Serial Number (email address). You can upload this file when you submit your support case. Make sure to review the file contents and remove anything you might not want to include.
  • Alteryx Downloads: Opens the Alteryx Downloads and Licenses portal where you can download the latest version of the software.
  • About: Open a dialog box with the Designer version information and the unique serial number for the license.
  • Privacy Policy: Access the Privacy Policy.
  • End User License Agreement: Access the End User License Agreement.

Localization Menu (Globe Icon)

Select the language version for Designer. Your options include...

  • English
  • 简体中文 (Simplified Chinese)
  • Français (French)
  • Deutsch (German)
  • Italiano (Italian)
  • 日本語 (Japanese)
  • Português (Portuguese)
  • Español (Spanish).

The Localization menu also provides quick access to the Localization User Settings.

Toolbar

The toolbar, located above the main menu, provides access to these actions:

Image showing the Designer toolbar with icons for open workflow, save, cut, copy, paste, undo, and redo.
  • Open Workflow (Ctrl+O): Browse to the file location to open a previously created workflow.
  • Save (Ctrl+S): Saves the active workflow.
  • Cut (Ctrl+X): Deletes an object and copies it to the clipboard for immediate pasting.
  • Copy (Ctrl+C): Copies an object to the clipboard.
  • Paste (Ctrl+V): Pastes a copied object.
  • Undo (Ctrl+Z): Automatically deletes the last action. Actions are recorded historically, so you can undo up to 32 actions.
  • Redo (Ctrl+Y): Repeats the action that you just undid.
Was This Page Helpful?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.