What's New in Designer

Version:
2021.3
Last modified: September 28, 2021

2021.3

Version: 2021.3.1.47945

Release Date: August 11, 2021

Compare Workflows

Use the Compare Workflows feature to compare 2 workflows and quickly identify the differences via visual indicators. You can access this feature via Options > Advanced Options in Alteryx Designer.

Recommended Tools

The new Recommended tab in the Designer tool palette suggests tools that you can use while you build out your workflow. Select a tool on your canvas and the Recommended tab displays 6 common downstream tools that typically follow the selected tool.

New Intelligence Suite Tools

The Alteryx Intelligence Suite now includes 2 new Computer Vision tools. The Image Profile tool allows you to extract helpful information from images, and the Image Recognition tool lets you train a machine learning model to classify images.

Tool Container Enhancements

We made some updates to the Tool Container tool. Now, when you disable a Tool Container, the disabled container remains expanded on the canvas and appears dimmed to indicate the disabled state. You can collapse a disabled container to hide its contents. Select the expand/collapse icon within the tool container to do so.

Performance Profiling with AMP Engine

To optimize your workflow when building workflows with AMP, you can now analyze the performance of specific tools with Performance Profiling with AMP. You can turn on profiling with the Enable Performance Profiling checkbox in the Workflow Configuration Runtime settings. For more information, visit the Performance Profiling with AMP Engine help page.

Microsoft Power BI

We made updates to the Microsoft Power BI connector:

  • Built-in multitenant Azure App with an option to use a custom Azure App.
  • Supports multiple table inputs.
  • Keeps existing dataset and its structure with updating and overwriting data.
  • Users can select which workspace to work with.
  • Proxy support.

Generate Support File

Generate a tech support file that contains information that helps our Customer Support Engineers properly troubleshoot your issue. You can upload this file when you submit your support case. Make sure to review the file contents and remove anything you might not want to include.

End User License Agreement and Privacy Policy

The Alteryx End User License Agreement (EULA) and Alteryx Privacy Policy are now accessible via the Help menu in Designer.

2021.2

Version: 2021.2.1.35394

Release Date: May 17, 2021

New Intelligence Suite Tools

The Alteryx Intelligence Suite now has Computer Vision tools. Use them to input, process, analyze, and then output images using Designer.

R Upgrade

We upgraded R to 4.0.4 from 3.6.3. The R 4.0 release features improvements in R's memory management, which means R can now work with more data without memory issues. Moving to the newer version allows our users who make use of custom R code in Alteryx to continue to be able to download binary installers of R packages from CRAN.

Separate Installer for Alteryx Intelligence Suite

Intelligence Suite is now installed separately from Designer. This improves the Designer install time while allowing users to quickly install Intelligence Suite.

Updated Trial Experience

We have updated the trial experience for new and current customers. Now, individuals can independently activate an Alteryx Intelligence Suite trial from the Alteryx Designer trial. Users that want to test Alteryx Intelligence Suite now have the ability to trial this functionality even if they already have a base Designer license.

Data Cleansing via the Results Grid

You can now perform data cleansing actions directly in the Results grid and apply these actions to your workflow via a preconfigured Data Cleanse tool. We also made some user interface updates to the Results grid to better organize the Data Cleanse, Filter, and Sort options.

Convert to Macro

You now have the option to convert an existing workflow (or a portion of the workflow) to a macro. Select at least one tool, right-click, and select Convert to Macro from the dropdown menu. Visit Convert to Macro to read about important limitations and additional instructions.

Global UID

Workflows (.yxmd, .yxmc, and .yxwz files) now track unique IDs in the XML. This includes the original workflow ID and the previous workflow ID. For example:

<WorkflowId value="f8e90084-fca0-4c5d-9c0e-5fe614d78df1" />
<Telemetry>
<PreviousWorkflowId value="" />
<OriginWorkflowId value="f8e90084-fca0-4c5d-9c0e-5fe614d78df1" />
</Telemetry>

Engine Asynchronous Logging

Local engine logs can now be written asynchronously for the original Engine. This improves performance, especially for administrators writing logs to a shared network file path.

Specify a Predictive Tools Code Page per Workflow

We’ve added Predictive Code Page settings to Workflow Configuration so that the predictive code page information gets saved within the workflow. This will avoid having workflows use different predictive code page settings based on the user's selected language.

Phonetic Sort Support for Kanji Characters

We’ve introduced more sorting methods available in the various areas of Designer that allow users to sort such as the Sort tool, IRG sorting behavior, Select tool, or any tool that has an embedded Select and Tile tool. These sorting methods include Pinyin, Gojūon, and Dictionary Order for all of our supported languages.

You can customize this setting via the Localization User Settings.

Updated Embedded Fonts in Predictive Macros

We’ve updated the hardcoded fonts that were embedded in Predictive macros. As a result, customers will avoid running into garbled results in their PDF reports. The font used supports the chosen language text of the user.

Topic Model Output

We've added an additional M output anchor to the Topic Modeling tool, which allows users to save models they can later use to make predictions about new data.

Google BigQuery Output Tool Updates

We updated the Google BigQuery Output tool to utilize bulk file write instead of streaming records to BigQuery. The tool now loads JSON files from the local machine into BigQuery. Please see the release notes in Gallery provided for these tools for additional update information.

Salesforce Input Tool Maintenance

We remedied defects in the Salesforce Input tool. Please see the release notes in Gallery provided for this tool for update information.

Update SafeMode Error Message Text to Restricted

When attempting to run a workflow (in Server, Gallery, or AAH) that contains restricted tools when the Safe or Semi-Safe mode is set, users will now get different error messages returned. For example, "Restricted Environment Error: The R tool is prohibited based on current run mode settings."

Deadlock Prevention Part 2: Limit Connections for Join Multiple, Action Order for Summarize, and Increase the Number of Threads if Memory Is Increased

In the case where a workflow contained multiple of these tools (Join, Join Multiple, Summarize, Tile, and FuzzyMatch), and the memory limit was too small, there was a high chance that the engine went to a memory deadlock. Now, this issue is resolved.

One Tool Example Updates

We converted several workflows into One Tool Examples. You can now find these under Help > Sample Workflows > Learn one tool at a time > Predictive. These were previously found under Help > Sample Workflows > Predictive Samples.

2021.1

Version: 2021.1.2.20534

Release Date: February 10, 2021

Licensing Update for Versions 11.7 and Older

You can’t upgrade directly from version 11.7 or older to version 2021.1. If you are using Designer version 11.7 or previous and want to upgrade to 2021.1, you have to first upgrade to version 2020.4 or previous. Then you can upgrade to 2021.1.

New Intelligence Suite Tools

The Alteryx Intelligence Suite has 4 new tools that help you assess the health of your data, set feature types, build features from multiple data streams, and automatically create machine learning models. The tools are AutoML, Build Features, Data Health, and Feature Types. You can find them in the Machine Learning category in Designer.

Text Pre-processing Tool Update

The Text Pre-processing tool now has a second input anchor that allows you to pass in lists of stop words.

Use AMP Engine for All New Workflows

You can now enable a user setting to use the AMP Engine for all new workflows that you create.

Designer Keyboard Navigation Upgrades

You can now navigate the tool palette with the keyboard and use the Enter key to place a tool on the canvas. You can also double-click a tool on the tool palette to add it to the canvas. Visit Shortcuts in Alteryx Designer to read more about this feature.

Find and Replace Update

We made several updates to the user interface of the Find and Replace window.

HTML Developer Tools

Users can now access developer tools via Options > Advanced Options > Show HTML Developer Tools.

Download Tool Update

The Download tool now has a Throttle Records checkbox. Use this to indicate the number of records that you want to pass through the tool per minute.

Analytic Applications Support in AMP

The running of Analytic Applications is already well utilized with the original engine. Now there is support for Analytic Applications with AMP.

Build Custom Formula Functions on AMP Using XML

As a Designer user working with AMP, you can use Custom Formula Functions. Now you are able to create specific functions with XML files and use them in workflows with AMP.

Prevent Deadlocks for Grouping and Blocking Tools with AMP

When you build and run workflows that contain grouping and blocking tools (Join, Join Multiple, Tile, Fuzzy Match, Sorting, etc.) with a low memory limit set, you won’t experience the hang issue on the Join tool anymore.

Improved Error Messaging when Connecting to Alteryx Analytics Hub

If you encounter an error when you connect Designer to Alteryx Analytics Hub, improved messaging lets you know what action you need to take to resolve the error.

New Localization User Setting

You can now customize the date format that displays in the Messages tab of the Results window.

New One Tool Examples

New One Tool Examples are available for tools in the Predictive, Time Series, AB Analysis, Data Investigation, and Machine Learning tool categories.

New One Model Example

A new One Model Example is available for Text Mining tools.

Updated Version of Hyper API

We updated the version of Hyper API used to V0.0.11889. Users can see increased performance when reading and writing Hyper files.

Snowflake Internal Stage Bulkloader Upgrade

We added options to Snowflake Bulk Loader (Local Staging). This allows users to select how to chunk and compress files for bulk loading and can increase performance.

2020.4

Version: 2020.4.5.12471

Release Date: November 18, 2020

To address security vulnerabilities in Python version 3.6, embedded Python has been upgraded from 3.6.8 in the 20.3 release to 3.8.5 in the 20.4 release. Custom tools and connectors (YXI files) developed by Alteryx, partners, or any 3rd party that don't ship with the Alteryx installer might need to be reinstalled. This impacts custom tools installed on Designer, Server, and Alteryx Analytics Hub.

Installation Experience Update

The current installation experience is now quicker due to the use of a new methodology. If you install this version and then decide to go back to a prior version (for example, you install version 2020.4 and then decide to go back to version 2020.3), you must uninstall this version through your operating system (OS) and then install the older version.

Select Alteryx Analytics Hub Upload Location in Designer

When you upload to AAH from Designer, you can now save to a location other than your personal folder. To do so from Alteryx Designer, select Save As > Analytics Hub and choose your AAH instance. Use the Select button next to the Location field and choose where you want to save your workflow. Note that only folders that you have permission to write to are available to select.

Designer Updates

We made several updates to Alteryx Designer to improve performance and usability:

  • You can now select and copy the Alteryx Designer version text (first 3 lines) from the version pop-up window accessed via Help > About.
  • The Select tool now auto-sizes the Field column to fit the field names without cutting off any text (up to 40 characters).
  • We made a performance improvement to the Data Cleanse tool. We now allow quotes in the field name.
  • We no longer store the tool, container, and comment position and width/height as floating-point values, but rather as integers.

Results Window Toolbar Updates

We made a couple of updates to the Results window toolbar.

  • The Apply and Cancel Data Manipulations icons were moved to the middle of the toolbar.
  • The export, copy, and new window options were consolidated under a single Actions menu item.

Sample Datasets

Sample Datasets are now accessible directly via the Designer Help menu. Go to Help > Sample Datasets.

Learn More about AMP Engine

When the workflow type is Macro, the Runtime tab is now available via the Workflow Configuration window. The Runtime tab gives you access to the Use AMP Engine setting so you can build macros with AMP. Additionally, we added inline links to AMP help content in the Runtime tab as well as the Workflow Complete dialog.

Adobe Analytics Authentication Update

When you use the Adobe Analytics tool, you can now authenticate with Adobe.io credentials for user authentication and JWT for service account authentication.

Sort/Join Memory and Threads Improvements

To efficiently utilize the maximum amount of memory when you run your workflows with AMP, you can now set the Memory Limit and Default Number of Processing Threads. Navigate to the Engine - General tab in System Settings, the Defatuls tab in User Settings, or the Runtime tab in Workflow Configuration.

Complete Formula Function Support in AMP

All built-in Formula functions available in the Formula, MultiRowFormula, and MultiFieldFormula tools in Designer are now supported with AMP.

Additional AMP Tools

With AMP, you can now run the Summarize and Download tools with full functionality.

  • The Download tool now supports all code pages listed in Designer GUI.
  • The Summarize tool supports these additional actions: Spatial Combine, Spatial Create Intersection.

CSV Reading and Writing with Code Pages in AMP

When using CSV file types in the Input and Output Data tools with AMP, you can now rely on additional code page support without fallback to the Original Engine.

Strings Transcoding for AMP

You are now able to transcode strings from different code pages. Visit Code Pages for a list of supported encodings/code pages.

International Numeric Display Support

There are 2 new settings that you can customize to change how numbers display in Designer: Thousand Separator and Decimal Symbol. These settings affect how numbers display on the Designer canvas, the Results window, and the Browse tool Data Profiling. The default settings depend on the language that you select for the Designer interface, but you can always update the defaults.

Visit Localization User Settings for details.

International Numeric Separator Support

The ToNumber and ToString Conversion functions were updated to support conversion to and from a wide range of numeric formats (including international formats). Visit Conversion functions for details.

2020.3

Version: 2020.3.4.30228

Release Date: September 1, 2020

Find and Replace Window

You can now replace text in Designer via the Find and Replace window. Access this feature in the Designer main menu via Edit > Find or via the Ctrl + F keyboard shortcut. Visit Find and Replace for more information.

Localization and International DateTime Support

  • International DateTime support was added to the Report Header and Date Time Now tools, as well as the DateTimeParse and DateTimeFormat functions.
  • Calendar display mirrors Alteryx Designer language instead of OS language.
  • Korean Code Page 949 was added to the Input Data tool.

Tool Conversions

The Dynamic Replace tool was converted to AMP. With AMP, you can now use these built-in macro tools: Select Records, Count Records, Weighted Average, Date Time Now, Random % Sample, and Create Samples. Additionally, the 17 Interface tools used in Analytic Apps have been converted to AMP.

We now have 74 fully converted and 14 partially converted tools for you to use with AMP. For more information about tools that have been converted from the original engine to AMP, visit Tool Use with AMP.

Text Mining

  • The Word Cloud tool has the option to Generate Phrases. If you select that option, the tool treats two-word phrases as single phrases.
  • The Image to Text tool can parse PDFs that contain multiple languages.
  • The Image Template tool has an extended markup field to accommodate more info.

Assisted Modeling

The Assisted Modeling tool has a new step. You can select whether you want the tool to walk you through each step in the modeling process or to build the model automatically.

Browse Tool Data Profiling

Several updates and improvements were made to the Browse tool data profiling:

  • Data Profiling in the Browse tool is now capped at 300 MB. This allows you to process very large datasets faster. For each record in the incoming dataset, we process the record and add the record size to a counter. Once the counter reaches 300MB, we stop processing records. It is important to note that there is no specific number of records we can process. The limit depends on the dataset since a record size can range from 1 byte to a few thousand bytes. This record size is different from the file size, displayed in the Results grid and Data Profiling Holistic View. The file size is generally different since it has been compressed to optimize spacing. In other words, 300 MB of record size is not the same as 300 MB of file size.
  • We added a Distincts count for Float and Double data types.
  • We updated the data type icons for all data types in Holistic Data Profiling.
  • We now show a sample icon when a field in the dataset shows only a sample of the full dataset.
  • You can now filter the Data Profiling Holistic view based on Fields (columns) and Data Types.

Email Events

You can now specify a port number for Email Events. The port number can still be added to the SMTP URL if needed.

Insight Tool

We fixed an issue that prevented users from creating filters in the Insights tool. Previously, the filter panel collapsed before a filter could be edited. This issue has been addressed.

Local Staging for Snowflake Bulk Loader

Previously, the Snowflake bulk loader only supported staging through an Amazon S3 bucket. You can now utilize Local Staging to stage data locally before it is copied to Snowflake. For more information, please visit Snowflake Help.

PostgreSQL Bulk Loader

The PostgreSQL Bulk Loading functionality stages the data locally and performs a bulk copy operation for more performant writing to the database.

Teradata Upgrade to 16.20

Teradata driver version 16.20 is now supported.

XLSX on Linux: Read and XLSX on Linux: Write

Users can now expect that XLSX files used in Input and Output tools will run with the AMP Engine when Use AMP Engine is selected.

One Tool Example for Insights Tool

A new One Tool Example (OTE) for the Insights tool is now available in Designer.

One Model Examples in Designer

One Model Examples, which feature tools from the Alteryx Intelligence Suite, are now built into Designer. Select Help > Sample Workflows > Learn One Model at a Time.

2020.2

Version: 2020.2.2.27029

Release Date: June 3, 2020

Alteryx Intelligence Suite

The Alteryx Intelligence Suite is now available as a Designer add-on. Alteryx Intelligence Suite offers Machine Learning and Natural Language Processing (NLP) capabilities on top of the great features that are already available with your Designer license. Visit Alteryx Intelligence Suite to learn more.

Alteryx Multi-threaded Processing (AMP)

Alteryx Multi-threaded Processing (AMP) is a new architecture of Alteryx Engine, designed to work with larger volumes of data at higher velocity. To learn more about the AMP Engine as well as differences between the original engine and AMP, visit these resources:

To run workflows with the AMP engine, navigate to the Workflow Configuration pane in Designer and select the Runtime tab. Then check the Use AMP Engine box to enable Alteryx Multi-threaded Processing.

AMP Engine supports Standard, Iterative, and Batch Macros. In addition, 50 tools have been converted to run with AMP.

Smarter Data Profiling

Several updates and improvements were made to the Browse tool data profiling:

  • The holistic view now shows the top values for each column of data. Use the toggle to switch between the top values view and the data profiling charts.
  • For columns that contain only one distinct value across all rows, the Only one value message displays.
  • For columns where each value is unique, the All values are unique message displays.
  • You can now see value ranges at a glance in the holistic view for numerical and data-time columns.
  • You can now see a list of up to 1,000 distinct top values via the more > link in the top values view.

Additional Enhancements

  • Two new functions were added to the Data Cleansing tool: Remove Null Rows and Remove Null Columns.
  • It's back! Due to popular demand, the OpenSaveCutCopyPasteUndo, and Redo functions were added to the Designer toolbar.
  • We made some updates to ensure a seamless, smooth experience when using Designer in a non-EN language.
    • In-product help directs to content in the selected language.
    • Search links to results in localized Community pages. Currently, this is supported for FR, DE, JP, ES, and PT languages.
    • Canvas annotation font defaults to a supported language font when you switch to a different language.
  • We added international support to the DateTime tool. Designer now supports dates and times in multiple languages and locale formats.
  • The Text Input tool cell import limit was increased to 10,000. 
  • We made a few enhancements to the Formula tool:
    • You can now delete formulas when they are collapsed in the Configuration window.
    • When you double-click a column name inside of an expression, the brackets around the column name are also selected.
    • Hover tooltips for functions were updated to improve accuracy and consistency.
  • New One Model Examples are available in all supported languages. Download these via the Licensing Portal. Select Alteryx Designer > Alteryx Machine Learning Toolkit and select a download option.
  • R was upgraded to 3.6.3 from 3.5.3., discontinuing support for Microsoft R Client and Microsoft Machine Learning Server.
  • CEF and Chromium were upgraded:
    • CEF was upgraded to 3.3396.1786.gd3e36d0 from 3.3202.1694.gf061c23.
    • Chromium was upgraded to 67.0.3396.79 from 62.0.3202.9400.

2020.1

Version: 2020.1.1.23790

Release Date: March 5, 2020

Publish to Public Gallery

  • Gallery Artisans can now see an additional confirmation dialog when they select Sharing > Place in Public Gallery. This reminds users content is being publicly shared in the Public Gallery.
  • Additionally, when users select Save As in Designer, they will now see explicit options for Private Gallery and Public Gallery.

Localization Updates

  • Simplified Chinese is now available in Designer, making it the 8th supported language.
  • You can now toggle to any one of our 8 supported languages within Designer. Access all supported languages and Localization Settings via the globe icon next to Help in the main menu.
  • You can now sort your tool palette to follow English Alphabetical order, even if you're using a non-EN user interface. Access this new feature via globe icon > Localization Settings > Tool Palette Order. We do not yet support the sorting of Kanji characters.

Excel Enhancements

Several enhancements related to Excel file input are now available:

  • When you select a .xlsx or .xlsm Excel file in the Input Data and the Output Data tools, you can now select a range for cells, rows, or columns.
  • The Excel Input screen now has a Refresh button. If you can't input an Excel sheet because the file is open in Excel, you can now close the file and select Refresh from the Excel Input screen without closing and reopening the screen.
  • The List of Sheet Names option in the Input Data tool for .xlsx files now returns the sheet names in the order they appear in Excel.
  • You can now Preserve Formatting on Overwrite when overwriting a sheet or range via the Output Data tool Options. In order to preserve formatting, you have to:
    • Select Overwrite Sheet or Range via Output Options.
    • Specify cell ranges in the output file path.

Smarter Data Profiling

Holistic profiling allows you to view profiling for multiple columns at once in a single view in the Browse tool.

Additional Enhancements

  • The following keyboard shortcuts are now available in Designer:
    • Select the Tool Palette: Ctrl + Shift + T
    • Select the Overview panel: Ctrl + Shift + V
    • Select the Results panel: Ctrl + Shift + G (results grid)
    • Select the Configuration panel: Ctrl + Shift + C
    • Select the Canvas: Ctrl + Shift + W
    • Select the Interface Designer Window: Ctrl + Shift + D
  • New one tool examples are available in In/Out, Preparation, Transform, Interface, Calgary, and Developer tool categories.
    • In/Out: Date Time Now
    • Preparation: Create Samples, Oversample Field
    • Transform: Arrange, Weighted Average
    • Interface: Control Parameter, Folder Browse, Macro Input, Macro Output
    • Calgary: Calgary Input, Calgary Join, Calgary Cross Count, Calgary Cross Count Append, Calgary Loader
    • Developer: API Output, Detour, Detour End, Python, Run Command
  • When you select a single tool on your canvas, the F2 key on your keyboard now opens the tool's Annotation configuration window with the cursor placed in the Annotation text field.
  • The font size of container names is no longer oversized when printing a workflow.
  • Macro Input questions are no longer deleted from the XML when they are cached.
  • Comments inside tool containers no longer hide tools.
  • The join order (Input_#1, Input_#2, etc.) in the Join Multiple tool is now maintained after saving.
  • You can now resize column widths in the tool configuration window. This is particularly helpful when working with long field names in the Join, Append Fields, and Join Multiple tools that previously required you to expand the configuration panel in order to see all columns.
  • You can now change the color of the input string number so that it is visible when opting into a darkened canvas in Designer. Go to User Settings > Canvas > Connection Settings > Text Color.
  • You can now open multiple copies of the same workflow again by selecting Allow multiple tabs of the same file to be open in User Settings or by selecting the Shift key while opening a file to open more than one of them.

2019.4

Version: 2019.4.4.20206

Release Date: December 9, 2019

  • The Input Data tool now supports reading Tableau Hyper Data Extract (.hyper) files.
  • The Multi-Field Formula tool field selection pane is now re-sizable and can accommodate a large number of fields.
  • You can now insert and delete a header from the drop-down menu in the Text Input tool, making copying and pasting easier.
  • You can now select all left or right fields in a Join Tool via the context menu.
  • The Find tool allows you to search by the Tool ID.
  • There are now more options for copying and pasting a tool in a workflow.
  • Multi Resolution Raster (MRR) created by Pitney Bowes is the new reader for read file only, supporting a single raster band from a file, with each pixel in the raster band containing a value.
  • You can now turn location data into business outcomes with high-quality, detailed base maps from Mapbox. Mapbox macros are now available in the Alteryx Gallery.
  • You can now use your dataset to calculate/aggregate (aggregate within the tool) the sum, count, average, minimum, and maximum of your selected value(s) chosen.
Was This Page Helpful?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.