Main Menus

Version:
2022.1
Last modified: May 04, 2022

Access various windows and common actions from the main menu in Alteryx Designer.

Image showing the Alteryx Designer main menus.

File Menu

These options are specific to creating and working with workflows.

  • New Workflow (Ctrl+N): Create a new workflow (*.yxmd).
  • Open Recent: Show the most recently accessed and saved workflows.
  • Open Workflow: Open a previously created workflow.
    • Browse: Open a workflow by browsing to the file location where the workflow was saved.
    • My Company's Server: Open a workflow from your company's Server (Private Gallery.) If you have connected to your company's Server, the connection is listed by the connection name.
    • Add New Server: Create a connection to your company's Server.
    • Alteryx Platform: Open a workflow saved to your Alteryx Platform. If you have connected to the Alteryx Platform, the connection is listed by the connection name. If you have not connected to the Alteryx Platform, go to Options > Manage Alteryx Links and add a new Platform link.
    • Open AutoRecovered Files: Open a list of auto-saved files. Open files are automatically saved at regular intervals. The auto-save interval is enabled by default and can be modified in User Settings.
  • Open Workflow Group: Open multiple workflows that have been saved into a workflow group. Go to Open a workflow group from a file directory for more details.
  • Manage Connections: When Data Connection Manager (DCM) is enabled, go here to control the Data Sources and the Credentials to authenticate to the Data Sources. 
  • Save (Ctrl+S): Save the active workflow.
  • Save As: Save the active workflow to the selected location.
    • Browse: Browse to a file location and save the workflow there.
    • Alteryx Server
      • Existing connections to your company's Server are listed here.
      • Add New Server: Create a connection to your company's Server and save the workflow there.
    • Alteryx Platform: Save the workflow to Alteryx Platform.  If you have connected to the Alteryx Platform, the connection is listed by the connection name. If you have not connected to the Alteryx Platform, go to Options > Manage Alteryx Links and add a new Platform link.
  • Create Workflow Group: Save all open workflows, which previously were saved as individual workflows, as a workflow group. Go to Save workflow groups for more details.
  • Print: Offers a preview of what the workflow will look like when printed.
  • Print Settings: Open settings for printing a workflow.
  • Exit: Close Designer.

Edit Menu

These options are common editing functions.

  • Undo (Ctrl+Z): Automatically undo the last action. Actions are recorded historically, so you can undo up to 32 actions.
  • Redo (Ctrl+Y): Redo an action that you just undid.
  • Cut (Ctrl+X): Delete an object and copies it to the clipboard for immediate pasting.
  • Copy (Ctrl+C): Copy an object to the clipboard.
  • Paste (Ctrl+V): Paste a copied object.
  • Delete (Del): Delete the selected object.
  • Find (Ctrl+F): Open the Find tab of the Find and Replace window. Use the Find and Replace window to search for, find, and replace text within your workflow. Go to Find and Replace documentation to learn more about this feature.
  • Replace (Ctrl+H): Open the Replace tab of the Find and Replace window. Use the Find and Replace window to search for, find, and replace text within your workflow. Go to Find and Replace documentation to learn more about this feature.

View Menu

Open or close these windows via the View menu:

  • Tool Palette (Ctrl+Alt+T): Display the tool palette underneath the menu. Go to User Interface for more information about the Designer user interface.
  • Overview (Ctrl+Alt+V): Display the Overview window docked in its last visible position.
  • Results (Ctrl+Alt+R): Display the Results window docked in its last visible position.
  • Configuration (Ctrl+Alt+C): Display the Configuration window docked in its last visible position.
  • Interface Designer (Ctrl+Alt+D): Display the Interface Designer window docked in its last visible position. Go to Interface Designer and Interface Designer Window for more information.

Options Menu

These options provide access to workflow, scheduling, license functionality, as well as user settings.

  • Run Workflow: Run the workflow. The Ctrl+R keyboard shortcut also runs the workflow. The icon changes to Stop Workflow while the workflow is running.
  • Schedule Workflow: Schedule workflows to run at specific times and frequencies. The Scheduler Service must be enabled as part of the Alteryx installation and the user must be licensed appropriately. The license should be installed by an Administrator to ensure all users are properly licensed and the service is properly configured. Go to Schedule Workflows for more information.
  • View Schedules: Schedule workflows and applications, see the jobs in queue, and view information about completed jobs. The Scheduler Service must be enabled as part of the Alteryx installation and the user must be licensed appropriately. The license should be installed by an Administrator to ensure all users are properly licensed and the service is properly configured. Go to Manage Schedules for more information.
  • Run Analytic Apps: Open the Choose Analytic App window that allows you to browse for apps and edit or run them. Go to Choose Analytic App for additional details.
  • Export Workflow: Open the Export Workflow window that allows you to take the active workflow and zip it up with all of its dependencies into a *.yxzp file. Go to Workflow Management for additional details.
  • Manage Licenses: View, add, and delete your Alteryx licenses via the License Manager.
  • Manage Alteryx Links: Link Designer with the Alteryx Platform. Go to Manage Alteryx Links for instructions.
  • Manage Connect Credentials: Open the Connect Sign In window that allows you to access Connect. Go to Use Connect Assets for additional details.
  • Add Promote Connection: Open the Promote Connection window that allows you to add connections to the Promote platform. To view all connections or delete a connection, access the Deploy tool or Score tool.
  • User Settings: Configure a workflow's appearance and specify system resource usage to optimize the project's performance specific to the user. Go to User Settings for more information.
    • Edit User Settings: Go to User Settings for additional details.
    • Save Layout & Settings on Exit: Save the GUI layout and user-specified settings upon exiting the program.
    • Save Layout & Settings Now: Save the GUI layout and user-specified settings.
    • Restore Defaults: Return the GUI layout to its original orientation.
  • Advanced Options
    • Compare Workflows: Compare 2 workflows and quickly identify the differences via visual indicators. Go to Compare Workflows for instructions and additional information.
    • Lock Workflow: Save a copy of a workflow so that it can be run, but can't be opened and edited in Alteryx Designer. Go to Lock Your Workflow for instructions and additional information.
    • Manage Data Connections: Create and manage your data connections from a central location. View connections you created and connections shared with you, as well as add new connections. Go to Manage Data Connections for more information.
    • Manage In-DB Connections: Create and manage your in-database connections from a central location. View existing in-database connections and add new in-database connections. Go to Manage In-DB Connections for additional details.
    • Show HTML Developer Tools: Automatically open the Alteryx HTML Developer Tools window when you select a tool or window that uses the Chromium Embedded Framework.
    • System Settings: Specify system resource usage to optimize the application's performance. System Settings require Administrator privileges to change. Go to System Settings for more information.
    • Workflow Dependencies: Control the input and output paths associated with the workflow as well as specific datasets. Go to Workflow Dependencies for more information.
  • Download Predictive Tools: The predictive tools use the R programming language. Go to Options > Download Predictive Tools and sign in to the Alteryx Downloads and Licenses portal to install R and the packages used by the R tool.

Help Menu

These options provide quick access to help with Alteryx Designer.

  • Alteryx Help: Open Designer Help. You can also access help via the F1 keyboard shortcut.
  • Tutorials: Open tutorial workflows that provide an introduction to building workflows in Designer.
  • Sample Workflows: Open the sample workflows that are available in Designer, including external installations such as Starter Kits. Go to Sample Workflows for more information.
  • Sample Datasets: Open the sample datasets that are available in Designer.
  • Community: Link to the Alteryx Community site where you can find access to our user forums, support questions, workflow exchange, FAQs, and more.
  • What's New: Open the What's New Help page for the current release version of Designer. This page highlights the new features and enhancements since the last official release.
  • Check for Updates: Designer checks if there is a newer version available than the current version. This feature requires an internet connection. Go to Version Updates for more information.
  • Generate Support File: Generate a tech support file that contains information that helps our team properly troubleshoot your issue. The file includes Runtime Settings and your Serial Number (email address). You can upload this file when you submit your support case. Make sure to review the file contents and remove anything you might not want to include.
  • Alteryx Downloads: Open the Alteryx Downloads and Licenses portal where you can download the latest version of the software.
  • About: Open a dialog box with the Designer version information and the unique serial number for the license.
  • Privacy Policy: Access the Privacy Policy.
  • End User License Agreement: Access the End User License Agreement.

Localization Menu (Globe Icon)

Select the language version for Designer. Your options include...

  • English
  • 简体中文 (Simplified Chinese)
  • Français (French)
  • Deutsch (German)
  • Italiano (Italian)
  • 日本語 (Japanese)
  • Português (Portuguese)
  • Español (Spanish)

The Localization menu also provides quick access to the Localization User Settings.

Toolbar

The toolbar, located above the main menu, provides access to these actions:

Image showing the Designer toolbar.
  • Open Workflow (Ctrl+O): Browse to the file location to open a previously created workflow.
  • Save (Ctrl+S): Save the active workflow.
  • Cut (Ctrl+X): Delete an object and copies it to the clipboard for immediate pasting.
  • Copy (Ctrl+C): Copy an object to the clipboard.
  • Paste (Ctrl+V): Paste a copied object.
  • Undo (Ctrl+Z): Automatically delete the last action. Actions are recorded historically, so you can undo up to 32 actions.
  • Redo (Ctrl+Y): Repeat the action that you just undid.
Was This Page Helpful?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.