User Settings

Version:
Current
Last modified: April 02, 2020

The User Settings window contains options for configuring workflow appearance and system resource usage to optimize performance.

System resource usage can be configured in three different areas: User Settings, System Settings, and Workflow Configuration. Settings configured in User Settings override settings in System Settings, and settings in Workflow Properties override settings in User Settings and System Settings.

To edit settings, navigate the tabs and edit settings as desired, then select Save.

Certain Designer processes might save your data to disk as temporary files in your designated temporary directory. In the event of an unexpected interruption or termination of the processes, temporary files might not be automatically deleted. We recommend that you secure your device, and check your temporary directory to remove any files that might not have been automatically deleted.

To determine the location of your temporary files, refer to the Defaults section below, select System Settings, or Workflow Configuration, and select the Runtime tab.

Defaults

The Defaults tab lists the Alteryx default runtime settings. The System Settings section shows settings configured in System Settings.

  • Override System Settings: Select to configure settings different from settings configured in System Settings.
    • Default Dedicated Sort/Join Memory Usage: Define the minimum amount of memory the Engine uses to perform sort and join operations in a workflow. Generally, this value should not be changed. For more information on how Designer uses memory, see Memory Use.
    • Default Temporary Directory: Displays the path to the location where temporary files used in workflow processing are saved.
    • Logging Directory (blank for no logging): Displays the path to the location where output logs produced during workflow processing are saved.
    • Run Designer x64 at a Lower Priority: Select to run other memory intensive applications at the same time as Designer. This setting impacts workflow processing speeds.
  • Collect and display data profile information: Enables data profiling in the Browse tool. Deselect to disable data profiling features. If disabled, the Browse tool does not display data profile information. This does not improve runtime performance. See Browse Tool.
  • Show Start Here at startup: Select to display Start Here when Designer starts. Start Here displays a helpful set of starter samples when Designer starts up.
  • Pop Up Dialog at Completion of Workflow: Select to display a notification when a workflow finishes running. The workflow status is always displayed in the Results window.
  • Play Sound at Completion of Workflow: Select to play a sound when a workflow finishes running.
  • Send Alteryx Tool Usage as Part of the Customer Experience Improvement Program: Deselect this option to opt out of sending usage data to Alteryx. When enabled, Alteryx collects usage data each time a workflow is run or Search is used. This information is used to plan future releases and prioritize fixes and features. Deselecting this option does not prevent your IT department from collecting usage data.
  • Open Alteryx files as new workflow tabs in same Designer window: Select this option so that when Alteryx file types (.yxmd, .yxmc, .yxwz, .yxwg, .yxzp, .yxi) are double-clicked, they open as a new workflow tab within an existing Designer instance.
  • Allow multiple tabs of the same file to be open: Select this option if you need to open the same workflow in multiple tabs in Designer.
  • Use classic mode for the Input/Output tool menu options: Select this option to use classic mode for the Input Data and Output Data tools.

Alteryx Usage Data

  • Sample workflow data: Includes the date and time the sample workflow was run, the version of Alteryx running the workflow, the serial number of the computer or server running Alteryx, and the name of the sample workflow.
  • Workflow data: Includes the same data collected for sample workflows and also the name of the tools in the workflow, the number of times a tool is used in the workflow, and tool connection data in the workflow.
  • Search data: Includes the terms on which users search and which results were clicked.

Dataset Defaults

On the Dataset Defaults tab, you can set your default datasets for all tools that require an installed dataset. When the tool uses a dataset, the dataset you selected will be used. If you have not installed a dataset, you will not have an option to select.

Advanced

The Advanced tab lists settings related to memory usage which affects program performance.

  • Undo Levels: Set the number of actions Alteryx remembers and allows you to undo. The default value is 10. Increasing the value negatively impacts performance.
  • Disable Auto Configure: Select this option to manually configure tools in a workflow. With this option selected, press the F5 key to manually refresh tool configurations. This option may optimize performance.
  • Display XML in Properties Window: Select to view the XML of the configuration for each tool in a workflow.
  • Display Asset Management in Properties Window: Select to view the file dependencies or assets for each tool in a workflow.
AutoRecover

Alteryx automatically recovers at least one of the files being processed in a workflow. Go to File > Open AutoRecover Files.

  • AutoRecover Interval in Minutes: Type or click to set the time Alteryx waits before automatically saving a file. The default is 10.
  • AutoRecover per File: Type or click to set the number of times a file is saved before it is saved again as a new version. The default is 3.
  • Days to Keep AutoRecover Files: Type or click to set the number of days to keep auto-saved files.
Tool Results Settings

These settings control the size of the data that displays in the Results window for each output anchor in a workflow.

Override System Settings: Select to edit the default setting.

  • ​​​Memory Limit per Anchor: Select to set a memory limit per anchor. Then, type or click to set the memory limit value in KB. The default value is 1024 KB (1 MB).

     

Proxy Settings

Enable Proxy Credentials: Select to use a proxy to access the internet instead of directly connecting to an internet host. The following tools and connections will work with a proxy: Download tool, Amazon Redshift Bulk loader, Amazon S3 Upload tool, Amazon S3 Download tool, and HDFS connections via the Input Data, Output Data, Data Stream In, and Write Data In-DB tools. You must manually configure a proxy in order to use this setting.

To set up a proxy, go to Network and internet settings on your computer, or Internet Options in Internet Explorer. In Internet Explorer, Internet Options, click the Connections tab, click LAN Settings and deselect Automatically Detect Settings, then select Proxy Server.

After setting up a proxy, select Enable Proxy Credentials and click Configure. Once configured, Designer will Autodetect proxy in use.

  1. Confirm the correct proxy is selected.
  2. Select Proxy requires password.
  3. Type credentials in Username and Password.
  4. Select OK.

Admins can configure a proxy in System Settings. Go to Options > Advanced Options > System Settings > Engine > Proxy.

Macros

On the Macros tab, you can create a repository of macros and set a default location to save macros. Alteryx displays the macros in the Tool Palette for you to use in building workflows. Each macro must have a unique name.

Add a Path to the Repository

  1. Select open macros icon to open the Add Search Path for Macros window.
  2. Category Name: Type a name. The default name is Macros.
  3. Search Path: Select more icon to browse to the location where you save macros on your computer or a network.

Any macro .yxmc file in the selected location displays in the tool category on the Tool Palette. Sub-folders in a search path cannot be added individually if their parent folder already exists in the Macros repository.

Set a Default Repository Location

  1. Select the repository search path in the list.
  2. Select Set as Default. An asterisk (*) displays next to the default repository.

Localization

The Localization tab lists settings related to internationalization and localization, including language and measurement conversion.

Interface Language: Select the language version for Designer. Choose from English, Italian, French, German, Japanese, Spanish, Portuguese, or Simplified Chinese.

Tool Palette Order: Sort your tool palette to follow either Current Language Alphabetical or English Alphabetical order, even if you're running in a non-EN user interface. We do not yet support the sorting of Kanji characters.

Code page: Select the code page to be used in encoding your toolset in Designer. See Code Pages.

Default System Font: Select the default font used by Designer.

Default Distance Units: Select the default units for measuring distance. Spatial tools use the selected unit of measure.

Predictive Tools Locale/Codepage: Select the code page to be used in encoding your Predictive Tools in Designer. See Code Pages.

Use the following options to customize your Help settings.

  • Source: Select the source of Help. By default, Auto-Detect displays online Help when internet is available and displays offline Help when internet is not available.
  • Language: Select the language used to display online Help.
Was This Helpful?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support.