AYX Python SDK

Last modified: July 08, 2021

Overview

The AYX Python SDK lets you extend the functionality of Alteryx Designer via custom tools and plugins. This SDK serves as the back-end engine component. Combine it with the AYX UI SDK (which serves as the user interface component) to create your custom tool or plugin.

Engine Compatibility

The AYX Python SDK requires that the AMP Engine is enabled.

Requirements and Prerequisites

To get started with the AYX Python SDK, you need these items installed on your machine:

  • Microsoft Windows 7 or Later (64-bit)
  • Python Version 3.8.5
  • Alteryx Designer Version 2021.2

Installation

To install the AYX Python SDK, run pip install ayx-python-sdk.

  • This command provides the AYX Plugin CLI (top-level CLI) as well as the AMP Provider classes.
  • The AYX Plugin CLI uses the Python SDK CLI to manage the creation and installation of Python tools.

As noted above, you can install the package via pip. Any updates to packages will also be available on pip. You do not need to update or manage this package directly since it is a dependency of the AYX Plugin CLI.

AYX Python SDK Documentation

You can access the AYX Python SDK documentation at https://alteryx.github.io/ayx-python-sdk/index.html. Additionally, after you install the AYX Python SDK distribution, you can run ayx_python_sdk docs to access the help documentation locally.

Was This Page Helpful?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.