box

Outil Sortie de Box

Version:
2022.3
Last modified: March 31, 2022

Utilisez l'outil Sortie de Box pour écrire des données ou télécharger des fichiers locaux dans votre espace de travail Box. 

Installer l'outil et se connecter à Box

Installer et configurer l'outil Sortie de Box

  1. Téléchargez l'outil à partir de la Communauté Alteryx

  2. Dans Designer, ouvrez le fichier YXI de Sortie de Box. Remarque : pour installer l'outil Sortie de Box pour tous les utilisateurs, ouvrez l'application Designer avec les identifiants de l'administrateur.

  3. Sélectionnez l'outil Sortie de Box pour accéder au panneau de configuration et ouvrez-le. 

  4. Vous pouvez sélectionner une connexion existante ou saisir vos identifiants dans le volet de gauche.

  5. Choisissez une méthode d'authentification : 

    1. Se connecter via un navigateur Internet : une fenêtre contextuelle s'affiche pour autoriser l'accès à Box. 

    2. Fournir un jeton d'accès : authentifiez-vous avec un jeton d'accès.

    3. Jetons Web JSON (JWT) : sélectionnez un fichier avec le jeton et entrez votre ID de compte utilisateur.

      Vous pouvez également vous Connecter via votre propre application Box avec l'ID et le secret client. 

  6. Sélectionnez Se connecter.

Configurer l’outil

Vous pouvez écrire les données entrantes dans un fichier ou télécharger des fichiers locaux vers votre espace de travail Box.

Écrire les données entrantes dans un fichier

  1. Choisissez une collection dans le menu déroulant Collections

    Pour sélectionner le fichier ou le dossier dans lequel écrire les données, vous pouvez entrer le chemin complet du fichier ou du dossier dans la zone de texte Chemin du fichier. Utilisez Rechercher pour rechercher le fichier avec son nom complet et son extension, ou sélectionnez un fichier dans l'arborescence. 

  2. Ou créez un nouveau fichier. Il existe 2 façons de créer un nouveau fichier…

    1. Sélectionnez Ajouter un fichier

      1. Par nom : écrivez une sortie dans un nouveau fichier portant le nom indiqué. 

      2. Par champ : écrivez des lignes de sortie dans de nouveaux fichiers nommés par colonne. 

    2. Utilisez le chemin d'accès au fichier. Écrivez le nom du fichier avec l'extension de fichier dans le champ Chemin du fichier et appuyez sur Entrée

      Sélectionnez le format de fichier approprié dans l'onglet Options

  3. Sélectionnez Exécuter pour exécuter le workflow. Un nouveau fichier est créé et affiché dans l'arborescence. Remarque : vous pouvez créer un nouveau dossier à l'aide du chemin d'accès au fichier.

    Dans l'onglet Options, vous pouvez choisir le format de fichier. Les champs d'option sont mis à jour en fonction de l'extension de fichier sélectionné.

  • Configurations de format de fichier XLSX 
    • Dans l'onglet Options, vous pouvez choisir l'action à entreprendre pour le fichier existant (Renommer, Remplacer, Ajouter et Abandonner) et indiquer si la première ligne contient les noms de champs
    • Dans l'onglet Données, vous pouvez sélectionner la plage de données : 
      • Par nom de feuille : nom de feuille qui sera créée dans Box, incluant la cellule de départ.

      • Par champ : permet de créer plusieurs feuilles en fonction du nom de champ de la feuille d'entrée.

Si vous sélectionnez les options Remplacer ou Ajouter dans Action à entreprendre pour le fichier existant, la feuille mise à jour devient la première feuille du fichier. Cela peut avoir un impact sur les outils utilisant les numéros d'ordre des feuilles.

  • Configurations de format de fichier CSV 
    • Dans l'onglet Options, vous pouvez sélectionner Format de fichier, Longueur de champ maximale, Séparateur de champ (virgule par défaut), Guillemet (aucune valeur par défaut) et Page de code
    • Vous pouvez également choisir Écrire les en-têtes, Commencer les données à la ligne et Action à entreprendre pour le fichier existant (Renommer, Remplacer, Ajouter et Abandonner).
  • Configurations de format de fichier YXDB 

    • Dans l'onglet Options, vous pouvez sélectionner Action à entreprendre pour le fichier existant (Renommer, Remplacer, Ajouter et Abandonner).

Charger les fichiers dans Box

Pour obtenir un guide détaillé, consultez l'article de la communauté.

  1. Sélectionnez le champ Source contenant le chemin complet des fichiers que vous souhaitez télécharger.

  2. Choisissez une collection dans le menu déroulant Collections.

    Pour sélectionner le fichier ou le dossier vers lequel télécharger les fichiers, vous pouvez entrer le chemin complet du fichier ou du dossier dans la zone de texte Chemin cible. Utilisez Définir le chemin du fichier par champ pour définir le Chemin cible à l'aide d'un champ entrant.

  3. Dans l'onglet Options, vous pouvez choisir l'Action à entreprendre pour le fichier existant (Renommer, Remplacer et Abandonner).

Cette page vous a-t-elle été utile ?

Vous rencontrez des problèmes avec votre produit Alteryx ? Visitez la communauté Alteryx ou contactez le  support. Vous n'arrivez pas à soumettre ce formulaire ? Envoyez-nous un e-mail.