Gestion des workflows

Version:
2022.3
Last modified: December 14, 2022

Dans le cadre de la gestion des workflows, vous pouvez enregistrer les workflows que vous créez dans Designer afin de pouvoir les réutiliser ou les partager avec d'autres utilisateurs dans le Server de votre société.

Vous pouvez également gérer les workflows existants dans le Server de votre société en les ouvrant dans Designer. À partir de Designer, vous pouvez les éditer, les enregistrer et les partager à nouveau vers le Server. Dans la mesure où Server conserve les versions antérieures d'un workflow, l'enregistrement du workflow révisé vers le Server de votre société n'entraîne pas le remplacement de la précédente version.

Si vous souhaitez enregistrer et partager un workflow avec ses dépendances, telles que les fichiers et les connexions, vous pouvez les exporter ensemble en tant que fichier .yxzp. Comme les workflows de fichiers uniques, vous pouvez partager des workflows exportés avec d'autres personnes dans Server et les ouvrir dans Designer.

Outre l'enregistrement de workflows uniques, vous pouvez enregistrer plusieurs workflows en tant que groupe de workflows, que vous pouvez ensuite ouvrir en tant qu'un fichier de groupe de workflows (.yxwg). Vous ne pouvez créer que des groupes de workflows composés de workflows existants, enregistrés localement.

Enregistrer les workflows individuels

Avec le workflow ouvert, sélectionnez Fichier > Enregistrer sous, puis sélectionnez l'emplacement où vous voulez enregistrer le workflow.

Répertoire de fichiers

  1. Sélectionnez Parcourir.
  2. Dans l’explorateur de fichiers, allez à l’emplacement où vous voulez enregistrer le workflow.
  3. Dans Nom de fichier, saisissez un nom pour le workflow.
  4. Sélectionnez Enregistrer.

Alteryx Server

Par défaut, les workflows que vous créez sont enregistrés dans votre espace de travail privé. Les workflows partagés avec vous à travers une collection sont enregistrés dans la collection.

  1. Sélectionnez Enregistrer sous.
  2. Sélectionnez Alteryx Server > Server de ma société.
  3. Connectez-vous avec votre nom d’utilisateur et votre mot de passe. Sélectionnez Me maintenir connecté pour garder votre session active si désiré.
  4. Dans la fenêtre Enregistrer un workflow, saisissez un nom dans le champ Nom du workflow. Par défaut, le champ Emplacement affiche le studio dans lequel le workflow sera enregistré. Si le workflow a été partagé avec vous dans une collection, le champ Emplacement affiche la collection.
  5. Dans Worker Tag, sélectionnez une option pour affecter un travailleur spécifique à l'exécution du workflow.
  6. (Facultatif) Dans Détails, entrez tous les commentaires utiles.
  7. (Facultatif) Cliquez sur Options du workflow pour sélectionner l'une de ces options :
    Option de workflow Description
    Publier cette version du workflow

    Publie cette version du workflow en tant que version disponible dans Server.

    Cette option n'est disponible que si le workflow a été enregistré dans Server précédemment. Ne sélectionnez pas cette option si vous ne voulez pas que les autres utilisateurs utilisent cette version du workflow.

    Pour mettre à jour la version du workflow dans Server...

    1. Affichez les détails de l'application et sélectionnez Version # pour afficher les versions disponibles.
    2. Sélectionnez une version, puis sélectionnez Make Published Version.
    Valider le workflow puis enregistrer

    (Option par défaut) Cette option est activée par défaut. La validation vérifie s'il existe des commandes ou des outils interdits. Si la validation échoue, le workflow nécessite une exception pour pouvoir être exécuté dans le Server de votre entreprise. Contactez votre administrateur Server pour lui demander de modifier le mode d'exécution de votre workflow. 

    Ces outils nécessitent des exemptions pour être exécutés dans Alteryx Public Gallery : Outil R, outil Exécuter une commande, outil Python, outil E-mail, et outil Télécharger.

    Un Server ne permet pas l'exécution d'événements ou d'applications associées. Rendez-vous sur Configuration du workflow et Fenêtre Concepteur d'interface.

    Rendez-vous sur Enregistrer dans les messages Gallery pour plus d'informations sur la demande d'une exception.

    AMP Engine

    Si votre workflow utilise AMP Engine mais pas votre contrôleur, la validation du workflow est désactivée et ne peut pas être activée. Pour activer la validation du workflow, activez AMP Engine sur le contrôleur ou modifiez votre workflow pour qu'il s'exécute sur le moteur d'origine Alteryx via la Configuration du workflow.

    Pour en savoir plus sur l'AMP Engine, consultez les ressources suivantes :

    Gérer les actifs du workflow

    Afficher et gérer les actifs associés au workflow.

    • Sélectionnez Regrouper les actifs par outil* pour afficher tous les actifs ou les dépendances de fichier du workflow qui sont regroupés avec l'outil auquel ils sont connectés.
    • Désélectionnez un actif pour l’exclure du paquet de workflow.
    • Les actifs incluant une constante dans le chemin d’entrée apparaissent dans la liste des actifs, mais ne sont pas inclus dans le paquet de workflow.

    *Ce paramètre organise les actifs de chaque outil afin que les informations soient plus faciles à analyser visuellement. Il ne modifie pas la façon dont le fichier YXZP est créé.

    Autoriser le verrouillage du workflow

    Affichez les options de verrouillage pour le workflow.

    • Sélectionnez Limiter l'utilisation à des numéros de série spécifiques pour limiter l'utilisation du workflow verrouillé aux numéros de série spécifiés. Lorsque cette option est sélectionnée, seuls les numéros de série (adresses e-mail) de la liste peuvent utiliser le workflow verrouillé. Pour permettre à un workflow de s'exécuter dans Server, vous devez indiquer le numéro de série du Server, qui est l'Administrateur Server par défaut. L'Administrateur Server par défaut est configuré lors de la configuration de l'authentification Server. Accédez à Configurer l'authentification Galerie pour plus d'informations. Saisissez chaque numéro de série unique (adresse e-mail), 1 par ligne.
    • Sélectionnez Définir la date d'expiration du workflow verrouillé pour qu'il expire à la date sélectionnée. Lorsque la date d'expiration est atteinte, le workflow ne peut pas être exécuté ou utilisé.
    • Cochez la case pour indiquer que vous comprenez les conséquences du verrouillage de votre workflow.
    • Sélectionnez Terminé pour verrouiller votre workflow.

    Rendez-vous sur Verrouiller votre workflow pour plus d'informations.

    Définir les informations d'identification du workflow

    Pour que cette option soit disponible, un Curateur (Admin Server) doit sélectionner la configuration Autoriser les utilisateurs à sélectionner l'option d'identifiants dans Server via Admin> IdentifiantsModifier.

    Une fois cette option activée, les utilisateurs peuvent sélectionner les identifiants pour exécuter le workflow.

    • L’utilisateur n’est pas tenu de saisir ses informations d’identification : cette option exécute le workflow à l’aide des identifiants par défaut du serveur ou du studio.
    • L'utilisateur doit spécifier ses propres informations d'identification : cette option invite l’utilisateur à saisir ses propres identifiants pour exécuter le workflow.
    • Toujours exécuter ce workflow avec ces informations d’identification : entrez les identifiants à utiliser à chaque fois que le workflow est exécuté.
  8. Sélectionnez Enregistrer. Rendez-vous sur Enregistrer dans les messages Gallery pour plus d'informations sur les erreurs et les avertissements qui peuvent s'afficher quand vous essayez d'enregistrer un workflow sur un Server.

Alteryx Server : ajouter un nouveau Server

  1. Sélectionnez Enregistrer sous > Alteryx Server > Ajouter un nouveau Server.
  2. Sur l'écran Enregistrer un workflow - Ajouter un Server, utilisez le champ URL pour saisir le chemin d'accès à l'URL du Server de votre société.
  3. Sélectionnez Se connecter.
  4. En fonction de la configuration de Server, les étapes d'authentification varient comme suit :
    Type de configuration Étapes d'authentification
    Authentification intégrée
    1. Dans E-mail et Mot de passe, saisissez votre e-mail et mot de passe Server.
    2. Sélectionnez Me maintenir connecté, si vous le souhaitez.
    3. Sélectionnez Se connecter.
    Authentification Windows
    1. Un nom d’utilisateur s’affiche.
    2. Sélectionnez Continuer pour vous connecter.
  5. Sélectionnez le Server dans la liste et suivez les étapes pour enregistrer le workflow sur le Server de votre société.

Alteryx Platform

Vous pouvez également enregistrer votre workflow Designer dans Alteryx Platform.

  1. Sélectionnez Enregistrer sous > Alteryx Platform. Si vous n'avez pas lié Designer à Alteryx Platform, accédez à Options > Gérer les liens Alteryx et créer un nouveau lien Platform.
  2. Sélectionnez votre lien Alteryx Platform.
  3. Attribuez un Nom à votre workflow et choisissez un Emplacement où vous souhaitez l'enregistrer.
  4. Sélectionnez Enregistrer.

Veuillez noter que tous les outils de Designer Desktop ne sont pas compatibles actuellement avec Designer Cloud. Même si vous pouvez enregistrer les workflows contenant des outils non compatibles avec Designer Cloud sur Platform, vous recevrez un message d'avertissement si vous ouvrez ces workflows dans Designer Cloud. Pour obtenir une liste des outils Designer Cloud actuels, rendez-vous sur Liste des outils Designer Cloud.

Exporter un workflow

Exportez un workflow et ses dépendances en tant que fichier de paquet (.yxzp). Vous devez enregistrer le workflow avant de pouvoir l'exporter.

Paquet de fichiers de dépendance

Ces actifs sont automatiquement inclus dans un workflow exporté :

  • Fichiers d’entrée
  • Références de sortie
  • Macros
  • Applications associées
  • Fichiers ajoutés par l’utilisateur

Ces fichiers ne sont pas inclus dans un workflow exporté :

  • Fichiers manquants
  • Fichiers identifiés comme faisant partie de l’installation Alteryx
  • Fichiers référencés par un chemin de réseau
  • Chemins d’entrée comprenant une constante

Lorsque vous exportez un workflow et ses dépendances, Designer conserve le format de fichier original de chaque fichier. La structure des dossiers des actifs inclus dans le workflow est maintenue tant que le fichier contenu est un enfant (ou frère) du fichier du workflow. Tous les autres fichiers sont considérés comme externes et, s'ils sont inclus dans le paquet, seront placés dans un dossier _externals.

Utilisez les Dépendances du workflow pour vous assurer qu'aucun chemin n'est rompu lors du référencement de fichiers manquants.

Exporter un workflow

  1. Sélectionnez Options > Exporter un workflow pour afficher la fenêtre Exporter un workflow. Workflow affiche le nom du workflow et son extension de fichier.
  2. Renseignez toutes les options de configuration disponibles :
    Option Description
    Verrouiller

    Créez une copie du workflow, de l'application ou de la macro qui peut être exécutée, mais ne peut pas être ouverte et éditée dans Designer.

    1. Sélectionnez le bouton Verrouiller.
    2. Sélectionnez Autoriser le verrouillage pour ce workflow.
    3. Configurez les options suivantes, le cas échéant :
      • Limiter l'utilisation à des numéros de série spécifiques (un par ligne) : entrez les numéros de série des licences qui doivent être en mesure d'accéder au workflow verrouillé. Énumérez chaque numéro de série sur une ligne séparée. Un numéro de série est utilisé pour chaque installation Alteryx. Pour afficher votre numéro de série...
        • Accédez à Options  > Gérer les licences et sélectionnez l'icône d'engrenage dans le coin supérieur droit.
        • Sélectionnez ensuite Afficher le Gestionnaire de licences de données partenaires et consultez votre Numéro de série de l'ordinateur dans la partie supérieure droite de la fenêtre.
      • Définir la date d'expiration du workflow verrouillé : configurez le workflow verrouillé pour expirer à la date sélectionnée. Lorsque la date d'expiration est atteinte, le workflow ne peut pas être exécuté ou utilisé.
      • Cochez la case pour indiquer que vous comprenez les conséquences du verrouillage de votre workflow.
      • Sélectionnez Terminé pour verrouiller votre workflow.
    • Vous ne pouvez pas annuler le verrouillage.
    • Alteryx vous recommande de configurer ce paramètre en dernier.

    Emplacement du paquet

    Changez l'emplacement où le fichier est enregistré.

    Regrouper les actifs par outil

    Regrouper les actifs du workflow par les outils dans lesquels ils sont utilisés. Si cette option n’est pas sélectionnée, les actifs sont répertoriés individuellement.

    Désélectionnez un actif pour l’exclure du paquet de workflow. L'actif est référencé, mais il n'est pas inclus dans le paquet.

    Les actifs comportant une constante dans le chemin d’entrée s’affichent dans la liste des actifs, mais ils ne sont pas intégrés dans le paquet du workflow.

  3. Sélectionnez Enregistrer. Rendez-vous sur Verrouiller votre workflow pour plus d'informations.

Enregistrer les groupes de workflows

Autres considérations

  • Vous ne pouvez créer qu'un groupes de workflows composés de workflows existants, enregistrés localement. Si vous essayez de créer un groupe de workflows à partir de workflows enregistrés dans Server, vous devez d'abord enregistrer chaque workflow individuellement sur votre disque local.
  • Si vous déplacez ou supprimez un workflow qui fait partie du groupe de workflow, Designer affiche une erreur lorsque vous essayez d'ouvrir le groupe de Workflow.
  1. Ouvrez tous les workflows enregistrés localement à inclure dans le groupe. Le fichier Commencez ici.yxmd n'est pas enregistré avec un groupe de workflow.
  2. Sélectionnez Fichier > Créer un groupe de workflows.
  3. Dans le fichier Explorateur, allez à l’emplacement où vous voulez enregistrer le groupe de workflows.
  4. Dans Nom de fichier, saisissez un nom pour le workflow.
  5. Sélectionnez Enregistrer pour enregistrer les workflows individuels comme un fichier de groupe de workflows (YXWG).

Ouvrir un workflow enregistré ou exporté

Ouvrez les workflows à partir d'un répertoire de fichiers ou de votre Server.

Ouvrir un workflow unique à partir du répertoire de fichiers

  1. Sélectionnez Fichier > Ouvrir un workflow > Parcourir.
  2. Accédez à l'emplacement où vous avez enregistré le workflow.
  3. Double-cliquez sur le nom du fichier afin d’ouvrir ce dernier dans Designer.

Workflows exportés

Si le workflow se trouve dans un fichier .yxzp exporté, procédez comme suit :

  1. Dans la boîte de dialogue Importation du package, sélectionnez Oui pour importer le workflow.
  2. Dans la fenêtre Importer un package de workflow, veuillez vérifier ces informations :
    • Nom du fichier du package : affiche le chemin complet vers le fichier.
    • Workflow : affiche le nom du workflow. Les actifs dans le package apparaissent dans le champ.
    • Répertoire de destination : affiche l'emplacement où vous souhaitez enregistrer le package. Pour modifier l'emplacement, cliquez sur l'icône de disquette et sélectionnez un nouvel emplacement.
  3. Sélectionnez Importer.
  4. Dans la fenêtre Progression de l'importation du workflow sélectionnez Oui pour charger le workflow. Si le workflow ne se charge pas correctement, réessayez.

Ouvrir un groupe de workflow à partir du répertoire de fichiers

  1. Sélectionnez Fichier > Ouvrir un groupe de workflow.
  2. Accédez à l'emplacement où le fichier de groupe de workflows a été enregistré.
  3. Double-cliquez sur le fichier YXWG pour l'ouvrir. Chaque workflow du groupe s'ouvre sur un onglet distinct dans Designer.

Ouvrir le workflow à partir de Server

  1. Sélectionnez Fichier > Ouvrir un workflow>Server de ma société.
  2. Connectez-vous avec votre nom d’utilisateur et votre mot de passe. Sélectionnez Me maintenir connecté pour garder votre session active si désiré.
  3. Dans la fenêtre Server de ma société, localisez le workflow. Vous pouvez utiliser Rechercher, utiliser la liste déroulante Tous les emplacements pour filtrer et sélectionner les en-têtes de colonne pour trier les résultats.
  4. Sélectionnez l'icône Versions à droite d'un workflow pour afficher les versions précédentes, si nécessaire. Pour être visible dans Designer, cette option doit être activée dans Server.
  5. Sélectionnez le workflow et sélectionnez Ouvrir. Rendez-vous sur Enregistrer dans les messages Gallery pour plus d'informations sur les erreurs et les avertissements qui peuvent s'afficher quand vous essayez d'enregistrer un workflow sur un Server.

Ajouter un nouveau Server

  1. Sélectionnez Fichier > Ouvrir un workflow > Ajouter un nouveau Server.
  2. Dans URL, saisissez le chemin d'accès à l'URL du Server de votre société.
  3. Sélectionnez Se connecter.
  4. En fonction de la configuration de Server, les étapes d'authentification varient comme suit :
    Type de configuration Étapes d'authentification
    Authentification intégrée
    1. Dans E-mail et Mot de passe, saisissez votre e-mail et mot de passe Server.
    2. Sélectionnez Me maintenir connecté, si vous le souhaitez.
    3. Sélectionnez Se connecter.
    Authentification Windows
    1. Un nom d’utilisateur s’affiche.
    2. Sélectionnez Continuer pour vous connecter.
  5. Sélectionnez le Server dans la liste, puis suivez les étapes pour ouvrir un workflow enregistré sur le Server de votre société.

Ouvrir un workflow à partir d'Alteryx Platform

Pour ouvrir un workflow à partir d'Alteryx Platform...

  1. Sélectionnez Fichier > Ouvrir un workflow > Alteryx Platform.
  2. Sélectionnez votre lien Alteryx Platform. Si vous n'avez pas lié Designer à Alteryx Platform, accédez à Options > Gérer les liens Alteryxet créez un nouveau lien Platform.
  3. Accédez à l'emplacement du workflow, sélectionnez le fichier de workflow, puis cliquez sur le bouton Ouvrir. Vous pouvez aussi double-cliquer sur le nom du fichier pour l'ouvrir dans Designer.
Cette page vous a-t-elle été utile ?

Vous rencontrez des problèmes avec votre produit Alteryx ? Visitez la communauté Alteryx ou contactez le  support. Vous n'arrivez pas à soumettre ce formulaire ? Envoyez-nous un e-mail.