メインメニュー

バージョン:
2021.3
Last modified: September 13, 2021

Alteryx Designer のメインメニューから、さまざまなウィンドウと一般的なアクションにアクセスします。

Image showing the main menu in Alteryx Designer, including the File, Edit, View, Options, Help, and Localization menus.

 

ファイルメニュー

これらのオプションは、ワークフローを作成して作業することに固有です。

  • 新しいワークフロー (Ctrl+N) : 新しいワークフロー (*.yxmd) を作成します。
  • [最近の使用を開く]: 最近アクセスして保存したワークフローを表示します。
  • [ワークフローを開く]: ファイルの場所を参照して、以前に作成したワークフローを開きます。
    • ブラウズ: ファイルの場所を参照し、そこにワークフローを保存します。
    • プライベート Gallery: 会社のプライベート Gallery に接続している場合は、接続名で接続が一覧表示されます。
    • Alteryx Gallery: ワークフローを Alteryx パブリック Gallery (gallery.alteryx.com) に保存します。このオプションは、Alteryx パブリック Gallery (gallery.alteryx.com) に接続するように事前に設定されています。Alteryx パブリック Gallery は、Alteryx Analytics Gallery とも呼ばれます。Gallery にサインインするには、ログイン資格情報が必要です。
    • ギャラリーを追加する: プライベートギャラリーへの接続を作成し、そこにワークフローを保存する機能があります。
    • 自動復元ファイルを開く: 自動保存されたファイルのリストを開きます。開いているファイルは定期的に自動保存されます。自動保存間隔は既定で有効になっており、ユーザー設定 で変更できます。
  • ワークフローグループを開く: ワークフローグループに保存されている複数のワークフローを開きます。詳細については、ファイルディレクトリからワークフローグループを開く を参照してください。
  • 保存 (Ctrl+S): アクティブなワークフローを保存します。
  • 名前を付けて保存: アクティブなワークフローを選択した場所に保存します。
    • ブラウズ: ファイルの場所を参照し、そこにワークフローを保存します。
    • プライベート Gallery
      • ここには、プライベート Gallery への既存の接続が一覧で表示されます。
      • 新しい Gallery を追加する: プライベート Gallery への接続を作成し、そこにワークフローを保存することができます。
    • パブリック Gallery (Alteryx Gallery): ワークフローを Alteryx パブリック Gallery (gallery.alteryx.com) に保存します。このオプションは、Alteryx パブリック Gallery (gallery.alteryx.com) に接続するように事前に設定されています。Alteryx パブリック Gallery は、Alteryx Analytics Gallery とも呼ばれます。Gallery にサインインするには、ログイン資格情報が必要です。
  • ワークフローグループの作成: 個々のワークフローとして保存されていた、開いているすべてのワークフローを一つのワークフローグループとしてまとめて保存できます 。詳細については、ワークフローグループを保存する を参照してください。
  • 印刷: 印刷時にワークフローがどのように表示されるかをプレビューします。
  • 印刷設定: ワークフローを印刷するための設定をします。
  • 終了: Designer を閉じます。

編集メニュー

これらのオプションは一般的な編集機能です。

  • 元に戻す (Ctrl+Z): 最後の操作を自動的に取り消します。動作は履歴的に記録され、最大32の動作を元に戻すことができます。
  • やり直し (Ctrl+Y): 取り消した操作をやり直します。
  • 切り取り (Ctrl+X): オブジェクトを削除し、そのまま貼り付けられるようにクリップボードにコピーします。
  • コピー (Ctrl+C): オブジェクトをクリップボードにコピーします。
  • 貼り付け (Ctrl+V): コピーしたオブジェクトを貼り付けます。
  • 削除 (Del): 選択したオブジェクトを削除します。
  • 検索 (Ctrl+F): 検索と置換 ウィンドウの 検索 タブを開きます。検索と置換 ウィンドウを使用して、ワークフロー内のテキストを検索したり、検索して置換したりできます。この機能の詳細については、検索と置換 のマニュアルを参照してください。
  • 置換 (Ctrl+H): 検索と置換 ウィンドウの 置換 タブを開きます。検索と置換 ウィンドウを使用して、ワークフロー内のテキストを検索したり、検索して置換したりできます。この機能の詳細については、検索と置換 のマニュアルを参照してください。

表示メニュー

表示 メニューを使用して、これらのウィンドウを開いたり閉じたりします。

  • ツールパレット (Ctrl+Alt+T): メニューの下にツールパレットを表示します。Designer ユーザーインターフェースの詳細については、ユーザーインターフェース を参照してください。
  • 概要 (Ctrl+Alt+V): 最終表示位置にドッキングされている 概要ウィンドウ を表示します。
  • 結果 (Ctrl+Alt+R): 最終表示位置にドッキングされている 結果ウィンドウ を表示します。
  • 設定 (Ctrl+Alt+C): 最終表示位置にドッキングされている 設定ウィンドウ を表示します。
  • インターフェース Designer (Ctrl+Alt+D) : 最終表示位置にドッキングされているインターフェース Designer ウィンドウを表示します。詳細については、インターフェース Designer および インターフェース Designer ウィンドウ を参照してください。

オプションメニュー

これらのオプションを使用すると、ワークフロー、スケジューリング、ライセンス機能、およびユーザー設定にアクセスできます。

  • ワークフローの実行: ワークフローを実行します。Ctrl+R のキーボードショートカットを使用すると、ワークフローも実行されます。ワークフローの実行中はアイコンが 停止 に変わります。
  • ワークフローのスケジュール: ユーザーは、特定の時間と頻度でワークフローを実行するようにスケジュールできます。スケジューラーサービスは、Alteryxインストールの一部として有効にする必要があるため、ユーザーには適切なライセンスが必要となります。すべてのユーザーに適切なライセンスが付与され、サービスが適切に構成されているよう、管理者によって適切なライセンスがインストールされている必要があります。詳細については、ワークフローのスケジュール設定 を参照してください。
  • [スケジュールの表示]: ワークフローとアプリケーションのスケジュール設定、キュー内のジョブの表示、および完了したジョブに関する情報の表示をユーザーに許可します。スケジューラーサービスは、Alteryxインストールの一部として有効にする必要があり、またユーザーが適切なライセンスを持っている必要があります。すべてのユーザーに適切なライセンスが付与され、サービスが適切に構成されているよう、管理者によって適切なライセンスがインストールされている必要があります。詳細については、スケジュールの管理 を参照してください。
  • 分析アプリの実行: 分析アプリの選択 ウィンドウを開き、アプリを参照して編集または実行できるようにします。詳細については、分析アプリの選択 を参照してください。
  • [ワークフローのエクスポート]: [ワークフローのエクスポート] ウィンドウを開き、アクティブなワークフローを取り込みすべての依存関係とともに*.yxzpファイルに圧縮することができます。詳細については、ワークフロー管理 を参照してください。
  • ライセンスの管理: ライセンスマネージャを使用して、ユーザーが Alteryx ライセンスを表示、追加、および削除できるようにします。
  • [接続資格情報の管理]: [接続サインイン] ウィンドウを開き、接続にアクセスできるようにします。詳細については、Connect アセットの使用 を参照してください。
  • プロモート接続の追加: プロモートプラットフォームへの接続を追加できる [プロモート接続] ウィンドウを開きます。すべての接続を表示したり接続を削除したりするには、配置ツール または スコアリングツール にアクセスします。
  • ユーザー設定: ワークフローの外観を設定し、システムリソースの使用状況を指定して、ユーザーのプロジェクトにパフォーマンスを最適化する機能を提供します。詳細については、ユーザー設定 を参照してください。
    • ユーザー設定の編集: 詳細については、ユーザー設定 を参照してください。
    • 終了時にレイアウトと設定を保存: プログラムの終了時に、GUI レイアウトとユーザー指定の設定を保存します。
    • レイアウトと設定を今すぐ保存: このオプションを選択すると、GUI レイアウトとユーザー指定の設定が保存されます。
    • デフォルトに戻す: GUI レイアウトを元の方向に戻します。
  • 詳細オプション
    • ワークフローの比較: 2 つのワークフローを比較し、ビジュアルインジケータを使用して相違点をすばやく特定します。手順および詳細については、ワークフローの比較 を参照してください。
    • ワークフローのロック: ワークフローのコピーを保存して実行できるようにしますが、Alteryx Designer では開いたり編集したりすることはできません。手順と詳細については、ワークフローのロック を参照してください。
    • データ接続の管理: 一元的な場所からデータ接続を作成および管理します。作成した接続と共有している接続を表示したり、新しい接続を追加したりできます。詳細については、データ接続の管理 を参照してください。
    • インデータベース接続の管理: インデータベース接続を一元的な場所から作成および管理します。既存のインデータベース接続を表示し、新しいインデータベース接続を追加します。詳細については、インデータベース接続の管理 を参照してください。
    • HTML 開発者ツールを表示: Chromium 組み込みフレームワーク を使用するツールまたはウィンドウを選択すると、Alteryx HTML 開発者ツール ウィンドウが自動的に開きます。
    • システム設定: システムリソースの使用状況を指定して、アプリケーションのパフォーマンスを最適化する機能を提供します。システム設定を変更するには管理者権限が必要です。詳細については、ユーザー設定 を参照してください。
    • ワークフロー依存関係: ワークフローおよび特定のデータセットに関連付けられた入出力パスを制御します。詳細については、ワークフロー依存関係 を参照してください。
  • 予測ツールのダウンロード: 予測ツールは R プログラミング言語を使用します。オプション > 予測ツールのダウンロード に移動し、Alteryx ダウンロードとライセンス ポータルにサインインして、R ツール で使用されるパッケージと R ツールをインストールします。

ヘルプメニュー

これらのオプションを使用すると、Alteryx Designer のヘルプに素早くアクセスできます。

  • Alteryx ヘルプ: Designer のヘルプを開きます。F1 のキーボードショートカットを使用してヘルプにアクセスすることもできます。
  • チュートリアル: Designer でのワークフローの構築について紹介しているチュートリアルワークフローを開きます。
  • サンプルワークフロー: スターターキットなどの外部インストールを含む、Designer で利用可能なサンプルワークフローを開きます。詳細については、サンプルワークフロー を参照してください。
  • サンプルデータセット: Designer で利用可能なサンプルデータセットを開きます。
  • コミュニティ: ユーザーフォーラム、サポートに関する質問、ワークフロー変換、FAQ などにアクセスできる Alteryx コミュニティサイトへのリンクです。
  • 新機能: Designer の現在のリリースバージョンの新機能ヘルプページを開きます。このページでは、最後の公式リリース以降の新機能と拡張機能について説明します。最新機能と拡張機能については、新機能 をご覧ください。
  • アップデートの確認: Designer は現在のバージョンよりも新しいバージョンが利用可能かどうかをチェックします。この機能にはインターネット接続が必要です。詳細については、バージョンの更新 を参照してください。
  • Alteryx ダウンロード: 最新バージョンのソフトウェアをダウンロードできる Alteryx ダウンロードとライセンス ポータルを開きます。
  • About: Designer のバージョン情報とライセンスの個別シリアル番号を持つダイアログボックスを開きます。
  • プライバシーポリシー: プライバシーポリシー にアクセスします。
  • エンドユーザー向けライセンス契約: エンドユーザー向けライセンス契約 にアクセスします。

ローカライゼーションメニュー (地球アイコン)

Designer の言語バージョンを選択します。オプションには以下が含まれます。

  • English
  • 简体中文 (簡体字中国語)
  • Français (フランス語)
  • Deutsch (ドイツ語)
  • Italiano (イタリア語)
  • 日本語 (日本語)
  • Português (ポルトガル語)
  • Español (スペイン語)

ローカライゼーションメニューを使用すると、ローカライゼーションユーザー設定 にすばやくアクセスすることもできます。

ツールバー

メインメニューの上にあるツールバーを使用すると、次のアクションにアクセスできます。

Image showing the Designer toolbar with icons for open workflow, save, cut, copy, paste, undo, and redo.
  • ワークフローを開く (Ctrl+O): ファイルの場所を参照して、以前に作成したワークフローを開きます。
  • 保存 (Ctrl+S): アクティブなワークフローを保存します。
  • 切り取り (Ctrl+X): オブジェクトを削除し、そのまま貼り付けられるようにクリップボードにコピーします。
  • コピー (Ctrl+C): オブジェクトをクリップボードにコピーします。
  • 貼り付け (Ctrl+V): コピーしたオブジェクトを貼り付けます。
  • 元に戻す (Ctrl+Z): 最後の操作を自動的に取り消します。動作は履歴的に記録され、最大32の動作を元に戻すことができます。
  • やり直し (Ctrl+Y): 取り消した操作を繰り返します。
役に立ちましたか?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.