Orange polygon containing globe.

レポートマップツール

バージョン:
2021.3
Last modified: September 25, 2020

[レポート マップ] を使用して、ワークフローからマップ イメージを作成します。 このツールは、複数の空間入力を受け入れ、これらの入力を重ねることができ、テーママップの作成をサポートします。 凡例、縮尺、参照レイヤーなどの他のカートグラフィック フィーチャを含めることができます。

マップにヘッダーまたはフッターを含めるには、マップ ツールの直下に [レポート テキスト] ツール を追加 し、[既存のフィールドにテキストを添付] を選択して 、[マップ] を選択します。 すべてのマップは、球状メルカトル投影法で描画されます。

ツール設定

[レポートマップ]ツールには、構成可能な多くのオプションがあります。 ツールのインターフェイスは、マップのプレビューとマップの構成の2つの主要なセクションに分かれています。

マップのプレビュー

レイヤー スタイルを適用すると、[ プレビュー(クリックして拡大)] ウィンドウに、構成されたスタイルを含むマップが表示されます。 プレビューは、実行時間前にサンプルデータを使用します。 ワークフローを実行して、実際のデータと、結果のマップの正確な表示を確認します。

  • 更新: ワークフローを再実行せずに新しく構成されたマップ スタイルを読み込むには、[更新] リンクを選択します。
  • プレビュー イメージを選択すると、マップ コンテンツを含む大きなウィンドウが表示されます。 大きなウィンドウでは、 ズームインズームアウト (マップナビゲーションのスクロールバーあり)、 実際のサイズウィンドウに合わせるなどのナビゲーションを追加できます。

特定の変更 (たとえば、グループ化を有効にする、主題を適用する、ズームを変更する) では、ワークフローの再実行またはプレビュー ウィンドウの更新が必要になります。

マップ構成

[設定] タブ

[設定]タブには、結果のマップ イメージの一般的な仕様が含まれています。

マップ サイズ (W x H):マップ サイズをインチで指定します。デフォルトのサイズは、幅 8 インチ、高さ 6 インチです。 マップの凡例が指定されている場合、指定したサイズには凡例が含まれます。 レンダリングされたマップ サイズは、レンダリング ツールの仕様に基づいて、出力レポートに収まるように、このマップ サイズとは若干異なる場合があります。

[既定の距離の単位]が [キロメートル] に設定されている場合、このフィールドはミリメートル単位で計算されます。 ローカリゼーションを参照してください。

マップのサイズとメモリ

マップサイズは30,000,000ピクセルに制限されています。 この制限に近づくサイズ マップがあると、Designer がメモリ不足になる可能性があります。

解像度: 画像の解像度を指定します。

  • 解像度を低くするとファイルサイズが小さくなり、モニタでの表示に最適です。
  • 解像度が高いほど、はるかに向上した印刷品質のより大きなファイルを作成できます。

スケール: スケールバーの測定単位を指定します。 縮尺記号は、マップ イメージの左下隅に表示されます。

  • なし: マップ イメージに縮尺記号が表示されません。
  • フィート: スケールバーはフィート単位で表示されます。
  • メートル: スケールバーはメートル単位で表示されます。
  • マイル: スケールバーはマイル単位で表示されます。
  • キロメートル: スケールバーはキロメートル単位で表示されます。

[参照ベースマップ]: ドロップダウン リストを使用して、マップ イメージに含める参照レイヤーのセットを指定します。 このリストには、現在インストールされているすべてのmapfile / layersetsが含まれています。

デフォルトのデータセットを設定するには、[オプション] > [ユーザー設定] > [ユーザ設定の編集]に移動し、[データセットのデフォルト]タブを選択します。 参照: ユーザー設定を参照してください。

レンダリングされたマップで TomTom ベースマップを使用する場合は、次の著作権を使用してください。

©[今年]トムトム。 All rights reserved. この資料は、TomTomまたはそのサプライヤーが所有する著作権保護、データベース権利保護およびその他の知的財産権の所有物および主題です。 この資料の使用は、ライセンス契約の条件の対象となります。 この資料の不正なコピーまたは開示は、刑事および民事責任につながります。

レンダリングされたマップで航空画像ベースマップを使用する場合は、この著作権を使用して、適用される年にアポイントを付けます。

© [今年] デジタルグローブ

背景色: カラー ピッカーを使用して、マップ イメージの背景色をコントロールします。 デフォルトは R=253, G=254, B=255 で、画像とページを区別します。

マップ ドロップ シャドウ: ドロップダウン リストを使用して、マップにドロップ シャドウのスタイルを適用するかどうか指定します。

範囲を拡張する 0.5 マイルの最小幅の場合は、範囲 10% の場合 : デフォルト値は 10% と .5 マイルを調整できます。 ズーム レベルを拡大または縮小するには、拡大または縮小する数値 (たとえば、ズーム レベルを 10% 増やして表示する割合を表す) を入力します。

  • 正の数はズームレベルを増やし(ズームアウト)、負の数値はズームレベルを減少します(ズームイン)。
  • 入力する値は整数で、値は -99 から 100 の範囲です。
[データ] タブ

[データ] タブには、マップ ツールに入るデータストリームを処理するための仕様が含まれています。

このタブには2つのペインがあります。 左側には、着信データ接続が表示されます。 右側には、選択したデータ接続のオプションが表示されます。

着信データ接続を構成するには、接続名を選択して左側のレイヤーをハイライト表示し、右側でそのレイヤーのプロパティを編集します。 接続には2種類あります。

  • 着信接続: 別のデザイナー ツールからマップ ツールに送り込まれる接続ストリーム。
  • ファイル接続: Alteryx が作成されたマップ イメージ内の空間オブジェクトを表示するために使用する外部ファイル。

左側のペインの上にあるボタンを使用して、接続を管理できます。

  • [+] ボタンをクリックすると、マップ ツールにデータ接続が追加されます。 既存の接続からまたはファイルからデータ接続を追加できます。 接続を追加するには、接続の種類を選択し、[追加] ボタンを選択します。
  • 「-」ボタンは、選択したデータ接続をレイヤーコントロールから削除します。

各データ接続に対して、次のオプションを構成します。

  • データ接続名: データ接続名は、デフォルトで接続名または使用されているファイル名になります。
  • 空間フィールド: ドロップダウンを使用して、マップ イメージに含める空間オブジェクトを指定します。 接続ストリーム内のすべての空間オブジェクト フィールドがこのリストに表示されます。 [すべての空間オブジェクト] は既定で選択されています。
  • グループ化フィールド: オプションの設定。 指定すると、レコードのグループごとにマップ イメージが作成され、複数のマップ イメージが作成されます。マップ ツールでのグループ化は、他のデザイナー ツールとは少し異なる動作をします。 グループ分けに使用されるすべてのフィールドは、まったく同じフィールドタイプを持つ必要があります。つまり、Int16とInt32を混在させることはできません。 Null 値と空の値は、同じグループ内で同じように扱われます。
  • 主題フィールド: オプション設定。 指定すると、レイヤーのマップ オブジェクトはレコード データに基づいてスタイル設定されます。 主題のスタイルは [レイヤー] タブで行います。
  • ラベル フィールド: マップ上でラベルを付けるデータ フィールドを指定します。 すべてのデータ フィールドは、ラベルなしの場合は [なし] を 含むドロップダウン リストで使用できます。
[レイヤー] タブ

[レイヤー]タブには、入力データがマップ上でどのように表示されるのかによって整理された[レポート マップ]ツールにストリーミングされた接続が含まれています。 マップオブジェクトを操作できます。

[マップ]ツールに流入する接続は、レイヤーに編成されます。 レイヤーは左ペインにあります。 レイヤーは、[データ]タブの[データ接続名]で表示されます。 レイヤーはリストと同じ順序でマップ上に描画されるため、リスト内の最上位項目のマップ オブジェクトが結果のマップの上に表示されます。

左側のリストでレイヤ名を選択すると、レイヤの基本的な表示オプションが表示されます。

  • レイヤー: 凡例に表示するレイヤーの名前を指定します。 何も指定しない場合は、接続文字列名が使用されます。 レイヤー名は、レイヤーコントロールリストの左側のパネルに表示されます。
  • データ接続: レイヤーのデータ接続を参照します。 ドロップダウンには、[データ] タブで設定されたデータ接続名が含まれます。
  • Showin凡例に表示 : 選択すると、レイヤーがマップの凡例に含まれます。
  • [レイヤーにズーム]: 選択すると、マップはレイヤーの範囲にズームされ、すべてのオブジェクトが結果のマップに表示されます。
  • 無効: このレイヤーを選択すると、最終的なマップには表示されません。

レイヤー名の左側にある「+」を選択して、スタイルパラメータを表示します。 個別のパラメータ ([スタイル]、[ラベル]、[テーマ] ) を選択して設定します。既定のスタイルは、ポリゴン、ライン、ポイントに対して設定されます。

スタイルの設定は編集可能です。 ベース レイヤーのスタイルを設定するには、レイヤー名を選択して[スタイルを上書き]を選択し、レイヤーの下に [スタイル] オプションを表示します。 使用可能な設定は、レイヤの種類によって異なります。 すべてのスタイルは、右上隅にある[デフォルトをリセット]リンクを使用してリセットできます。

ポイント スタイルの構成

[ポイント スタイル]:マップ上でポイントのスタイルを設定する方法を選択します。 選択肢には次のものが含まれます。

Image showing available points styles.
  • カスタム ポイント: カスタム ポイントを使用する必要があるかどうかを指定します。ボックスを選択し、イメージ (.png、.jpg、および .gifs) を参照します。 イメージはワークフローに格納されます。
  • サイズ: ポイントのサイズをピクセル単位で指定します。 デフォルトは 10です。
  • : 点の色を指定します。 デフォルトはです。
  • [アウトライン色]:点のアウトライン色を指定します。 デフォルトはなしです。
  • アウトラインサイズ: ポイントのアウトラインサイズをピクセル単位で指定します。 デフォルトは 1 ピクセルです。
  • 不透明度: 点の不透明度を指定します。 デフォルトは100%です。

線スタイルの設定

  • : 線の色。 デフォルトは 灰色です。
  • サイズ: ピクセル単位の線のサイズです。 デフォルトは 4です。
  • オーバーレイを使用: オーバーレイをラインに使用する場合に指定します。 線の色とは別の色でオーバーレイを使用すると、輪郭のように見える線の効果が得られます。 オーバーレイサイズは、線サイズより小さくする必要があります。
    • オーバーレイ: オーバーレイの色は、線に対して選択した色とは異なる必要があります。
    • オーバーレイサイズ: オーバーレイのサイズ (ピクセル単位) は、線のサイズよりも小さくする必要があります。
  • 不透明度: 点の不透明度の割合。デフォルトは 100% です。

ポリゴン スタイルの設定

  • アウトライン: ポリゴンのアウトライン色。 デフォルトは です。
  • アウトラインサイズ: ポリゴンのアウトライン サイズ (ピクセル単位)。 デフォルトは 3px です。
  • [塗りつぶし色]を使用 : ポリゴンを塗りつぶすかどうかを指定します。 既定値は [はい] です。[塗りつぶし色]を使用して、ポリゴンの塗りつぶし色を指定します。 デフォルトは R=152,G=133,B=118 です。
  • ハッチング: ポリゴンにハッチングを含めるかどうかを指定します。 デフォルトは [いいえ] です。
    • ハッチ色: ハッチ色。 デフォルトはです。
    • [ハッチングスタイル]: ハッチングの種類。 デフォルトは [単一] です
    • [ハッチングサイズ]: ハッチング サイズの値を変更する場合に選択します。 既定値は1px です。
    • [ハッチング間隔]: ハッチング間隔の値を変更する場合に選択します。 既定値は10px です。
    • ハッチング角度: ハッチング角度の値を変更する場合に選択します。 既定値は45度です。
  • 不透明度: 0 (非表示) から 100 (不透明) までの値を使用して、ポリゴンの不透明度を指定します。 デフォルトは50%に設定されています。不透明度の割合は、塗りつぶしの色とアウトラインの色に影響します。

ラベル スタイルの構成

  • 角度: ラベル00、45、90、180180度、またはAUTOを描画する角度を指定して、角度を計算できるようにします。 45 90AUTO は、LINE レイヤーに対してのみ有効です。 FOLLOW は、マップ コンポーネント エンジンに対して、適切な線形フィーチャの曲線ラベルを計算するように指示します。
  • 背景色Color: ラベルの周囲に背景の四角形を描画する色を指定します。 これはデフォルトではオフになっています。
  • 背景の影の: ラベルの周囲に背景の四角形の影を描画する色を指定します。 これはデフォルトではオフになっています。
  • 背景の影のサイズ: 背景の影をオフセットする距離を指定します。 デフォルトは1です。
  • バッファー: ラベルの周囲のパディングをピクセル単位で指定します。 この設定は、読みやすさを向上させるためにテキストの周りのスペースを維持するのに便利です。 デフォルトは0です。
  • : ラベルのテキストの色。
  • フォント: ラベルテキストのフォントの種類/名前。
  • フォントサイズ: ラベル テキストのフォントのサイズ。
  • 強制: ラベル テキストが重なっていても、ラベルを強制的にオンにします。デフォルトは false です。
  • 最小距離: 重複するラベル間の最小距離をピクセル単位で指定します。
  • 最小機能サイズ: フィーチャにラベルを付ける必要がある最小サイズをピクセル単位で指定します。 ライン データでは、表示されるラインの全体の長さが使用され、ポリゴン フィーチャの場合は、境界ボックスの最小の寸法が使用されます。
  • アウトライン色: テキストの周囲にアウトラインを描画する色。
  • アウトラインサイズ: ラベルテキストの周囲に描画するアウトラインサイズ(ピクセル単位)。
  • 位置: ラベル付け点を基準にしたラベルの位置を指定します。 オートは、他のラベルと干渉しないラベルの位置を計算します。 すべての位置が競合を引き起こす場合、ラベルは描画されません(ラベルの FORCE パラメータが"yes"に設定されていない場合)。
  • 優先度: 複数のレイヤーのラベルが重なったときに表示するラベルを制御します。 優先順位が最も高いレイヤが表示されます。 最大の優先度は10です。
  • の色: ラベルのドロップシャドウの色。
  • シャドウオフセット: ドロップ シャドウのオフセット (ピクセル単位)。
  • 囲み文字: ラベル テキストの行末条件を表す文字で、複数行のラベルになります。

テーマ スタイルの構成

[データ] タブで選択した主題フィールドに、スタイルを設定できるテーマが含まれている各レイヤー。

主題スタイルはオブジェクト スタイルをオーバーライドするので、レイヤーにマップ テーマがある場合は、オブジェクト スタイルを指定する必要はありません。 ただし、テーマに設定するマップ レイヤーにラベルを付けることを選択することもできます。

タイルの方法: 使用するタイルの方法を指定します: スマート タイル、均等タイル数、均等タイル サイズ、または一意の値。 選択した Tile メソッドに応じて、これらの設定を使用できます。

  • スマートタイル: 指定したフィールドの値の標準偏差に基づいてタイルを作成します。 割り当てられたタイルは、レコードの値が平均範囲内か(=0)、平均を上回るか(1)、平均を下回るか(-1)などを示します。
  • 等しい範囲: タイル フィールドの最小値と最大値が決定されます。 範囲は同じサイズのサブ範囲に分割され、レコードはこれらの範囲に基づいてタイルに割り当てられます。
  • 等しいレコード: 入力レコードは、主題フィールドで並べ替えられ、指定したタイルの量に分割され、各タイルに同じ量のレコードが割り当てられます。 これは、「テーマの」フィールドでソートされた後の入力ストリームで、レコードの位置のみに基づいています。 入力のレコード数は、指定したタイル数で等しく割り切られるわけではありません。
  • 固有: 指定したフィールドの一意の値ごとに、一意のタイルが割り当てられます。
  • 手動タイル: ユーザーは、各範囲の下限値を別々の行に入力することで、タイルのカットオフ値を指定できます。 たとえば、 異なるラインで 2、4、6、および 8 を入力すると、2、2-4、4-6、6-8、8 の下の 5 つのタイルが表示されます。

[管理] ボタンを使用して、レイヤの順序と外観を制御します。

  • 上矢印ボタンは、クリックごとに選択したレイヤーを 1 つ上の位置に並べ替えます。
  • 下向き矢印は、クリックごとに選択したレイヤーを 1 つ下の位置に並べ替えます。
  • 「+」ボタンは、使用可能な接続からレイヤーを追加します。 これは、スタイリングの目的で、重複レイヤーをレイヤーの上に重ねる場合に便利です。
    • ポイントレイヤー: 使用可能な接続を表示し、選択した接続のポイントレイヤーを追加します。
    • レイヤー: 使用可能な接続を表示し、選択した接続の線レイヤーを追加します。
    • ポリゴンレイヤー: 使用可能な接続を表示し、選択した接続に Polygons レイヤーを追加します。
  • 「-」ボタンは、選択したレイヤーをレイヤーコントロールから削除します。
  • [上/下へ移動] ボタンをクリックすると、選択したレイヤーをすばやく並べ替える複数のオプションが表示されます。
    • [上へ移動]: 選択したレイヤーをレイヤーリストの最初の位置に移動します。
    • [下へ移動]: 選択したレイヤーをレイヤーリストの最後の位置に移動します。
    • グループの先頭に移動: 選択したレイヤーをグループの先頭に移動します。
    • グループの下に移動: 選択したレイヤーをグループの最後の位置に移動します。

グループは、レイヤー タイプ (ポイント、ライン、ポリゴン) として定義され、ユーザー レイヤまたは参照ベース マップ レイヤーのどちらであるかが定義されます。 グループの基本的な順序は次のとおりです。

  • ユーザーポイント
  • ベース レイヤ ポイント
  • ユーザーライン
  • ベース レイヤー ライン
  • ユーザー ポリゴン
  • ベース レイヤー ポリゴン
[凡例] タブ

[凡例] タブには、マップ イメージに付随する凡例をカスタマイズするための多くの設定可能なオプションがあります。

  • 位置: マップに関連してマップの凡例が表示される場所を選択します。
    • [なし]: 凡例は出力されません。
    • 個別のフィールド: 凡例は、マップから別のレポート スニペットとして処理されます。 [フィールドを分離]を選択した場合は、レンダリングの前にレイアウト ツールまたはオーバーレイ ツールを使用する必要があります。
    • 左にレイアウト: 凡例はマップイメージの左側に表示されます。
    • 右にレイアウト: 凡例はマップ イメージの右側に表示されます。
  • 背景色: 凡例ボックスの色。 背景色は、マップオブジェクトの特定のスタイルを正しく表示するために、最も顕著なマップ機能と同じ色でなければなりません。 たとえば、ポリゴンの透過表示は、凡例の背景色がマップ イメージの上に配置されているポリゴンと一致しない限り、凡例で同じように見えない場合があります。
  • テキストの色: 凡例のテキストの色。
  • フォント: 凡例のテキストのフォント スタイル。
  • フォントサイズ: 凡例のテキストのサイズ。
  • アイコン: 凡例上のマップ レイヤーを表すために使用されるイメージのサイズ。
  • アイコンの高さ: 凡例上のマップ レイヤーを表すために使用されるイメージのサイズ。
  • 数値のカンマ区切り: ドロップダウンを使用して、数値にカンマを含めるかどうかを選択します。

このツールには式エディターが含まれているため、このツールをアプリまたはマクロワークフローで使用すると、追加の入力アンカーが表示されます。 インターフェースツールを使用して質問アンカーに接続します。 参照: インターフェースツール

役に立ちましたか?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.