メインメニュー

バージョン:
2022.1
Last modified: May 05, 2022

Alteryx Designer のメインメニューから、さまざまなウィンドウと一般的なアクションにアクセスします。

Image showing the Alteryx Designer main menus.

ファイルメニュー

これらのオプションは、ワークフローを作成して作業することに固有です。

  • 新しいワークフロー (Ctrl+N): 新しいワークフロー (*.yxmd) を作成します。
  • 最近の使用を開く: 最近アクセスして保存したワークフローを表示します。
  • ワークフローを開く: 以前に作成したワークフローを開きます。
    • 参照: ワークフローが保存されたファイルの場所を参照してワークフローを開きます。
    • 会社の Alteryx Server: 会社の Alteryx Server (プライベート Gallery) からワークフローを開きます。会社の Alteryx Server に接続している場合は、接続名順に接続が一覧表示されます。
    • 新しい Server を追加: 会社の Alteryx Server への接続を作成します。
    • Alteryx Platform: Alteryx Platform に保存されているワークフローを開きます。Alteryx Platform に接続している場合は、接続名順に接続が一覧表示されます。Alteryx Platform に接続していない場合は、オプション > Alteryx のリンクを管理 に移動し、新しい Platform リンクを追加します
    • 自動復元されたファイルを開く: 自動保存されたファイルのリストを開きます。開いているファイルは定期的に自動保存されます。自動保存間隔は既定で有効になっており、ユーザー設定 で変更できます。
  • ワークフローグループを開く: ワークフローグループに保存されている複数のワークフローを開きます。詳細については、ファイルディレクトリからワークフローグループを開く を参照してください。
  • Manage Connections: データ接続マネージャー (DCM) が有効になっている場合は、ここをクリックしてデータソースを制御し、資格情報を使用してデータソースを認証します。 
  • 保存 (Ctrl+S): アクティブなワークフローを保存します。
  • 名前を付けて保存: アクティブなワークフローを選択した場所に保存します。
    • 参照: ファイルの場所を参照し、そこにワークフローを保存します。
    • Alteryx Server
      • 会社の Alteryx Server への既存の接続がここに表示されます。
      • 新しい Server を追加: 会社の Alteryx Server への接続を作成し、そこにワークフローを保存します。
    • Alteryx Platform: ワークフローを Alteryx Platform に保存します。  Alteryx Platform に接続している場合は、接続名順に接続が一覧表示されます。Alteryx Platform に接続していない場合は、オプション > Alteryx のリンクを管理 に移動し、新しい Platform リンクを追加します
  • ワークフローグループの作成: 個々のワークフローとして保存された、開いているすべてのワークフローを、一つのワークフローグループとしてまとめて保存します。詳細については、ワークフローグループを保存する を参照してください。
  • 印刷: 印刷時にワークフローがどのように表示されるかをプレビューします。
  • 印刷設定: ワークフローを印刷するための設定を開きます。
  • 終了: Designer を閉じます。

編集メニュー

これらのオプションは一般的な編集機能です。

  • 元に戻す (Ctrl+Z): 最後の操作を自動的に取り消します。動作は履歴的に記録され、最大32の動作を元に戻すことができます。
  • やり直し (Ctrl+Y): 取り消した操作をやり直します。
  • 切り取り (Ctrl+X): オブジェクトを削除し、そのまま貼り付けられるようにクリップボードにコピーします。
  • コピー (Ctrl+C): オブジェクトをクリップボードにコピーします。
  • 貼り付け (Ctrl+V): コピーしたオブジェクトを貼り付けます。
  • 削除 (Del): 選択したオブジェクトを削除します。
  • 検索 (Ctrl+F): 検索と置換 ウィンドウの 検索 タブを開きます。検索と置換 ウィンドウを使用して、ワークフロー内のテキストを検索したり、検索して置換したりできます。この機能の詳細については、検索と置換 のドキュメントを参照してください。
  • 置換 (Ctrl+H): 検索と置換 ウィンドウの 置換 タブを開きます。検索と置換 ウィンドウを使用して、ワークフロー内のテキストを検索したり、検索して置換したりできます。この機能の詳細については、検索と置換 のドキュメントを参照してください。

表示メニュー

表示 メニューを使用して、これらのウィンドウを開いたり閉じたりします。

オプションメニュー

これらのオプションを使用すると、ワークフロー、スケジューリング、ライセンス機能、およびユーザー設定にアクセスできます。

  • ワークフローの実行: ワークフローを実行します。Ctrl+R のキーボードショートカットを使用すると、ワークフローも実行されます。ワークフローの実行中はアイコンが 停止 に変わります。
  • ワークフローのスケジュール設定: 特定の時間と頻度で実行するワークフローのスケジュールを設定します。スケジューラーサービスは、Alteryxインストールの一部として有効にする必要があり、またユーザーが適切なライセンスを持っている必要があります。すべてのユーザーに適切なライセンスが付与され、サービスが適切に構成されているよう、管理者によって適切なライセンスがインストールされている必要があります。詳細については、ワークフローのスケジュール設定 を参照してください。
  • スケジュールの表示: ワークフローとアプリケーションのスケジュール設定、キュー内のジョブの確認、および完了したジョブに関する情報の表示を実行します。スケジューラーサービスは、Alteryxインストールの一部として有効にする必要があり、またユーザーが適切なライセンスを持っている必要があります。すべてのユーザーに適切なライセンスが付与され、サービスが適切に構成されているよう、管理者によって適切なライセンスがインストールされている必要があります。詳細については、スケジュールの管理 を参照してください。
  • 分析アプリの実行: 分析アプリの選択 ウィンドウを開き、アプリを参照して編集または実行できるようにします。詳細については、分析アプリの選択 を参照してください。
  • ワークフローのエクスポート: ワークフローのエクスポート ウィンドウを開き、アクティブなワークフローを取り込みすべての依存関係とともに *.yxzp ファイルに圧縮することができます。詳細については、ワークフロー管理 を参照してください。
  • ライセンスの管理: License Manager を使用して、Alteryx ライセンスを表示、追加、および削除します。
  • Alteryx のリンクを管理: Designer を Alteryx Platform にリンクします。手順については、Alteryx のリンクを管理 を参照してください。
  • 接続資格情報の管理: 接続サインイン ウィンドウを開き、接続にアクセスできるようにします。詳細については、Connect アセットの使用 を参照してください。
  • プロモート接続の追加: プロモートプラットフォームへの接続を追加できるプロモート接続ウィンドウを開きます。すべての接続を表示したり接続を削除したりするには、配置ツール または スコアリングツール にアクセスします。
  • ユーザー設定: ワークフローの外観を設定し、システムリソースの使用状況を指定して、ユーザーに固有のプロジェクトのパフォーマンスを最適化します。詳細については、ユーザー設定 を参照してください。
    • ユーザー設定の編集: 詳細については、ユーザー設定 を参照してください。
    • 終了時にレイアウトと設定を保存: プログラムの終了時に、GUI レイアウトとユーザー指定の設定を保存します。
    • レイアウトと設定を今すぐ保存: GUI レイアウトとユーザー指定の設定を保存します。
    • デフォルトに戻す: GUI レイアウトを元の方向に戻します。
  • 詳細オプション
    • ワークフローの比較: 2 つのワークフローを比較し、ビジュアルインジケータを使用して相違点をすばやく特定します。手順および詳細については、ワークフローの比較 を参照してください。
    • ワークフローのロック: ワークフローのコピーを保存して実行できるようにしますが、Alteryx Designer では開いたり編集したりすることはできません。手順と詳細については、ワークフローのロック を参照してください。
    • データ接続の管理: 一元的な場所からデータ接続を作成および管理します。作成した接続と共有している接続を表示したり、新しい接続を追加したりできます。詳細については、データ接続の管理 を参照してください。
    • インデータベース接続の管理: インデータベース接続を一元的な場所から作成および管理します。既存のインデータベース接続を表示し、新しいインデータベース接続を追加します。詳細については、In-DB 接続の管理 を参照してください。
    • HTML 開発者ツールを表示: Chromium 組み込みフレームワーク を使用するツールまたはウィンドウを選択すると、Alteryx HTML 開発者ツール ウィンドウが自動的に開きます。
    • システム設定: システムリソースの使用状況を指定して、アプリケーションのパフォーマンスを最適化します。システム設定を変更するには管理者権限が必要です。詳細については、システム設定 を参照してください。
    • ワークフロー依存関係: ワークフローおよび特定のデータセットに関連付けられた入出力パスを制御します。詳しくは、ワークフロー依存関係 を参照してください。
  • 予測ツールのダウンロード: 予測ツールは R プログラミング言語を使用します。オプション > 予測ツールのダウンロード に移動し、Alteryx ダウンロードとライセンス ポータルにサインインして、R ツール で使用されるパッケージと R ツールをインストールします。

ヘルプメニュー

これらのオプションを使用すると、Alteryx Designer のヘルプに素早くアクセスできます。

  • Alteryx ヘルプ: Designer のヘルプを開きます。F1 のキーボードショートカットを使用してヘルプにアクセスすることもできます。
  • チュートリアル: Designer でのワークフローの構築について紹介しているチュートリアルワークフローを開きます。
  • サンプルワークフロー: スターターキットなどの外部インストールを含む、Designer で利用可能なサンプルワークフローを開きます。詳細については、サンプルワークフロー を参照してください。
  • サンプルデータセット: Designer で利用可能なサンプルデータセットを開きます。
  • コミュニティ: ユーザーフォーラム、サポートに関する質問、ワークフロー変換、FAQ などにアクセスできる Alteryx コミュニティサイトへのリンクです。
  • 新機能: Designer の現在のリリースバージョンの 新機能ヘルプページ を開きます。このページでは、最後の公式リリース以降の新機能と拡張機能について説明します。
  • 更新の確認: Designer で現在のバージョンよりも新しいバージョンが利用可能かどうかをチェックします。この機能にはインターネット接続が必要です。詳細については、バージョンの更新 を参照してください。
  • サポートファイルを生成: チームが問題を適切にトラブルシューティングするのに役立つ情報を含むテクニカルサポートファイルを生成します。このファイルには、ランタイム設定とシリアル番号 (メールアドレス) が含まれています。このファイルは、サポートケースの送信時にアップロードできます。ファイルの内容を確認し、含める必要がないものはすべて削除してください。
  • Alteryx ダウンロード: 最新バージョンのソフトウェアをダウンロードできる Alteryx ダウンロード & ライセンス ポータルを開きます。
  • About: Designer のバージョン情報とライセンスの個別シリアル番号を持つダイアログボックスを開きます。
  • プライバシーポリシー: プライバシーポリシー にアクセスします。
  • エンドユーザー向けライセンス契約: エンドユーザー向けライセンス契約 にアクセスします。

ローカライゼーションメニュー (地球アイコン)

Designer の言語バージョンを選択します。オプションには以下が含まれます。

  • English
  • 简体中文 (簡体字中国語)
  • Français (フランス語)
  • Deutsch (ドイツ語)
  • Italiano (イタリア語)
  • 日本語 (日本語)
  • Português (ポルトガル語)
  • Español (スペイン語)

ローカライゼーションメニューを使用すると、ローカライゼーションユーザー設定 にすばやくアクセスすることもできます。

ツールバー

メインメニューの上にあるツールバーを使用すると、次のアクションにアクセスできます。

Image showing the Designer toolbar.
  • ワークフローを開く (Ctrl+O): ファイルの場所を参照して、以前に作成したワークフローを開きます。
  • 保存 (Ctrl+S): アクティブなワークフローを保存します。
  • 切り取り (Ctrl+X): オブジェクトを削除し、そのまま貼り付けられるようにクリップボードにコピーします。
  • コピー (Ctrl+C): オブジェクトをクリップボードにコピーします。
  • 貼り付け (Ctrl+V): コピーしたオブジェクトを貼り付けます。
  • 元に戻す (Ctrl+Z): 最後の操作を自動的に取り消します。動作は履歴的に記録され、最大32の動作を元に戻すことができます。
  • やり直し (Ctrl+Y): 取り消した操作を繰り返します。
このページは役に立ちましたか?

Alteryx 製品のご利用中に何か問題がございましたら、Alteryx コミュニティにアクセスするか、サポートにお問い合わせください。このフォームを送信できない場合E メールでお送りください。