マクロ

バージョン:
2022.3
Last modified: August 23, 2021

マクロとは、別のワークフローに挿入できる単一のツールに組み込まれたワークフローまたはツールのグループです。繰り返し実行する分析プロセスを保存するマクロを作成します。毎回分析プロセスを作成し直すことなく、ワークフロー内でマクロを使用します。

デザイナーで使用する、または Alteryx Analytics ギャラリー (gallery.alteryx.com) またはプライベートギャラリーで共有するためにアップロードするマクロを yxmc ファイルとして保存します。

マクロのタイプ

  • 標準マクロ: このマクロは、ワークフローに挿入できるツールとしてワークフロー内のプロセスをパッケージ化するように設計されています。
  • バッチマクロ: このマクロは、ワークフロー内で複数回実行され、各実行後に出力が作成されます。マクロは、各レコードまたはデータの選択されたレコードグループに対して1回実行されます。マクロには、入力として[制御パラメータ]ツールが必要です。「バッチ マクロ」を参照してください。
  • 反復マクロ: このマクロは、ワークフロー内で、条件が満たされるまで、または構成で設定された回数または連続的に実行されます。反復マクロを参照してください。
  • 場所オプティマイザーマクロ: このマクロは、最適な場所または場所を識別するためにネットワーク解析で使用できる反復マクロです。「位置オプティマイザマクロ」を参照してください。

マクロを構築する

マクロは、[インターフェース]ツールを使用して作成されたワークフローとユーザーインターフェースで構成されます。「インターフェイス ツールとインターフェイスデザイナ ウィンドウ」を参照してください。

または、HTML - GUI ライブラリ ツールを使用してカスタム ユーザー インターフェイスを作成することもできます。

マクロを構築するには:

既存のワークフローを使用している場合は、マクロとして保存するワークフローの部分を選択し、新しいワークフロータブにコピーしアンドペーストします。

  1. 新しいワークフローを作成するか、既存のワークフローを開きます。
  2. マクロ入力を追加する:
    • ワークフローに入力が含まれていない場合は、[マクロ入力]ツールを追加します。
    • ワークフローに入力ツール (入力データやテキスト入力ツールなど) が含まれている場合は、ツールを右クリックし、[マクロ入力に変換]を選択します。
  3. [マクロ入力]ツールを構成します。マクロ入力ツールを参照してください。
  4. [マクロ出力]ツールを追加して構成します。「マクロ出力ツール」を参照してください。

デフォルトでは、[マクロ入力]ツールがワークフローに追加されると、ワークフロータイプは標準マクロに変更されます。ワークフローに[制御パラメータ]ツールを追加すると、マクロタイプはデフォルトでバッチマクロになります。反復マクロを作成するには、マクロタイプを反復に設定します。

マクロのタイプを設定するには:

  1. キャンバスをクリックし、[ワークフロー構成] ウィンドウの[ワークフロー]タブをクリックします。
  2. [タイプ]で、[マクロ]の横で、マクロの種類を選択します。

マクロを保存する

将来の使用と共有のためにマクロを保存します。マクロを一意の名前で特定の場所に保存します。Designerでは、コンピュータまたはネットワーク上の場所にマップされたマクロリポジトリを作成し、マクロを簡単に保存してワークフローで使用することができます。

マクロを保存するには:

  1. [ファイル]> [名前を付けて保存]をクリックします。
  2. マクロを保存するとき、コンピュータまたはネットワーク上のフォルダを探し出します。
  3. マクロの一意の名前を入力し、[保存]をクリックします。

カスタムマクロを使用するワークフローを共有するには、ワークフローをエクスポートして、マクロを含むすべてのワークフローの依存関係をワークフローとともに保存するようにします。ワークフローには、マクロへの相対パスを含める必要があります。「ワークフロー管理ワークフローの依存関係」を参照してください。

マクロリポジトリを作成する

Designerで、マクロを保存した場所にマップすると、マクロリポジトリを作成してマクロを保存し、ワークフローで使用することが簡単にできます。選択した場所にあるマクロ.yxmcファイルがツールパレットのツールカテゴリに表示されます。

マクロリポジトリを作成するには:

  1. [オプション]> [ユーザー設定]> [ユーザー設定の編集]> [マクロ] に移動します。
  2. クリックします。
  3. カテゴリ名に名前を入力します。デフォルトの名前はMacrosです。
  4. クリックして、コンピュータまたはネットワークにマクロを保存する場所を参照します。

親フォルダがマクロリポジトリに既に存在する場合、検索パス内のサブフォルダを個別に追加することはできません。

デフォルトのリポジトリの場所を設定するには:

  1. リスト内のリポジトリ検索パスをクリックします。
  2. [既定値として設定] をクリックします。既定のリポジトリの横にアスタリスク (*)が表示されます。

ワークフローでマクロを使用する

マクロリポジトリに保存されているマクロを使用するには、ツールパレットでマクロを検索するか、[検索]を使用します。

ツール パレットにないマクロを使用するには、ワークフロー キャンバスを右クリックし、[マクロの挿入]を選択します。キャンバスで現在開いているマクロは、このリストから選択するか、別のマクロ* .yxmcファイルの場所を閲覧できます。

ワークフローで特定のマクロ バージョンを使用するには、マクロを右クリックし、実行するバージョンを選択します。マクロ バージョンはすべて同じディレクトリに格納する必要があります。この場所は、[ユーザー設定]で構成できます。

ワークフロー内のツールからマクロを区別するには、[ツールのマクロ インジケーターの表示]オプションを選択して、[ユーザー設定]> [キャンバス]のアイコンを表示します。「ユーザー設定」を参照してください。

マクロのワークフローを表示するには、ワークフロー内のマクロを右クリックし、[マクロを開く]を選択します。ワークフロー内のマクロは、そのマクロに対する変更が保存されると自動的に更新されます。

カスタムマクロを使用するワークフローを共有するには、ワークフローをエクスポートして、マクロを含むすべてのワークフローの依存関係をワークフローとともに保存するようにします。ワークフローには、マクロへの相対パスを含める必要があります。「ワークフロー管理ワークフローの依存関係」を参照してください。

サンプルマクロ

Alteryx Designerには、マクロの使用方法や作成方法を学習するためのマクロが含まれています。

  • コンピュータ上のプログラム ファイル: \プログラム ファイル\Alteryx\bin\RuntimeData\マクロに移動します。
  • Designer:
    • [ヘルプ]> [サンプル ワークフロー]> [チュートリアル]> [マクロのビルド]に移動します。
    • ツールパレットの一部のツールはマクロです。たとえば、[サンプル作成]ツールと[データクレンジング]ツールです。ツールを右クリックし、[マクロを開く]を選択してマクロ ワークフローを表示します。
  • Alteryx アナリティクス ギャラリー: Alteryx パブリック ギャラリーに公開されたアプリにアクセスします。
このページは役に立ちましたか?

Alteryx 製品のご利用中に何か問題がございましたら、Alteryx コミュニティにアクセスするか、サポートにお問い合わせください。このフォームを送信できない場合E メールでお送りください。