マクロ

バージョン:
Current
Last modified: May 18, 2021

マクロとは、別のワークフローに挿入できる単一のツールに組み込まれたワークフローまたはツールのグループです。繰り返し実行する分析プロセスを保存するマクロを作成します。毎回分析プロセスを作成し直すことなく、ワークフロー内でマクロを使用します。

マクロを .yxmc ファイルとして保存し、Designer で使用するか、Alteryx Analytics Gallery (gallery.alteryx.com) またはプライベート Gallery にアップロードして共有します。

マクロタイプ

  • 標準マクロ: このマクロは、ワークフロー内のプロセスを、ワークフローに挿入できるツールとしてパッケージ化するために設計されています。
  • バッチマクロ: このマクロはワークフローで複数回実行され、実行ごとに出力が作成されます。マクロは、各レコードまたはデータの選択されたレコードグループに対して1回実行されます。マクロには、入力として[制御パラメータ]ツールが必要です。
  • 反復マクロ: このマクロは、構成で設定された回数だけ、または条件が満たされるまで連続してワークフロー内で実行されます。
  • 位置最適化マクロ: このマクロは、ネットワーク分析で 1 つ以上の最適な場所を特定するために使用できる反復マクロです。

マクロを構築する

マクロは、[インターフェース]ツールを使用して作成されたワークフローとユーザーインターフェースで構成されます。詳細については、インターフェースツール および インターフェースデザイナーウィンドウ を参照してください。または、HTML-GUI ライブラリツール を使用してカスタムユーザインターフェースを作成することもできます。

マクロを構築するには、以下の手順に従います。

既存のワークフローを使用している場合は、マクロとして保存するワークフローの部分を選択し、新しいワークフロータブにコピーしアンドペーストします。

  1. 新しいワークフローを作成するか、既存のワークフローを開きます。
  2. マクロ入力を追加する:
    • ワークフローに入力が含まれていない場合は、[マクロ入力]ツールを追加します。
    • ワークフローに入力ツール (入力データツールやテキスト入力ツールなど) が含まれている場合は、そのツールを右クリックして、マクロ入力に変換 を選択します。
  3. マクロ入力 ツールを構成します。
  4. マクロ出力ツール を追加して構成します。

デフォルトでは、[マクロ入力]ツールがワークフローに追加されると、ワークフロータイプは標準マクロに変更されます。ワークフローに[制御パラメータ]ツールを追加すると、マクロタイプはデフォルトでバッチマクロになります。反復マクロを作成するには、マクロタイプを反復に設定します。

マクロのタイプを設定するには:

  1. キャンバスを選択し、[ワークフロー設定] ウィンドウで、ワークフロー タブを選択します。
  2. マクロ の隣りにある タイプ で、マクロタイプを選択します。

マクロに変換する

マクロを最初から作成するだけでなく、既存のワークフロー (またはワークフローの一部) をマクロに変換することもできます。マクロに変換する前に、次のようないくつかの制限事項があるので注意してください。

  • ワークフローでは、複数のツールを選択する必要があります。
  • 選択するすべてのツールは、連続したパス内にあり、互いに接続されている必要があります (コメント、エクスプローラーボックス、およびツールコンテナは除外されます)。
  • ツールを選択する前に、最初にワークフローを実行する必要があります。
  • 選択したツールにエラーがあってはなりません。
  • 選択したツールに In-DB ツールを含めることはできません。
  • 選択したツールは、アクションツールに接続できません。
  • マクロに変換する機能は、Python ツールでは機能しません。

マクロに変換するには、以下の手順に従いします。

  1. ワークフローで 2 つ以上のツールを選択します。クリックして、ワークフローキャンバスにドラッグします。
  2. 選択したツールの 1 つを右クリックして、ツールメニューを開きます。
  3. ドロップダウンから マクロに変換 を選択して、マクロに変換 ウィンドウを開きます。
  4. [マクロに変換] ウィンドウで、次の操作を実行します。
    • マクロの ファイル名 を入力します。
    • マクロを保存する 場所 を選択します。
    • マクロの アイコン を選択します。
  5. ワークフローまたはワークフローの一部をマクロに変換するには、変換 を選択します。このプロセスを中止するには、キャンセル を選択します。
  6. 新しく作成されたマクロファイルは Designer の新しいタブで開きますが、元のワークフローでは、選択したツールがマクロに変換されて表示されます。

マクロを保存する

将来の使用と共有のためにマクロを保存します。マクロを一意の名前で特定の場所に保存します。Designerでは、コンピュータまたはネットワーク上の場所にマップされたマクロリポジトリを作成し、マクロを簡単に保存してワークフローで使用することができます。

マクロを保存するには、以下の手順に従います。

  1. ファイル > 名前を付けて保存 を選択します。
  2. マクロを保存するとき、コンピュータまたはネットワーク上のフォルダを探し出します。
  3. マクロの一意の名前を入力して 保存 を選択します。

カスタムマクロを使用するワークフローを共有するには、ワークフローをエクスポートして、マクロを含むすべてのワークフローの依存関係をワークフローとともに保存するようにします。ワークフローには、マクロへの相対パスを含める必要があります。詳細については、ワークフロー管理 および ワークフローの依存関係 を参照してください。

マクロリポジトリを作成する

Designerで、マクロを保存した場所にマップすると、マクロリポジトリを作成してマクロを保存し、ワークフローで使用することが簡単にできます。選択した場所にあるマクロ.yxmcファイルがツールパレットのツールカテゴリに表示されます。

マクロリポジトリを作成するには、以下の手順に従います。

  1. オプション > ユーザー設定 > ユーザー設定の編集 > マクロ の順に移動します。
  2. [+] ボタンを選択します。
  3. カテゴリ名 に名前を入力します。デフォルトの名前はMacrosです。
  4. [...] ボタンを選択して、コンピューターまたはネットワーク上のマクロを保存する場所を参照します。

検索パス内のサブフォルダーは、その親フォルダーがすでにマクロリポジトリに存在する場合は、個別に追加することはできません。

既定のリポジトリの場所を設定するには、以下の手順に従います。

  1. リスト内のリポジトリ検索パスを選択します。
  2. 既定に設定 を選択します。デフォルトリポジトリーの横にアスタリスク (*) が表示されます。

ワークフローでのマクロの使用

マクロリポジトリに保存されているマクロを使用するには、ツールパレットでマクロを検索するか、[検索]を使用します。

ツールパレットにないマクロを使用するには、ワークフローキャンバスを右クリックし、挿入 > マクロ の順に選択します。キャンバスで現在開いているマクロは、このリストから選択するか、別のマクロ* .yxmcファイルの場所を閲覧できます。

ワークフローで特定のマクロバージョンを使用するには、マクロを右クリックして、実行するバージョンを選択します。マクロのバージョンはすべて同じディレクトリに保存する必要があります。この場所は ユーザー設定 で構成できます。

ワークフロー内のツールとマクロを区別するには、ツールのマクロインジケーターを表示する オプションを選択して、ユーザー設定 > キャンバス の画面に + アイコンが表示されるようにします。詳細については、ユーザー設定 を参照してください。

マクロのワークフローを表示するには、ワークフロー内のマクロを右クリックし、マクロを開く を選択します。ワークフロー内のマクロは、そのマクロに対する変更が保存されると自動的に更新されます。

カスタムマクロを使用するワークフローを共有するには、ワークフローをエクスポートして、マクロを含むすべてのワークフローの依存関係をワークフローとともに保存するようにします。ワークフローには、マクロへの相対パスを含める必要があります。詳細については、ワークフロー管理 および ワークフローの依存関係 を参照してください。

サンプルマクロ

Designer には、マクロの使用方法や作成方法を学習するためのマクロが含まれています。マクロにアクセスするには、以下の手順に従いいます。

  • コンピューターの Program Files から、\Program Files\Alteryx\bin\RuntimeData\Macros に移動します。
  • Designer で、次の操作を実行します。
    • ヘルプ > サンプルワークフロー > チュートリアル > マクロの構築 の順に選択します。
    • ツールパレットの一部のツールはマクロです。たとえば、サンプル作成ツールデータクレンジングツール です。ツールを右クリックして、マクロを開く (可能な場合) を選択し、マクロワークフローを表示します。
  • Alteryx Analytics Gallery で、Alteryx パブリック Gallery で公開されているアプリにアクセスします。
役に立ちましたか?

Running into problems or issues with your Alteryx product? Visit the Alteryx Community or contact support. Can't submit this form? Email us.