Alteryx Designer FIPS

Versão:
2022.3
Last modified: October 20, 2022

O Alteryx Designer FIPS versão 2022.1 é a primeira versão do Designer que oferece uma opção capaz de operar com FIPS 140-2 para clientes que exigem conformidade com FIPS. Observe que os padrões FIPS são desenvolvidos pelo NIST (Instituto Nacional de Padrões e Tecnologia) dos EUA para uso por agências e fornecedores do governo dos EUA. Para obter mais informações sobre o FIPS, acesse a página do NIST de perguntas frequentes sobre o FIPS.

A versão de lançamento geral (não FIPS) do Alteryx Designer não é capaz de operar com FIPS. Uma versão separada (e instalador) está disponível sob termos de licença distintos para nossos clientes FIPS 140-2.

Designer x Designer FIPS

Se você já usou o Alteryx Designer anteriormente, talvez note que determinadas ferramentas e recursos do Designer não estão disponíveis ou oferecem funcionalidade limitada com a versão 2022.1 do Alteryx Designer FIPS. Com o tempo, planejamos disponibilizar muitas dessas ferramentas e recursos novamente em futuras versões do Alteryx Designer FIPS.

Alteryx Designer FIPS versão 2022.2

A versão 2022.2 do Alteryx Designer FIPS contém recursos e ferramentas que não estavam disponíveis na versão 2022.1 inicial. Acesse estes recursos para saber mais:

Diferenças de recursos e ferramentas na versão atual FIPS 140-2

Se você já usou o Alteryx Designer anteriormente, observe que alguns recursos que você normalmente encontra no Designer não estão disponíveis no Alteryx Designer FIPS.

Recursos excluídos ou limitados

Para saber mais sobre os recursos do Designer que não estão disponíveis ou têm funcionalidade limitada na versão atual do Alteryx Designer FIPS, acesse Alteryx Designer e FIPS: diferenças de recursos.

Ferramentas excluídas ou limitadas

Para saber mais sobre as ferramentas do Designer que não estão disponíveis ou têm funcionalidade limitada na versão atual FIPS 140-2, acesse Alteryx Designer e FIPS: diferenças de ferramentas.

Bibliotecas de terceiros não compatíveis para fins não relacionados à segurança

Esta tabela lista bibliotecas de terceiros não compatíveis que são usadas em nossa versão FIPS 140-2.[1]

Biblioteca Algoritmos Objetivo
AG Grid MD5 Usada internamente para validação de licença do AG Grid.

Módulos criptográficos certificados FIPS 140-2 usados pelo Alteryx Designer

  • OpenSSL versão 3.0.0 – OpenSSL FIPS Provider – Revisão pendente – certificados de algoritmo (A1938)[2]
  • Windows 10 - Biblioteca de Primitivos Criptografados - Certificado Nº 3197

Observações

[1]: a Alteryx descobriu que essas bibliotecas contêm uso limitado de algoritmos criptografados não compatíveis. Afirmamos que o uso dessas bibliotecas de terceiros não se destina a fins relacionados à segurança.

[2]: a Alteryx não tem a opção de certificar nossa compilação do OpenSSL 3.0.0 FIPS 140-2, pois o CMVP não está mais aceitando envios FIPS 140-2 para novos certificados de validação. Isso significa que teremos que esperar que a certificação do OpenSSL FIPS Provider seja emitida pelo NIST e, em seguida, passaremos para o uso do OpenSSL FIPS Provider certificado, assim que ele estiver disponível.

Esta página foi útil?

Problemas com seu produto Alteryx? Visite a Comunidade Alteryx ou entre em contato com nossa Equipe de Suporte. Não é possível enviar este formulário? Envie-nos um e-mail.