Macros

Versão:
2022.3
Last modified: August 23, 2021

Uma macro é um fluxo de trabalho ou grupo de ferramentas integrado em uma única ferramenta que pode ser inserida em outro fluxo de trabalho. Crie uma macro para salvar um processo analítico executado repetidamente. Use a macro em um fluxo de trabalho sem ter que recriar o processo de análise de dados todas as vezes.

Salve uma macro como um arquivo .yxmc a ser usado no Designer ou carregado para compartilhamento no Alteryx Analytics Gallery (gallery.alteryx.com) ou em uma galeira privada.

Tipos de macros

  • Macro padrão: esta macro foi projetada para empacotar um processo em um fluxo de trabalho como uma ferramenta que pode ser inserida em um fluxo de trabalho.
  • Macro de lote: esta macro é executada várias vezes em um fluxo de trabalho e cria uma saída após cada execução. A macro é executada uma vez para cada registro ou grupo selecionado de registros em dados. A macro requer uma ferramenta Parâmetro de controle como entrada.
  • Macro iterativa: esta macro é executada no fluxo de trabalho quantas vezes estiver definido na configuração ou continuamente até que uma condição seja atendida.
  • Macro otimizadora de localização: esta é uma macro iterativa que pode ser usada na análise de rede para identificar uma ou mais localizações ideais.

Criar uma macro

Uma macro consiste de um fluxo de trabalho com uma interface de usuário criada usando Ferramentas de interface. Visite Ferramentas de interface e Janela do designer de interface para obter mais informações. Alternativamente, uma interface de usuário personalizada pode ser criada usando a ferramenta HTML – Biblioteca GUI.

Para criar uma macro...

Se você estiver usando um fluxo de trabalho existente, selecione a parte do fluxo de trabalho que deseja salvar como uma macro e, em seguida, copie-a e cole-a em uma nova guia de fluxo de trabalho.

  1. Crie um novo fluxo de trabalho ou abra um fluxo de trabalho existente.
  2. Adicionar uma entrada de macro:
    • Se o fluxo de trabalho não contiver uma entrada, adicione uma ferramenta Entrada de macro.
    • Se o fluxo de trabalho contiver uma ferramenta de entrada (como uma ferramenta Dados de entrada ou Entrada de texto), clique com o botão direito do mouse na ferramenta e selecione Converter para entrada de macro.
  3. Configure a ferramenta Entrada de macro.
  4. Adicione e configure uma ferramenta Saída de macro.

Por padrão, o tipo de fluxo de trabalho muda para Macro padrão quando uma ferramenta Entrada de Macro é adicionada a um fluxo de trabalho. O tipo de macro é padronizado como Macro de lote quando você adiciona uma ferramenta Parâmetro de controle ao fluxo de trabalho. Para criar uma macro iterativa, defina o tipo de macro como Iterativa.

Para definir o tipo de macro:

  1. Selecione a tela e selecione a guia Fluxo de trabalho na janela Configuração do fluxo de trabalho.
  2. Em Tipo, ao lado de Macro, selecione um tipo de macro.

Converter para macro

Além de criar uma macro do zero, você tem a opção de converter um fluxo de trabalho existente (ou uma parte do fluxo de trabalho) para uma macro. Há algumas limitações que você deve conhecer antes de converter para uma macro:

  • Você deve selecionar mais de uma ferramenta em um fluxo de trabalho.
  • Todas as ferramentas que você selecionar devem estar em um caminho contínuo e conectadas entre si (comentários, caixas de navegação e contêineres de ferramentas estão isentos disso).
  • Você deve primeiro executar o fluxo de trabalho antes de selecionar qualquer ferramenta.
  • As ferramentas selecionadas não devem conter erros.
  • As ferramentas selecionadas não devem conter nenhuma ferramenta na base de dados.
  • As ferramentas selecionadas não devem estar conectadas a nenhuma ferramenta de ação.
  • Converter para Macro não funciona com a ferramenta Python.

Para converter para uma macro...

  1. Selecione pelo menos duas ferramentas em um fluxo de trabalho. Clique e arraste na tela do fluxo de trabalho.
  2. Clique com o botão direito do mouse em uma das ferramentas selecionadas para abrir o menu de ferramentas.
  3. Selecione Converter para macro no menu suspenso para abrir a janela Converter para macro.
  4. Na janela Converter para macro...
    • Insira um Nome de arquivo para a macro.
    • Escolha um Local para salvar a macro.
    • Escolha um Ícone para a macro.
  5. Selecione Converter para converter seu fluxo de trabalho ou uma parte do fluxo de trabalho para uma macro. Selecione Cancelar para abandonar esse processo.
  6. O arquivo de macro recém-criado é aberto em uma nova guia no Designer, enquanto o fluxo de trabalho original mostra que as ferramentas selecionadas foram convertidas para uma macro.

Salvar macro

Salve uma macro para uso e compartilhamento futuros. Salvar macros com um nome exclusivo em um local específico. No Designer, você pode criar um repositório de macros mapeado para um local no computador ou na rede para salvar macros facilmente e usá-las em um fluxo de trabalho.

Para salvar uma macro...

  1. Selecione Arquivo > Salvar como.
  2. Localize uma pasta no computador ou na rede onde você salva as macros.
  3. Digite um nome exclusivo para a macro e selecione Salvar.

Para compartilhar fluxos de trabalho que usam macros personalizadas, exporte o fluxo de trabalho para garantir que todas as dependências do fluxo de trabalho, incluindo a macro, sejam salvas com o fluxo de trabalho. O fluxo de trabalho deve incluir um caminho relativo para a macro. Visite Gerenciamento do fluxo de trabalho e Dependências do fluxo de trabalho para obter mais informações.

Criar Repositório de macros

No Designer, você pode mapear para o local onde salva macros e criar um repositório de macros para salvá-las facilmente e usá-las em um fluxo de trabalho. Qualquer arquivo de macro .yxmc na localização selecionada é exibido na categoria de ferramenta na Paleta de ferramentas.

Para criar um repositório de macros...

  1. Acesse Opções > Configurações de usuário > Editar configurações de usuário > Macros.
  2. Selecione o botão “+”.
  3. Em Nome da categoria, digite um nome. O nome padrão é Macros.
  4. Selecione o botão “...” para navegar até a localização do computador ou de uma rede onde você salva macros.

As subpastas em um caminho de pesquisa não podem ser adicionadas individualmente se sua pasta pai já existir no repositório Macros.

Para definir um local de repositório padrão...

  1. Selecione o caminho de pesquisa do repositório na lista.
  2. Selecione Definir como padrão. Um asterisco (*) é exibido ao lado do repositório padrão.

Use Macro no fluxo de trabalho

Para usar uma macro salva em seu repositório de macros, localize a macro na Paleta de ferramentas ou use Pesquisar.

Para usar uma macro que não esteja na Paleta de ferramentas, clique com o botão direito do mouse na tela do fluxo de trabalho e selecione Inserir > Macro. Qualquer macro atualmente aberta na tela pode ser selecionada nessa lista ou você pode navegar até a localização de um arquivo de macro .yxmc diferente.

Para usar uma versão de macro específica em seu fluxo de trabalho, clique com o botão direito do mouse na macro e selecione a versão que deseja executar. Todas as versões de macro devem ser armazenadas no mesmo diretório. Você pode configurar essa localização em Configurações de usuário.

Para diferenciar uma macro de uma ferramenta dentro de um fluxo de trabalho, selecione a opção Exibir indicadores de macro em ferramentas para exibir o ícone + em Configurações de usuário > Tela. Visite Configurações de usuário para obter mais informações.

Para exibir o fluxo de trabalho de uma macro, clique com o botão direito do mouse na macro em um fluxo de trabalho e selecione Abrir macro. Uma macro em um fluxo de trabalho é atualizada automaticamente quando as alterações feitas na macro são salvas.

Para compartilhar fluxos de trabalho que usam macros personalizadas, exporte o fluxo de trabalho para garantir que todas as dependências do fluxo de trabalho, incluindo a macro, sejam salvas com o fluxo de trabalho. O fluxo de trabalho deve incluir um caminho relativo para a macro. Visite Gerenciamento do fluxo de trabalho e Dependências do fluxo de trabalho para obter mais informações.

Amostras de macros

As macros são incluídas no Designer para ajudar você a aprender a usar e criar macros. Para acessar macros...

  • Em Arquivos de programas no seu computador, acesse \Program Files\Alteryx\bin\RuntimeData\Macros.
  • No Designer...
    • Acesse Ajuda > Fluxos de trabalho de amostra > Tutoriais > Criar uma macro.
    • Algumas ferramentas na Paleta de ferramentas são macros. Por exemplo, a ferramenta Criar amostras e a ferramenta Limpeza de dados. Clique com o botão direito do mouse em uma ferramenta e selecione Abrir macro, se disponível, para visualizar o fluxo de trabalho da macro.
  • No Alteryx Analytics Gallery, acesse aplicativos publicados no Alteryx Gallery público.
Esta página foi útil?

Problemas com seu produto Alteryx? Visite a Comunidade Alteryx ou entre em contato com nossa Equipe de Suporte. Não é possível enviar este formulário? Envie-nos um e-mail.