Orange polygon containing globe.

Ferramenta Mapa Do Relatório

Versão:
2022.3
Last modified: September 25, 2020

Use o Mapa do Relatório para criar uma imagem de mapa a partir de um fluxo de trabalho. A ferramenta aceita múltiplas entradas espaciais, permite a estratificação dessas entradas e oferece suporte à criação de mapas temáticos. Você pode incluir outros recursos cartográficos, como uma lenda, escala e camadas de referência.

Para incluir um cabeçalho ou rodapé no mapa, adicione uma ferramenta De texto de relatório diretamente abaixo da ferramenta Mapa, selecione Anexar texto ao campo existente e selecione Mapa. Todos os mapas são desenhados em projeção esférica de Mercator.

Configurar a ferramenta

A ferramenta mapa de relatórios tem muitas opções configuráveis. A interface para a ferramenta é organizada em duas seções principais: visualização do mapa e configuração do mapa

Previsualização do mapa

Ao aplicar estilos de camada, a janela Visualização (Clique para ampliar) exibe o mapa com estilos configurados. A visualização usa dados de exemplo antes do tempo de execução. Execute o fluxo de trabalho para ver os dados reais e uma representação precisa de como o mapa resultante se parece.

  • Atualização: Selecione o link Atualizar para carregar os estilos de mapa recém-configurados sem a necessidade de re-executar o fluxo de trabalho.
  • Selecione a imagem de visualização para iniciar uma janela maior com o conteúdo do mapa. Na janela maior, está disponível navegação adicional: Zoom In e Zoom Out (com barras de rolagem para navegação no mapa), Tamanho Reale Ajuste para Janela.

Certas alterações (por exemplo, ativar o agrupamento, aplicar um tema ou alterar o zoom) requerem uma re-execução do fluxo de trabalho ou uma atualização da janela de visualização para ver as alterações.

Configuração do mapa

Guia de configurações

A guia Configurações inclui as especificações gerais para a imagem do mapa resultante.

Tamanho do mapa (W x H): Especifique o tamanho do mapa em polegadas.O tamanho padrão é de 8 polegadas de largura por 6 polegadas de altura. O tamanho especificado inclui a legenda se uma legenda de mapa for especificada. O tamanho do mapa renderizado pode diferir ligeiramente deste Tamanho do Mapa para caber no relatório de saída, com base nas especificações da ferramenta Render.

Se as Unidades de Distância Padrão forem definidas em quilômetros, este campo será calculado em milímetros. Ver Localização.

Tamanho e memória do mapa

O tamanho do mapa é limitado a 30 milhões pixels. Qualquer mapa de tamanho que se aproxime desse limite pode fazer com que o Designer se escora com a memória.

Resolução: Especificar resolução de imagem.

  • A resolução mais baixa cria um arquivo menor e é melhor para visualização em um monitor.
  • Maior resolução cria um arquivo maior com qualidade de impressão muito melhor.

Escala: Especifique as unidades de medição para a barra de escala. A barra de escala aparece no canto inferior esquerdo da imagem do mapa.

  • Nenhum: Nenhuma barra de escala aparece na imagem do mapa.
  • Pés: A barra de escala é exibida em unidades de pés.
  • Metros: A barra de escala é exibida em unidades de metros.
  • Milhas: A barra de escala é exibida em unidades de milhas.
  • Quilômetros: A barra de escala é exibida em unidades de quilômetros.

Reference Mapa base dereferência : Use a lista suspensa para especificar qual conjunto de camadas de referência incluir dentro da imagem do mapa. A lista inclui todos os mapfile/Layersets atualmente instalados.

Para definir o conjunto de dados padrão, vá para Opções > Configurações do usuário > Editar configurações do usuário e selecionar a guia Padrão do Conjunto de dados. Consulte Configurações de usuário.

Quando você usar um mapa base do TomTom em um mapa renderizado, use este direito autoral:

© [Ano Atual] TomTom. Todos os direitos reservados. Este material é proprietário e o tema da proteção de direitos autorais, proteção direita do banco de dados e outros direitos de propriedade intelectual pertencentes à TomTom ou seus fornecedores. O uso deste material está sujeito aos termos de um contrato de licença. Qualquer cópia ou divulgação não autorizada deste material levará a responsabilidades criminais e civis.

Quando você usar um mapa base de imagens aéreas em um mapa renderizado, use este direito autoral e anote o ano aplicável.

© [Ano atual] DigitalGlobe

Cor de fundo:Use o catador de cores para controlar a cor de fundo da imagem do mapa. O padrão é R=253, G=254, B=255 para diferenciar a imagem da página.

Sombra de gota domapa : Use a lista suspensa para especificar se o mapa é estilizado com uma sombra de gota.

Expansão Extensão 10% c/ uma Largura Mínima de 0,5 Milhas: Os padrões de 10% e 0,5 milhas podem ser ajustados. Para expandir ou contrair o nível de zoom, digite o número (representando uma porcentagem, por exemplo, aumentar o nível de zoom em 10%) para expandir ou contratar.

  • Os números positivos aumentam o nível de zoom (zoom-out), enquanto os números negativos diminuem o nível de zoom (zoom-in).
  • Os valores inscritos devem ser inteiros e os valores podem variar de -99 a 100.
Guia dados

A guia Dados inclui especificações para lidar com os fluxos de dados que entram na ferramenta Mapa.

Há 2 painéis nesta aba. O lado esquerdo exibe a conexão de dados de entrada. O lado direito exibe as opções para a conexão de dados selecionada.

Para configurar uma conexão de dados recebida, selecione o nome da conexão para destacar a camada à esquerda e, em seguida, edite as propriedades para essa camada à direita. Existem dois tipos de conexões:

  • Conexão de entrada: Um fluxo de conexão alimentando-se na ferramenta Mapa a partir de outra ferramenta Designer.
  • Conexão dearquivos : Um arquivo externo que o Alteryx usa para exibir os objetos espaciais na imagem do mapa resultante.

As conexões podem ser gerenciadas usando os botões localizados acima do painel do lado esquerdo.

  • O botão "+" adiciona uma conexão de dados à ferramenta Mapa. Você pode adicionar conexões de dados de uma conexão existente ou de um arquivo. Para adicionar uma conexão, selecione o tipo de conexão e selecione o botão Adicionar.
  • O botão "-" exclui a conexão de dados selecionada do controle de camadas.

Para cada conexão de dados, configure essas opções:

  • Nome da conexão dedados : O nome de conexão de dados padrão para o nome de conexão ou o nome do arquivo que está sendo usado.
  • Campo Espacial: Use a gotícula para especificar quais objetos espaciais incluir na imagem do mapa. Todos os campos de objeto espacial no fluxo de conexão exibem nesta lista. Todos os Objetos Espaciais são selecionados por padrão.
  • Campo de agrupamento: Configuração opcional. Quando especificado, uma imagem de mapa é feita para cada grupo de registros resultando em várias imagens de mapa.O agrupamento na ferramenta Mapa se comporta de forma ligeiramente diferente das outras ferramentas de Designer. Todos os campos que são usados para agrupamento devem ter exatamente o mesmo tipo de campo, ou seja, você não pode misturar Int16 e Int32. Os valores nulos e vazios são tratados da mesma forma — eles estão no mesmo grupo.
  • Campo Temático: Configuração opcional. Quando especificados, os objetos de mapa das camadas são estilizados com base em dados de registro. O estilo temático é feito na guia Camadas.
  • Campo de etiqueta: Especifique qual campo de dados rotular no mapa. Todos os campos de dados estão disponíveis na lista suspensa, incluindo Nenhum sem rótulo.
Guia de camadas

A guia Camadas contém as conexões transmitidas na ferramenta Mapa de relatórios organizadas pela forma como os dados recebidos são exibidos no mapa. Você pode manipular os objetos de mapa.

As conexões de streaming para a ferramenta de mapa são organizadas em camadas. As camadas estão localizadas no painel esquerdo. As camadas são listadas pelo nome da conexão de dados na guia dados. As camadas se desenham no mapa na mesma ordem que a lista, o que significa que os objetos de mapa do item superior na lista aparecem na parte superior do mapa resultante.

Selecione um nome de camada na lista à esquerda para revelar essas opções básicas de exibição para a camada:

  • Layer Nome dacamada : Especifique o nome da camada a ser exibida na legenda. Se nada for especificado, o nome da sequência de conexão será usado. O nome Camada aparece no painel esquerdo na lista de controle de camadas.
  • Data Conexão dedados : Refere-se à conexão de dados de onde vem a camada. A lista suspensa contém o conjunto Nomes de Conexão de Dados na guia Dados.
  • Show in Legend: Quando selecionada, a camada é incluída na legenda do mapa.
  • Zoom para camada: Quando selecionado, o mapa é ampliado na extensão da camada para garantir que todos os objetos sejam exibidos no mapa resultante.
  • Desabilitar: Quando selecionada, esta camada não é exibida no mapa final.

Selecione o "+" à esquerda do nome da camada para revelar os parâmetros de estilo. Selecione os parâmetros individuais(Estilo, Rótulo, Tema) para defini-los.Os estilos padrão são definidos para polígonos, linhas e pontos.

As configurações de estilo são editável. Para estilizar camadas de base, selecione o nome da camada e selecione Estilo de substituição para revelar uma opção Estilo abaixo da camada. As configurações disponíveis variam por tipo de camada. Todos os estilos podem ser redefinidos através do Reset the Defaults por link no canto superior direito.

Configurar estilos de ponto

Estilo deponto : Selecione como os pontos são estilizados no mapa. As opções incluem...

Thumbnail
  • Ponto personalizado: Para especificar se um ponto personalizado deve ser usado. selecione a caixa e navegue até a imagem (.png, .jpg e.gifs). A imagem é armazenada no fluxo de trabalho.
  • Tamanho: Especifique o tamanho do ponto em pixels. O padrão é 10.
  • Cor:Especifique a cor do ponto. O padrão é Azul.
  • Cor do contorno Color: Especifique a cor do contorno do ponto. O padrão é None.
  • Outline Tamanhodo contorno : Especifique o tamanho do contorno do ponto em pixels. O padrão é 1 pixel.
  • Opacidade: Especifique a porcentagem de opacidade para o ponto. O padrão é 100%.

Configurar estilos de linha

  • Cor:A cor da linha. O padrão é Gray.
  • Tamanho:O tamanho da linha em pixels. O padrão é 4.
  • Use sobreposição: Especifique se uma sobreposição deve ser usada para uma linha. Usando uma sobreposição em outra cor que a cor da linha dá o efeito da linha aparecendo como ele é descrito. O tamanho da sobreposição deve ser menor do que o tamanho da linha.
    • Cor da sobreposição Color: A cor para a sobreposição, deve ser diferente da cor escolhida para a linha.
    • Tamanho da sobreposição : O tamanho da sobreposição em pixels, deve ser menor do que o tamanho da linha.
  • Opacidade: A porcentagem de opacidade para o ponto.A inadimplência é de 100%.

Configurar estilos de polígono

  • Cor do contorno Color: A cor do contorno para o polígono. O padrão é Black.
  • Tamanho do contorno: O tamanho do contorno em pixels para o polígono. O padrão é 3px.
  • Use a cor do preenchimento: Especifique se o polígono deve ser preenchido. O padrão é Sim.Use a Cor de Enchimento para especificar a cor de preenchimento do polígono. O padrão é R=152, G=133, B=118.
  • Eclodido: Especifique se o polígono deve conter eclosão. O padrão é Não.
    • Cor do hatch:A cor hatch. O padrão é Black.
    • Estilo Hatch Style: O tipo de eclosão. O padrão é Único.
    • Hatch Tamanho dohatch : Selecione para alterar o valor do tamanho da eclosão. O padrão é 1px.
    • Hatch Espaçamento dohatch : Selecione para alterar o valor do espaçamento da eclosão. O padrão é 10px.
    • Hatch Ângulodo hatch : Selecione para alterar o valor do ângulo de eclosão. O padrão é 45 graus.
  • Opacidade: Especifique a porcentagem de opacidade para o polígono utilizando um valor de 0 (invisível) a 100 (opaco). O padrão é definido como 50%.A porcentagem de opacidade afeta a cor de preenchimento e a cor do contorno.

Configurar estilos de rótulo

  • Ângulo: Especifique o ângulo para desenhar a etiqueta 0, 45, 90, 180 graus ou AUTO para permitir que o software calcule o ângulo.Auto é válido apenas para camadas LINE. FOLLOW diz ao motor componente do mapa para calcular uma etiqueta curva para características lineares apropriadas.
  • Background Corde fundo : Especifique a cor para desenhar um retângulo de fundo ao redor das etiquetas. Isso está desligado por padrão.
  • Cor da sombra de fundo : Especifique a cor para desenhar uma sombra retângulo de fundo ao redor das etiquetas. Isso está desligado por padrão.
  • Tamanho da sombra de fundo: Especifique até onde a sombra de fundo deve ser compensada. O padrão é 1.
  • Buffer: Especifique o preenchimento, em pixels, em torno de rótulos. Essa configuração é útil para manter o espaçamento em torno do texto para aprimorar a legibilidade. O padrão é 0.
  • Cor:A cor do texto das etiquetas.
  • Fonte: O tipo/nome da fonte do texto da etiqueta.
  • Font Tamanho dafonte : O tamanho da fonte do texto da etiqueta.
  • Força: Força os rótulos ligados, independentemente do texto de rótulo sobreposto.O padrão é falso.
  • Distância mínima: Especifique, em pixels, a distância mínima entre as etiquetas duplicadas.
  • Tamanho do recurso min: Especificar, em pixels, o tamanho mínimo que um recurso deve ser rotulado. Para dados de linha, o comprimento total da linha exibida é usado, para características do polígono a menor dimensão da caixa delimitadora é usada.
  • Descrição Da cor: A cor para desenhar um contorno em torno do texto.
  • Outline Tamanhodo contorno : O tamanho do contorno, em pixels, para desenhar em torno do texto da etiqueta.
  • Posição: Especifique a posição da etiqueta em relação ao ponto de rotulagem. Auto calcula uma posição de etiqueta que não interferirá com outros rótulos. Se todas as posições causarem um conflito, então o rótulo não será desenhado (a menos que o parâmetro FORCE do rótulo seja definido como "sim").
  • Prioridade: Controles que rotulam quando rótulos de várias camadas se sobrepõem. A camada com a maior prioridade é exibida. O valor máximo de prioridade é 10.
  • Cor da sombra: A cor da sombra de gota para as etiquetas.
  • Shadow Deslocamentoda sombra : A sombra de queda compensada em pixels.
  • Wrap Character: O caractere que representa uma condição de fim de linha no texto da etiqueta, resultando assim em um rótulo multi-linha.

Configurar estilos temáticos

Cada camada onde um campo temático que escolhi na guia Dados tem um tema que pode ser estilizado.

Estilos temáticos substituem estilos de objeto, portanto, não há necessidade de especificar um estilo de objeto se houver um tema de mapa em uma camada. Você pode, no entanto, optar por rotular a camada de mapa em que você está sediando.

Método de ladrilho : Especifique qual método de ladrilho usar: Azulejo inteligente, Contagem de telhas iguais, Tamanho igual de ladrilho ou valor único. Dependendo do método de ladrilho escolhido, essas configurações estão disponíveis.

  • Ladrilho inteligente: Cria telhas com base no Desvio Padrão dos valores no campo especificado. Os blocos atribuídos indicam se o valor do registro se enquadra na faixa média (=0), acima da média (1) ou abaixo da média (-1) etc.
  • Equal Faixasiguais : Os valores mínimos e máximos do campo de ladrilhos são determinados. O intervalo é dividido em subfaixas de tamanho igual e os registros são atribuídos a telhas com base nessas faixas.
  • Equal Registrosiguais : Os registros de entrada são classificados pelo campo temático e, em seguida, divididos na quantidade especificada de telhas para que cada telha seja atribuída a mesma quantidade de registros. Isso se baseia unicamente na posição do registro no fluxo de entrada depois que ele é classificado pelo campo temático. O número de registros na entrada pode não ser igualmente divisível pelo número de telhas especificadas.
  • Unique ValorÚnico : Para cada valor único em um campo ou campos especificados, uma telha única é atribuída.
  • Manual Azulejomanual : O usuário pode especificar os Valores de Corte para as telhas digitando o valor mais baixo para cada faixa em uma linha separada. Por exemplo, Entrar 2, 4, 6 e 8 em linhas diferentes resulta em 5 telhas: abaixo de 2, 2-4, 4-6, 6-8 e 8 e acima.

Use os botões de gerenciamento para controlar a ordem da camada e aparência.

  • O botão up-arrow reordena a camada selecionada até uma posição para cada clique.
  • A seta para baixo reordena a camada selecionada para baixo de uma posição para cada clique.
  • O botão "+" adiciona uma camada de uma conexão disponível. Isso é útil para empilhar uma camada duplicada em cima de si mesmo para fins de estilo.
    • Points Camada depontos : Exibe conexões disponíveis e adicionará uma camada de pontos para a conexão escolhida.
    • Lines Camada delinhas : Exibe conexões disponíveis e adicionará uma camada de linhas para a conexão escolhida.
    • Camada de polígonos : Exibe conexões disponíveis e adicionará uma camada de Polígonos para a conexão escolhida.
  • O botão "-" exclui a camada selecionada do controle de camadas.
  • O botão Mover para Cima/Inferior expõe várias opções para reordenar rapidamente a camada selecionada:
    • Mova-se para cima: Move a camada selecionada para a primeira posição da lista de camadas.
    • Mova-se para baixo: Move a camada selecionada para a última posição da lista de camadas.
    • Mova-se para o Topo do Grupo: Move a camada selecionada para a primeira posição de seu grupo.
    • Mova-se para Baixo do Grupo: Move a camada selecionada para a última posição de seu grupo.

Os grupos são definidos como tipos de camada (Pontos, Linhas e Polígonos) e se são camadas de usuário ou camadas de mapa base de referência. A ordem fundamental dos grupos é esta:

  • Pontos de usuário
  • Pontos de camada base
  • Linhas de Usuário
  • Linhas de camada base
  • Polígonos do usuário
  • Polígonos de camada base
Guia da Lenda

A guia Legend oferece muitas opções configuráveis para personalizar a legenda que acompanha a imagem do mapa.

  • Posição: Selecione onde a legenda do mapa aparece em relação ao mapa.
    • [Nenhum]: Nenhuma lenda é saída.
    • Campo Separado: A lenda é tratada como um trecho de relatório separado do mapa. Se o Campo Separado for escolhido, uma ferramenta layout ou ferramenta sobreposição deve ser usada antes da renderização.
    • Layout à esquerda: A legenda aparece no lado esquerdo da imagem do mapa.
    • Layout para a direita: A legenda aparece no lado direito da imagem do mapa.
  • Cor de fundo: A cor da caixa de legendas. A cor do plano de fundo deve ser da mesma cor que o recurso de mapa mais proeminente para mostrar adequadamente determinados estilos de objetos de mapa. A transparência do polígono, por exemplo, pode não parecer a mesma na legenda, a menos que a cor de fundo da legenda corresponda ao que os polígonos estão colocando em cima na imagem do mapa.
  • Text Cordo texto : A cor do texto na legenda.
  • Fonte: O estilo de fonte do texto na legenda.
  • Font Tamanho dafonte : O tamanho do texto na legenda.
  • Icon Largura doícone : O tamanho da imagem usada para representar a camada do mapa na legenda.
  • Icon Alturado ícone : O tamanho da imagem usada para representar a camada do mapa na legenda.
  • Separadores numéricos de comma: Use a gota para escolher se deve incluir írgulas dentro de valores numéricos.

Como essa ferramenta inclui um editor de expressões, uma âncora de entrada adicional é exibida quando a ferramenta é usada em um fluxo de trabalho de aplicativo ou de macro. Use as ferramentas de Interface para conectar a uma âncora de pergunta. Consulte Ferramentas de Interface.

Esta página foi útil?

Problemas com seu produto Alteryx? Visite a Comunidade Alteryx ou entre em contato com nossa Equipe de Suporte. Não é possível enviar este formulário? Envie-nos um e-mail.