Skip to main content

drop box input Outil Entrée Dropbox

Utilisez l'outil Entrée Dropbox pour lire les données stockées dans votre espace de travail Dropbox.

Configuration de l'outil

Pour installer l'outil Entrée Dropbox

  1. Téléchargez l'outil à partir de la Communauté Alteryx .

  2. Dans Designer, accédez à Fichier > Ouvrir un workflow .

  3. Ouvrez le fichier Entrée Dropbox YXI. 

  4. Sélectionnez Installer .

Note

Pour installer l'outil Entrée Dropbox pour tous les utilisateurs, ouvrez Designer avec les informations d'identification de l'administrateur.

Pour ajouter l'outil Entrée Dropbox au workflow

  1. Accédez à l'onglet Connecteurs et sélectionnez Entrée Dropbox. Faites glisser l'outil sur le canevas. Remarque : si vous ne disposez pas de l'onglet Connecteurs dans votre palette d'outils, vous pouvez l'ajouter via l'icône Plus à la fin de la palette d'outils.

  2. Sélectionnez l'outil Entrée Dropbox pour ouvrir le panneau de configuration.

  3. Choisissez une méthode d'authentification :

    1. Se connecter via un navigateur Internet  : une fenêtre contextuelle s'affiche pour autoriser l'accès à Dropbox.

    2. Obtenir les fichiers à partir de l'URL  : vous pouvez indiquer l'URL de vos fichiers.

    3. Jeton d'accès  : authentification avec un jeton d'accès généré pour appeler votre compte sans passer par le flux d'autorisation. Avec cette méthode d'authentification, vous décidez également de vous connecter à un compte Personnel ou Professionnel .

    4. Vous pouvez également choisir de vous connecter via votre propre application Dropbox avec l'ID et le secret client.

  4. Sélectionnez Se connecter .

  5. Sélectionnez Site et Bibliothèque de documents .

  6. Pour sélectionner votre fichier, parcourez les dossiers ou utilisez Rechercher pour rechercher votre site, votre bibliothèque et votre fichier. Notez que le chemin du fichier sélectionné est modifié en fonction de la sélection effectuée.

  7. Dans l'onglet Options , vous pouvez vérifier le format de fichier , la longueur de champ maximale et le séparateur de champ (virgule par défaut). Vous pouvez également vérifier les options Guillemet (aucun par défaut), Joindre des métadonnées et la page de code. Si le format de fichier n'est pas pris en charge (autre que CSV, XLSX et YXDB), un message d'erreur s'affiche.

  8. La vue Arborescence est générée en fonction du site sélectionné. En fonction du format de fichier sélectionné, plusieurs options sont disponibles dans l'onglet Options .

  9. Pour le format de fichier XLSX, dans l'onglet Données , vous pouvez sélectionner les options de plage de données : Toutes les feuilles , Noms de feuilles , Numéros de feuilles avec une plage particulière, Plage nommée ou Importer seulement la liste des noms de feuilles .

    CONSEIL

    Vous pouvez également choisir un dossier avec tous les sous-dossiers (un format de fichier est défini manuellement) ou définir le chemin du fichier à l'aide de caractères génériques (par exemple, « …/*2020.xlsx » pour tous les fichiers .xlsx se terminant par « 2020 »).

  10. Sélectionnez Exécuter pour lancer le workflow.