Skip to main content

DCM - Designer

Le gestionnaire de connexion aux données (DCM) est une solution de stockage centralisé assurant l'interopérabilité des connexions cloud et aux bases de données (informations d'identification liées aux sources de données), qui permet la gestion des connexions de workflows et la collaboration pour tous les produits Alteryx. Utilisez DCM pour saisir et utiliser vos connexions et informations d'identification parmi les outils et les workflows.

Avec DCM , vous pouvez gérer les sources de données, les informations d'identification et les connexions :

  • Les objets de source de données représentent les bases de données, les services cloud et plus encore.

  • Les objets d'information d'identification représentent les combinaisons de nom d'utilisateur et de mot de passe ainsi que les jetons OAuth.

  • Les objets de connexion associent des sources de données à des informations d'identification et sont utilisés par un ou plusieurs outils de votre workflow.

Pour plus d'informations, accédez à  Connecteurs et outils pris en charge .

Configuration du Gestionnaire de connexions aux données

Paramètres administrateur

Il existe une option pour modifier le Mode DCM et choisir le Mode d'accès SDK .

Ces options sont disponibles dans le paramètre  Mode DCM  pour définir la gestion et le stockage des informations d'identification :

  • DCM facultatif  : les connexions (y compris les mots de passe) sont stockées dans un workflow par défaut. Vous pouvez choisir de stocker et de gérer les connexions dans DCM.

  • DCM par défaut  : les connexions (y compris les mots de passe) sont stockées et gérées dans DCM par défaut. Vous pouvez choisir de les stocker dans un workflow.

  • DCM uniquement  : vous ne pouvez pas configurer de connexions dans un workflow. Vous pouvez uniquement sélectionner des connexions stockées dans DCM. Les workflows avec mots de passe intégrés peuvent s'exécuter.

  • DCM appliqué  : les workflows avec mots de passe intégrés ne fonctionnent pas.

Voici plusieurs options d'administration pour la prise en charge des outils SDK (Galerie) :

  • Refuser  : les outils SDK ne sont pas pris en charge et la case à cocher Autoriser les informations d'identification pour les outils SDK n'est pas affichée dans l'interface utilisateur des informations d'identification.

  • Autoriser  : les outils SDK sont pris en charge et la case à cocher Autoriser les informations d'identification pour les outils SDK est affichée dans l'interface utilisateur avec une option qui permet de sélectionner manuellement chaque information d'identification.

  • Autoriser tout  : les outils SDK sont pris en charge et la case à cocher Autoriser les informations d'identification pour les outils SDK n'est pas affichée dans l'interface utilisateur des informations d'identification.

Paramètres utilisateur

En tant qu'utilisateur, vous pouvez changer le mode DCM et choisir le Mode d'accès SDK dans Options > Paramètres utilisateur > Modifier les paramètres utilisateur > DCM .

Ces options sont disponibles dans le paramètre  Mode DCM  pour définir la gestion et le stockage des informations d'identification :

  • DCM facultatif  : les connexions (y compris les mots de passe) sont stockées dans un workflow par défaut. Vous pouvez choisir de stocker et de gérer les connexions dans DCM.

  • DCM par défaut  : les connexions (y compris les mots de passe) sont stockées et gérées dans DCM par défaut. Vous pouvez choisir de les stocker dans un workflow.

  • DCM uniquement  : vous ne pouvez pas configurer de connexions dans un workflow. Vous pouvez uniquement sélectionner des connexions stockées dans DCM. Les workflows avec mots de passe intégrés peuvent s'exécuter.

  • DCM appliqué  : les workflows avec mots de passe intégrés ne fonctionnent pas.

Pour le mode d'accès SDK, voici les options disponibles :

  • Refuser  : les outils SDK ne sont pas pris en charge et la case à cocher Autoriser les informations d'identification pour les outils SDK n'est pas affichée dans l'interface utilisateur des informations d'identification.

  • Autoriser  : les outils SDK sont pris en charge et la case à cocher Autoriser les informations d'identification pour les outils SDK est affichée dans l'interface utilisateur avec une option qui permet de sélectionner manuellement chaque information d'identification.

  • Autoriser tout  : les outils SDK sont pris en charge et la case à cocher Autoriser les informations d'identification pour les outils SDK n'est pas affichée dans l'interface utilisateur des informations d'identification.

Gestionnaire de connexions

Vous pouvez contrôler les sources de données et les informations d'identification qui authentifient les sources de données dans le Gestionnaire de connexions. De plus, vous pouvez lier Designer Desktop à Alteryx Analytics Cloud Platform (AACP). Accédez à  Fichier Gérer les connexions  pour accéder à ces fonctionnalités.

Gestion des sources de données

Pour ajouter une source de données dans le Gestionnaire de connexions :

  1. Accédez à Sources de données .

  2. Sélectionnez + Nouveau.

  3. Choisissez la  Technologie .

  4. Renseignez les informations requises pour la technologie que vous souhaitez connecter. Vous pouvez éventuellement Tester la connexion .

  5. Sélectionnez Enregistrer .

Vous pouvez combiner la source de données avec les identifiants pour créer une connexion. Dans la section Sources de données > Connexions , vous pouvez voir la liste des informations d'identification liées à la connexion ou lier une nouvelle information d'identification :

  1. Sélectionnez + Connecter les informations d'identification .

  2. Choisissez une méthode d'authentification .

  3. Saisir l'information d'identification.

  4. Vous pouvez éventuellement choisir d' autoriser la connexion pour SDK .

  5. Vous pouvez sélectionner Tester la connexion ou Créer et lier pour terminer.

Gestion des informations d'identification

Pour ajouter une information d'identification dans le Gestionnaire de connexions, accédez à la section Informations d'identification . Les options suivantes sont disponibles :

  • Ajouter des informations d'identification  : sélectionnez + Nouveau . Saisissez le  nom d'informations d'identification . Sélectionnez une méthode . Saisissez les informations requises (par exemple, ID client, clé secrète, nom d'utilisateur, mot de passe) pour la méthode sélectionnée. Sélectionnez Enregistrer .

  • Afficher les identifiants  : sélectionnez les identifiants que vous souhaitez afficher dans la liste.

  • Modifier un identifiant  : pour modifier un identifiant dans le Gestionnaire de connexion, sélectionnez l'identifiant à modifier dans la liste. Sélectionnez Modifier . Sélectionnez Enregistrer .

  • Supprimer un identifiant  : sélectionnez l'identifiant à supprimer dans le Gestionnaire de connexions. Sélectionnez l'icône de corbeille . Sélectionnez Supprimer .

Pour vous connecter avec votre connexion, placez l'outil sur le canevas du workflow Designer et sélectionnez Configurer une connexion . Dans la fenêtre du Gestionnaire de connexions, choisissez votre connexion et utilisez les identifiants liés en sélectionnant le bouton Se connecter .

Gestion des liens Alteryx

Les liens Alteryx vous permettent de lier Designer Desktop à un espace de travail Alteryx Analytics Cloud Platform (AACP) afin d'enregistrer et d'exécuter des workflows Designer Desktop dans le cloud. Pour en savoir plus sur ces fonctionnalités, rendez-vous sur la page  Exécution Cloud pour Desktop .

Créer un lien Alteryx

Pour lier Designer Desktop à AACP, procédez comme suit :

  1. Dans Designer Desktop, accédez à  Fichier Gérer les connexions  pour ouvrir DCM.

  2. Sélectionnez Liens Alteryx dans le menu de gauche et cliquez sur le bouton + Nouveau .

  3. Analytics Cloud est présélectionné comme  Technologie par défaut. Fournissez les informations requises :

    • Nom de source de données  : il s'agit du nom d'affichage (étiquette) de ce lien. Le nom s'affiche dans les menus  Enregistrer sous  et  Ouvrir , et permet aux utilisateurs d'identifier cette connexion.

    • URL de base  : il s'agit de l'URL que vous utilisez pour accéder à Alteryx Analytics Cloud (par exemple, https://company.alteryxcloud.com/). Contactez votre administrateur AACP pour obtenir ces informations.

    • Nom de l'espace de travail  : il s'agit du nom de votre espace de travail Analytics Cloud, tel qu'il apparaît dans l'URL (après l'URL de base). Par exemple, vous pouvez accéder à Analytics Cloud depuis https://company.alteryxcloud.com/?workspace=my-workspace. Dans ce cas, vous devez saisir le nom de l'espace de travail dans le champ Workspace Name . Contactez votre administrateur AACP pour obtenir ces informations.

  4. Sélectionnez Enregistrer . Ensuite, vous devez lier les informations d'identification.

  5. Sélectionnez  + Connecter les informations d'identification  pour commencer.

  6. Exécution Cloud pour Desktop prend en charge la méthode d'authentification OpenID Connect (OIDC). Cette option est présélectionnée dans la liste déroulante  Méthode d'authentification .

  7. Dans la section JETONS OIDC, utilisez la liste déroulante  Informations d'identification  pour choisir une information d'identification existante ou sélectionnez  Créer une nouvelle information d'identification .

  8. Si vous devez créer une nouvelle information d'identification, saisissez un  nom d'identification . Il s'agit d'une étiquette qui devrait vous aider à identifier ces informations d'identification à l'avenir.

  9. Le  Coffre  est défini par défaut sur DCM.

  10. Vous pouvez également sélectionner  Tester la connexion  ou  Créer et lier  pour terminer.

    Important

    Si votre connexion échoue, assurez-vous que l'URL de base et le Nom de l'espace de travail de votre connexion AACP sont corrects.

Une fois que vous avez réussi à connecter Designer Desktop à un espace de travail AACP, les détails de connexion sont disponibles via  Fichier  >  Gérer les connexions  >  Liens Alteryx . Sélectionnez le Nom de source de données dans la colonne Nom pour afficher les détails de la connexion, la modifier et la supprimer.

Afficher, modifier et synchroniser les liens Alteryx existants

Pour afficher les liens Alteryx existants, dans Designer :

  1. Accédez à  Fichier  >  Gérer les connexions  >  Liens Alteryx .

  2. Sélectionnez le Nom du lien existant à ouvrir et affichez les détails.

  3. Pour mettre à jour le lien, cliquez sur le bouton  Modifier . Effectuez les modifications nécessaires et sélectionnez  Enregistrer  ou  Annuler  pour revenir à l'écran précédent.

  4. Dans la section  Connexions , vous pouvez également sélectionner  Synchroniser  pour synchroniser vos informations d'identification entre Designer Desktop et AACP.

Supprimer un lien Alteryx

Pour supprimer un lien Alteryx existant, dans Designer Desktop :

  1. Accédez à  Fichier  > Gérer les connexions  >  Liens Alteryx .

  2. Sélectionnez l'icône de  corbeille  associée au lien Alteryx que vous souhaitez supprimer. La boîte de dialogue Supprimer s'affiche. Sélectionnez le bouton  Supprimer * pour confirmer la suppression ou sélectionnez Annuler pour revenir à l'écran précédent.

*La suppression est définitive. Cette action ne peut pas être annulée.

Synchronisation des informations d'identification

Avec DCM, vous pouvez synchroniser les informations d'identification dans l'ensemble de la suite de produits Alteryx.

Synchronisation des informations d'identification entre Designer et Server

  1. Accédez à Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions.

  2. Sélectionnez Synchroniser.

  3. Pour une nouvelle connexion Server :

    1. Sélectionnez + Nouveau.

    2. Saisissez l' URL d'instance Server et sélectionnez Se connecter .

    3. Saisissez l' adresse e-mail et le mot de passe , puis sélectionnez Se connecter .

  4. Sélectionnez l'instance Server pour laquelle effectuer la synchronisation.

  5. Sélectionnez Synchroniser.

  6. Cliquez sur Terminé .

Ajout d'informations d'identification avec synchronisation

  1. Accédez à Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions.

  2. Accédez à Identifiants .

  3. Sélectionnez Ajouter des informations d'identification .

  4. Saisissez les détails de l'identifiant.

  5. Sélectionnez Enregistrer .

  6. Suivez les étapes 2 à 5 de la section Synchronisation des informations d'identification entre Designer et Server .

Modification des informations d'identification avec synchronisation

  1. Accédez à Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions.

  2. Accédez à Identifiants .

  3. Sélectionnez les informations d'identification à mettre à jour.

  4. Sélectionnez Modifier .

  5. Mettez à jour les détails de l'identifiant.

  6. Sélectionnez Enregistrer .

  7. Suivez les étapes 2 à 5 de la section Synchronisation des informations d'identification entre Designer et Server .

Suppression des informations d'identification avec synchronisation

  1. Accédez à Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions.

  2. Accédez à Identifiants .

  3. Sélectionnez les informations d'identification à supprimer.

  4. Sélectionnez l'icône de corbeille .

  5. Cliquez sur Supprimer pour confirmer.

  6. Suivez les étapes 2 à 5 de la section Synchronisation des informations d'identification entre Designer et Server .

Synchronisation du workflow avec les informations d'identification DCM

  1. Téléchargez un workflow en vous référant à l'article Workflows .

  2. Suivez les étapes 2 à 5 de la section Synchronisation des informations d'identification entre Designer et Server .

Sauvegarde et restauration

Vous pouvez sauvegarder votre stockage DCM et le restaurer à partir du fichier de sauvegarde.

Important

Cette fonctionnalité est basée sur votre licence Designer. Bien que la restauration fonctionne entre deux licences différentes achetées au sein de la même organisation, dans ce cas, la sauvegarde et la restauration de deux licences différentes au sein de la même organisation doivent également se trouver dans les différentes instances de Designer pour fonctionner. La sauvegarde et la restauration ne fonctionnent pas dans les version d'essai ou avec plusieurs licences actives dans une seule instance de Designer.

Sauvegarde

  1. Accédez à Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions.

  2. Sélectionnez Sauvegarder .

  3. Saisissez le mot de passe de votre fichier de sauvegarde.

  4. Sélectionnez Sauvegarder .

  5. Choisissez un emplacement et éventuellement un nom pour votre fichier de sauvegarde.

  6. Sélectionnez Enregistrer .

Restauration

  1. Accédez à Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions.

  2. Sélectionnez Restaurer .

  3. Saisissez le mot de passe de votre fichier de sauvegarde.

  4. Sélectionnez Restaurer .

Synchronisation de DCM entre Server et Designer

Trois paramètres de synchronisation sont disponibles :

  • No Synchronization  : (Aucune synchronisation) la synchronisation des connexions DCM est bloquée dans les deux sens.

  • One-way to Designer :  (Synchronisation unilatérale vers Designer) la synchronisation des connexions DCM n'est activée que de Server vers Designer.

  • Full Synchronization :  (Synchronisation complète) la synchronisation des connexions DCM est activée de Server vers Designer et de Designer vers Server.

Pour synchroniser DCM entre Server et Designer, procédez comme suit :

  1. Accédez à Designer > Fichier > Gérer les connexions pour ouvrir le Gestionnaire de connexions . Sélectionnez ensuite Synchroniser dans le menu.

  2. Sélectionnez le Server à synchroniser dans la liste.

  3. Sélectionnez Synchroniser.

Une fois que vous avez synchronisé DCM entre Server et Designer, toutes les informations d'identification que vous possédez et toutes les sources de données auxquelles vous avez accès sont visibles et prêtes à être utilisées dans le Gestionnaire de connexions.

Connecteurs et outils pris en charge

Pour obtenir la liste des outils et des connecteurs pris en charge par DCM, consultez  Connecteurs et outils pris en charge par DCM .