Skip to main content

Nouveautés de Designer

2023.2

Version : 2023.2.1.7 (consultez la page Notes de publication )

Date de publication : 1 novembre 2023

Nouvelles fonctionnalités : Designer

Modèles personnalisés

Vous pouvez désormais créer et utiliser des modèles personnalisés dans Alteryx Designer. Enregistrez votre workflow, macro ou application en tant que modèle que vous (et d'autres personnes, en cas de partage) pourrez réutiliser ultérieurement. Vous pouvez enregistrer des modèles avec des configurations de workflow courantes et passer moins de temps à formater les workflows et plus de temps à fournir des solutions. Accédez à Modèles pour en savoir plus.

Rechercher les macros manquantes dans les workflows

Vous ne verrez plus les icônes noires de point d'interrogation ! Lorsque vous ouvrez un workflow avec des macros manquantes, vous pouvez maintenant résoudre le problème de macro manquante et ouvrir le workflow sans erreur. Accédez à Mettre à jour les macros manquantes pour en savoir plus.

Améliorations apportées à la grille de résultats interactive

Nous avons apporté des améliorations aux fonctionnalités de la grille de résultats interactive. Nous avons ajouté un indicateur de modification pour faciliter la vérification de l'application d'une action de nettoyage, de filtrage ou de tri des données à une colonne de données. De plus, vous avez désormais accès à de nouveaux opérateurs pour les champs de date et vous pouvez désormais filtrer les résultats qui sont OK et Non OK. Accédez à Manipulations de données de la fenêtre Résultats pour en savoir plus.

Nouvelles fonctions de l'outil Formule

Nous avons ajouté trois nouvelles fonctions chaîne  :

  • GetPart

  • GetLeft

  • GetRight

Vous pouvez utiliser ces fonctions partout où elles sont disponibles.

Création de fonctions de formule personnalisées via C++ avec AMP

Les développeurs de workflows avancés qui utilisent des fonctions de formule personnalisées peuvent désormais utiliser des fonctions de formule C++ personnalisées avec AMP Engine (fonctions nouvelles et existantes). Pour plus d'informations, reportez-vous à la section Création de fonctions de formule personnalisées .

Mises à jour des fonctions IRR et XIRR

Les fonctions IRR et XIRR (disponibles dans les outils Formule et Agréger) ont été mises à jour pour utiliser la méthode Newton-Raphson. Ces améliorations devraient permettre aux fonctions IRR et XIRR de fournir des solutions pour plus de cas qu'auparavant. Avec la modification de la méthode de calcul sous-jacente, vous pouvez voir de légères modifications dans les résultats des fonctions lorsque vous utilisez les mêmes valeurs d'entrée.

Une correction de ces fonctions a également été apportée pour le cas de gestion des erreurs. Dans la version précédente, des cas pouvaient produire la valeur erronée « 999999 » si les fonctions ne convergeaient pas sur un résultat. Nous avons procédé à une mise à jour pour générer un message d'avertissement et retourner une valeur NULL dans ces cas.

Calculer le produit via l'outil Agréger

Vous pouvez maintenant calculer le produit pour un groupe de valeurs numériques via l'outil Agréger. Accédez à Outil Agréger pour en savoir plus.

Mises à jour de l'expérience Exécution Cloud pour Desktop

Nous avons apporté plusieurs améliorations à la convivialité de l'expérience Exécution Cloud pour Desktop dans Alteryx Designer. Vous pouvez désormais voir une barre de progression lorsque vous enregistrez vos workflows dans Alteryx Analytics Cloud Platform (AACP). Vous avez désormais également accès à un lien rapide qui vous amène à l'emplacement où votre workflow est enregistré dans AACP. De plus, lorsque vous souhaitez ouvrir votre workflow Desktop (précédemment enregistré dans AACP) dans Designer Desktop, vous pouvez maintenant rechercher le workflow par nom et trier la liste de workflows.

Mises à jour du mode sombre

Des composants Designer supplémentaires sont désormais compatibles avec le mode sombre. Nous avons également commencé à mettre à jour plusieurs composants de configuration d'outil pour être compatibles avec le mode sombre. Accédez à Mode sombre pour en savoir plus.

Version Bêta

La fonctionnalité de mode sombre est toujours en version Bêta pour le moment. Cela signifie que seuls certains composants de l'interface Designer ont été convertis en mode sombre. En outre, il se peut que certains composants (y compris de nombreuses configurations d'outils) ne soient que partiellement convertis en mode sombre. Nous continuerons d'inclure des éléments supplémentaires pour le mode sombre dans les prochaines versions.

Mises à jour de l'outil Rendu

Nous avons ajouté la prise en charge des langues de droite à gauche pour les sorties PDF à partir de l' outil Rendu . De plus, vous pouvez désormais sélectionner une taille de diapositive grand écran (16:9) lorsque vous effectuez une sortie PowerPoint à partir de l'outil Rendu.

Mises à jour de l'interface utilisateur des outils

Nous avons actualisé l'interface utilisateur pour les outils ID d'enregistrement, Trier, Échantillon et Unique.

Outils entièrement compatibles avec AMP

Ces outils sont maintenant entièrement convertis pour fonctionner avec AMP :

  • L'outil Conversion de Blob est maintenant entièrement converti pour la compatibilité avec AMP. Une nouvelle fonctionnalité est disponible dans l' outil Conversion de Blob qui vous permet de convertir un champ Blob en un hachage SHA256.

  • Créer des échantillons

  • Distance

  • Formule

  • Imputation

  • Formule à plusieurs champs

  • Formule à plusieurs lignes

  • Processus géographique

Nouveau paramètre utilisateur pour activer l'état par défaut pour le mode de compatibilité du moteur

Vous avez maintenant la possibilité d'activer automatiquement le mode de compatibilité du moteur chaque fois que vous activez AMP Engine. Accédez à Mode de compatibilité du moteur pour en savoir plus.

Génération de rapports automatisée des incidents

Une nouvelle fonctionnalité de génération de rapports des incidents utilise les informations de débogage collectées à partir des exécutions du moteur. Ces informations sont utilisées pour analyser les problèmes et apporter des améliorations au produit. Pour plus d'informations, consultez la page d'aide Génération de rapports automatisée des incidents .

Outils Amazon

Les outils Amazon S3 prennent désormais en charge les chemins de type hébergement virtuel. Vous pouvez également entrer un chemin URL direct vers un fichier ou un dossier. Ils peuvent désormais également lire, créer et écraser des fichiers XLSX.

Outil de migration DCM

Il existe un nouvel outil de migration pour vous aider à transférer rapidement et sans effort vos workflows actuels vers des connexions utilisant DCM.  Pour plus d'informations, reportez-vous à la page d'aide Outil Migration .

Adoption du DCM

L'option permettant d'activer et de désactiver le Gestionnaire de connexions aux données (DCM) dans les paramètres système et utilisateur n'est plus disponible. Si vous avez désactivé le DCM dans Designer et Server, il est automatiquement activé lorsque vous effectuez la mise à jour vers 2023.2.

La sélection du mode DCM est toujours disponible au niveau Paramètres système et Paramètres utilisateur, avec les options Facultatif, Par défaut, Uniquement et Appliqué, ce qui vous permet de choisir une méthode préférée d'utilisation de Designer et DCM. Dans le mode Facultatif, les nouvelles connexions sont configurées en dehors de DCM avec la possibilité d'opter pour DCM pour des outils individuels.

Lorsque DCM est en mode Par défaut, les connexions sont stockées par défaut dans DCM avec la possibilité de ne pas utiliser DCM. Les modes Uniquement et Appliqué ne permettent pas de configurer de nouveaux outils en dehors de DCM, tandis que le mode Uniquement n'applique pas l'utilisation de DCM aux outils déjà configurés dans les workflows existants.

Prise en charge de DCM pour les technologies ODBC

Nous étendons la prise en charge de DCM à toutes les technologies de base de données. Vous n'avez plus besoin de créer des DSN en premier, vous pouvez désormais créer et stocker des connexions à l'aide de DCM. En outre, vous pouvez synchroniser les connexions entre vos instances Designer et Server via DCM, sans avoir à configurer de DSN.

Délai d'expiration de la connexion configurable pour les connexions ODBC

Vous pouvez désormais améliorer l'expérience de connexion et vous connecter à des sources de données distantes ou à des sources de données fonctionnant en période de forte activité qui ne peuvent pas répondre dans les 30 secondes imparties.

Authentification OIDC pour HashiCorp Vault

Vous pouvez désormais utiliser l'authentification par jeton OIDC lors de la récupération de secrets à partir de HashiCorp Vault avec DCM.

OAuth générique

Cette fonctionnalité vous permet d'améliorer considérablement la sécurité lorsque vous vous connectez à des sources de données basées sur des pilotes et prises en charge par Designer. Lorsque vous activez les méthodes d'authentification OAuth génériques, vous pouvez utiliser des fournisseurs d'identité (IdP) personnalisés au moment d'établir des connexions avec des sources de données individuelles.

Databricks Unity Catalog

La nouvelle fonctionnalité vous permet de travailler avec des instances Databricks compatibles avec Unity Catalog. Consultez la page d'aide Databricks Unity Catalog pour plus d'informations sur la configuration et l'utilisation.

Fusionner les tables dans Databricks

La fonctionnalité de fusion de tables vous permet désormais de mettre à jour ou supprimer des données dans votre table delta cible dans Databricks Unity Catalog à l'aide des outils InDB. Consultez la page d'aide Fusionner les tables pour plus d'informations sur la configuration et l'utilisation.

Annuler la logique de requête pour Snowflake

Vous pouvez désormais débloquer vos pipelines de données lorsque vous annulez l'exécution localement. Cette fonctionnalité réduit les coûts lorsque vous travaillez avec Snowflake et améliore l'interaction globale avec la base de données.

Mises à jour de l'authentification avec Azure AD

  • Redshift : avec cette fonctionnalité, Alteryx permet une authentification professionnelle pour Redshift. Cela vous permet d'utiliser des identités Azure Active Directory lorsque vous accédez aux données dans Redshift.

  • Transfert ADLS pour le chargeur en masse Databricks : cette fonctionnalité vous permet d'améliorer la sécurité lorsque vous travaillez avec le chargeur en masse Databricks. Pour les organisations, la gestion de l'accès aux conteneurs individuels au sein d'un compte de stockage est granulaire, elles n'ont plus besoin d'accorder un accès au niveau du compte de stockage.

  • Azure SQL Server, Azure Synapse et Azure SQL Database : cette fonctionnalité améliore considérablement l'expérience utilisateur lorsque vous travaillez avec les sources de données référencées. Au lieu de vous authentifier à nouveau à chaque exécution de workflow, vous pouvez désormais utiliser les informations d'identification stockées dans DCM pour configurer des connexions à ces sources de données.

Suppression de l'outil Publier sur Tableau Server

L'outil Publier sur Tableau Server a été supprimé du programme d'installation. Veuillez utiliser l' outil Sortie Tableau à la place (qui comprend des fonctionnalités mises à jour).

Fin de la prise en charge des fichiers Tableau au format .tde

Avertissement

Depuis sa version 2023.1, Tableau a abandonné le format de fichier d'extraction .tde et interdit par défaut de publier du contenu .tde. À partir de Designer 2023.2, Alteryx ne prend plus en charge les fichiers d'extraction Tableau au format .tde. Les workflows existants continueront de s'exécuter tant qu'ils ne sont pas modifiés.

Suppression de l'outil Exemple Python SDK

L'outil Exemple Python SDK (catégorie d'outils Exemples SDK) n'est plus disponible. Vous pouvez accéder aux outils Exemple SDK qui utilisent le nouveau SDK de Python v2 sur  Ressources Alteryx IO .

Mise à niveau de la version d'OpenSSL

Nous avons effectué une mise à jour d'OpenSSL vers la version 3.0.8. Elle corrige plusieurs vulnérabilités présentes dans les versions antérieures :

  • CVE-2023-0286

  • CVE-2023-0401

  • CVE-2023-0217

  • CVE-2023-0216

  • CVE-2023-0215

  • CVE-2022-4450

  • CVE-2022-4304

  • CVE-2022-4203

Consultez la page https://www.openssl.org/news/secadv/20230207.txt pour plus d'informations.

Mise à niveau de la version Python

Nous avons mis à niveau la version Python intégrée vers 3.8.16 .

Mise à niveau de la version CEF

Nous avons mis à niveau la version Chromium Embedded Framework (CEF) vers la version 111.2.4+g49cae37+chromium-111.0.5563.65 / Chromium 111.0.5563.65 . Cette version CEF inclut Chromium  111.0.5563.148 .

Accès à l'ancienne Alteryx Platform

Vous n'avez plus accès à l'ancienne Alteryx Platform via les options Enregistrer et Ouvrir du menu Fichier. En outre, l'option Gestion des liens Alteryx (précédemment utilisée pour gérer les liens vers l'ancienne Alteryx Platform) n'est plus disponible via le menu Options.

Important

Veuillez noter que l'ancienne Alteryx Platform, dans ce cas, ne fait pas référence à la nouvelle Alteryx Analytics Cloud Platform (AACP).

Prise en charge de Windows 11

Alteryx Designer prend désormais en charge Microsoft Windows 11 pour Designer versions 2023.2 et ultérieures.

Fin de la prise en charge de Windows Server 2012

Avertissement

À partir de la version 2023.2 de Designer, Alteryx ne prend plus en charge Windows Server 2012, car il a atteint la fin de la prise en charge par Microsoft. Accédez à https://learn.microsoft.com/en-us/lifecycle/announcements/windows-server-2012-r2-end-of-support pour en savoir plus.

Nouvelles fonctionnalités : Intelligence Suite

Mise à niveau de la version Python

Nous avons mis à niveau la version Python Intelligence Suite vers 3.8.16.

Dépendances de l'outil Code-barres

Pour Designer 2023.2 ou version ultérieure, l'outil Code-barres nécessite des dépendances supplémentaires pour s'exécuter. Téléchargez et installez le package redistribuable Microsoft Visual C++ 2013 pour ajouter ces dépendances requises.

2023.1

Version : 2023.1.1.12 (consultez la page Notes de publication )

Date de publication : 17 mai 2023

Nouvelles fonctionnalités : Designer

Nouvel outil : Conteneurs de contrôle

L'outil Conteneur de contrôle est un nouvel outil disponible dans la catégorie d'outils Développeur de Designer. Les Conteneurs de contrôle vous permettent de créer des processus plus dynamiques et complexes grâce à de meilleures capacités d'orchestration, de journalisation et d'exécution conditionnelle.

Voici quelques-unes des fonctionnalités offertes par les Conteneurs de contrôle :

  • Gestion de l'ordre d'exécution des outils dans votre workflow. Par exemple, vous pouvez utiliser les Conteneurs de contrôle pour séquencer les sorties vers différentes feuilles du même classeur Excel, ou même sortir un fichier d'un workflow et l'utiliser plus tard comme entrée dans le même workflow !

  • Exécution conditionnelle des branches du workflow : utilisez un outil Filtrer pour exécuter une branche de votre workflow selon que les enregistrements passent par les sorties True (Vrai) ou False (Faux).

  • Utilisation des informations relatives aux outils exécutés, sous la forme d'informations de journalisation ou de données à utiliser dans votre workflow. Par exemple, vous pouvez utiliser les Conteneurs de contrôle pour créer un journal de sortie pour un workflow. Possibilité de placer tous les outils dans le conteneur, puis de générer un fichier à partir de l'ancrage de sortie Journal du conteneur pour afficher les messages générés par l'exécution de votre workflow.

AMP uniquement

L'outil Conteneur de contrôle est compatible uniquement avec Alteryx Multi-threaded Processing (AMP) .

Nouvelles fonctions de l'outil Formule

Nous avons ajouté plusieurs nouvelles fonctions de l'outil Formule  :

  • AverageNonNull (catégorie Mathématiques)

  • Between (catégorie Min/Max)

  • Les fonctions Ceil et Floor comportent un nouveau paramètre facultatif qui vous permet d'augmenter/de réduire les valeurs numériques au multiple spécifié le plus proche (catégorie Mathématiques).

  • Factorial (catégorie Mathématiques)

  • ToRadians et ToDegrees (catégorie Conversion)

Vous pouvez utiliser ces fonctions partout où elles sont disponibles.

Paramètre Date et heure plus précis

Vous pouvez maintenant spécifier une précision supplémentaire pour vos types de données DateTime et Time . Vous pouvez ainsi obtenir une précision supérieure à celle des secondes, par exemple, des millisecondes, des microsecondes, des nanosecondes, etc.

  • L' outil DateHeure intègre désormais un nouveau paramètre  f qui vous permet de définir un temps de précision.

  • Un nouveau spécificateur de date-heure %1-%18 est disponible pour les fonctions DateTimeFormat et DateTimeParse.

  • Les fonctions DateTimeAdd, DateTimeDiff, DateTimeFormat, DateTimeNow, DateTimeParse et DateTimeSeconds offrent un niveau de précision supérieur. Accédez aux Fonctions DateHeure pour plus de détails.

  • Une nouvelle fonction DateTimeNowPrecise est désormais disponible. Cette fonction renvoie les date et heure actuelles de votre système d'exploitation avec un niveau de précision correspondant au nombre de chiffres spécifié à l'aide du paramètre.

  • Vous pouvez désormais utiliser l' outil Sélectionner (ainsi que d'autres outils qui intègrent une fonctionnalité de sélection) pour ajuster la taille des données Date-heure et Heure afin d'obtenir la précision souhaitée. Cette fonctionnalité est également disponible à l'aide d'autres outils où vous pouvez sélectionner la taille de champ, par exemple Formule et Générer les lignes.

Forcer la prise en charge SQL WChar via l'outil Sortie de données

L'option Forcer la prise en charge SQL WChar est désormais disponible via l'outil Sortie de données pour les connexions Oracle OCI. Cette option vous permet de forcer la sortie de tous les champs de caractères sous format WString pour traiter les caractères multioctets.

Correction de la troncature des données dans l'outil Rendu

Nous avons effectué une mise à jour afin d'empêcher la troncature inattendue des données dans l'outil Rendu. Un message d'erreur s'affiche maintenant lorsque vous essayez de produire une sortie au format PDF et que la taille de la page est trop petite pour contenir les données de votre jeu de données.

Mise à jour du changement de casse des noms de champs

Pour améliorer le processus de création de workflows, nous avons effectué une mise à jour afin que les changements de casse d'un nom de champ/colonne se propagent automatiquement aux outils en aval sans nécessiter de reconfiguration manuelle. Cette mise à jour ne s'applique pas aux macros et n'a aucun effet sur les outils qui utilisent une fenêtre contextuelle de configuration (par exemple, les outils Analyse et Graphique interactif).

Notez que cette modification n'affecte ni le moteur, ni le comportement d'exécution d'un workflow. Sauf indication contraire, les noms de champ ont toujours été insensibles à la casse du point de vue du moteur.

Mode sombre Bêta

Alteryx Designer vous permet désormais de sélectionner une option Mode sombre comme thème Designer. Prévisualisez le Mode sombre via l'onglet Personnalisation des paramètres utilisateur de Designer.

Version Bêta

La version initiale du mode sombre est une version Bêta. Cela signifie que seuls certains composants de l'interface Designer ont été convertis en mode sombre. En outre, il se peut que certains composants (y compris de nombreuses configurations d'outils) ne soient que partiellement convertis en mode sombre. Nous continuerons d'inclure des éléments supplémentaires pour le mode sombre dans les prochaines versions.

Prise en charge de Denodo

Alteryx prend désormais en charge la connexion à la plateforme Denodo. Vous pouvez utiliser non seulement le traitement de workflow standard, mais également les outils de traitement de workflow en base de données pour lire et écrire vos données. Pour plus d'informations, consultez Denodo .

Prise en charge de l'authentification Okta pour SAP HANA

La version 2023.1 introduit la prise en charge de l'authentification Okta, l'authentification unique (SSO), pour SAP HANA. Vous pouvez désormais vous authentifier sur SAP HANA Cloud à l'aide de comptes Okta.

AWS Secrets Manager

Vous pouvez maintenant connecter DCM à votre instance d'AWS Secrets Manager, puis extraire les données d'authentification d'AWS Secrets Manager pour votre workflow. Pour plus d'informations sur la configuration d'AWS Secrets Manager, consultez la page Configuration d'AWS Secrets Manager .

Activation de DCM comme option par défaut

DCM est maintenant activé et défini par défaut dans Paramètres système , et est activé dans Paramètres utilisateur . Par ailleurs, SDK est défini sur Allow (Autoriser) et la case DCM est cochée au niveau de l'outil.

Si vous effectuez une mise à niveau à partir de versions ultérieures à la version 21.4, vos paramètres DCM reflètent la configuration de votre installation précédente.

Prise en charge de Microsoft Access

Alteryx prend désormais en charge MS Access 2016 Runtime et MS Access 365 Runtime pour la lecture des fichiers ACCDB.

Support des rôles IAM pour les outils d'Amazon S3

Dans les outils Téléchargement et Chargement d'Amazon S3, vous pouvez maintenant sélectionner l'option Assumer un rôle comme nouvelle méthode d'authentification pour tirer pleinement parti des rôles dans votre IAM AWS.

Fin de la période de prise en charge prolongée des connexions 32 bits

Pendant deux ans à compter de la date de lancement de la version 2021.2 d'Alteryx (la « Période de prise en charge prolongée »), Alteryx assurait une assistance technique aux clients pour les connexions 32 bits. Si vous utilisez actuellement des connexions 32 bits, un message d'erreur s'affiche et vous ne pourrez plus utiliser ces connexions. Pour plus d'informations, consultez la FAQ sur la fin de la prise en charge des connexions aux bases de données 32 bits .

Nouvelles fonctionnalités : Intelligence Suite

Outil Classification du texte

Utilisez l'outil Classification du texte pour créer un modèle personnalisé qui classifie le texte. Étiquetez vos données de texte avec des catégories pour entraîner un modèle, puis classez le nouveau texte à l'aide de l'outil Prédire.

Étape Amélioration dans l'outil Traitement d'image

Une étape Amélioration de l'image a été ajoutée à l'outil Traitement d'image. L'étape Amélioration augmente la résolution d'image de vos documents numérisés. Utilisez l'étape  Amélioration pour améliorer les résultats de vos tâches de vision par ordinateur.

Ajout d'une option Auto à l'étape Alignement de l'outil Traitement d'image

Auto permet d'aligner automatiquement vos documents numérisés dans vos workflows OCR.

Appliquer des annotations à toutes les pages

Ajout de la case à cocher Appliquer la première page d'annotations de l'outil Modèle d'image à toutes les pages dans les outils PDF vers texte et Image en texte. Utilisez cette case à cocher pour appliquer la première page d'annotations de l'outil Modèle d'image à toutes les pages dans le cadre d'un traitement par lots.

2022.3

Version : 2023.1.395 (consultez la page Notes de publication )

Date de publication : 29 novembre 2022

Nouvelles fonctionnalités : Designer

Mises à jour du programme d'installation

À compter de la version 2022.3, Alteryx Designer, Server et les outils Prédictifs en R utilisent une nouvelle technologie d'installation. Le programme d'installation mis à jour détecte la langue de votre système d'exploitation et installe les produits Alteryx dans cette langue (le cas échéant). Consultez la page Télécharger et installer un produit pour connaître les principales considérations relatives à la mise à niveau et la rétrogradation, ainsi que les options de ligne de commande mises à jour .

Recherche dans « Sélectionner »

Vous pouvez maintenant effectuer une recherche dans les outils Designer qui utilisent la fonctionnalité « Sélectionner ». La recherche renvoie uniquement les champs qui correspondent à vos critères de recherche : elle examine les colonnes Champ, Renommer et Description. Vous pouvez ensuite sélectionner ou désélectionner rapidement tous les champs renvoyés pour effectuer des actions sur ces champs : modifier leurs types de données, les renommer, etc. Nous avons également ajouté une case à cocher pour vous permettre de sélectionner et désélectionner rapidement tous les champs visibles. Cette fonctionnalité est disponible dans les outils : Sélectionner, Jointures, Plusieurs Jointures, Ajouter des champs, Sélectionner en BDD, Trouver le plus proche et Correspondance géographique.

Améliorations de l'outil Formule

Nous avons ajouté des améliorations à l'outil Formule. Chaque expression contient désormais un numéro d'ID d'expression pour vous aider à documenter et à dépanner vos expressions. De plus, vous pouvez désormais développer et réduire rapidement toutes les expressions dans l'outil Formule à l'aide du bouton de bascule Développer tout/Réduire tout.

Mise en cache d'outils à plusieurs ancrages

Vous pouvez désormais mettre en cache les outils qui ont plusieurs ancrages de sortie (5 ancrages maximum). Cette fonctionnalité étend la fonctionnalité de mise en cache à plus de 50 outils supplémentaires. Notez que certains outils (y compris ceux détenant plus de 5 ancrages de sortie et les outils en BDD) peuvent ne pas prendre encore en charge la mise en cache.

Désactivation d'un seul outil Sortie de données

Vous pouvez désormais désactiver rapidement un seul outil Sortie de données pendant que vous développez votre workflow ou résolvez un problème. Utilisez la case à cocher Désactiver l'outil dans la fenêtre de configuration de l'outil. Lorsqu'il est désactivé, l'outil Sortie de données est grisé sur le canevas pour vous aider à déterminer visuellement son état désactivé.

Prise en charge de la correspondance partielle pour le japonais

Nous avons ajouté la prise en charge du japonais à l'outil Correspondance partielle. Vous pouvez désormais appliquer des styles de correspondance prédéfinis, qui tiennent compte de l'orthographe japonaise, à des adresses, des noms ou du texte japonais.

Mises à jour de l'accessibilité de la grille de résultats

Nous avons mis à jour l'interface utilisateur de la grille des résultats de Designer afin d'améliorer son accessibilité par les lecteurs d'écran et autres technologies d'assistance. Les boutons et les commandes qui n'étaient auparavant visibles que dans certaines conditions sont désormais toujours visibles, bien qu'inactifs s'ils ne s'appliquent pas.

Améliorations de la fonctionnalité « Comparer les workflows »

Nous avons apporté des améliorations à la fonctionnalité « Comparer les workflows ». Lorsque vous comparez 2 workflows avec les outils conteneur, si leurs états activé et désactivé sont différents, la fonctionnalité Comparer les workflows les identifie comme différents.

Mises à jour de l'onglet « Commencez ici »

Nous avons repensé et mis à jour l'expérience « Commencez ici » lorsque vous lancez Designer. « Commencez ici » se lance désormais dans sa propre fenêtre plutôt que sous la forme d'un onglet sur le canevas Designer. Nous mettrons régulièrement à jour le contenu afin de mettre en évidence les nouvelles fonctionnalités et les mises à jour dans Designer. Si vous fermez la fenêtre, vous pouvez la rouvrir via Aide  > Exemples de workflows  > Commencez ici .

Support de l'outil AMP

Actuellement, 166 outils sont entièrement pris en charge et 11 outils le sont partiellement. Les outils partiellement pris en charge reviennent au moteur d'origine pour certaines fonctionnalités non prises en charge.

Tous les outils de Génération de rapports et R sont désormais compatibles avec AMP (à l'exception de l'outil Analyse de la catégorie Génération de rapports).

Il existe 7 autres Connecteurs exclusivement AMP, avec plusieurs autres prévus dans les prochains mois et encore plus pour 2023*, 1 nouvel outil Parité des moteurs , 13 outils Génération de rapports et 65 outils R pour un total de 86 nouveaux outils AMP pris en charge, y compris l'outil R dans la catégorie Développeur.

* Ces outils Connecteur sont disponibles en tant que moteur AMP uniquement, et ne fonctionnent pas avec le moteur d'origine : Entrée de fichier Azure Data Lake, Sortie de fichier Azure Data Lake, Sortie Microsoft Power BI, Entrée OneDrive, Sortie OneDrive, Entrée de SharePoint et Sortie de SharePoint.

Prise en charge de proxy dans AMP

La mise en réseau via proxy est désormais prise en charge dans AMP. Le SFTP sur proxy HTTP est désormais pris en charge dans les deux moteurs. Le contournement du proxy pour les deux moteurs est désormais possible. Vous pouvez désormais spécifier le type de protocole proxy (HTTP et SOCKS5h sont pris en charge) dans Paramètres utilisateur et Paramètres système. Si vous ne spécifiez pas de protocole, la valeur par défaut est HTTP.

Utilitaire de parité des moteurs

L'utilitaire de parité des moteurs est un moyen facile de comparer le moteur d'origine au moteur AMP. Il vous permet d'exécuter les deux moteurs en parallèle, d'évaluer les résultats et de décider quel workflow vous pouvez convertir en AMP en toute confiance. Vous pouvez exécuter l'utilitaire de parité via la ligne de commande avec AlteryxEngineCmd.exe ou via Designer à l'aide du téléchargement de macros de la galerie. Pour plus d'informations,consultez Utilitaire de parité .

Paramètre global permettant d'activer la liste d'autorisations pour la validation d'homologue

En tant qu'administrateur avec une version Designer non FIPS, vous pouvez désormais spécifier une liste d'hôtes problématiques dans un fichier plat pour laquelle la validation d'homologue sera ignorée. Si les utilisateurs rencontrent des problèmes d'autorisation de certificat, il n'est pas nécessaire d'arrêter leur travail.

Obsolescence des outils Analyse comportementale

Les outils Analyse comportementale d'Alteryx Designer sont désormais obsolètes. Ces outils continueront à fonctionner avec les packages de données Business Insights 2021 Q4 et les versions antérieures.

Coffre externe DCM

La fonctionnalité de coffre externe vous permet de connecter DCM au coffre de votre choix. Vous pouvez utiliser des coffres externes dans DCM pour récupérer les identifiants de votre coffre et les utiliser en toute sécurité dans votre workflow. Pour plus d'informations, consultez la rubrique Coffres externes DCM .

Chargement en masse Google BigQuery

Le chargement en masse Google BigQuery est maintenant disponible dans l'outil Sortie. Cette fonctionnalité est prise en charge avec l'authentification OAuth à l'aide de DCM. Nous utilisons Google Cloud Storage pour le transfert de données.

Prise en charge en BDD de Google BigQuery

Google BigQuery est désormais pris en charge dans les outils En base de données. Il est pris en charge avec l'authentification OAuth à l'aide de DCM et comprend le chargement par lot pour la transmission en continu des données.

Prise en charge de l'authentification OAuth pour l'outil E-mail

Vous pouvez désormais vous authentifier auprès de Microsoft Exchange Online avec l'authentification OAuth via DCM et obtenir une paire de jetons qui vous permet d'envoyer des e-mails à partir de votre compte Exchange Online. Pour plus d'informations, consultez Outil E-mail .

Prise en charge d'Azure AD pour Snowflake

Vous pouvez désormais accéder à vos données Snowflake et les gérer grâce à l'authentification OAuth via DCM. Pour plus d'informations, consultez Authentification Snowflake avec Azure AD .

Prise en charge d'Azure AD pour Databricks

Vous pouvez désormais accéder et gérer (lecture/écriture/écriture en masse) vos données Databricks via les applications privées (mono-propriétaire) et publiques (multi-propriétaire) avec une authentification OAuth via DCM. Pour plus d'informations, consultez Authentification Databricks avec OAuth Azure .

Obsolescence des connecteurs

Les connecteurs suivants sont désormais obsolètes :

  • Entrée et sortie Dynamics CRM

  • Entrée et sortie Google Sheets

  • Publier vers Tableau Server

  • Sortie analytique Salesforce Einstein

  • Sortie Salesforce Wave

  • Entrée et sortie de liste SharePoint

Pour plus d'informations, consultez Sources de données .

Affichage des mises à jour sur les cartes

Le logo Mapbox et le texte de l'attribut apparaissent désormais en bas des cartes de base.

Configuration des données d'utilisation

Nous avons supprimé la configuration d'envoi des données d'utilisation dans les paramètres utilisateur de Designer. Pour en savoir plus sur notre philosophie en matière de données d'utilisation, consultez la section Amélioration de nos produits grâce aux données d'utilisation , ainsi que la politique de confidentialité d'Alteryx .

Nouvelles fonctionnalités : Intelligence Suite

Outil PDF vers texte

Extrayez le texte encodé en caractères directement à partir de vos fichiers PDF avec une précision supérieure à 99 %. Ajoutez la reconnaissance optique des caractères (OCR) afin d'extraire des images pour une couverture supplémentaire. Dans la plupart des cas, vous constaterez une augmentation de la précision, de la vitesse et de l'exhaustivité par rapport à l'outil Image en texte.

Outil Classification du texte Zero-shot

Classez le texte dans les catégories de votre choix sans avoir besoin de données d'entraînement.

Outil Résumé de texte>

Extrayez un résumé de votre texte basé sur la méthodologie TextRank. Vous pouvez spécifier la longueur du résumé en nombre de phrases.

Améliorations de l'outil Modèle d'image

Nous avons ajouté la possibilité de modifier les cadres d'annotation dans l'outil Modèle d'image. Nous avons activé cette fonctionnalité avec mini-tate, une nouvelle bibliothèque open source React d'Alteryx.

Étape Décalage dans l'outil Traitement d'image

Ajout d'une étape Décalage à l'outil Traitement d'image. Cette étape permet d'aligner automatiquement les documents en fonction d'un ancrage défini par l'utilisateur. Utilisez l'outil Modèle d'image pour définir l'ancrage avec une annotation. L'étape Décalage peut améliorer les résultats OCR des images décalées pendant le processus de numérisation.

Améliorations de l'outil Reconnaissance d'image

Ajout d'ancrages Métriques d'évaluation et Sortie du rapport du modèle à l'outil Reconnaissance d'image. Les mesures comprennent des renseignements sur la précision, le rappel et l'exactitude de chaque étiquette de classification. La sortie du rapport comprend des tracés de perte et de précision pour chaque période. Utilisez ces tracés pour visualiser si l'outil a suffisamment entraîné le modèle.

2022.2 Designer-FIPS

Important

La version 2022.2 est une version Alteryx Designer-FIPS uniquement. Veuillez noter qu'il n'existe pas de version 2022.2 pour la version non FIPS d'Alteryx Designer.

La version la plus récente d'Alteryx Designer (non FIPS) est la version  2022.1 .

Version : 2022.2.1.39654 (consultez la page Notes de publication )

Date de publication : 24 août 2022

2022.1

Version  : 2022.1.1.25127 (consultez la page Notes de publication )

Date de publication  : 4 mai 2022

Nouvelles fonctionnalités : Designer

AMP comme moteur par défaut

AMP est désormais le moteur par défaut pour tous les nouveaux workflows que vous créez. Toutefois, vous pouvez toujours choisir le moteur de vos workflows via le paramètre au niveau du workflow. Accédez au volet Configuration du workflow dans Designer et sélectionnez l'onglet Exécution. Ensuite, activez ou désactivez la case à cocher Utiliser AMP Engine pour sélectionner votre moteur.

Veuillez noter que lorsque vous lancez la version 22.1 de Designer, une fenêtre contextuelle s'affiche vous informant qu'AMP est la valeur par défaut pour les nouveaux workflows. Vous pouvez alors choisir de ne plus afficher le message si vous le souhaitez.

Alteryx Multi-threaded Processing (AMP) est la nouvelle architecture d'Alteryx Engine. Elle est conçue pour fonctionner avec de plus gros volumes de données à une vitesse supérieure. Pour en savoir plus sur AMP Engine et sur les différences entre le moteur d'origine et AMP, consultez les ressources suivantes :

AMP Engine prend en charge les macros standard, itératives et batch. En outre, plus de 85 outils ont été convertis pour fonctionner avec AMP. Les outils qui n'ont pas été convertis utiliseront automatiquement le moteur d'origine.

Limite de champ pour les données d'entrée et de sortie avec le moteur d'origine et AMP

Pour les données d'entrée et de sortie, il existe désormais une limite supérieure de 32 000 champs par enregistrement pour le moteur d'origine et AMP.

  • Lorsque les données en lecture/écriture sont inférieures ou égales à 32 000 champs, un workflow valide s'exécute correctement.

  • Lorsque les données en lecture/écriture dépassent 32 000 champs, une erreur est renvoyée lors d'une exécution de workflow pour indiquer que le nombre maximal de champs a été dépassé : « Erreur : le nombre de champs est supérieur à la limite de 32 000. Veuillez réduire le nombre de champs. »

Modifications de la structure de regroupement AMP

La structure de regroupement sur AMP Engine a été modifiée pour se comporter de manière similaire au moteur d'origine. Cela affecte les outils Agréger, Jointure et Plusieurs Jointures.

Améliorations de l'interface utilisateur de Designer

Nous avons mis à jour l'interface utilisateur de Designer afin de mieux l'aligner sur les autres produits Alteryx. Dans le cadre de l'actualisation, vous remarquerez de nouvelles polices, couleurs et icônes, qui font toutes partie d'une apparence plus moderne.

Un changement notable est que lorsque vous exécutez votre workflow, la mention « (En cours d'exécution) » n'apparaît plus dans l'onglet de workflow. Elle est remplacée par une icône de rotation/chargement, à côté du titre du workflow dans le même onglet.

Téléchargeur Auto Insights

L' outil Téléchargeur Auto Insights est désormais intégré par défaut dans Alteryx Designer. Vous pouvez accéder à l'outil Téléchargeur Auto Insights via la catégorie d'outils Entrée/Sortie .

Outil Connexion DCM

L' outil Connexion DCM est un nouvel outil de la famille d'outils Interface . Avec l' outil Connexion DCM , vous pouvez afficher une invite dans une application ou une macro et permettre à l'utilisateur de choisir une connexion à partir de son stockage DCM.

Prise en charge de Databricks Delta Lake

Une nouvelle fonctionnalité prend en charge les tables Delta sur Databricks . Vous pouvez utiliser des clusters de point de terminaison SQL ou interactifs sur AWS et Azure. Le chargement en masse est pris en charge avec le transfert de données dans les ADLS AWS S3 ou Azure.

Références « Galerie » remplacées par « Server »

Nous avons remplacé toutes les références à « Galerie » dans Designer par « Server ». Nous nous alignons donc sur les récentes mises à jour terminologiques du produit Alteryx Server.

Nouvelles fonctionnalités : Intelligence Suite

Créateur d'étiquette morpho-syntaxique

L' outil Créateur d'étiquette morpho-syntaxique vous permet d'identifier la catégorie morpho-syntaxique d'un mot donné. Vous pouvez analyser des éléments morpho-syntaxiques spécifiques et affiner les résultats pour d'autres outils Exploration de texte . Par exemple, vous pouvez créer des nuages de mots avec des verbes uniquement ou des modèles de thèmes avec des noms uniquement.

Outil Code-barres

L' outil Code-barres extrait les informations stockées dans les codes QR et les codes-barres. L'outil peut également générer des codes QR et des codes-barres. Vous pouvez extraire des informations sous-jacentes dans des codes QR et des codes-barres pour automatiser les processus métiers. Par exemple, certaines entreprises utilisent des codes QR pour déterminer si les documents sont pertinents pour certains services, puis organisent les documents par département Finance, RH, Marketing, etc. en conséquence.

Fonctionnalité d'optimisation de l'OCR de l'outil Traitement d'image

Nous avons ajouté une fonctionnalité d'optimisation de l'OCR à l'outil Traitement d'image pour les PDF numérisés. Utilisez l'étape d'optimisation de l'OCR pour prétraiter les PDF bruyants et numérisés (par exemple, les documents numérisés qui contiennent des arrière-plans et des filigranes non blancs ou texturés) pour la reconnaissance optique des caractères (OCR). Cette étape supplémentaire peut considérablement améliorer les résultats de l'outil Extraction de paires clé-valeur.

Extraction de paires clé-valeur

L' outil Extraction de paires clé-valeur relie deux éléments de données, une clé qui définit le jeu de données, et sa valeur qui appartient à ce dernier. Par exemple :

  • Société : Alteryx

    • « Société » est la clé.

    • « Alteryx » est la valeur de la clé « Société ».

Optimisation de la vitesse de l'OCR

Nous avons amélioré les performances des outils Entrée d'image et Image en texte permettant d'accélérer encore davantage vos workflows ! Vous pourrez constater des améliorations significatives (jusqu'à 40 % d'augmentation de la vitesse) lorsque vous analysez des documents plus volumineux, tels que des PDF multipages.

Nouvelles fonctionnalités : installation et activation de licence

Alteryx License Server

Nous avons rationalisé le processus d'activation avec Alteryx License Server pour vous permettre de vous concentrer sur les produits disponibles en supprimant les clés de licence de l'affichage.

Nouvelles options pour AlteryxActivateLicenseKeyCmd

Nous avons ajouté une option pour mettre à jour le stockage sécurisé avec les informations sur License Server. Nous avons également ajouté une option pour renvoyer la configuration actuelle, y compris le mode de licence, l'adresse e-mail et l'URL License Server, le cas échéant.

2021.4

Version  : 2021.4.1.04899 (consultez la page Notes de publication )

Date de publication  : 2 février 2022

Lier Designer à Alteryx Platform

Vous pouvez maintenant lier Designer à Alteryx Platform . Cela vous permet d'enregistrer vos workflows Designer sur Platform, ainsi que d'ouvrir des workflows à partir de Platform dans Designer..Gestion des liens Alteryx

Amélioration de l'outil Analyse XML

L'outil Analyse XML inclut désormais une option permettant de ne pas transmettre en aval le champ analysé d'origine.

Générer un fichier de support

Le fichier de support technique contient désormais des informations supplémentaires, comme des informations système, des variables d'environnement, des journaux de moteur, des pilotes et versions ODBC, et bien d'autres encore ! Accédez à Générer un fichier de support pour en savoir plus sur cette fonctionnalité.

Réservation de produits pour des utilisateurs spécifiques (administrateur uniquement)

Les administrateurs peuvent réserver l'accès aux produits pour des utilisateurs spécifiques via les groupes de réservation. Cela garantit aux utilisateurs l'accès aux produits et fonctionnalités dont ils ont besoin. Accédez à Réservations Alteryx License Server pour en savoir plus.

Public Gallery et Designer

Vous ne pouvez plus enregistrer de workflows de Designer dans Public Gallery. Consultez la FAQ sur la migration du site Public Gallery pour en savoir plus.

Améliorations des messages d'erreur

Certains messages d'erreur de la fenêtre Résultats sont désormais liés à des articles de la communauté qui vous aideront à comprendre et à résoudre les erreurs.

Mise à niveau CEF

Nous avons mis à niveau CEF vers la version 91.0.4472.124. Vous pouvez rencontrer un écran vide lors de l'authentification aux connecteurs OneDrive, Dropbox, Dataverse, Box, SharePoint et Power BI. Veuillez noter que vous devez mettre à jour ces connecteurs pour résoudre ce problème. Pour en savoir plus sur la compatibilité des connecteurs avec Designer, rendez-vous sur Compatibilité de Designer avec les connecteurs de données .

Nouvel outil Intelligence Suite

Alteryx Intelligence Suite inclut désormais un nouvel outil Exploration de texte. L'outil Reconnaissance d'entités nommées vous permet d'entraîner un modèle qui identifie des entités prédéfinies ou personnalisées, telles que des personnes, des lieux ou des objets, dans des données de texte.

Nouveaux Connecteurs de données

Ces outils Connecteur de données sont désormais disponibles :

Gestionnaire de connexions aux données (DCM)

Le gestionnaire de connexions aux données (DCM) est le coffre-fort sécurisé unifié pour stocker les identifiants des utilisateurs. Utilisez DCM pour améliorer la sécurité en déplaçant vos identifiants à l'extérieur du workflow et en les synchronisant dans la suite de produits Alteryx. Pour en savoir plus sur cette nouvelle fonctionnalité, rendez-vous sur la page d'aide DCM .

Mode de compatibilité du moteur

Le mode de compatibilité du moteur est une nouvelle option de configuration au niveau du workflow. Il est utile lorsque vous devez conserver l'ordre des enregistrements de sortie provenant d'outils spécifiques sur les deux moteurs. Il fournit un chemin de migration plus facile qui permet aux utilisateurs de transférer des workflows exigeant un ordre d'enregistrement spécifique du moteur d'origine vers AMP. Pour plus d'informations, consultez la page d'aide Mode de compatibilité du moteur .

Prise en charge de la limite d'enregistrement pour toutes les entrées dans AMP

Le paramètre global Limite d'enregistrement pour toutes les entrées est désormais pris en charge par AMP. Dans l'onglet Configuration du workflow - Exécution, vous pouvez définir la limite d'enregistrement à un seul endroit pour toutes les entrées.

Télémétrie gérée par le client

Configurez vos installations Designer de type bureau pour qu'elles consignent localement les métadonnées de workflow et les XML. Vous pouvez utiliser ces journaux pour automatiser un nombre illimité de processus, comme le contrôle des modifications ou les métriques d'utilisation des services. Afin de répondre aux exigences les plus élevées en matière de confidentialité des clients, ces journaux sont gérés par le client et ne sont pas envoyés à la société Alteryx ni enregistrés par cette dernière.

2021.3

Version  : 2021.3.1.47945

Date de publication  : 11 août 2021

Comparer les workflows

Utilisez la fonctionnalité Comparer les workflows pour comparer 2 workflows et identifier rapidement les différences à l'aide d'indicateurs visuels. Vous pouvez accéder à cette fonctionnalité via Options > Options avancées dans Alteryx Designer.

Outils recommandés

Le nouvel onglet Recommandé de la palette d'outils Designer propose des outils que vous pouvez utiliser pendant la création de votre workflow. Sélectionnez un outil sur votre canevas et l'onglet Recommandé affiche 6 outils communs en aval qui suivent généralement l'outil sélectionné.

Nouveaux outils Intelligence Suite

Alteryx Intelligence Suite inclut désormais 2 outils dans la catégorie Vision par ordinateur. L'outil Profil d'image vous permet d'extraire des informations utiles à partir d’images et l'outil Reconnaissance d'image vous permet d'entraîner un modèle de machine Learning pour classer les images.

Amélioration de l'outil Conteneur d'outils

Nous avons mis à jour l'outil Conteneur d'outils. Maintenant, lorsque vous désactivez un conteneur d'outils, le conteneur désactivé reste développé sur le canevas et apparaît grisé pour indiquer l'état désactivé. Vous pouvez réduire un conteneur désactivé pour en masquer le contenu. Pour ce faire, sélectionnez l'icône Développer/Réduire dans le conteneur d'outils.

Profilage des performances avec AMP Engine

Pour optimiser votre workflow lors de la création de workflows avec AMP, vous pouvez désormais analyser les performances d'outils spécifiques grâce au profilage des performances avec AMP. Vous pouvez activer le profilage à l'aide de la case à cocher Activer le profilage des performances dans les paramètres Exécution de la configuration du workflow. Pour plus d'informations, consultez la page d'aide Profilage des performances avec AMP Engine .

Microsoft Power BI

Nous avons mis à jour le connecteur Microsoft Power BI :

  • Application Azure multi-propriétaire intégrée avec option d'utilisation d'une application Azure personnalisée.

  • Prend en charge les entrées de tables multiples.

  • Conserve le jeu de données existant et sa structure avec la mise à jour et le remplacement des données.

  • Les utilisateurs peuvent sélectionner l'espace de travail avec lequel travailler.

  • Prise en charge de proxy.

Générer un fichier de support

Générez un fichier d'assistance technique contenant des informations qui aident les ingénieurs de notre service clientèle à résoudre correctement votre problème. Vous pouvez charger ce fichier lorsque vous soumettez votre cas de support. Vérifiez le contenu du fichier et supprimez tout élément que vous ne souhaitez peut-être pas inclure.

Contrat de licence de l'utilisateur final et politique de confidentialité

Le contrat de licence de l'utilisateur final (CLUF) et la politique de confidentialité d'Alteryx sont désormais accessibles via le menu Aide de Designer.

2021.2

Version  : 2021.2.1.35394

Date de publication  : 17 mai 2021

Nouveaux outils Intelligence Suite

Alteryx Intelligence Suite dispose désormais d'outils de Vision par ordinateur. Utilisez-les pour entrer, traiter, analyser, puis sortir des images à l'aide de Designer.

Mise à niveau de R

Nous avons mis à niveau R vers la version 4.0.4 à partir de la version 3.6.3. La version R 4.0 offre des améliorations dans la gestion de la mémoire de R, ce qui signifie que R peut désormais travailler avec plus de données sans problème de mémoire. Cette nouvelle version permet à nos utilisateurs qui utilisent le code R personnalisé dans Alteryx de continuer de télécharger les programmes d'installation binaires des paquets R depuis CRAN.

Programme d'installation séparé pour Alteryx Intelligence Suite

Intelligence Suite est maintenant installé séparément de Designer. Cela améliore le temps d'installation de Designer tout en permettant aux utilisateurs d'installer rapidement Intelligence Suite.

Mise à jour de l'expérience d'essai

Nous avons mis à jour l'expérience d'essai pour les nouveaux clients et les clients actuels. Désormais, les utilisateurs peuvent activer un essai d'Alteryx Intelligence Suite indépendamment de l'essai d'Alteryx Designer. Les utilisateurs qui souhaitent tester Alteryx Intelligence Suite ont désormais la possibilité d'essayer cette fonctionnalité même s'ils disposent déjà d'une licence Designer de base.

Nettoyage des données via la grille de résultats

Vous pouvez désormais effectuer des actions de nettoyage de données directement dans la grille des résultats et appliquer ces actions à votre workflow via un outil Nettoyage des données préconfiguré. Nous avons également mis à jour l'interface utilisateur de la grille des résultats afin de mieux organiser les options de nettoyage des données, de filtre et de tri.

Convertir en macro

Vous avez maintenant la possibilité de convertir un workflow existant en macro, dans sa totalité ou en partie. Sélectionnez au moins un outil, cliquez avec le bouton droit de la souris et sélectionnez Convertir en macro dans le menu déroulant. Reportez-vous à la section Convertir en macro pour en savoir plus sur les limitations et les instructions supplémentaires importantes.

UID global

Les workflows (fichiers .yxmd, .yxmc et .yxwz) suivent désormais les ID uniques dans le XML. Cela inclut l'ID de workflow d'origine et l'ID de workflow précédent. Par exemple :

<WorkflowId value="f8e90084-fca0-4c5d-9c0e-5fe614d78df1" />

<Telemetry>

<PreviousWorkflowId value="" />

<OriginWorkflowId value="f8e90084-fca0-4c5d-9c0e-5fe614d78df1" />

</Telemetry>

Journalisation asynchrone du moteur

Les journaux du moteur local peuvent désormais être écrits de manière asynchrone pour le moteur d'origine. Les performances sont ainsi améliorées, en particulier pour les administrateurs qui écrivent des journaux sur un chemin de fichier réseau partagé.

Spécifiez une page de code d'outils prédictifs par workflow

Nous avons ajouté les paramètres de la page de code prédictif à la configuration du workflow afin que les informations de cette page puissent être enregistrées dans le workflow. Cela évitera que les workflows utilisent des paramètres de page de code prédictifs différents en fonction de la langue sélectionnée par l'utilisateur.

Prise en charge du tri phonétique pour les Kanji

Nous avons introduit d'autres méthodes de tri, disponibles dans les différentes zones de Designer, qui permettent aux utilisateurs de trier tels que l'outil Trier, le comportement de tri de la grille interactive de résultats, l'outil Sélectionner (ou tout autre outil doté d'une fonctionnalité de l'outil Sélectionner intégrée) et l'outil Ensemble. Ces méthodes de tri incluent Pinyin, Gojūon et Ordre du dictionnaire pour toutes nos langues prises en charge.

Vous pouvez personnaliser ce paramètre via les Paramètres utilisateur de localisation .

Mise à jour des polices incorporées dans les macros prédictives

Nous avons mis à jour les polices codées en dur qui étaient incorporées dans les macros prédictives. Ainsi, les clients éviteront de tomber sur des résultats incompréhensibles dans leurs rapports PDF. La police utilisée prend en charge le texte de la langue choisie par l'utilisateur.

Sortie de l'outil  Modélisation de thèmes

Nous avons ajouté un point d'ancrage de sortie M supplémentaire à l'outil Modélisation de thèmes, qui permet aux utilisateurs d'enregistrer des modèles qu'ils pourront utiliser ultérieurement pour faire des prédictions sur de nouvelles données.

Mises à jour de l'outil Sortie Google BigQuery

Nous avons mis à jour l'outil Sortie Google BigQuery pour utiliser l'écriture de fichiers en bloc au lieu de diffuser des enregistrements dans BigQuery. L'outil charge maintenant les fichiers JSON de la machine locale dans BigQuery. Pour plus d'informations sur les mises à jour, reportez-vous aux notes de publication de Gallery fournies pour ces outils.

Maintenance de l'outil Entrée Salesforce

Nous avons corrigé les défauts dans l'outil Entrée Salesforce Veuillez consulter les notes de publication dans Gallery pour cet outil, pour obtenir des informations sur la mise à jour.

Mise à jour du texte de message d'erreur avec la mention Restreint en mode sans échec

Lorsqu'ils tentent d'exécuter un workflow (dans Server, Gallery ou AAH) contenant des outils restreints en mode sans échec ou semi sans échec, les utilisateurs reçoivent désormais différents messages d'erreur. Par exemple, « Erreur d'environnement restreint : l'outil R est interdit en raison des paramètres actuels du mode d'exécution. »

Prévention des blocages partie 2 : limite des connexions pour l'outil Plusieurs Jointures, ordre des actions pour l'outil Agréger et augmentation du nombre de threads si la mémoire est augmentée

Lorsqu'un workflow contenait plusieurs de ces outils (Jointure, Plusieurs Jointures, Agréger, Ensemble et Correspondance partielle) et que la limite de mémoire était trop basse, il était très probable que le moteur rencontre un blocage de la mémoire. Ce problème est maintenant résolu.

Mises à jour de l'exemple d'outil unique

Nous avons converti plusieurs workflows en exemple d'outil unique. Vous pouvez maintenant les trouver sous Aide > Exemples de workflows > Apprendre un outil à la fois > Prédictif . Ils se trouvaient précédemment sous Aide > Exemples de workflows > Exemples prédictifs .