Skip to main content

Notes de publication Server 2022.1

Notes de publication - Versions produit

Version

Date

Version

Arrêt de la prise en charge

2022.1.1.25127

4 mai 2022

Majeure

4 mai 2024

2022.1.1.30569* (Correctif 1)

15 juin 2022

Mineur/correctif

4 mai 2024

2022.1.1.30961 (Correctif 1)

23 juin 2022

Mineur/correctif

4 mai 2024

2022.1.1.40869 (Version mineure)

2022.1.1.2.40869 (Correctif 2)

8 septembre 2022

Mineur/correctif

4 mai 2024

2022.1.1.42590 (Version mineure)

2022.1.1.3.42590 (Correctif 3)

21 novembre 2022

Mineur/correctif

4 mai 2024

2022.1.1.42604 (Version mineure)

2022.1.1.4.42604 (Correctif 4)

4 janvier 2023

Mineur/correctif

4 mai 2024

2022.1.1.42619 (Version mineure)

2022.1.1.5.42619 (Correctif 5)

15 février 2023

Mineur/correctif

4 mai 2024

2022.1.1.42636 (Version mineure)

2022.1.1.6.42636 (Correctif 6)

29 mars 2023

Mineur/correctif

4 mai 2024

2022.1.1.42654 (Version mineure)

2022.1.1.7.42654 (Correctif 7)

24 mai 2023

Mineur/correctif

4 mai 2024

2022.1.1.42673 (version mineure)

2022.1.1.8.42673 (correctif 8)

24 juillet 2023

Mineur/correctif

4 mai 2024

2022.1.1.42691 (Minor)

mineure) 2022.1.1.9.42691 (correctif 9)

20 septembre 2023

Mineur/correctif

4 mai 2024

2022.1.1.42707 (Minor)

2022.1.1.10.42707 (Patch 10)

November 30, 2023

Minor/Patch

May 4, 2024

2022.1.1.42716 (Minor)

2022.1.1.11.42716 (Patch 11)

February 1, 2024

Minor/Patch

May 4, 2024

Note

*Mise à jour du correctif 2022.1.1.30569

Le correctif/version mineure 2022.1.1.30569 a été supprimé du portail de téléchargement en raison d'une signature manquante dans certains des fichiers inclus. Les fichiers ne sont donc pas reconnus comme des fichiers valides fournis par Alteryx et peuvent être à l'origine du déclenchement de messages d'avertissement par certains programmes tiers.

Si vous avez installé la version 2022.1.1.30569, nous vous recommandons d'installer la dernière version du correctif. Il n'est pas nécessaire de désinstaller la version 2022.1.1.30569.

Note

Considérations sur la mise à niveau

À partir de la version 2022.1, il existe une limitation de compatibilité Designer pour les environnements avec authentification intégrée. Pour maintenir la compatibilité avec Server, téléchargez la dernière version de Designer.

Note

Mises à jour de correctifs

Alteryx vous donne maintenant la possibilité d'appliquer un correctif à votre installation de Designer ou de Server sans avoir à effectuer une désinstallation et une réinstallation complètes. Vous pouvez télécharger le correctif le plus récent sur le portail des licences et téléchargements . Pour les anciennes versions des correctifs, contactez l'équipe Fulfillment .

Nouvelles fonctionnalités

Suppression des points de terminaison OAuth1 hérités

En vue d'une future offre FIPS-140, nous avons supprimé nos anciens points de terminaison publics d'API OAuth1 (ils nécessitaient un hachage SHA1 qui n'est pas conforme à la norme FIPS). Cette suppression inclut les points de terminaison WCF (Windows communication Framework) hérités, Swagger pour ces points de terminaison hérités et le middleware OAuth1. Pour remplacer les points de terminaison OAuth1, vous pouvez utiliser les versions OAuth2 des API héritées publiées dans la version 2021.4. Vous obtenez la même fonctionnalité avec les API OAuth2 que celle disponible avec les API OAuth1. La seule exception concerne l'appel GET/workflows/id/package, qui renvoie désormais un fichier au lieu d'un objet binaire dans la réponse.

Nous continuerons à prendre en charge la souscription et les points de terminaison V1 et V2 sous OAuth2.

Pour en savoir plus sur la conversion et son impact, consultez la page d'aide Instructions de migration d'OAuth1 vers OAuth2 ou les  instructions de conversion .Instructions de migration d'OAuth1 vers OAuth2

AMP Engine activé par défaut

Nous avons activé AMP Engine par défaut sur Server. Ainsi, les nouveaux nœuds worker peuvent exécuter simultanément des workflows pour le moteur d'origine et pour AMP Engine. Nous fournirons des directives sur la manière de gérer la mémoire avec plusieurs tâches simultanées, et dans différentes combinaisons du moteur d'origine et d'AMP Engine. Pour plus d'informations sur AMP Engine, consultez les pages d'aide Meilleures pratiques d'AMP Engine et Moteur .MoteurMeilleures pratiques d'AMP Engine

Important

Lorsque vous effectuez une mise à niveau vers la version 2022.1 de Server, nous vous recommandons de valider les paramètres de choix du moteur et les allocations de ressources. La nouvelle fonctionnalité « Autoriser Server à gérer les workflows s'exécutant simultanément » et la nouvelle activation d'AMP par défaut peuvent entraîner des modifications des paramètres dans votre environnement.

Si vous disposez déjà de Server et que vous souhaitez conserver vos paramètres système actuels, veuillez lire ces instructions avant de procéder à la mise à niveau.

1. Controller  (Contrôleur) > General  (Général) > Enable AMP Engine  (Activer AMP Engine)

1. Avant la mise à niveau, notez vos paramètres actuels.

2. Après la mise à niveau, restaurez la sélection à la valeur souhaitée.

2. Worker  > General  (Général) > Allow Server to manage workflows running simultaneously  (Autoriser Server à gérer les workflows s'exécutant simultanément)

1. Avant la mise à niveau, notez le nombre défini de workflows autorisés à s'exécuter simultanément.

2. Après la mise à niveau, désélectionnez «  Allow Server to manage workflows running simultaneously  » (Autoriser Server à gérer les workflows s'exécutant simultanément).

3. Entrez le nombre de workflows autorisés à s'exécuter simultanément que vous avez noté.

3. Engine (Moteur) > General (Général) > Engine  (Moteur)

1. Avant la mise à niveau, notez vos paramètres actuels.

2. Après la mise à niveau, restaurez la sélection à la valeur souhaitée.

4. Engine (Moteur) >  General  (Général) > Run engine at a lower priority  (Exécuter le moteur en basse priorité)

1. Avant la mise à niveau, notez vos paramètres actuels.

2. Après la mise à niveau, restaurez la sélection à la valeur souhaitée.

Réinitialisation obligatoire du mot de passe pour l'authentification intégrée

Si vous utilisez l'authentification intégrée, vous devez réinitialiser votre mot de passe en raison des améliorations de sécurité. Si vous ne réinitialisez pas votre mot de passe dans la version 2022.1, vous devez activer SMTP pour le réinitialiser dans la version 2022.2. Pour plus d'informations sur la réinitialisation du mot de passe Server après la mise à niveau vers la version 2022.1, consultez la page d'aide Réinitialiser le mot de passe Server d'un utilisateur .Réinitialisation du mot de passe Server d'un utilisateur

Outre la réinitialisation du mot de passe, il existe une limitation de compatibilité Designer pour les environnements avec authentification intégrée. Les versions antérieures de Designer ne disposent pas du mécanisme de modification de mot de passe nécessaire pour s'authentifier auprès de Server 2022.1 et des versions ultérieures. Pour garantir la compatibilité, vous devez exécuter Designer 2022.1 ou une version ultérieure.

Localisation de l'interface utilisateur Server (Bêta)

Nous avons localisé les pages utilisateur de Server en 8 langues (anglais, japonais, chinois, espagnol, français, Italien, allemand et portugais) et plus de 90 paramètres régionaux. Il s'agit d'une version Bêta car certains contenus sont encore en cours de création. Pour mettre à jour votre langue et vos préférences régionales, accédez à Mon profil  > Général .

Refonte de l'interface utilisateur Server

Nous avons repensé les pages utilisateur Catégories, Résultats du workflow et Planifications ainsi que les pages d'administration Collections, Informations d'identification, Utilisateurs et Groupes. La fonctionnalité de ces pages reste la même.

Nouvel e-mail de bienvenue aux utilisateurs créés via un appel d'API POST /Users

Nous avons créé un e-mail de bienvenue pour les nouveaux utilisateurs créés via un appel d'API POST /users. Le nouvel e-mail de bienvenue comprend un lien pour que l'utilisateur définisse son mot de passe. Cette expérience utilisateur est similaire à celle que les nouveaux utilisateurs voient lors de la création manuelle de leur compte. Notez que l'e-mail de bienvenue n'est envoyé que si SMTP est configuré.

Options de configuration de l'authentification intégrée pour les tentatives de connexion et le verrouillage de compte

Pour éviter une attaque par force brute, nous avons ajouté un paramètre de configuration nommé Nombre de tentatives de connexion autorisées , avec lequel un administrateur peut définir le nombre de tentatives autorisées avant le verrouillage d'un utilisateur. Nous avons également ajouté un paramètre nommé Délai de verrouillage du compte (minutes) , qui définit le délai en minutes pendant lequel un utilisateur est bloqué après avoir atteint le nombre maximum de tentatives infructueuses. La valeur par défaut est de 5 tentatives de connexion, après quoi le compte est verrouillé pendant 5 minutes. Nous avons également ajouté une option de paramètre qui permet aux administrateurs de décider s'ils veulent appliquer un délai d'expiration de tentative de connexion. L'administrateur peut mettre à jour ces 3 paramètres de sécurité sous Configuration de Server  > Paramètres de sécurité . Ces paramètres ne sont disponibles que lorsque vous utilisez l'authentification intégrée.

Pour plus d'informations, reportez-vous à la page Configuration d'Alteryx Server .Alteryx Server-FIPS

Mise à niveau de jQuery utilisé par la nouvelle documentation de Swagger 2.0

Nous avons mis à niveau jQuery vers sa dernière version 3.6.0, pour la documentation Swagger de l'API V3 de Server. Cela fait partie d'un effort plus important pour supprimer les anciennes versions de jQuery. Nous prévoyons de terminer dans le courant de l'année, lorsque nous aurons remanié l'ensemble de l'interface utilisateur dans la nouvelle interface React.

Migration de tous les algorithmes de hachage vers SHA2 à l'aide de CryptoLib

En vue d'une future offre conforme à la norme FIPS, nous avons mis à jour tous les appels cryptographiques non-Windows de notre base de code afin de nous appuyer sur un fournisseur de services cryptographiques (CSP) unique, le module basé sur la norme OpenSSL3 conçu et géré par notre équipe DevSec, conformément à la norme FIPS-140. Cette mise à jour ne doit pas avoir d'impact direct sur l'expérience utilisateur, sauf pour rendre la solution plus fiable dans son fonctionnement global.

Mise à jour du chiffrement AES-256

Nous avons migré la cryptographie utilisée pour sécuriser les connexions aux données héritées (par exemple, DCM.E et les secrets API) vers AES 256. Cette mise à jour n'a aucune conséquence directe sur l'expérience utilisateur, mais elle rend notre solution plus sécurisée pour nos clients.

Internet Explorer non pris en charge

Internet Explorer ne sera plus pris en charge à partir de la version 2022.1. Les navigateurs pris en charge sont Chrome, Firefox, Edge et Safari. Pour plus d'informations, reportez-vous à la page Politique de prise en charge des versions .

Fuseau horaire pour les planifications dans l'API Server V3

Ajout d'un fuseau horaire pour les points de terminaison de l'API V3 suivants :

  • POST /v3/schedules : ce point de terminaison a été mis à jour pour vous permettre de définir l'heure et le fuseau horaire des planifications.

    Par exemple, si vous souhaitez définir une planification pour 17:00, heure des Rocheuses, vous devriez pouvoir définir l'horaire sur 17:00 et sélectionner Heure des Rocheuses comme fuseau horaire. L'option Fuseau horaire est facultative, et si vous ne spécifiez pas le fuseau horaire, le fuseau horaire par défaut sera l'heure UTC (Temps universel coordonné).

  • PUT /v3/schedules : ce point de terminaison a été mis à jour pour vous permettre de mettre à jour les planifications existantes créées à l'aide de l'API et d'ajouter, si vous le souhaitez, un fuseau horaire sélectionné. 

    Par exemple, si vous avez créé une planification à l'aide des points de terminaison d'API et que l'heure devait être définie en UTC, vous devriez pouvoir mettre à jour la planification et modifier l'heure et le fuseau horaire.

    Toutefois, les planifications existantes continueront à s'exécuter comme prévu si vous choisissez de ne pas ajouter de fuseau horaire.

  • GET /v3/schedules/{id} : ce point de terminaison a été mis à jour pour vous permettre d'afficher le fuseau horaire d'une planification existante filtrée par ID.

  • GET /v3/schedules/ : ce point de terminaison a été mis à jour pour vous permettre d'afficher les fuseaux horaires de toutes les planifications existantes.

Pour plus d'informations sur les points de terminaison, accédez à la documentation Swagger en sélectionnant l'icône point d'interrogation dans le coin supérieur droit de l'interface Server. Pour connaître les fuseaux horaires valides à utiliser dans les points de terminaison d'API ci-dessus, consultez la page d'aide Points de terminaison des planifications .Points de terminaison des planifications

Option CLI pour se connecter à un contrôleur à distance

En tant qu'administrateur, vous pouvez désormais transférer en toute sécurité des clés de chiffrement depuis votre environnement existant pour migrer Server vers un nouvel hôte ou pallier une panne.

Pour plus d'informations, reportez-vous à la section Clés DCME à sauvegarder .Clés DCME à sauvegarder

Problèmes connus et résolus

Résolu

Version majeure 2022.1.1.25127

ID

Description

Version

Statut du problème

TCPE-56

DE17441

L'ajout d'une connexion aux données échoue si le mot de passe comporte une barre verticale « | ».

2022.1.1.25127

Résolu

TCPE-89

DE33954

Lorsqu'AlteryxService demande à un worker de s'arrêter, Alteryx Engine ne traite pas le message annulé par l'utilisateur comme une erreur.

2022.1.1.25127

Résolu

TCPE-106

GCSE-296

L'outil Encodeur Base64 accepte une colonne de données, mais ne code correctement qu'un enregistrement sur trois.

2022.1.1.25127

Résolu

TCPE-123

DE22217

Les workflows Alteryx sont signalés comme « Erreur » alors que le message et les journaux d'événements indiquent « Succès ».

2022.1.1.25127

Résolu

TCPE-149

TGAL-6137

Planifications : l'horodatage de la prochaine exécution est antérieur à celui de la dernière exécution.

2022.1.1.25127

Résolu

TGAL-2716

DE27806

La migration des planifications de Designer vers Server entraîne un message d'erreur.

2022.1.1.25127

Résolu

TGAL-2718

DE27828

L'option de renommage s'affiche pour les utilisateurs non propriétaires de la collection.

2022.1.1.25127

Résolu

TGAL-2727

DE28053

Les tâches du planificateur présentent un temps d'exécution de 0,0 seconde.

2022.1.1.25127

Résolu

TGAL-2743

DE28593

La page de configuration de worker dans la fenêtre de configuration de Server contient une entrée active lorsque la case à cocher correspondante est désélectionnée.

2022.1.1.25127

Résolu

TGAL-2892

DE34042

Lors de l'ajout d'un workflow renommé à une collection, l'ancien nom s'affiche dans la boîte de dialogue Ajouter un workflow. Après l'avoir ajouté à la collection, le nouveau nom s'affiche.

2022.1.1.25127

Résolu

TGAL-5831

Création d'un utilisateur via « Admin » -> « Users » ajoute deux studios sous « Subscriptions ».

2022.1.1.25127

Résolu

TGAL-5875

Le bouton Enregistrer ne s'affiche pas lors de l'enregistrement d'un workflow provenant du studio d'un autre utilisateur sur Server.

2022.1.1.25127

Résolu

TGAL-5938

DE33992

Dans le panneau d'administrateur > Tâches >, onglet  « Migration », il est impossible de rechercher un utilisateur si son rôle est défini par défaut sur « Visiteur » ou« Membre ».

2022.1.1.25127

Résolu

TGAL-6009

La version du client affiche une valeur non valide dans l'interface utilisateur de Server.

2022.1.1.25127

Résolu

TGAL-6039

Impossible de modifier le propriétaire de la collection.

2022.1.1.25127

Résolu

TGAL-6042

L'utilisateur disposant d'un accès administrateur conserve les autorisations de planification jusqu'à ce que l'onglet soit actualisé.

2022.1.1.25127

Résolu

TGAL-6046

Nombre négatif du temps d'exécution indiqué dans AS_Queue.

2022.1.1.25127

Résolu

TGAL-6080

API Server : POST et PUT /schedules utilisent un nom au lieu d'un nombre pour dayNumber.

2022.1.1.25127

Résolu

TGAL-6083

Possibilité de créer une souscription dont le nom ne contient que des espaces vides.

2022.1.1.25127

Résolu

TGAL-6085

La recherche d'un utilisateur ne fonctionne pas lors de la saisie de la partie médiane du prénom uniquement.

2022.1.1.25127

Résolu

TGAL-6122

GBETA-106

Le numéro de version du workflow est incorrect.

2022.1.1.25127

Résolu

TGAL-6142

GBETA-123

Le libellé de la colonne Date de téléchargement du workflow dans les collections est incorrect.

2022.1.1.25127

Résolu

TGAL-6189

La mise en forme de la documentation d'aide d'AlteryxService est difficile à lire.

2022.1.1.25127

Résolu

TGAL-6222

GS-505

Erreur lors de l'exécution de workflows avec des connexions partagées DCMe pour les utilisateurs non-propriétaires.

2022.1.1.25127

Résolu

TGAL-6250

GCSE-343

API Server v3 : POST /v3/usergroups/{id}/users ne permet pas d'ajouter des utilisateurs lors de l'utilisation de l'authentification WinAuth.  

2022.1.1.25127

Résolu

TGAL-6251

Le tri sur la colonne Source partagée entraîne un problème de chargement sur la page Mon espace de travail.

2022.1.1.25127

Résolu

TGAL-6267

GCSE-327

Les workflows peuvent être publiés à partir d'une version ultérieure de Designer sur une version antérieure de Server et les tâches planifiées peuvent être exécutées.

2022.1.1.25127

Résolu

TGAL-6268

TLF-2990

API Server v1 : les points de terminaison de l'API Server GET /admin/v1/workflows et GET /admin/v1/workflows/jobs/ sans filtre de recherche ne renvoient pas de données.

2022.1.1.25127

Résolu

TGAL-6303

API Server v1 : lors de l'utilisation du point de terminaison /webapi/v1/workflows/{id}/package endpoint via la nouvelle structure d'API, le téléchargement du package est défini par défaut sur une extension de fichier incorrecte.

2022.1.1.25127

Résolu

TGAL-6317

API Server v1 : lors de l'utilisation des API de tâches v1 dont les ports sont définis sur WebAPI, les utilisateurs de la structure dans un environnement WinAuth ne peuvent pas interroger les points de terminaison v1/jobs et renvoyer les résultats.

2022.1.1.25127

Résolu

TGAL-6323

GCSE-368

L'utilisation des clés d'API souscription privée/studio avec les points de terminaison de l'API Server v1 échoue avec une exception inconnue. Les points de terminaison dans la version 21.4.1 reconnaissent de manière incorrecte les clés souscription/studio.

2022.1.1.25127

Résolu

TGAL-6332

API Server v1 : le point de terminaison GET /v1/jobs/...{outputId} entraîne le code de réponse 500.

2022.1.1.25127

Résolu

TGAL-6340

GCSE-367

Les planifications ne se chargent pas lorsque la base de données contient un horodatage de paramètre régional LastModifiedDate incorrect.

2022.1.1.25127

Résolu

TGAL-6361

GCSE-415

DCMe : lors du partage de connexions de source de données avec des groupes personnalisés, tout utilisateur de ce groupe personnalisé reçoit l'erreur « La connexion sélectionnée n'est pas disponible. Configurez-en une pour utiliser l'outil. » après l'exécution du workflow.

2022.1.1.25127

Résolu

TGAL-6376

Lors de la création d'un nouvel utilisateur dans le portail d'administration, le message « Impossible de créer l'utilisateur » s'affiche, mais l'utilisateur est créé.

2022.1.1.25127

Résolu

TGAL-6393

TGAL-6375

API Server V3 : la création de planification ne définit pas les bonnes dates/heures et les paramètres récurrents comme souhaité.

2022.1.1.25127

Résolu

TGAL-6414

GCSE-440

Les utilisateurs créateurs ne peuvent pas exécuter certains points de terminaison V1 via WebAPI lors de l'authentification via OAuth2.

2022.1.1.25127

Résolu

TGAL-6420

GCSE-441

API Server v3 : le message de validation demande toujours le paramètre revisionId au lieu du paramètre versionId lors de la tentative de mise à jour du workflow existant.

2022.1.1.25127

Résolu

TMEE-208

La page d'administration Server « Collections » est inaccessible via le lien Analyse.

2022.1.1.25127

Résolu

TMEE-314

Collections > Workflows : les icônes des workflows sont mal dimensionnées dans la liste déroulante lors de l'ajout d'un workflow.

2022.1.1.25127

Résolu

TMEE-340

GBETA-100

La restriction du fichier d'image de profil ne correspond pas au filtre de type de fichier.

2022.1.1.25127

Résolu

TMEE-341

GBETA-98

Les journaux de l'historique des tâches affichent l'ID du type de message au lieu de l'étiquette.

2022.1.1.25127

Résolu

TMEE-440

TCPE-204

Les applications associées sur Server exécutent uniquement la première application de la chaîne.

2022.1.1.25127

Résolu

TMEE-527

GBETA-230

Dans les environnements WinAuth, les onglets « Publics » et « Partagés avec moi » de la page Mon espace de travail ne se chargent pas lorsque le propriétaire d'un workflow public/partagé n'a pas de nom.

2022.1.1.25127

Résolu

Version mineure 2022.1.1.30569

ID

Description

Version

Statut du problème

TMEE-549

GCSE-492

Après la mise à niveau vers la version 21.4, le texte multiligne est tronqué et les URL ne sont plus visibles sur la page Galerie.

2022.1.1.30569

Résolu

TCPE-305

GCSE-496

2021.4 : l'outil Interface du sélecteur de date qui n'inclut pas de valeur par défaut entraîne des erreurs dans l'interface utilisateur Server.

2022.1.1.30569

Résolu

TMEE-382

Les bannières publicitaires ne fonctionnent plus dans la version 21.4+.

2022.1.1.30569

Résolu

TMEE-383

Server : le texte de survol ne s'affiche pas lors du survol d'une bannière publicitaire.

2022.1.1.30569

Résolu

Version mineure 2022.1.1.40869

ID

Description

Version

Statut du problème

TCPE-278 GCSE-465

La planification partagée dans un espace Studio privé ne peut pas être supprimée par un utilisateur non propriétaire. Une erreur 403 Forbidden se produit dans le back-end, mais aucune erreur ne s'affiche dans le front-end, sauf si l'utilisateur non propriétaire est un administrateur.

2022.1.1.40869

Résolu

TGAL-6480

GBETA-302

Point de terminaison des utilisateurs de l'API Alteryx Server V3 : échec de la tentative de création de l'utilisateur.

2022.1.1.40869

Résolu

TGAL-6590

GCSE-561

Le service Alteryx ne démarre pas si MongoDB utilise le moteur de stockage MMAPv1.

Lors de la migration vers la dernière version de MongoDB, le processus de migration convertira désormais votre base de données de MMAPv1 en WiredTiger afin d'éviter les problèmes de compatibilité qui empêchent le service Alteryx de démarrer.

2022.1.1.40869

Résolu

TGAL-6599

TPM-1133

Les outils avec SDK Python, qui utilisent DCM, s'exécutent en continu sur Server sans terminer ou échouer la validation.

2022.1.1.40869

Résolu

TGAL-6733

Les outils Python avec DCM.E activé n'ont pas pu être exécutés sur Server dans la version 22.1 GA (2022.1.1.38360).

2022.1.1.40869

Résolu

TMEE-710

TGAL-6698

Quelques pages ne se chargent pas dans l'interface utilisateur et l'interface administrateur après l'application du correctif.

2022.1.1.40869

Résolu

TMEE-757

Les propriétaires de workflow ne peuvent pas mettre à jour l'indicateur « Prêt pour la migration » via les Paramètres de workflow.

2022.1.1.40869

Résolu

Version mineure 2022.1.1.42590

ID

Description

Version

Statut du problème

TGAL-6674

Résolution d'un problème de performances de chargement de page dû à un nombre excessif d'appels vers un point de terminaison d'état.

2022.1.1.42590

Résolu

TGAL-6740

Le point de terminaison POST /v3/workflows/{workflowId}/versions n'a pas fonctionné comme prévu. Cela était dû à une différence inhérente à la façon dont les workflows sont stockés dans Server lorsqu'ils sont publiés via Designer, par rapport à la façon dont ils sont publiés via l'API. Afin de prévenir d'autres problèmes liés à ce point de terminaison, nous avons temporairement désactivé ce point de terminaison et l'avons retiré de la documentation. Nous réintroduirons le point de terminaison dès qu'une solution lui permettant de fonctionner comme prévu sera disponible.

2022.1.1.42590

Résolu

TGAL-6848

GCSE-946

Problèmes intermittents avec l'interface utilisateur Server/le service après la mise à niveau des Services professionnels. Le client rencontre des problèmes d'accès à Server pour les collections et d'autres pages après la mise à niveau vers 2022.1.

2022.1.1.42590

Résolu

TGAL-6909

Correction d'un problème dans lequel le programme d'installation ne reconnaissait pas correctement la version de MongoDB lors d'une mise à niveau, si un correctif avait été appliqué pour mettre à jour MongoDB de la version 4.2.15 à la version 4.2.22. Le programme d'installation signalait alors à tort une erreur indiquant que l'utilisateur tentait d'effectuer une mise à niveau à partir d'une version non prise en charge de MongoDB.

2022.1.1.42590

Résolu

TMEE-444

Réexécution de l'application : les questions de l'application analytique sont réinitialisées aux valeurs par défaut et ne conservent pas les valeurs saisies.

2022.1.1.42590

Résolu

Version mineure 2022.1.1.42604

ID

Description

Version

Statut du problème

TGAL-6985

Le point de terminaison POST admin/v1/workflows/ ne permet pas d'exécuter un workflow si celui-ci porte un nom différent de celui du workflow téléchargé à l'origine.

2022.1.1.42604

Résolu

TGAL-6990

GCSE-1027

La migration du schéma de la base de données échoue si l'environnement contient des connexions aux données de Server avec des mots de passe NULL ou vides. Consultez cet article de la communauté pour plus d'informations.

2022.1.1.42604

Résolu

TPRI-639

GCSE-530

Dans les versions 2021.4 et ultérieures, seuls le propriétaire du workflow et les administrateurs peuvent accéder aux Paramètres de workflow. Dans les versions précédentes, tous les utilisateurs ayant accès au workflow pouvaient accéder aux Paramètres de workflow.

2022.1.1.42604

Résolu

Version mineure 2022.1.1.42619

ID

Description

Version

Statut du problème

TCPE-490

GCSE-960

L'URL de l'API Web n'autorise pas la politique CORS dans la balise AccessControlAllowOrigin du fichier RuntimeSettings.xml.

2022.1.1.42619

Résolu

TGAL-6992

Lorsque vous enregistrez une nouvelle version d'un workflow qui a déjà une planification, la nouvelle version ne s'exécute qu'une seule fois. Ensuite, la planification revient à la version précédente du workflow.

2022.1.1.42619

Résolu

TGAL-7053

Ce correctif permet aux utilisateurs Server d'exécuter des workflows dans Server lorsque ces workflows utilisent des connexions aux données Server qui ne sont pas explicitement partagées avec ces utilisateurs pour une autre utilisation dans Designer. Il s'agit d'un paramètre global pour tous les workflows d'une instance Server que les administrateurs peuvent contrôler dans la section Administrateur  > Paramètres  > Configuration  > Ressources de Server.

2022.1.1.42619

Résolu

Version mineure 2022.1.1.42636

ID

Description

Version

Statut du problème

TGAL-6769

La connexion est uniquement partagée avec les membres directs du groupe d'utilisateurs sur Alteryx Server et non avec les membres du groupe AD qui fait partie de ce groupe d'utilisateurs sur Alteryx Server.

2022.1.1.42636

Résolu

Version mineure 2022.1.1.42654

ID

Description

Version

Statut du problème

TPRI-737

TMEE-737

Remplacer le workflow : si plus de 10 workflows sont disponibles pour la fonctionnalité Remplacer le workflow, la recherche ne trouve que les 10 premiers workflows dans l'ordre alphabétique. La recherche échoue encore, même si les workflows sont supprimés et que la liste complète contient moins de 10 workflows.

2022.1.1.42654

Résolu

Résolu

Version mineure 2022.1.1.42673

ID

Description

Version

Statut du problème

TCPE-618

GCSE-1210

Les workflows chargés via le point de terminaison d'API admin/v1/workflows ne se chargent pas dans Server après la mise à niveau vers 2021.4 - 2022.3, ce qui entraîne une erreur 404 dans l'onglet réseau et une erreur « Page introuvable » avec une redirection vers Mon espace de travail.

2022.1.1.42673

Résolu

Version mineure 2022.1.1.42691

ID

Description

Version

Statut du problème

TGAL-8049

GCSE-1059

Échec des appels API vers le point de terminaison admin/v1/{appId}/package par intermittence avec une erreur.

2022.1.1.42691

Résolu

TPRI-1077

GCSE-1135

Les messages d'exécution n'ont pas de retour à la ligne dans les résultats du workflow et ne peuvent pas être copiés complètement.

2022.1.1.42691

Résolu

TPRI-2273

Les utilisateurs ne peuvent pas copier le texte des messages des résultats de tâches.

2022.1.1.42691

Résolu

Fixed

Minor Release Version 2022.1.1.42707

ID

Description

Version

Issue Status

TDSL-4801

GCSE-894

AMP Engine: When running a workflow on Server with AMP Engine enabled, an error appears: 'Error opening file. The filename, directory name, or volume label syntax is incorrect.' Despite this error, the files still write out. When the AMP Engine is disabled, the error is not produced.

2022.1.1.42707

Fixed

Fixed

Minor Release Version 2022.1.1.42716

ID

Description

Version

Issue Status

TCPE-648

GCSE-1295

Issue with WorkflowFilePath tag in Customer Managed Telemetry.

2022.1.1.42716

Fixed

TCPE-921

GCSE-1888

The POST /admin/v1/workflows endpoint is returning "An item with the same key has already been added." exception message for specific YXZP files.

2022.1.1.42716

Fixed

Connu

Version majeure 2022.1.1.25127

ID

Description

Version

Statut du problème

TGAL-5930

DE28486

Lorsque vous enregistrez une nouvelle version d'un workflow avec une planification existante, la version du workflow mise à jour ne s'affiche pas sur la planification.

2022.1.1.25127

Connu

TGAL-6264

GCSE-339

Les utilisateurs ne sont pas affichés dans la liste déroulante Ajouter un utilisateur dans les connexions aux données lorsque le nom d'utilisateur est en caractères japonais. Le problème concerne Lucene.

2022.1.1.25127

Connu

TGAL-6307

WebAPI : l'API Get Package v1 corrompt les fichiers YXZP lors de l'utilisation de la documentation interactive (Swagger).

2022.1.1.25127

Connu

TGAL-6338

Certains formulaires de connexion IDP ne s'affichent pas correctement dans la configuration Alteryx.

2022.1.1.25127

Connu

TGAL-6394

GS-610

L'heure d'été modifie les intervalles de planification ultérieurs des tâches/workflows.

2022.1.1.25127

Connu

TGAL-6401

Le lien envoyé par e-mail pour confirmer une adresse e-mail redirige vers une erreur indiquant que l'utilisateur a déjà été validé.

2022.1.1.25127

Connu

TGAL-6408

GS-622

L'attribution d'une balise worker par défaut aux souscriptions ne fonctionne pas correctement.

2022.1.1.25127

Connu

TGAL-6417

TMEE-518

Le nom canonique n'a pas d'incidence sur les URL de notification.

2022.1.1.25127

Connu

TGAL-6425

GBETA-177

La modification des autorisations échoue avec une erreur lors de la configuration de l'utilisateur avec un nom de famille nul.

2022.1.1.25127

Connu

TGAL-6443

GCSE-453

POST /v3/workflows/{workflowId}/versions ne s'affiche pas dans l'interface utilisateur pour les workflows téléchargés depuis Designer.

2022.1.1.25127

Connu

TGAL-6468

GCSE-462

Impossible de créer un filtre de date via le point de terminaison de l'API de Gallery v3/schedules.

2022.1.1.25127

Connu

TGAL-6480

GBETA-302

Point de terminaison des utilisateurs de l'API Alteryx Server V3 : échec de la tentative de création de l'utilisateur.

2022.1.1.25127

Connu

TGAL-6482

DELETE v3 for /users/ échoue si l'espace public contient un workflow.

2022.1.1.25127

Connu

TGAL-6483

GCSE-479

PUT /users/ v3 échoue si la valeur lastName (nom de famille) de l'utilisateur est nulle.

2022.1.1.25127

Connu

TGAL-6489

GS-646

Vous devez vérifier les attributs de l'historique des demandes avant de vérifier les alternatives.

2022.1.1.25127

Connu

TMEE-382

Les bannières publicitaires ne fonctionnent plus dans la version 21.4+.

2022.1.1.25127

Connu

TMEE-383

Server : le texte de survol ne s'affiche pas lors du survol d'une bannière publicitaire.

2022.1.1.25127

Connu

Version mineure 2022.1.1.42590

ID

Description

Version

Statut du problème

TGAL-6990

GCSE-1027

La migration du schéma de la base de données échoue si l'environnement contient des connexions aux données de Server avec des mots de passe NULL ou vides. Consultez cet article de la communauté pour plus d'informations.

2022.1.1.42590

Connu

TGAL-6992

Lorsque vous enregistrez une nouvelle version d'un workflow qui a déjà une planification, la nouvelle version ne s'exécute qu'une seule fois. Ensuite, la planification revient à la version précédente du workflow.

2022.1.1.42590

Connu

Version mineure 2022.1.1.42604

ID

Description

Version

Statut du problème

TCPE-618

GCSE-1210

Les workflows chargés via le point de terminaison d'API admin/v1/workflows ne se chargent pas dans Server après la mise à niveau vers 2021.4 - 2022.3, ce qui entraîne une erreur 404 dans l'onglet réseau et une erreur « Page introuvable » avec une redirection vers Mon espace de travail.

2022.1.1.42604

Connu

Version mineure 2022.1.1.42691

ID

Description

Version

Statut du problème

TGAL-8602

Lorsque vous utilisez le point de terminaison put/v3/schedules/{scheduleid}, l'heure de fin est incorrecte et ne correspond pas au fuseau horaire indiqué dans le corps de réponse.

2022.1.1.42691

Connu

Mises à jour de sécurité

Résolu

Version majeure 2022.1.1.25127

ID

Description

Version

Statut du problème

TGAL-2069

DE13482

SV : correction d'une vulnérabilité potentielle de la traversée du répertoire qui aurait pu permettre une reconnaissance limitée du système de fichiers de la structure de dossiers de Server.

2022.1.1.25127

Résolu

TGAL-2601

DE25080

SV : suppression du champ « Password2 » inutilisé de la réponse du texte brut.

2022.1.1.25127

Résolu

Connu

Version mineure 2022.1.1.40869

ID

Description

Version

Statut du problème

TGAL-6764

À communiquer.*

Toutes les versions 2022.x

Connu

TGAL-6772

GCSE-822

À communiquer.*

Toutes les versions 2022.x

Connu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. À partir de 2022.3, les versions et mises à jour seront disponibles et cela se poursuivra jusqu'à ce que le correctif soit fourni pour toutes les versions prises en charge. Afin de garantir que toutes les versions que vous utilisez sont rapidement corrigées, nous vous recommandons d'effectuer régulièrement les mises à jour. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge concernées.

Résolu

Version mineure 2022.1.1.42590

ID

Description

Version

Statut du problème

TDS-555

SV : mise à jour d'OpenSSL vers la version 3.0.7 ; cela corrige les CVE-2022-3602 et CVE-2022-3786.

2022.1.1.42590

Résolu

TGAL-6764

À communiquer. *

2022.1.1.42590

Résolu

TGAL-6772

GCSE-822

À communiquer. *

2022.1.1.42590

Résolu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge qui sont concernées.

Connu

Version mineure 2022.1.1.42604

ID

Description

Version

Statut du problème

TGAL-2207

À communiquer.*

2020.4 et versions plus récentes.

Connu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge qui sont concernées.

Résolu

Version mineure 2022.1.1.42636

ID

Description

Version

Statut du problème

TVULC-1373

À communiquer.*

2022.1.142636

Résolu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. À partir de 2021.4, les versions et mises à jour seront disponibles et cela se poursuivra jusqu'à ce que le correctif soit fourni pour toutes les versions prises en charge. Afin de garantir que toutes les versions que vous utilisez sont rapidement corrigées, nous vous recommandons d'effectuer régulièrement les mises à jour. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge concernées.

Résolu

Version mineure 2022.1.1.42691

ID

Description

Version

Statut du problème

TGAL-8405

À communiquer.*

2022.1.1.42691

Résolu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. À partir de 2021.4, les versions et mises à jour seront disponibles et cela se poursuivra jusqu'à ce que le correctif soit fourni pour toutes les versions prises en charge. Afin de garantir que toutes les versions que vous utilisez sont rapidement corrigées, nous vous recommandons d'effectuer régulièrement les mises à jour. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge concernées.

Fixed

Minor Release Version 2022.1.1.42707

ID

Description

Version

Issue Status

TGAL-8498

GVM-584

Potential XSS in Designer/Server Open Workflow interaction.

2022.1.1.42707

Fixed