Skip to main content

Notas de versão do Server 2022.1

Notas de lançamento das versões do produto

Versão

Data

Lançamento

Fim do suporte

2022.1.1.25127

4 de maio de 2022

Principal

4 de maio de 2024

2022.1.1.30569* (patch 1)

15 de junho de 2022

Secundária/Patch

4 de maio de 2024

2022.1.1.30961 (patch 1)

23 de junho de 2022

Secundária/Patch

4 de maio de 2024

2022.1.1.40869 (Secundária)

2022.1.1.2.40869 (patch 2)

8 de setembro de 2022

Secundária/Patch

4 de maio de 2024

2022.1.1.42590 (Secundária)

2022.1.1.3.42590 (patch 3)

21 de novembro de 2022

Secundária/Patch

4 de maio de 2024

2022.1.1.42604 (Secundária)

2022.1.1.4.42604 (patch 4)

4 de janeiro de 2023

Secundária/Patch

4 de maio de 2024

2022.1.1.42619 (Secundária)

2022.1.1.5.42619 (patch 5)

15 de fevereiro de 2023

Secundária/Patch

4 de maio de 2024

2022.1.1.42636 (Secundária)

2022.1.1.6.42636 (patch 6)

29 de março de 2023

Secundária/Patch

4 de maio de 2024

2022.1.1.42654 (Secundária)

2022.1.1.7.42654 (patch 7)

24 de maio de 2023

Secundária/Patch

4 de maio de 2024

2022.1.1.42673 (Secundária)

2022.1.1.8.42673 (patch 8)

24 de julho de 2023

Secundária/Patch

4 de maio de 2024

2022.1.1.42691 (Minor)

Secundária) 2022.1.1.9.42691 (Patch 9)

20 de setembro de 2023

Secundária/Patch

4 de maio de 2024

2022.1.1.42707 (Minor)

2022.1.1.10.42707 (Patch 10)

November 30, 2023

Minor/Patch

May 4, 2024

2022.1.1.42716 (Minor)

2022.1.1.11.42716 (Patch 11)

February 1, 2024

Minor/Patch

May 4, 2024

Nota

*Atualização do lançamento do patch 2022.1.1.30569

A versão secundária de patch 2022.1.1.30569 foi removida do Portal de Downloads devido à falta de assinatura em alguns dos arquivos incluídos. Isso faz com que os arquivos não sejam reconhecidos como arquivos válidos fornecidos pela Alteryx e pode acionar mensagens de aviso em alguns programas de terceiros.

Se você instalou a versão 2022.1.1.30569, recomendamos a instalação da versão de patch mais recente. Não é necessário desinstalar o 2022.1.1.30569.

Nota

Considerações sobre o upgrade

A partir da versão 2022.1, existe uma limitação de compatibilidade do Designer com ambientes que usam autenticação interna. Para manter a compatibilidade com o Server, baixe a versão mais recente do Designer.

Nota

Atualizações de patch

Agora, o Alteryx permite aplicar patch à sua instalação do Designer ou do Server sem a necessidade de executar uma desinstalação e reinstalação completas. Você pode fazer download do patch mais recente no Portal de Downloads e Licenças . Para versões de patch mais antigas, entre em contato com a Equipe de Atendimento .

Novos recursos

Remoção dos pontos de extremidade OAuth1 herdados

Em preparação para uma futura oferta FIPS-140, removemos nossos pontos de extremidade de API Oauth1 herdados públicos (eles exigiam hash SHA1, que não é compatível com FIPS). Essa remoção inclui os pontos de extremidade WCF (Windows Communication Framework) herdados, o Swagger para esses pontos de extremidade herdados e o middleware de OAuth1. Para substituir os pontos de extremidade OAuth1, você pode usar as versões OAuth2 das APIs herdadas lançadas na versão 2021.4. As APIs OAuth2 oferecem a mesma funcionalidade das APIs OAuth1. A única exceção é que a chamada GET/workflows/id/package agora retorna um arquivo em vez de um objeto binário na resposta.

Continuaremos a oferecer suporte a pontos de extremidade V1, V2 e de assinatura no OAuth2.

Para saber mais sobre a conversão e seus impactos, acesse a página de ajuda Instruções para conversão de OAuth1 para OAuth2 ou este artigo .Instruções para conversão de OAuth1 para OAuth2

AMP Engine habilitado por padrão

O AMP Engine está habilitado por padrão no Server para que os novos nós de trabalho possam executar fluxos de trabalho dos motores original e AMP simultaneamente. Forneceremos orientações sobre como gerenciar a memória com vários trabalhos simultâneos e com diferentes combinações entre o motor original e o AMP. Para mais informações sobre o AMP Engine, acesse as páginas de ajuda Engine e Práticas recomendadas do AMP Engine .MotorPráticas recomendadas do AMP Engine

Importante

Quando fizer o upgrade do Server para a versão 2022.1, recomendamos validar as configurações de escolha do motor e de alocação dos recursos. A nova funcionalidade para permitir que o Server gerencie fluxos de trabalho executados simultaneamente e a alteração para habilitar o AMP por padrão podem resultar em alterações nas configurações do seu ambiente.

Caso você já tenha um Server e deseje manter suas seleções atuais de configurações do sistema, leia estas instruções antes de fazer o upgrade.

1.  Controller  > General  > Enable AMP Engine

1. Antes de fazer o upgrade, anote suas configurações atuais.

2. Após fazer o upgrade, restaure a seleção para o valor desejado.

2. Worker  > General  > Allow Server to manage workflows running simultaneously

1. Antes de fazer o upgrade, anote o número definido na opção "Workflows allowed to run simultaneously".

2. Após fazer o upgrade, desmarque Allow Server to manage workflows running simultaneously .

3. Introduza o número anotado para "Workflows allowed to run simultaneously".

3. Engine  > General  > Engine

1. Antes de fazer o upgrade, anote suas configurações atuais.

2. Após fazer o upgrade, restaure a seleção para o valor desejado.

4.  Engine  > General  > Run engine at a lower priority

1. Antes de fazer o upgrade, anote suas configurações atuais.

2. Após fazer o upgrade, restaure a seleção para o valor desejado.

Redefinição de senha obrigatória para autenticação interna

Se você utiliza autenticação interna, será necessário redefinir sua senha devido a melhorias na segurança. Se você não redefinir sua senha na versão 2022.1, o SMTP deverá estar habilitado para redefini-la na versão 2022.2. Para mais informações sobre como redefinir a senha do Server após a atualização para a versão 2022.1, acesse a página de ajuda Redefinir a senha de um usuário do Server .Redefinir a senha do Server de um usuário

Além da redefinição de senha, o Designer tem uma limitação de compatibilidade com ambientes que usam autenticação interna. As versões mais antigas do Designer não apresentam as alterações do mecanismo de senha necessárias para a autenticação com o Server 2022.1 ou versões posteriores. Para garantir a compatibilidade, é necessário executar o Designer 2022.1 ou posterior.

Localização da IU do Server (Beta)

Localizamos as páginas de usuário do Server em 8 idiomas (inglês, japonês, chinês, espanhol, francês, italiano, alemão e português) e mais de 90 localidades. Esta é uma versão beta porque a localização de alguns conteúdos ainda está em andamento. Acesse Meu perfil  > Geral para atualizar o idioma e suas preferências locais.

Novo design da IU do Server

As páginas de usuário "Distritos", "Resultados dos fluxos de trabalho" e "Agendamentos", bem como as páginas de administrador "Coleções", "Credenciais", "Usuários" e "Grupos" agora têm um novo design. A funcionalidade dessas páginas permanece a mesma.

Novo e-mail de boas-vindas aos usuários criados por meio de uma chamada de API POST /users

Criamos um e-mail de boas-vindas para os novos usuários que são criados por meio de uma chamada de API POST /users. O novo e-mail de boas-vindas inclui um link para o usuário definir a senha. Essa experiência de usuário é semelhante ao que os novos usuários veem quando a conta é criada manualmente. Observe que o e-mail de boas-vindas é enviado somente se o SMTP estiver configurado.

Opções de configuração de autenticação interna para tentativas de login e bloqueio de conta

Para evitar ataques de força bruta, adicionamos uma configuração chamada Número de tentativas de login permitidas , em que um administrador pode definir o número de tentativas permitidas antes que um usuário seja bloqueado. Também adicionamos uma configuração chamada Tempo de bloqueio de conta (minutos) , que define o tempo em minutos durante o qual o usuário fica bloqueado após atingir o número máximo de tentativas de login malsucedidas. O padrão são cinco tentativas de login, depois das quais o usuário fica bloqueado por cinco minutos. Além disso, adicionamos uma configuração que permite que os administradores decidam se querem ou não impor um tempo de espera para tentativas de login. O administrador pode atualizar essas três configurações de segurança em Configuração do Server  > Configurações de segurança . Essas configurações só estão disponíveis ao utilizar a autenticação interna.

Acesse Configuração do Alteryx Server para obter mais informações.[configuração do alteryx server]

Atualização do jQuery utilizado pela documentação do Swagger 2.0

Atualizamos o jQuery para a versão mais recente, 3.6.0, para a documentação do Swagger da API V3 do Server. Essa atualização é parte do processo de remoção de versões antigas do jQuery. Esperamos concluir isso ainda este ano, quando toda a UI estiver completamente reprojetada dentro da nova interface do React.

Todos os algoritmos de hash foram migrados para SHA2 usando o CryptoLib

Em preparação para uma futura oferta compatível com o FIPS, atualizamos todas as chamadas criptográficas que não são do Windows em nossa base de códigos para contar com um único provedor de serviços de criptografia (CSP), o módulo baseado em OpenSSL3 criado e mantido por nossa equipe DevSec de acordo com as especificações FIPS-140. Essa atualização não deve causar impactos diretos sobre a experiência do usuário, a não ser para tornar a solução mais segura de forma geral em sua operação.

Atualização de criptografia AES-256

Migramos a criptografia usada para proteger conexões de dados herdadas (por exemplo, DCM.E e segredos de API) para AES 256. Essa atualização não tem impactos diretos sobre a experiência do usuário, mas torna nossa solução mais segura para os nossos clientes.

Incompatibilidade com o Internet Explorer

O Internet Explorer não será mais compatível a partir da versão 2022.1. Os navegadores compatíveis são Chrome, Firefox, Edge e Safari. Acesse Política de suporte para versões para obter mais informações.

Fuso horário para agendamentos na API V3 do Server

Adicionamos fuso horário para os seguintes pontos de extremidade da API V3:

  • POST /v3/schedules: esse ponto de extremidade foi atualizado para permitir que você defina hora e fuso horário para agendamentos.

    Por exemplo, se você quiser definir um agendamento para 17:00 (Hora Padrão das Montanhas), pode defini-lo para o horário das 17:00 e selecionar a Hora Padrão das Montanhas como o fuso horário. O fuso horário é opcional e, se você não especificá-lo, o padrão será UTC.

  • PUT /v3/schedules: esse ponto de extremidade foi atualizado para permitir que você atualize agendamentos existentes criados usando a API e adicione uma seleção de fuso horário se assim desejar. 

    Por exemplo, se você criou um agendamento usando os pontos de extremidade de API e a hora teve que ser definida em UTC, pode atualizar o agendamento e alterar a hora e o fuso horário.

    No entanto, os agendamentos existentes continuarão a ser executados como esperado se você optar por não adicionar um fuso horário.

  • GET /v3/schedules/{id}: esse ponto de extremidade foi atualizado para que você possa visualizar o fuso horário de um agendamento existente filtrado pelo ID.

  • GET /v3/schedules/: esse ponto de extremidade foi atualizado para permitir que você visualize o fuso horário de todos os agendamentos existentes.

Para obter mais informações sobre pontos de extremidade, acesse a documentação do Swagger selecionando o ícone de ponto de interrogação no canto superior direito da interface do Server. Para ver os fusos horários válidos para uso nos pontos de extremidade de API acima, consulte a página de ajuda Pontos de extremidade de agendamento .Pontos de extremidade de agendamentos

Opção CLI para conectar ao controlador remoto

Como administrador, agora você pode transferir chaves de criptografia com segurança do seu ambiente existente para migrar o Server para um novo host ou mitigar uma interrupção.

Para obter mais informações, vá para Chaves DCM.E para backup .Chaves DCM.E para backup

Problemas conhecidos e corrigidos

Corrigido

Versão de lançamento principal 2022.1.1.25127

ID

Descrição

Versão

Status do problema

TCPE-56

DE17441

Ocorre uma falha ao adicionar conexões de dados se a senha inclui uma barra vertical "|".

2022.1.1.25127

Corrigido

TCPE-89

DE33954

Quando o Alteryx Service instrui um trabalhador a parar, o Alteryx Engine não interpreta a mensagem de cancelamento pelo usuário como um erro.

2022.1.1.25127

Corrigido

TCPE-106

GCSE-296

A ferramenta Codificador Base64 aceita uma coluna de dados, mas codifica corretamente apenas a cada terceiro registro.

2022.1.1.25127

Corrigido

TCPE-123

DE22217

Fluxos de trabalho do Alteryx estão sendo sinalizados com erro, enquanto os logs e a mensagem de evento parecem indicar êxito.

2022.1.1.25127

Corrigido

TCPE-149

TGAL-6137

Agendamentos: o carimbo de data/hora da próxima execução está exibindo uma referência anterior à última execução.

2022.1.1.25127

Corrigido

TGAL-2716

DE27806

Migrar agendamentos do Designer para o Server resulta em uma mensagem de erro.

2022.1.1.25127

Corrigido

TGAL-2718

DE27828

A opção de renomear é exibida para não proprietários da coleção.

2022.1.1.25127

Corrigido

TGAL-2727

DE28053

Os trabalhos do Scheduler têm um tempo de execução de 0.0 segundo.

2022.1.1.25127

Corrigido

TGAL-2743

DE28593

A página de configuração do trabalhador na janela de configuração do Server apresenta campo de entrada ativo mesmo quando a caixa de seleção correspondente está desmarcada.

2022.1.1.25127

Corrigido

TGAL-2892

DE34042

Ao adicionar um fluxo de trabalho renomeado a uma coleção, o nome antigo é exibido na caixa de diálogo "Adicionar fluxo de trabalho". Depois de adicioná-lo à coleção, o novo nome é exibido.

2022.1.1.25127

Corrigido

TGAL-5831

Ao criar um usuário por meio de "Admin" -> "Users", aparece um estúdio duplicado em "Subscriptions".

2022.1.1.25127

Corrigido

TGAL-5875

O botão "Salvar" não é exibido ao salvar um fluxo de trabalho que pertence ao estúdio de outro usuário no Server.

2022.1.1.25127

Corrigido

TGAL-5938

DE33992

No painel do administrador > "Trabalhos" > guia "Migração", a pesquisa por um usuário não funciona se a função dele estiver definida como "Padrão", "Visualizador" ou "Membro".

2022.1.1.25127

Corrigido

TGAL-6009

A versão de cliente mostra um valor inválido na IU do Server.

2022.1.1.25127

Corrigido

TGAL-6039

Não é possível alterar o proprietário da coleção.

2022.1.1.25127

Corrigido

TGAL-6042

O usuário com acesso de administrador retém as permissões de agendamento até que a guia seja atualizada.

2022.1.1.25127

Corrigido

TGAL-6046

É exibido um número negativo para o tempo de execução em AS_Queue.

2022.1.1.25127

Corrigido

TGAL-6080

API do Server: POST e PUT /schedules usam um nome em vez de um número para dayNumber.

2022.1.1.25127

Corrigido

TGAL-6083

É possível criar uma assinatura com um nome que contém apenas espaços em branco.

2022.1.1.25127

Corrigido

TGAL-6085

A pesquisa por usuários não funciona quando se usa texto encontrado no meio do nome do usuário.

2022.1.1.25127

Corrigido

TGAL-6122

GBETA-106

O número da versão de fluxos de trabalho está incorreto.

2022.1.1.25127

Corrigido

TGAL-6142

GBETA-123

Em coleções, a coluna de data de upload do fluxo de trabalho está rotulada incorretamente.

2022.1.1.25127

Corrigido

TGAL-6189

A formatação da documentação de ajuda do Alteryx Service causa dificuldades para a leitura.

2022.1.1.25127

Corrigido

TGAL-6222

GS-505

Erro ao executar fluxos de trabalho com conexões DCM.E compartilhadas para não proprietário.

2022.1.1.25127

Corrigido

TGAL-6250

GCSE-343

Versão 3 da API do Server: POST /v3/usergroups/{id}/users não consegue adicionar usuários ao usar a autenticação WinAuth.

2022.1.1.25127

Corrigido

TGAL-6251

A classificação por coluna de origem compartilhada causa problema de carregamento na página "Meu espaço de trabalho".

2022.1.1.25127

Corrigido

TGAL-6267

GCSE-327

Um fluxo de trabalho pode ser publicado a partir de uma versão posterior do Designer para uma versão anterior do Server, e um trabalho agendado pode ser executado.

2022.1.1.25127

Corrigido

TGAL-6268

TLF-2990

Versão 1 da API do Server: pontos de Extremidade de API do Server GET /admin/v1/workflows e GET /admin/v1/workflows/jobs/ sem filtro de pesquisa não retornam dados.

2022.1.1.25127

Corrigido

TGAL-6303

Versão 1 da API do Server: ao usar o ponto de extremidade /webapi/v1/workflows/{id}/package por meio da nova estrutura de API, o download do pacote adota uma extensão de arquivos incorreta.

2022.1.1.25127

Corrigido

TGAL-6317

Versão 1 da API do Server: ao usar as APIs de tarefas V1 portadas para a WebAPI, os usuários da estrutura de um ambiente WinAuth não conseguem consultar os pontos de extremidade v1/jobs e retornar resultados.

2022.1.1.25127

Corrigido

TGAL-6323

GCSE-368

Quando são utilizadas chaves de API privadas para assinatura/estúdio com pontos de extremidade V1 da API do Server, é gerada uma falha com exceção desconhecida. Os pontos de extremidade na versão 21.4.1 não estão reconhecendo as chaves de assinatura/estúdio corretamente.

2022.1.1.25127

Corrigido

TGAL-6332

Versão 1 da API do Server: o ponto de extremidade GET /v1/jobs/...{outputId} está resultando em um código de resposta 500.

2022.1.1.25127

Corrigido

TGAL-6340

GCSE-367

Os agendamentos não são carregados quando o banco de dados contém o carimbo de data/hora de localidade incorreto em LastModifiedDate (data da última modificação).

2022.1.1.25127

Corrigido

TGAL-6361

GCSE-415

DCM.E: ao compartilhar conexões de fonte de dados com grupos personalizados, os usuários desses grupos recebem o erro "A conexão selecionada não está disponível. Configure uma para usar a ferramenta." após executar o fluxo de trabalho.

2022.1.1.25127

Corrigido

TGAL-6376

Ao criar um novo usuário no portal do administrador, a mensagem "Falha ao criar usuário" é exibida, mas o usuário é criado.

2022.1.1.25127

Corrigido

TGAL-6393

TGAL-6375

Versão 3 da API do Server: a criação de agendamentos não define as datas/horas corretas e as configurações de recorrência conforme o desejado.

2022.1.1.25127

Corrigido

TGAL-6414

GCSE-440

Usuários com a função de criador não conseguem executar determinados pontos de extremidade V1 via WebAPI ao fazer a autenticação via Oauth2.

2022.1.1.25127

Corrigido

TGAL-6420

GCSE-441

Versão 3 da API do Server: ao tentar atualizar fluxos de trabalho, ainda há uma mensagem de validação solicitando revisionId em vez de versionId.

2022.1.1.25127

Corrigido

TMEE-208

A página de administrador do Server para coleções para de funcionar se o usuário clica em um link de insight.

2022.1.1.25127

Corrigido

TMEE-314

Coleções > Fluxos de trabalho: na lista suspensa, os ícones dos fluxos de trabalho adicionados não são exibidos em um tamanho adequado.

2022.1.1.25127

Corrigido

TMEE-340

GBETA-100

A restrição de arquivos para a imagem de perfil não corresponde ao filtro de tipos de arquivo.

2022.1.1.25127

Corrigido

TMEE-341

GBETA-98

Os logs do histórico de trabalho exibem o ID do tipo de mensagem em vez do rótulo.

2022.1.1.25127

Corrigido

TMEE-440

TCPE-204

No Server, apenas o primeiro aplicativo da cadeia é executado em aplicativos encadeados.

2022.1.1.25127

Corrigido

TMEE-527

GBETA-230

Em ambientes WinAuth, as guias "Públicos" e "Compartilhados comigo" na página "Meu espaço de trabalho" não são carregadas quando o sobrenome do proprietário de um fluxo de trabalho público/compartilhado não está presente.

2022.1.1.25127

Corrigido

Versão de lançamento secundária 2022.1.1.30569

ID

Descrição

Versão

Status do problema

TMEE-549

GCSE-492

Após a atualização para 21.4, textos multilinha são truncados e os URLs não ficam mais visíveis na página do Server.

2022.1.1.30569

Corrigido

TCPE-305

GCSE-496

2021.4: uma ferramenta de interface para seleção de datas sem valor padrão resulta em erros na IU do Server.

2022.1.1.30569

Corrigido

TMEE-382

Os banners de anúncio não estão mais funcionando na versão 21.4 nem em versões posteriores.

2022.1.1.30569

Corrigido

TMEE-383

Server: o texto de focalização não é exibido ao passar o mouse sobre um banner de anúncio.

2022.1.1.30569

Corrigido

Versão de lançamento secundária 2022.1.1.40869

ID

Descrição

Versão

Status do problema

TCPE-278 GCSE-465

Agendamentos compartilhados em um estúdio privado não podem ser excluído por um não proprietário. O erro "403 Forbidden" ocorre no back-end, mas nenhum erro é exibido no front-end, a menos que o não proprietário seja um administrador.

2022.1.1.40869

Corrigido

TGAL-6480

GBETA-302

Ponto de extremidade de usuários da versão 3 da API do Alteryx Server: falha na tentativa de criar usuário.

2022.1.1.40869

Corrigido

TGAL-6590

GCSE-561

O Alteryx Service não é iniciado se o MongoDB está usando o motor de armazenamento MMAPv1.

Ao migrar para a versão mais recente do MongoDB, o processo de migração converterá agora seu banco de dados de MMAPv1 para WiredTiger a fim de evitar problemas de compatibilidade que impeçam o início do Alteryx Service.

2022.1.1.40869

Corrigido

TGAL-6599

TPM-1133

As ferramentas Python-SDK que usam o DCM são executadas continuamente no Server sem concluir ou falhar a validação.

2022.1.1.40869

Corrigido

TGAL-6733

As ferramentas Python com DCM.E habilitado não puderam ser executadas no Server build 22.1 GA (2022.1.1.38360).

2022.1.1.40869

Corrigido

TMEE-710

TGAL-6698

Algumas páginas não estão sendo carregadas nas interfaces de administrador e de usuário após a aplicação do patch.

2022.1.1.40869

Corrigido

TMEE-757

Os proprietários do fluxo de trabalho não podem atualizar o sinalizador "Pronto para ser migrado" em "Configurações do fluxo de trabalho".

2022.1.1.40869

Corrigido

Versão de lançamento secundária 2022.1.1.42590

ID

Descrição

Versão

Status do problema

TGAL-6674

Resolvido um problema de desempenho de carregamento de página devido a chamadas excessivas para um ponto de extremidade de status.

2022.1.1.42590

Corrigido

TGAL-6740

O ponto de extremidade POST /v3/workflows/{workflowId}/versions não funcionou como esperado. Isso se deve a uma diferença inerente na forma como os fluxos de trabalho são armazenados no Server quando publicados via Designer em comparação com a forma como são publicados através da API. Como uma etapa provisória para evitar outros problemas com esse ponto de extremidade, o desabilitamos temporariamente e o removemos da documentação. Reintroduziremos o ponto de extremidade assim que uma solução estiver disponível para que ele funcione da maneira pretendida.

2022.1.1.42590

Corrigido

TGAL-6848

GCSE-946

Problemas intermitentes com o serviço/IU do Server após a atualização dos Serviços Profissionais. O cliente está enfrentando problemas intermitentes de acesso ao Server com coleções e outras páginas após a atualização para a versão 2022.1.

2022.1.1.42590

Corrigido

TGAL-6909

Corrigido um problema em que o instalador não estava reconhecendo a versão do MongoDB corretamente durante uma atualização se um patch tivesse sido aplicado para atualizar o MongoDB de 4.2.15 para 4.2.22. Isso fazia com que o instalador informasse incorretamente um erro indicando que o usuário estava tentando atualizar de uma versão incompatível do MongoDB.

2022.1.1.42590

Corrigido

TMEE-444

Re-execução do aplicativo: as perguntas do aplicativo analítico são redefinidas para os padrões em vez de manter os valores inseridos.

2022.1.1.42590

Corrigido

Versão de lançamento secundária 2022.1.1.42604

ID

Descrição

Versão

Status do problema

TGAL-6985

O ponto de extremidade POST admin/v1/workflows/ quebra a capacidade de executar um fluxo de trabalho se ele tiver um nome diferente do fluxo carregado originalmente.

2022.1.1.42604

Corrigido

TGAL-6990

GCSE-1027

A migração do esquema do banco de dados falha se o ambiente contém conexões de dados do Server com senhas nulas ou vazias. Consulte este artigo da Comunidade para obter mais informações.

2022.1.1.42604

Corrigido

TPRI-639

GCSE-530

Nas versões 2021.4 e posteriores, somente o proprietário e os administradores de um fluxo de trabalho podem acessar as configurações do fluxo de trabalho. Nas versões anteriores, todos os usuários com acesso ao fluxo podiam acessar as configurações do fluxo de trabalho.

2022.1.1.42604

Corrigido

Versão de lançamento secundária 2022.1.1.42619

ID

Descrição

Versão

Status do problema

TCPE-490

GCSE-960

O URL da API Web não permite a Política CORS na tag AccessControlAllowOrigin do arquivo RuntimeSettings.xml.

2022.1.1.42619

Corrigido

TGAL-6992

Quando você salva uma nova versão de um fluxo de trabalho que já tem um agendamento, a nova versão só é executada uma vez. Depois, o agendamento volta para a versão anterior do fluxo.

2022.1.1.42619

Corrigido

TGAL-7053

O patch permite que os usuários executem fluxos de trabalho dentro do Server quando esses fluxos estão usando conexões de dados do Server que não são explicitamente compartilhadas com esses usuários para outros usos no Designer. Esta é uma configuração global para todos os fluxos de trabalho em uma instância do Server que os administradores podem controlar na seção Administrador  > Configurações  > Configuração Ativos .

2022.1.1.42619

Corrigido

Versão de lançamento secundária 2022.1.1.42636

ID

Descrição

Versão

Status do problema

TGAL-6769

A conexão é compartilhada somente com membros diretos do grupo de usuários no Alteryx Server, não com membros do grupo do AD que pertencem a esse grupo de usuários no Alteryx Server.

2022.1.1.42636

Corrigido

Versão de lançamento secundária 2022.1.1.42654

ID

Descrição

Versão

Status do problema

TPRI-737

TMEE-737

Substituir fluxo de trabalho: se houver mais de 10 fluxos de trabalho disponíveis para a funcionalidade "Substituir fluxo de trabalho", a pesquisa encontrará apenas os primeiros 10 em ordem alfabética. A pesquisa ainda falha mesmo se os fluxos de trabalho forem excluídos e a lista completa contiver menos de 10 fluxos.

2022.1.1.42654

Corrigido

Corrigido

Versão de lançamento secundária 2022.1.1.42673

ID

Descrição

Versão

Status do problema

TCPE-618

GCSE-1210

Os fluxos de trabalho enviados por meio do ponto de extremidade de API admin/v1/workflows não carregam no Server após a atualização para 2021.4 - 2022.3, resultando em um erro 404 na guia de rede e um erro "Página não encontrada", redirecionando para "Meu espaço de trabalho" como resultado.

2022.1.1.42673

Corrigido

Versão de lançamento secundária 2022.1.1.42691

ID

Descrição

Versão

Status do problema

TGAL-8049

GCSE-1059

As chamadas de API para o ponto de extremidade admin/v1/{appId}/package falham intermitentemente com um erro.

2022.1.1.42691

Corrigido

TPRI-1077

GCSE-1135

As mensagens de execução não apresentam quebra de linha nos resultados dos fluxos de trabalho e não podem ser copiadas completamente.

2022.1.1.42691

Corrigido

TPRI-2273

Os usuários não podem copiar o texto das mensagens dos resultados dos trabalhos.

2022.1.1.42691

Corrigido

Fixed

Minor Release Version 2022.1.1.42707

ID

Description

Version

Issue Status

TDSL-4801

GCSE-894

AMP Engine: When running a workflow on Server with AMP Engine enabled, an error appears: 'Error opening file. The filename, directory name, or volume label syntax is incorrect.' Despite this error, the files still write out. When the AMP Engine is disabled, the error is not produced.

2022.1.1.42707

Fixed

Fixed

Minor Release Version 2022.1.1.42716

ID

Description

Version

Issue Status

TCPE-648

GCSE-1295

Issue with WorkflowFilePath tag in Customer Managed Telemetry.

2022.1.1.42716

Fixed

TCPE-921

GCSE-1888

The POST /admin/v1/workflows endpoint is returning "An item with the same key has already been added." exception message for specific YXZP files.

2022.1.1.42716

Fixed

Conhecido

Versão de lançamento principal 2022.1.1.25127

ID

Descrição

Versão

Status do problema

TGAL-5930

DE28486

Ao salvar uma nova versão de um fluxo de trabalho com um agendamento existente, a versão atualizada do fluxo não é exibida no agendamento.

2022.1.1.25127

Conhecido

TGAL-6264

GCSE-339

Usuários não são exibidos no menu suspenso "Adicionar usuário" de conexões de dados quando o nome de usuário contém caracteres em japonês. Este problema está relacionado ao Lucene.

2022.1.1.25127

Conhecido

TGAL-6307

WebAPI: Get Package na API V1 corrompe arquivos YXZP ao usar a documentação interativa (Swagger).

2022.1.1.25127

Conhecido

TGAL-6338

Alguns formulários de login do IDP não são renderizados corretamente nas configurações do Alteryx.

2022.1.1.25127

Conhecido

TGAL-6394

GS-610

O horário de verão altera o agendamento dos intervalos futuros para trabalhos/fluxos de trabalho.

2022.1.1.25127

Conhecido

TGAL-6401

O link enviado para confirmar o endereço de e-mail direciona o usuário a um erro que informa que ele já foi validado.

2022.1.1.25127

Conhecido

TGAL-6408

GS-622

A atribuição de tags de trabalhador padrão a assinaturas não funciona corretamente.

2022.1.1.25127

Conhecido

TGAL-6417

TMEE-518

O nome canônico não tem influência nos URLs de notificação.

2022.1.1.25127

Conhecido

TGAL-6425

GBETA-177

Configurar um usuário com sobrenome nulo resulta em falha na alteração de permissões.

2022.1.1.25127

Conhecido

TGAL-6443

GCSE-453

O POST /v3/workflows/{workflowId}/versions não é exibido na IU para fluxos de trabalho carregados a partir do Designer.

2022.1.1.25127

Conhecido

TGAL-6468

GCSE-462

Não é possível filtrar datas via ponto de extremidade da API do Gallery v3/schedules.

2022.1.1.25127

Conhecido

TGAL-6480

GBETA-302

Ponto de extremidade de usuários da versão 3 da API do Alteryx Server: falha na tentativa de criar usuário.

2022.1.1.25127

Conhecido

TGAL-6482

Falha em DELETE v3 para /users/ se há um fluxo de trabalho no espaço público.

2022.1.1.25127

Conhecido

TGAL-6483

GCSE-479

PUT /users/ v3 falha se o sobrenome (lastName) do usuário é nulo.

2022.1.1.25127

Conhecido

TGAL-6489

GS-646

É necessário verificar os atributos de solicitações históricas antes de verificar as alternativas.

2022.1.1.25127

Conhecido

TMEE-382

Os banners de anúncio não estão mais funcionando na versão 21.4 nem em versões posteriores.

2022.1.1.25127

Conhecido

TMEE-383

Server: o texto de focalização não é exibido ao passar o mouse sobre um banner de anúncio.

2022.1.1.25127

Conhecido

Versão de lançamento secundária 2022.1.1.42590

ID

Descrição

Versão

Status do problema

TGAL-6990

GCSE-1027

A migração do esquema do banco de dados falha se o ambiente contém conexões de dados do Server com senhas nulas ou vazias. Consulte este artigo da Comunidade para obter mais informações.

2022.1.1.42590

Conhecido

TGAL-6992

Quando você salva uma nova versão de um fluxo de trabalho que já tem um agendamento, a nova versão só é executada uma vez. Depois, o agendamento volta para a versão anterior do fluxo.

2022.1.1.42590

Conhecido

Versão de lançamento secundária 2022.1.1.42604

ID

Descrição

Versão

Status do problema

TCPE-618

GCSE-1210

Os fluxos de trabalho enviados por meio do ponto de extremidade de API admin/v1/workflows não carregam no Server após a atualização para 2021.4 - 2022.3, resultando em um erro 404 na guia de rede e um erro "Página não encontrada", redirecionando para "Meu espaço de trabalho" como resultado.

2022.1.1.42604

Conhecido

Versão de lançamento secundária 2022.1.1.42691

ID

Descrição

Versão

Status do problema

TGAL-8602

Ao usar o ponto de extremidade put/v3/schedules/{scheduleid}, a hora de término não é exibida de acordo com o fuso horário determinado no corpo de resposta.

2022.1.1.42691

Conhecido

Atualizações de segurança

Corrigido

Versão de lançamento principal 2022.1.1.25127

ID

Descrição

Versão

Status do problema

TGAL-2069

DE13482

SV: correção de um ponto fraco em potencial para directory traversal, que poderia permitir um reconhecimento limitado do sistema de arquivos da estrutura de pastas do Server.

2022.1.1.25127

Corrigido

TGAL-2601

DE25080

SV: campo "Password2" não utilizado removido da resposta em texto sem formatação.

2022.1.1.25127

Corrigido

Conhecido

Versão de lançamento secundária 2022.1.1.40869

ID

Descrição

Versão

Status do problema

TGAL-6764

A ser divulgado.*

Todas as versões 2022.x

Conhecido

TGAL-6772

GCSE-822

A ser divulgado.*

Todas as versões 2022.x

Conhecido

*De acordo com as práticas recomendadas de segurança e para evitar uma possível manipulação por agentes mal-intencionados, a Alteryx não divulga os detalhes de nenhuma vulnerabilidade até que todas as versões compatíveis sejam atualizadas com uma correção. A partir da versão 2022.3, lançamentos e atualizações serão disponibilizados e continuarão até que a correção seja fornecida para todas as versões com suporte. Para garantir que todas as versões que você usa sejam corrigidas, atualização regulares são altamente recomendadas. Mais informações serão disponibilizadas assim que a vulnerabilidade for corrigida para todas as versões com suporte afetadas.

Corrigido

Versão de lançamento secundária 2022.1.1.42590

ID

Descrição

Versão

Status do problema

TDS-555

SV: Atualizar OpenSSL para 3.0.7; isso corrige CVE-2022-3602 e CVE-2022-3786.

2022.1.1.42590

Corrigido

TGAL-6764

A ser divulgado. *

2022.1.1.42590

Corrigido

TGAL-6772

GCSE-822

A ser divulgado. *

2022.1.1.42590

Corrigido

*De acordo com as práticas recomendadas de segurança e para evitar uma possível manipulação por agentes mal-intencionados, a Alteryx não divulga os detalhes de nenhuma vulnerabilidade até que todas as versões compatíveis sejam atualizadas com uma correção. Mais informações serão disponibilizadas assim que a vulnerabilidade for corrigida para todas as versões com suporte afetadas de que temos conhecimento.

Conhecido

Versão de lançamento secundária 2022.1.1.42604

ID

Descrição

Versão

Status do problema

TGAL-2207

A ser divulgado.*

2020.4 e mais recentes.

Conhecido

*De acordo com as práticas recomendadas de segurança e para evitar uma possível manipulação por agentes mal-intencionados, a Alteryx não divulga os detalhes de nenhuma vulnerabilidade até que todas as versões compatíveis sejam atualizadas com uma correção. Mais informações serão disponibilizadas assim que a vulnerabilidade for corrigida para todas as versões com suporte afetadas de que temos conhecimento.

Corrigido

Versão de lançamento secundária 2022.1.1.42636

ID

Descrição

Versão

Status do problema

TVULC-1373

A ser divulgado.*

2022.1.142636

Corrigido

*De acordo com as práticas recomendadas de segurança e para evitar uma possível manipulação por agentes mal-intencionados, a Alteryx não divulga os detalhes de nenhuma vulnerabilidade até que todas as versões compatíveis sejam atualizadas com uma correção. A partir da versão 2021.4, lançamentos e atualizações serão disponibilizados e continuarão até que a correção seja fornecida para todas as versões com suporte. Para garantir que todas as versões que você usa sejam corrigidas, atualização regulares são altamente recomendadas. Mais informações serão disponibilizadas assim que a vulnerabilidade for corrigida para todas as versões com suporte afetadas.

Corrigido

Versão de lançamento secundária 2022.1.1.42691

ID

Descrição

Versão

Status do problema

TGAL-8405

A ser divulgado.*

2022.1.1.42691

Corrigido

*De acordo com as práticas recomendadas de segurança e para evitar uma possível manipulação por agentes mal-intencionados, a Alteryx não divulga os detalhes de nenhuma vulnerabilidade até que todas as versões compatíveis sejam atualizadas com uma correção. A partir da versão 2021.4, lançamentos e atualizações serão disponibilizados e continuarão até que a correção seja fornecida para todas as versões com suporte. Para garantir que todas as versões que você usa sejam corrigidas, atualização regulares são altamente recomendadas. Mais informações serão disponibilizadas assim que a vulnerabilidade for corrigida para todas as versões com suporte afetadas.

Fixed

Minor Release Version 2022.1.1.42707

ID

Description

Version

Issue Status

TGAL-8498

GVM-584

Potential XSS in Designer/Server Open Workflow interaction.

2022.1.1.42707

Fixed