Skip to main content

UnknownTool_71x71.png Herramienta genérica/desconocida

Los íconos de las herramientas de Designer representan la tarea o la macro específica de la herramienta. Cuando Alteryx Designer no puede encontrar una macro a la que se hace referencia en un flujo de trabajo, Designer muestra la herramienta desconocida junto con un mensaje de error. Esto te permite volver a configurar (haz clic con el botón secundario y selecciona Insertar > Macro para examinar la macro), lo que restaura la herramienta deseada.

Actualizar una macro ausente

A partir de la versión 2023.2 de Designer, se puede actualizar una macro ausente antes de que aparezca el ícono de herramienta desconocida. Consulta las instrucciones que aparecen a continuación o ve a la página de ayuda Actualizar macros ausentes .

La herramienta genérica, que también muestra el ícono del signo de interrogación, se utiliza para acceder a una biblioteca de enlaces dinámicos (DLL) o un complemento.

Nota

Esta herramienta no está visible en la paleta de herramientas de Designer.

Para sustituir la herramienta, realiza lo siguiente:

  1. Selecciona la herramienta genérica/desconocida para ver su configuración.

  2. Utiliza esta información para agregar la herramienta de Designer adecuada al flujo de trabajo y configurarla.

  3. Elimina la herramienta genérica/desconocida del flujo de trabajo.

Actualizar macros ausentes en un flujo de trabajo

Cuando intentas abrir un flujo de trabajo (archivo YXMD, YXMC o YXWZ) con una macro ausente, aparece la ventana emergente Actualizar macros ausentes en Designer para avisarte del problema.

update-missing-macros-1.png

La ventana Actualizar macros ausentes comunica que el flujo de trabajo hace referencia al menos a una macro ausente o inaccesible. El mensaje proporciona detalles sobre estas macros. Ten en cuenta en que la ventana se muestra un máximo de tres macros ausentes (aunque podrían ser más).

Tienes 2 opciones:

  • Actualizar : selecciona Actualizar para efectuar la actualización de las rutas de archivos de las macros ausentes. Esto abre el flujo de trabajo original donde puedes realizar cambios. Sin embargo, Designer no guarda automáticamente el flujo de trabajo. Después de realizar las actualizaciones, puedes ir a Archivo > Guardar como , o bien presionar el atajo de teclado Ctrl+S (Guardar) para guardar una nueva versión del flujo de trabajo o reescribir el flujo de trabajo original, si es necesario. Ten en cuenta que necesitas acceder a los archivos de macros ausentes para poder navegar a sus ubicaciones. Si recibiste el flujo de trabajo de alguien que no incluyó las macros, es probable que tengas que comunicarte con esa persona y pedirle que te proporcione los archivos. Si elegiste no actualizar las rutas del archivo, el flujo de trabajo se abrirá con los íconos de las herramientas ausentes.

  • Cerrar (no actualizar): selecciona Cerrar . Esto abre el flujo de trabajo original sin las macros actualizadas. Las macros tendrán el ícono de la herramienta ausente ( UnknownTool_71x71.png) y, si deseas corregir estas macros ausentes más adelante, deberás agregarlas y reconfigurarlas manualmente.

Actualizar una macro

Para actualizar las macros, sigue estos pasos:

  1. En la ventana Actualizar macros ausentes, selecciona Actualizar .

  2. Esto abre la ventana Actualizar macros ausentes , similar a la experiencia de Dependencias del flujo de trabajo. Aquí, puedes editar la ruta de archivo de cada macro ausente y actualizar su ubicación. Ten en cuenta que no puedes editar dependencias que no sean de macro a través de esta ventana.

    update-missing-macros-2.png
  3. Selecciona el ícono de edición de lápiz asociado a la macro ausente. Esto abre el Explorador de archivos, en donde puedes buscar la ubicación correcta de la macro. Selecciona la macro y, luego, Designer actualiza la ruta de macro y cambia su color a verde.

  4. Haz esto para cualquier macro adicional y selecciona Aceptar cuando termines. También puedes seleccionar Cancelar en este punto, lo que abre el flujo de trabajo original con rutas de archivo rotas (íconos de signo de interrogación de herramienta ausente).

  5. Si actualizaste las rutas de macros y seleccionaste Aceptar en el paso anterior, tu flujo de trabajo se abrirá con las macros actualizadas y sin íconos de herramienta ausente.

Si la macro es la misma y la cantidad de conexiones de entrada y salida de las rutas de macro nuevas coincide con la cantidad en el flujo de trabajo, Designer intenta realizar las conexiones automáticamente. Sin embargo, en algunos casos (por ejemplo, si conectas una macro diferente con la misma cantidad de entradas y salidas), Designer no puede realizar las conexiones. Si este es el caso, debes revisarlas y configurarlas manualmente. 

Importante

Cuando utilizas la característica Actualizar macros ausentes, Designer actualiza el flujo de trabajo original, aunque el flujo de trabajo no se guarda automáticamente. Puedes usar Archivo > Guardar como o el atajo de teclado Ctrl+S (Guardar) para guardar una nueva versión del flujo de trabajo o sobrescribir el flujo de trabajo original si es necesario. Si cierras el flujo de trabajo sin guardar, se perderán las actualizaciones.

Cerrar (no actualizar)

Si deseas abrir el flujo de trabajo y no actualizar las macros, sigue estos pasos:

  1. Cuando intentas abrir un flujo de trabajo con macros ausentes, aparece la ventana Actualizar macros ausentes .

  2. Para abrir el flujo de trabajo sin actualizar las ubicaciones de macros, selecciona Cerrar .

  3. Se abrirá tu flujo de trabajo y las macros ausentes mostrarán el ícono de herramienta ausente ( UnknownTool_71x71.png). Si deseas actualizar las macros ausentes, debes agregar las macros y volver a configurarlas manualmente.