Skip to main content

UnknownTool_71x71.png Strumento generico/sconosciuto

Le icone dello strumento Designer rappresentano l'attività o la macro specifica dello strumento. Quando Alteryx Designer non riesce a trovare una macro referenziata in un flusso di lavoro, Designer visualizza lo strumento sconosciuto insieme a un messaggio di errore per avvisarti. Ciò ti consente di riconfigurarlo (fai clic con il pulsante destro del mouse e scegli Inserisci > Macro per accedere alla macro), ripristinando lo strumento desiderato.

Aggiornamento della macro mancante

A partire dalla versione 2023.2, Designer ora consente di aggiornare una macro mancante prima che venga visualizzata l'icona dello strumento sconosciuto. Fai riferimento alle istruzioni riportate di seguito o vai alla pagina di assistenza Aggiornamento delle macro mancanti .

Lo strumento generico, che visualizza anche l'icona del punto interrogativo, viene utilizzato per accedere a una libreria di collegamento dinamico (DLL) o a un plug-in.

Nota

Questo strumento non è visibile nella tavolozza degli strumenti di Designer.

Per sostituire lo strumento...

  1. Seleziona lo strumento generico/sconosciuto per visualizzarne la configurazione.

  2. Utilizza queste informazioni per aggiungere lo strumento Designer appropriato al flusso di lavoro e configurarlo di conseguenza.

  3. Elimina lo strumento generico/sconosciuto dal flusso di lavoro.

Aggiornamento delle macro mancanti nel flusso di lavoro

Quando tenti di aprire un flusso di lavoro (file YXMD, YXMC o YXWZ) con una macro mancante, in Designer appare la finestra a comparsa Aggiorna macro mancanti per segnalare il problema.

update-missing-macros-1.png

La finestra Aggiorna macro mancanti comunica che il flusso di lavoro fa riferimento ad almeno una macro mancante o inaccessibile. Il messaggio fornisce dettagli su queste macro. Tieni presente che la finestra indica un massimo di 3 macro mancanti (anche se potrebbero mancarne altre).

Sono disponibili 2 opzioni:

  • Aggiorna : seleziona Aggiorna per aggiornare i percorsi dei file per le macro mancanti. Viene visualizzato il flusso di lavoro originale, in cui è possibile apportare modifiche. Tuttavia, Designer non salva automaticamente il flusso di lavoro. Dopo aver effettuato gli aggiornamenti, puoi selezionare File > Salva con nome o il tasto di scelta rapida Ctrl+S (Salva) per salvare una nuova versione del flusso di lavoro o sovrascrivere il flusso originale se necessario. È necessario poter accedere ai file delle macro mancanti e alle relative posizioni. Se il flusso di lavoro ti è stato inviato da un utente che non ha incluso le macro, è probabile che dovrai contattarlo e chiedergli di fornirti i file. Se scegli di non aggiornare i percorsi dei file qui, il flusso di lavoro si aprirà con le icone degli strumenti mancanti.

  • Chiudi (senza aggiornare): seleziona Chiudi . Viene visualizzato il flusso di lavoro originale senza le macro aggiornate. Le macro avranno l'icona dello strumento mancante ( UnknownTool_71x71.png) e se desideri risolvere il problema in un secondo momento, dovrai aggiungerle e riconfigurarle manualmente.

Aggiornamento delle macro

Per aggiornare le macro, attieniti alla seguente procedura:

  1. Nella finestra Aggiorna macro mancanti, seleziona Aggiorna .

  2. Viene visualizzata la finestra Aggiorna macro mancanti , simile a Dipendenze del flusso di lavoro. Qui puoi modificare il percorso del file di ogni macro mancante e aggiornarne la posizione. Non puoi modificare le dipendenze non macro tramite questa finestra.

    update-missing-macros-2.png
  3. Seleziona l'icona di modifica a forma di matita associata a una macro mancante. Viene visualizzato File Explorer, dove puoi selezionare la posizione corretta della macro. Una volta selezionata la macro, Designer aggiorna il relativo percorso e ne modifica il colore in verde.

  4. Esegui questa procedura per eventuali macro aggiuntive e seleziona OK al termine dell'operazione. A questo punto, puoi anche selezionare Annulla per aprire il flusso di lavoro originale con i percorsi dei file interrotti (icone di strumenti mancanti con i punti interrogativi).

  5. Se hai aggiornato i percorsi delle macro e hai selezionato OK nel passaggio precedente, il flusso di lavoro si aprirà con le macro aggiornate e non saranno presenti icone di strumenti mancanti.

Se la macro è la stessa e il numero di connessioni di input e output dai nuovi percorsi macro corrisponde a quello indicato nel flusso di lavoro, Designer tenta di stabilire le connessioni automaticamente. Tuttavia, in alcuni casi (ad esempio, se colleghi una macro diversa con lo stesso numero di input e output), Designer non è in grado di effettuare le connessioni. In questo caso, dovrai eseguire un controllo e una configurazione manuali. 

Importante

Quando utilizzi la funzionalità Aggiorna macro mancanti, Designer aggiorna il flusso di lavoro originale ma non lo salva automaticamente. Puoi selezionare File > Salva con nome o utilizzare la combinazione di tasti Ctrl+S (Salva) per salvare una nuova versione del flusso di lavoro o sovrascrivere il flusso originale se necessario. Se chiudi il flusso di lavoro senza salvare, gli aggiornamenti andranno persi.

Chiudi (senza aggiornare)

Se desideri aprire il flusso di lavoro e non aggiornare le macro, attieniti alla seguente procedura:

  1. Quando tenti di aprire un flusso di lavoro con macro mancanti, viene visualizzata la finestra Aggiorna macro mancanti .

  2. Per aprire il flusso di lavoro senza aggiornare le posizioni delle macro, seleziona Chiudi .

  3. Il flusso di lavoro si apre e le macro mancanti mostrano l'icona di strumento mancante ( UnknownTool_71x71.png). Se desideri aggiornare le macro mancanti, devi aggiungerle e riconfigurarle manualmente.