Skip to main content

Makros

Ein Makro ist ein Workflow oder eine Gruppe von Tools, die in einem Tool zusammengefasst sind, das Sie in einen anderen Workflow einfügen können. Erstellen Sie ein Makro, um einen Analyseprozess zu speichern und zu automatisieren, den Sie wiederholt durchführen. Verwenden Sie das Makro innerhalb eines Workflows, ohne den Analyseprozess jedes Mal neu erstellen zu müssen.

Speichern Sie ein Makro als YXMC-Datei für die Verwendung in Designer, oder geben Sie es über die Alteryx Community Gallery oder den Server Ihres Unternehmens für andere Benutzer frei.

Makro-Typen

  • Standard-Makro: Dieses Makro dient dazu, einen Prozess in einem Workflow als Tool zusammenzustellen, das in einen Workflow eingefügt werden kann.

  • Batch-Makro : Dieses Makro läuft wiederholt in einem Workflow und erzeugt nach jeder Ausführung eine Ausgabe. Das Makro läuft einmal für jeden Datensatz oder eine ausgewählte Gruppe von Datensätzen in den Daten. Das Makro erfordert ein Steuerungsparameter-Tool als Eingabe.

  • Iteratives Makro : Dieses Makro läuft im Workflow so oft ab, wie in der Konfiguration festgelegt, oder kontinuierlich, bis eine Bedingung erfüllt ist.

  • Standortoptimierung-Makro : Dieses Makro ist ein iteratives Makro, das bei der Netzwerkanalyse verwendet werden kann, um einen oder mehrere optimale Standorte zu ermitteln.

Makro erstellen

Ein Makro besteht aus einem Workflow und einer mit Schnittstellen-Tools erstellten Benutzeroberfläche. Weitere Informationen finden Sie unter Schnittstellen-'Tools und Schnittstellen-Designer-Fenster . Alternativ können Sie mit dem HTML-GUI-Bibliothek-Tool eine benutzerdefinierte Benutzeroberfläche erstellen.

So erstellen Sie ein Makro:

Wenn Sie einen vorhandenen Workflow verwenden, markieren Sie den Arbeitsschritt, den Sie als Makro speichern möchten, kopieren Sie diesen und fügen Sie ihn auf einer neuen Workflow-Registerkarte ein.

  1. Erstellen Sie einen neuen Workflow oder öffnen Sie einen vorhandenen Workflow.

  2. Makroeingabe hinzufügen:

    • Wenn der Workflow keine Eingabe enthält, fügen Sie ein Makroeingabe-Tool hinzu.

    • Wenn der Workflow ein Eingabe-Tool enthält (z. B. ein Eingabedaten- oder ein Texteingabe-Tool), klicken Sie mit der rechten Maustaste auf das Tool und wählen Sie In Makroeingabe konvertieren aus.

  3. Konfigurieren Sie das Makroeingabe-Tool .

  4. Fügen Sie ein Makroausgabe-Tool hinzu und konfigurieren Sie es.

Der Workflow-Typ wird standardmäßig in „Standard-Makro“ geändert, wenn ein Makroeingabe-Tool einem Workflow hinzugefügt wird. Der Makro-Typ wird standardmäßig in „Batch-Makro“ geändert, wenn ein Steuerungsparameter-Tool dem Workflow hinzugefügt wird. Um ein iteratives Makro zu erstellen, legen Sie für den Makrotyp „Iterativ“ fest.

So legen Sie den Makrotyp fest:

  1. Wählen Sie den Canvas aus und wählen Sie dann im Workflow-Konfiguration-Fenster die Workflow -Registerkarte.

  2. Wählen Sie unter Typ neben Makro einen Makrotyp aus.

In Makro konvertieren

Sie haben nicht nur die Möglichkeit, ein Makro von Grund auf neu zu erstellen, Sie können auch einen vorhandenen Workflow (oder einen Teil eines Workflows) in ein Makro konvertieren. Vor der Konvertierung in ein Makro sollten Sie die folgenden Anforderungen und Einschränkungen beachten:

  • Sie müssen zuerst den Workflow ausführen und alle verfügbaren Daten durchsuchen.

  • Sie müssen den Workflow vor der Konvertierung als Makro speichern.

  • Die ausgewählten Tools müssen sich in einem kontinuierlichen Pfad befinden und miteinander verbunden sein (Kommentare, Explorer-Felder und Tool-Behälter sind hiervon ausgenommen).

  • Die ausgewählten Tools dürfen keine Fehler enthalten.

  • Die ausgewählten Tools dürfen keine In-DB-Tools enthalten.

  • Die ausgewählten Tools dürfen nicht mit Aktion-Tools verbunden sein.

  • Die ausgewählten Tools dürfen keine Python-Tools enthalten.

  • Die ausgewählten Tools dürfen keine Daten enthalten, die Geo-Datentypen, BLOB-Datentypen oder Berichtsdatentypen enthalten.

So konvertieren Sie in ein Makro:

  1. Wählen Sie mindestens ein Tool in einem Workflow aus. Klicken Sie auf den Workflow-Canvas, und ziehen Sie ihn, um mehrere Tools auszuwählen.

  2. Klicken Sie mit der rechten Maustaste auf eines der ausgewählten Tools, um das Tool-Menü zu öffnen.

  3. Wählen Sie In Makro konvertieren in der Dropdown-Liste aus, um das Makro erstellen -Fenster zu öffnen.

  4. Im Makro-erstellen-Fenster

    • Geben Sie einen Dateinamen für das Makro ein.

    • Wählen Sie einen Speicherort für das Makro aus.

    • Wählen Sie ein Symbol für das Makro aus.

  5. Wählen Sie OK , um Ihren Workflow oder einen Bereich des Workflows in ein Makro zu konvertieren. Wählen Sie Abbrechen , um diesen Vorgang abzubrechen.

  6. Die neu erstellte Makrodatei wird in Designer in einer neuen Registerkarte geöffnet, während im ursprünglichen Workflow angezeigt wird, dass ausgewählte Tools in ein Makro konvertiert wurden.

Makro speichern

Speichern Sie ein Makro für die zukünftige Verwendung und Freigabe. Speichern Sie Makros mit einem eindeutigen Namen an einem spezifischen Speicherort. In Designer können Sie ein Makro-Repository erstellen, das einem Speicherort auf Ihrem Computer oder im Netzwerk zugeordnet ist. So können Sie Makros auf einfache Weise speichern und in einem Workflow wiederverwenden.

So speichern Sie ein Makro:

  1. Wählen Sie Datei > Speichern unter aus.

  2. Navigieren Sie zu einem Ordner auf Ihrem Computer oder in Ihrem Netzwerk, in dem Sie Makros speichern.

  3. Geben Sie einen eindeutigen Namen für das Makro ein und klicken Sie auf Speichern .

Um einen Workflow freizugeben, der benutzerdefinierte Makros verwendet, müssen Sie den Workflow exportieren, um sicherzustellen, dass alle Workflow-Abhängigkeiten, einschließlich des Makros, mit dem Workflow gespeichert werden. Der Workflow muss einen relativen Pfad zum Makro enthalten. Weitere Informationen finden Sie unter Workflow-Verwaltung und Workflow-Abhängigkeiten .

Fehlendes Makro aktualisieren

Wenn beim Importieren oder Öffnen eines Workflows mit einem vorhandenen Makro dieses Makro im Workflow fehlte (aufgrund einer Namensänderung, eines geänderten Speicherorts, eines falschen Pakets usw.), zeigte das Makro auf dem Workflow-Canvas bisher ein schwarzes Fragezeichensymbol ( UnknownTool_71x71.png) an.

Anschließend mussten Sie einen mühsamen Prozess durchlaufen, bei dem Sie das Makro manuell erneut hinzufügen und den Workflow neu konfigurieren mussten, damit alles ordnungsgemäß funktionierte.

Jetzt haben Sie die Option, den korrekten Speicherplatz des Makros zu identifizieren, bevor der Workflow geöffnet wird, und den Fehler aufgrund eines fehlenden Makros komplett zu vermeiden!

Tipp

Weitere Details und Anwendungsfälle finden Sie unter Fehlende Makros aktualisieren .

Fehlende Makros im Workflow aktualisieren

Wenn Sie versuchen, einen Workflow (YXMD-, YXMC- oder YXWZ-Datei) zu öffnen, in dem ein Makro fehlt, wird in Designer ein Popup-Fenster Fehlende Makros aktualisieren eingeblendet, um Sie auf das Problem hinzuweisen.

update-missing-macros-1.png

Im Fenster Fehlende Makros aktualisieren wird mitgeteilt, dass der Workflow mindestens ein Makro referenziert, das fehlt oder auf das nicht zugegriffen werden kann. Die Meldung enthält außerdem Details zu diesen Makros. Beachten Sie, dass im Fenster maximal drei fehlende Makros aufgeführt werden (es können jedoch weitere fehlen).

Sie haben zwei Optionen:

  • Aktualisieren : Klicken Sie auf Aktualisieren , um die Dateipfade für die fehlenden Makros zu aktualisieren. Dadurch wird der ursprüngliche Workflow geöffnet, in dem Sie dann die Änderungen vornehmen können. Designer speichert den Workflow jedoch nicht automatisch. Nachdem Sie Aktualisierungen vorgenommen haben, können Sie über Datei > Speichern unter oder mit der Tastenkombination Strg+S (Speichern) eine neue Version des Workflows speichern oder den ursprünglichen Workflow bei Bedarf überschreiben. Beachten Sie, dass Sie Zugriff auf die fehlenden Makrodateien benötigen und zu deren Speicherorten navigieren können müssen. Wenn Sie den Workflow von einer Person erhalten haben, die vergessen hat, die Makros einzufügen, müssen Sie sich wahrscheinlich an diese Person wenden und sie bitten, Ihnen die Dateien zur Verfügung zu stellen. Wenn Sie sich hier dagegen entscheiden, die Dateipfade zu aktualisieren, wird der Workflow mit den Symbolen für fehlende Tools geöffnet.

  • Schließen (nicht aktualisieren): Klicken Sie auf Schließen . Dadurch wird der ursprüngliche Workflow ohne die aktualisierten Makros geöffnet. Die Makros werden mit dem Symbol für fehlende Tools versehen ( UnknownTool_71x71.png). Wenn Sie das Problem der fehlenden Makros später beheben möchten, müssen Sie die Makros manuell hinzufügen und neu konfigurieren.

Makro aktualisieren

Um Makros zu aktualisieren, gehen Sie wie folgt vor:

  1. Klicken Sie im Fenster „Fehlende Makros aktualisieren“ auf Aktualisieren .

  2. Dadurch wird ein Fenster Fehlende Makros aktualisieren geöffnet, das der Oberfläche für Workflow-Abhängigkeiten ähnelt. Hier können Sie den Dateipfad aller fehlenden Makros bearbeiten und ihren Speicherort aktualisieren. Beachten Sie, dass Sie in diesem Fenster keine Abhängigkeiten bearbeiten können, die nicht mit Makros im Zusammenhang stehen.

    update-missing-macros-2.png
  3. Klicken Sie auf das Bleistiftsymbol, das einem fehlenden Makro zugeordnet ist. Dadurch wird der Datei-Explorer geöffnet, in dem Sie zum richtigen Makrospeicherort navigieren können. Wählen Sie das Makro aus. Daraufhin aktualisiert Designer den Makropfad und ändert die Farbe des Pfads zu Grün.

  4. Führen Sie diese Aktion für alle weiteren Makros aus. Wenn Sie fertig sind, klicken Sie auf OK . Sie können an dieser Stelle auch auf Abbrechen klicken. In diesem Fall wird der ursprüngliche Workflow mit unterbrochenen Dateipfaden (Fragezeichensymbole für fehlende Tools) geöffnet.

  5. Wenn Sie die Makropfade aktualisiert und im vorherigen Schritt auf OK geklickt haben, wird Ihr Workflow mit den aktualisierten Makros und ohne Symbole für fehlende Tools geöffnet.

Wenn das Makro identisch ist und die Anzahl der Eingabe- und Ausgabeverbindungen aus den neuen Makropfaden mit der Anzahl im Workflow übereinstimmt, versucht Designer, die Verbindungen automatisch herzustellen. In einigen Fällen (z. B., wenn Sie ein anderes Makro mit derselben Anzahl von Ein- und Ausgängen verbinden) kann Designer die Verbindungen jedoch nicht herstellen. In diesem Fall müssen Sie sie prüfen und manuell konfigurieren. 

Wichtig

Wenn Sie die Funktion zum Aktualisieren fehlender Makros verwenden, aktualisiert Designer den ursprünglichen Workflow zwar, speichert ihn aber nicht automatisch. Über Datei > Speichern als oder mit der Tastenkombination Strg+S (Speichern) können Sie eine neue Version des Workflows speichern oder gegebenenfalls den ursprünglichen Workflow überschreiben. Wenn Sie den Workflow schließen, ohne zu speichern, gehen Ihre Aktualisierungen verloren.

Schließen (ohne zu aktualisieren)

Wenn Sie den Workflow öffnen möchten, ohne die Makros zu aktualisieren, gehen Sie wie folgt vor:

  1. Wenn Sie versuchen, einen Workflow mit fehlenden Makros zu öffnen, wird das Fenster Fehlende Makros aktualisieren eingeblendet.

  2. Um den Workflow zu öffnen, ohne die Speicherorte der Makros zu aktualisieren, klicken Sie auf Schließen .

  3. Ihr Workflow wird geöffnet und für die fehlenden Makros wird das Symbol für fehlende Tools angezeigt ( UnknownTool_71x71.png). Wenn Sie die fehlenden Makros aktualisieren möchten, müssen Sie die Makros manuell hinzufügen und neu konfigurieren.

Makro-Repository erstellen

In Designer können Sie ein Makro-Repository erstellen, dem Sie den Speicherort für Ihre Makros zuordnen. So können Sie Makros auf einfache Weise speichern und in Workflows verwenden. Jede YXMC-Datei am ausgewählten Speicherort wird in der Tool-Kategorie in der Tool-Palette angezeigt.

So erstellen Sie ein Makro-Repository:

  1. Klicken Sie auf Optionen  > Benutzereinstellungen  > Benutzereinstellungen bearbeiten  > Makros .

  2. Wählen Sie die +-Schaltfläche aus.

  3. Geben Sie unter Kategoriename einen Namen ein. Der Standardname lautet „Makros“.

  4. Wählen Sie die ...-Schaltfläche aus, um zu dem Verzeichnis zu navigieren, in dem Sie Makros auf Ihrem Computer oder in Ihrem Netzwerk speichern.

Unterordner eines Suchpfads können nicht einzeln hinzugefügt werden, wenn der übergeordnete Ordner bereits im Makro-Repository vorhanden ist.

So legen Sie ein Standardverzeichnis für das Repository fest:

  1. Wählen Sie in der Liste den Repository-Suchpfad aus.

  2. Wählen Sie Als Standard festlegen aus. Daraufhin wird neben dem Standard-Repository ein Sternchen ( * ) angezeigt.

Makros in Workflows verwenden

Um ein Makro zu verwenden, das in Ihrem Makro-Repository gespeichert ist, suchen Sie das Makro in der Tool-Palette oder verwenden Sie die Suchen-Funktion.

Um ein Makro zu verwenden, das sich nicht in der Tool-Palette befindet, klicken Sie mit der rechten Maustaste auf den Workflow-Canvas und wählen Sie  Einfügen  > Makro . aus. Sie können ein beliebiges Makro aus dieser Liste auswählen, das derzeit auf dem Canvas geöffnet ist, oder zum Speicherort einer anderen YXMC-Makrodatei navigieren.

Wenn Sie eine spezifische Makroversion in Ihrem Workflow verwenden möchten, wählen Sie mit der rechten Maustaste das Makro und dann die Version aus, die Sie ausführen möchten. Alle Makroversionen müssen im selben Verzeichnis gespeichert werden. Sie können diesen Speicherort in den Benutzereinstellungen konfigurieren.

Wählen Sie zur Unterscheidung eines Makros von einem Tool innerhalb eines Workflows die Makroindikatoren auf Tools anzeigen -Option aus, um das + -Symbol unter Benutzereinstellungen  > Canvas anzuzeigen. Weitere Informationen finden Sie unter Benutzereinstellungen .

Um den Workflow eines Makros anzuzeigen, klicken Sie in einem Workflow mit der rechten Maustaste auf das Makro und wählen Sie Makro öffnen aus. Ein Makro in einem Workflow wird automatisch aktualisiert, wenn Änderungen an diesem Makro gespeichert werden.

Um einen Workflow freizugeben, der benutzerdefinierte Makros verwendet, müssen Sie den Workflow exportieren, um sicherzustellen, dass alle Workflow-Abhängigkeiten, einschließlich des Makros, mit dem Workflow gespeichert werden. Der Workflow muss einen relativen Pfad zum Makro enthalten. Weitere Informationen finden Sie unter Workflow-Verwaltung und Workflow-Abhängigkeiten .

Makrovorlagen

Wenn Sie feststellen, dass Sie viele Komponenten und Konfigurationen in Ihren Makros wiederverwenden, können Sie Vorlagen erstellen, um Zeit zu sparen. Gehen Sie zu Vorlagen , um zu erfahren, wie Sie Ihr Makro als Vorlage speichern.

Beispiel-Makros

Makros sind in Designer enthalten, um Ihnen beim Erlernen der Verwendung und Erstellung von Makros zu helfen. So greifen Sie auf die Makros zu:

  • Gehen Sie auf Ihrem Computer unter Programme zu \Programme\Alteryx\bin\RuntimeData\Macros .

  • In Designer:

    • Gehen Sie zu Hilfe > Beispielworkflows > Scripterstellung- und Automatisierung-Tools verwenden > Makro erstellen .

    • Die Tool-Palette enthält auch Makros. Beispielsweise das Stichprobenerstellung-Tool und das Datenbereinigung-Tool . Klicken Sie mit der rechten Maustaste auf ein Tool und wählen Sie Makro öffnen aus (sofern verfügbar), um den Makro-Workflow anzuzeigen.

  • Sie können auch Apps aufrufen, die in der Alteryx Community Gallery veröffentlicht wurden.