Skip to main content

Notes de publication Server 2022.3

Notes de publication - Versions produit

Version

Date

Version

Arrêt de la prise en charge

2022.3.1.395

29 novembre 2022

Disponibilité limitée

29 novembre 2024

2022.3.1.430

25 janvier 2023

Majeure

29 novembre 2024

2022.3.1.450 (Correctif 2)

8 mars 2023

Mineur/correctif

29 novembre 2024

2022.3.1.486 (Correctif 3)

2 mai 2023

Mineur/correctif

29 novembre 2024

2022.3.1.508 (Correctif 4)

28 juin 2023

Mineur/correctif

29 novembre 2024

2022.3.1.532 (Correctif 5)

30 août 2023

Mineur/correctif

29 novembre 2024

2022.3.1.553 (correctif 6)

9 novembre 2023

Mineur/correctif

29 novembre 2024

2022.3.1.573 (Patch 7)

January 4, 2024

Minor/Patch

November 29, 2024

2022.3.1.590 (Patch 8)

February 15, 2024

Minor/Patch

November 29, 2024

Important

Veuillez noter que tous les clients qui ont participé au programme de disponibilité limitée de la version 2022.3 doivent procéder à une mise à niveau complète vers la version 2022.3.1.430, qui réinstalle entièrement Server avec la version générale 2022.3.1.430.

Important

En raison de la migration de la cryptographie dans la version 2022.3, seules les versions 2021.2 et ultérieures de Server pourront être mises à niveau vers la version 2022.3. Si vous possédez une version antérieure à 2021.2, effectuez une mise à niveau vers la version 2021.2 ou une version plus récente avant de passer à la version 2022.3.

Important

La version 2022.3 d'Alteryx Server propose des versions en disponibilité générale et  compatibles avec la norme FIPS 140-2  distinctes. Veuillez noter que ces normes sont élaborées par le NIST (US National Institute of Standards and Technology) à l'intention des organismes gouvernementaux et des sous-traitants américains. Pour plus d'informations sur FIPS, consultez la page FAQ FIPS du NIST .Alteryx Server-FIPS

La version générale (non FIPS) d'Alteryx Server n'est pas en mesure de répondre aux exigences FIPS. Une version distincte (et un installateur distinct) est disponible sous des conditions de licence distinctes pour nos clients FIPS 140-2. Pour plus d'informations, contactez votre représentant commercial Alteryx .

Différences en matière de fonctionnalités

Server-FIPS 2022.3 offre quelques fonctionnalités qui ne sont pas disponibles ou dont le fonctionnement est limité par rapport aux versions précédentes non-FIPS de Server. Consultez Alteryx Server et Server-FIPS : différences entre les fonctionnalités à titre de référence.Alteryx Server et Alteryx Server-FIPS : différences entre les fonctionnalités

Important

Instructions d'installation pour les utilisateurs de systèmes d'exploitation japonais, chinois, français et italien

Erreur de l'interface utilisateur Server sur les systèmes d'exploitation japonais, chinois, français et italien : une erreur HTTP 500 s'affiche lorsque vous ouvrez l'interface utilisateur Server (par exemple, Erreur de serveur interne HTTP500 : impossible d'afficher cette page Web.) Pour résoudre ce problème, remplacez le paramètre de langue sur le système d'exploitation non anglais par Anglais et installez Alteryx Server. Après l'installation, vous pourrez rétablir la langue de votre choix.

Note

Considérations sur la mise à niveau

À compter de la version 2022.3, les versions de Designer antérieures à la 2022.3 n'offriront PAS la possibilité de partager les workflows avec Server. Vous devez télécharger ces workflows vers Server 2022.3 à l'aide de l'interface utilisateur ou de l'API de l'administrateur. Pour maintenir la compatibilité avec Server, téléchargez la dernière version de Designer.

Note

Réinitialisation obligatoire du mot de passe pour l'authentification intégrée

Si vous utilisez l'authentification intégrée et que vous effectuez une mise à niveau à partir d'une version antérieure à 22.1, vous devez réinitialiser votre mot de passe en raison d'améliorations en matière de sécurité. Si vous n'avez pas réinitialisé votre mot de passe dans la version 22.1, vous devez activer SMTP. Les utilisateurs peuvent ainsi réinitialiser leur mot de passe via la fonctionnalité Mot de passe oublié ou pour qu'un administrateur puisse déclencher la réinitialisation de mot de passe pour tous les utilisateurs via l'interface utilisateur ou l'API. Pour plus d'informations sur la réinitialisation du mot de passe Server après la mise à niveau vers la version 22.1, consultez la page d'aide Réinitialiser le mot de passe Server d'un utilisateur .Réinitialisation du mot de passe Server d'un utilisateur

Note

Changements à venir dans le format de l'horodatage

Dans une prochaine version, tous les horodatages des bases de données Server seront convertis au format UTC. Il n'y aura pas de changement de fonctionnalité dans l'interface utilisateur Server front-end et toutes les heures s'afficheront comme prévu selon les paramètres de configuration de Server. Si vous relevez les horodatages directement à partir de la base de données Server, veuillez noter que ces horodatages seront convertis au format UTC à des fins de normalisation dans l'ensemble du produit et de limitation des problèmes liés à l'heure d'été.

Nouvelles fonctionnalités

Mises à jour du programme d'installation

À compter de la version 2022.3, Alteryx Designer, Server et les outils Prédictifs en R utilisent une nouvelle technologie d'installation. Le programme d'installation mis à jour détecte la langue de votre système d'exploitation et installe les produits Alteryx dans cette langue (si disponible). Consultez la page Télécharger et installer un produit pour connaître les principales considérations relatives à la mise à niveau et la rétrogradation, ainsi que les options de ligne de commande mises à jour .

Outil Préparation à la migration

Pour utiliser la cryptographie la plus récente et la plus efficace de Server afin de protéger les données au repos et les données en transit, vous pouvez désormais migrer vers les algorithmes les plus modernes sans subir de temps d'arrêt ni interrompre votre activité.

Dans le cadre du passage à une cryptographie plus moderne, compatible avec la norme FIPS, Alteryx a mis au point un outil Préparation à la migration afin de limiter les temps d'arrêt liés aux plages de maintenance dont vous avez besoin pour migrer tous vos workflows vers la nouvelle norme cryptographique.

L'outil Préparation à la migration pour Server est un utilitaire de ligne de commande distinct qui permet la prémigration d'une base de données de workflows et d'applications pour accélérer la migration vers la nouvelle norme AES256.

Cet outil est facultatif et ne doit être exécuté qu'une seule fois avant de mettre à niveau une version antérieure de Server vers Server 2022.2.x (version FIPS), 2022.3.x (version FIPS ou générale) ou une version ultérieure. Cependant, nous vous recommandons d'exécuter l'outil Préparation à la migration dans certains cas.

Pour plus d'informations sur cet outil, consultez la page d'aide de l'outil Préparation à la migration .Outil Préparation à la migration

Refonte de l'interface utilisateur Server

Nous avons repensé ces pages d'administration : Notifications, Paramètres (anciennement Configuration et Thème), Tâches, Planifications, Contenus multimédia, Analyses, Workflows, Souscriptions, Diagnostics, Connexion aux données, Catégories, Pages et Liens. La fonctionnalité de ces pages reste la même.

L'interface utilisateur de la recherche globale a également été mise à jour. Les résultats de la recherche contiennent désormais plus d'informations, telles que la date de création, l'auteur et le type. Vous pouvez également sélectionner les types de ressources à inclure dans votre recherche. Ces mises à jour vous donnent plus de contrôle sur ce que vous recherchez et plus d'informations sur vos résultats directement à partir de la page de recherche.

Localisation

La localisation en chinois, français, italien, japonais, allemand, espagnol et portugais a été étendue à toutes les pages de Server, à l'exception de la page de connexion et de la page Application analytique.

Mises à jour du module cryptographique OpenSSL3

  • Nous avons mis à jour notre moteur cryptographique OpenSSL3 groupé vers la version OpenSSL 3.0.7, qui corrige les vulnérabilités CVE-3602 et CVE-3786, toutes deux classées comme étant de gravité élevée.

  • Nous avons ajouté le fournisseur hérité OpenSSL3, qui fournit des algorithmes et des chiffrements plus anciens (MD2, MD4, RC4, DES, IDEA et d'autres) qui ne sont plus intégrés dans le moteur cryptographique de base de la série 3.x. Notez que le fournisseur hérité n'est pas chargé, sauf s'il a été activé manuellement via la configuration principale sur un hôte Designer ou Server particulier.

Mises à jour du chiffrement et du hachage

Nous avons apporté les mises à jour suivantes au chiffrement de Server :

  • Tout le chiffrement des données au repos utilise désormais AES256.

  • Les hachages MD5 et SHA1 ont été mis à jour vers SHA256.

  • Alteryx Server-FIPS utilise les modules cryptographiques certifiés FIPS 140-2 suivants :

    • OpenSSL version 3.0.0 – Fournisseur OpenSSL FIPS – certifications des algorithmes ( A1938 ) [1]

    • Windows 10 - Bibliothèque de primitives cryptographiques - Certificat n° 3197

  • Pour Server-FIPS, les champs d'application analytiques ne sont pas chiffrés dans cette version.* Si vous disposez d'informations personnelles d'identification (IPI) dans les champs d'application analytique, ces données ne bénéficieront pas d'une protection supplémentaire.

* Nous avons corrigé cette information le 23 mars 2023, pour indiquer qu'elle ne touche que Server-FIPS. Dans la version standard (non FIPS) de Server, les IPI des champs de l'application analytique sont protégés.

API Server V3 : points de terminaison de workflows, tâches et identifiants

Nous avons également mis à jour l'API Server V3 pour les utilisateurs disposant de droits d'administrateur et de créateur :

  • En tant qu'administrateur Alteryx Server, vous pouvez désormais automatiser de nombreux processus, tels que le chargement de workflows et l'accès aux workflows et aux identifiants.

  • En tant qu'utilisateur disposant de droits de créateur, vous pouvez désormais accéder à certains points de terminaison /workflows et /jobs depuis v1/v2/subscriptions dans le cadre de votre API V3. Vous pouvez également publier un workflow et spécifier ses identifiants, afin que le workflow dispose de toutes ses métadonnées nécessaires pour fonctionner correctement.

Pour plus d'informations sur l'API Server V3, consultez les pages d'aide  API Alteryx Server V3  et  Objets de l'API Server V3 .Accès à l'API Server V3Objets de l'API Server V3

Mise à jour des paramètres système

  • SSL/TLS  : AlteryxService prend désormais en charge le protocole TLS pour la communication interne et directe de la couche de service. Dans Server-FIPS, TLS est activé pour tous les services et ne peut pas être désactivé.En raison de cette modification, vous devez installer un certificat X.509 (TLS) sur les nœuds de l'interface utilisateur Server et du contrôleur. Cela permet à la communication entre les nœuds de fonctionner avec TLS. Nous vous recommandons d'installer des certificats sur toutes les machines hébergeant Server, quelle que soit leur configuration. Pour plus d'informations sur les paramètres TLS, consultez la page d'aide Paramètres système .Paramètres système

  • Engine : lorsque vous activez le paramètre « Allow Server to manage engine resources » (Autoriser Server à gérer les ressources du moteur) dans Paramètres système > Engine > General, le paramètre « Allow users to override these settings » (Autoriser les utilisateurs à remplacer ces paramètres) est maintenant désactivé.

Mise à jour de la prise en charge du protocole SAML

Nous avons supprimé la dépendance à IdentityServer 3 et au processus AlteryxAuthHost.exe. La fonctionnalité SAML est désormais fournie dans le cadre du processus AlteryxServerWebApiHost.exe. Nous avons également ajouté la prise en charge de la signature des demandes dans cette mise à jour.

Cela signifie qu'à partir de la version 2022.3, nous utilisons des points de terminaison de fournisseurs de services mis à jour via le service API Web. Notez que les configurations existantes utilisant les points de terminaison précédents continuent de fonctionner et qu'aucune action n'est requise à ce stade pour continuer à utiliser SAML dans votre système Alteryx Server existant.

URL de base ACS des paramètres système Alteryx :

  • Précédente valeur par défaut : http(s)://host.domain.tld/aas/

  • Nouvelle valeur par défaut : http(s)://host.domain.tld/webapi/

URI d'audience du fournisseur d'identité :

  • Précédente valeur par défaut : http(s)://host.domain.tld/aas/Saml2

  • Nouvelle valeur par défaut : http(s)://host.domain.tld/webapi/Saml2

URL d'authentification unique du fournisseur d'identité :

  • Précédente valeur par défaut : http(s)://host.domain.tld/aas/Saml2/Acs

  • Nouvelle valeur par défaut : http(s)://host.domain.tld/webapi/Saml2/Acs

Configuration des données d'utilisation

Nous avons supprimé la configuration pour l'envoi des données d'utilisation dans les paramètres de l'environnement de Server. Pour en savoir plus sur notre philosophie en matière de données d'utilisation, consultez la section Amélioration de nos produits grâce aux données d'utilisation , ainsi que la politique de confidentialité d'Alteryx .

Obsolescence du rapport d'utilisation de Server

Le rapport d'utilisation de Server est disponible sous forme de téléchargement distinct en parallèle du produit Server et aide les administrateurs à obtenir des statistiques utiles sur leur environnement Server en exécutant un workflow dans Designer qui se connecte à leur MongoDB.

En raison des modifications continues apportées aux schémas de la base de données de Server, la validité et la valeur des sorties de rapport ont diminué au fil du temps et les ajouts de nouveaux schémas dans la base de données sous-jacente du produit Server ne sont pas capturés dans le rapport d'utilisation de Server par la suite. Par conséquent, le rapport d'utilisation de Server ne sera plus publié en même temps que Server en tant que téléchargement distinct. Les versions précédentes du rapport continueront d'être disponibles au téléchargement, mais les modifications continues de la base de données dévalueront les résultats de ce rapport au fil du temps.

En tant que macro Designer, ce rapport peut être téléchargé et mis à jour par n'importe quel utilisateur pour une utilisation continue en fonction des informations souhaitées de la base de données MongoDB. Cependant, l'équipe produit Alteryx ne mettra pas à jour ou ne maintiendra pas le rapport depuis son état actuel.

Si vous souhaitez envoyer des commentaires sur le  rapport d'utilisation de Server , répondez à  cette enquête  afin que notre équipe produit Server puisse tenir compte des demandes en vue de leur inclusion future dans notre suite de produits.Installer le rapport d'utilisation de Server

Fuseau horaire pour les planifications dans l'API Server V3

Ajout d'un fuseau horaire pour les points de terminaison de l'API V3 suivants :

  • POST /v3/schedules : ce point de terminaison a été mis à jour pour vous permettre de définir l'heure et le fuseau horaire des planifications.

    Par exemple, si vous souhaitez définir une planification pour 17:00, heure des Rocheuses, vous devriez pouvoir définir l'horaire sur 17:00 et sélectionner Heure des Rocheuses comme fuseau horaire. L'option Fuseau horaire est facultative, et si vous ne spécifiez pas le fuseau horaire, le fuseau horaire par défaut sera l'heure UTC (Temps universel coordonné).

  • PUT /v3/schedules : ce point de terminaison a été mis à jour pour vous permettre de mettre à jour les planifications existantes créées à l'aide de l'API et d'ajouter, si vous le souhaitez, un fuseau horaire sélectionné. 

    Par exemple, si vous avez créé une planification à l'aide des points de terminaison d'API et que l'heure devait être définie en UTC, vous devriez pouvoir mettre à jour la planification et modifier l'heure et le fuseau horaire.

    Toutefois, les planifications existantes continueront à s'exécuter comme prévu si vous choisissez de ne pas ajouter de fuseau horaire.

  • GET /v3/schedules/{id} : ce point de terminaison a été mis à jour pour vous permettre d'afficher le fuseau horaire d'une planification existante filtrée par ID.

  • GET /v3/schedules/ : ce point de terminaison a été mis à jour pour vous permettre d'afficher les fuseaux horaires de toutes les planifications existantes.

Pour plus d'informations sur les points de terminaison, accédez à la documentation Swagger en sélectionnant l'icône point d'interrogation dans le coin supérieur droit de l'interface Server. Pour connaître les fuseaux horaires valides à utiliser dans les points de terminaison d'API ci-dessus, consultez la page d'aide Points de terminaison des planifications .Points de terminaison des planifications

Option CLI pour se connecter à un contrôleur à distance

En tant qu'administrateur, vous pouvez désormais transférer en toute sécurité des clés de chiffrement depuis votre environnement existant pour migrer Server vers un nouvel hôte ou pallier une panne.

Pour plus d'informations, reportez-vous à la page Processus de transfert de la clé de chiffrement .Encryption Key Transfer Process

Problèmes connus et résolus

Résolu

Version 2022.3.1.395 en disponibilité limitée

ID

Description

Version

Statut du problème

TGAL-6307

Lors de l'utilisation du point de terminaison /webapi/v1/workflows/{id}/package via la nouvelle documentation API interactive, le fichier .yxzp téléchargé est corrompu en raison d'un problème avec SwaggerUI 2.0. Pour contourner ce problème, récupérez les packages à partir de l'API à l'aide d'un code personnalisé ou d'outils d'API tiers tels que Postman.

2022.3.1.395

Résolu

TGAL-6338

Certains formulaires de connexion IDP ne s'affichent pas correctement dans la configuration Alteryx.

2022.3.1.395

Résolu

TGAL-6401

Le lien envoyé pour confirmer l'adresse e-mail redirige vers une erreur indiquant que l'utilisateur a déjà été validé.

2022.3.1.395

Résolu

TGAL-6408

GS-622

L'attribution de la balise worker par défaut à la souscription n'est pas enregistrée correctement.

2022.3.1.395

Résolu

TGAL-6417

TMEE-518

Le nom canonique n'a pas d'incidence sur les URL de notification.

2022.3.1.395

Résolu

TGAL-6425

GBETA-177

La modification des autorisations échoue lors de la configuration de l'utilisateur avec un nom de famille détenant une valeur null. Aucun message d'erreur ne s'affiche pour vous informer de l'échec.

2022.3.1.395

Résolu

TGAL-6443

GCSE-453

Le point de terminaison POST /v3/workflows/{workflowId}/versions ne s'affiche pas dans l'interface utilisateur pour les workflows chargés depuis Designer.

2022.3.1.395

Résolu

TGAL-6468

GCSE-462

Impossible de filtrer par date via le point de terminaison v3/schedules de l'API Server.

2022.3.1.395

Résolu

TGAL-6480

GBETA-302

Point de terminaison des utilisateurs de l'API Alteryx Server V3 : échec de la tentative de création d'un utilisateur.

2022.3.1.395

Résolu

TGAL-6482

API Server : DELETE v3 pour /users/ échoue si l'espace public contient un workflow.

2022.3.1.395

Résolu

TGAL-6483

GCSE-479

API Server : PUT /users/ v3 échoue si la valeur nom de famille de l'utilisateur est nulle.

2022.3.1.395

Résolu

TGAL-6530

2022.1 : le profil des utilisateurs affiche toujours l'événement de clé API de souscription bien que cette fonctionnalité ait été supprimée dans la version 22.1. En outre, il est toujours possible pour les administrateurs d'activer/de désactiver l'API à partir d'une souscription.

2022.3.1.395

Résolu

TGAL-6537

GCSE-502

Prévision de planification : une erreur s'est produite lors de la tentative de chargement de vos workflows planifiés dans l'onglet Administrateur > Tâches > Workflows planifiés.

2022.3.1.395

Résolu

TGAL-6590

GCSE-561

Échec du démarrage du service sur MongoDB 4.2 à l'aide du moteur de stockage MMAPv1.

2022.3.1.395

Résolu

TGAL-6592

API V3 pour POST, PUT /workflows ne permet pas de définir workflowCredentialType.

2022.3.1.395

Résolu

TGAL-6702

TMEE-687

Les sorties .yxdb qui contiennent des données de carte ne génèrent pas correctement les aperçus.

2022.3.1.395

Résolu

TGAL-6706

GCSE-635

Lorsque l'option « Désactivation des téléchargements directs » d'une interface utilisateur Server est activée dans la configuration, tout workflow migré vers l'environnement ou téléchargé via la page workflows d'administration génère une erreur.

2022.3.1.395

Résolu

TGAL-6720

La clé d'accès API et la clé secrète API ne sont pas disponibles pour les utilisateurs créés à partir de la page Utilisateurs.

2022.3.1.395

Résolu

TGAL-6740

API Server : le point de terminaison POST /v3/workflows/{workflowId}/versions ne fonctionne pas comme prévu. Nous avons temporairement désactivé le point de terminaison. Nous le réintroduirons lorsqu'une solution sera disponible.

2022.3.1.395

Résolu

TMEE-382

Les bannières ne fonctionnent plus dans la version 21.4+.

2022.3.1.395

Résolu

TMEE-383

Le texte de survol ne s'affiche pas lors du survol d'une bannière publicitaire.

2022.3.1.395

Résolu

TMEE-444

Réexécution de l'application : les questions de l'application sont réinitialisées aux valeurs par défaut et ne conservent pas les valeurs saisies.

2022.3.1.395

Résolu

TMEE-457

La recherche globale ne fonctionne pas si le mot-clé contient un tiret bas.

2022.3.1.395

Résolu

TMEE-520

GBETA-179

Les identifiants de l'API n'apparaissent que si la page est actualisée.

2022.3.1.395

Résolu

TMEE-549

GCSE-492

Mise à niveau 2021.4 : problèmes d'affichage des méta-infos dans l'interface utilisateur de Server.

2022.3.1.395

Résolu

TMEE-564

TGAL-6536

Les utilisateurs créés ne s'affichent pas tant qu'un utilisateur n'actualise pas la page dans un environnement MultiNode.

2022.3.1.395

Résolu

TMEE-606

La page Paramètres administrateur renvoie les erreurs 400 et 500 lors de la mise à jour des paramètres.

2022.3.1.395

Résolu

TMEE-608

L'activation du paramètre « Les utilisateurs peuvent s'enregistrer » dans Administrateur > Paramètres > Configuration (case cochée) désactive la connexion en définissant « SignupDisabled » sur Vrai.

2022.3.1.395

Résolu

TMEE-609

Catégories d'administrateur : dans la page Créer une catégorie, le texte du titre ne se remplit pas automatiquement lors de la sélection du champ NavLink.

2022.3.1.395

Résolu

TMEE-618

Catégories (Administrateur) : la fenêtre modale Charger l'icône de la catégorie ne contient pas l'icône Réinitialiser les valeurs par défaut.

2022.3.1.395

Résolu

TMEE-630

Corrections de bogues 22.2 : lorsqu'ils utilisent Windows comme méthode d'authentification, les administrateurs ne doivent pas être invités à saisir leur nom d'utilisateur et leur mot de passe.

2022.3.1.395

Résolu

TMEE-636

Corrections de bogues 22.2 : les administrateurs ne peuvent pas modifier l'icône du workflow dans les détails d'un workflow.

2022.3.1.395

Résolu

TMEE-643

Corrections de bogues 22.2 : les administrateurs ne peuvent pas voir l'heure planifiée sous forme de colonne dans les tâches.

2022.3.1.395

Résolu

TMEE-652

Recherche globale dans l'interface utilisateur Server : impossible d'afficher l'option Créé par pour Workflows, Pages, Catégories dans les résultats de recherche globale.

2022.3.1.395

Résolu

TMEE-824

Utilisateurs (Administrateur) : impossible de charger des fichiers de photo de profil d'une taille supérieure ou égale à 197 Ko et inférieure ou égale à 200 Ko.

2022.3.1.395

Résolu

Résolu

Version majeure 2022.3.1.430

ID

Description

Version

Statut du problème

TCPE-490

GCSE-960

Un attribut de politique CORS dans la balise AccessControlAllowOrigin du fichier RuntimeSettings.xml entraîne l'échec de l'API Web, ce qui a pour conséquence l'échec du démarrage des nœuds de la Galerie.

2022.3.1.430

Résolu

TGAL-6743

Selon votre configuration, les cartes de référence peuvent ne pas s'afficher dans les applications qui utilisent l'outil Entrée de carte. Consultez Les ensembles de cartes ne s'affichent pas dans l'interface utilisateur Server (article de la communauté) pour obtenir plus d'informations et pour savoir comment résoudre ce problème.

2022.3.1.430

Résolu

TGAL-6794

Lorsque vous enregistrez une nouvelle version d'un workflow qui a déjà une planification, la nouvelle version ne s'exécute qu'une seule fois, puis la planification revient à la version précédente du workflow.

2022.3.1.430

Résolu

TGAL-6986

Le point de terminaison POST admin/v1/workflows/ ne permet pas d'exécuter un workflow si celui-ci porte un nom différent de celui du workflow téléchargé à l'origine.

2022.3.1.430

Résolu

TGAL-6990

GCSE-1027

La migration du schéma de la base de données échoue si l'environnement contient des connexions aux données de Server avec des mots de passe NULL ou vides.

2022.3.1.430

Résolu

TGAL-7078

GCSE-1069

Les workflows de la version Server 2022.3 en disponibilité limitée ne peuvent pas être rechargés après le chiffrement.

2022.3.1.430

Résolu

TPRI-933

Dans les versions 2021.4 et ultérieures, seuls le propriétaire du workflow et les administrateurs peuvent accéder aux Paramètres de workflow . Dans les versions précédentes, tous les utilisateurs ayant accès au workflow pouvaient accéder aux Paramètres de workflow .

2022.3.1.430

Résolu

TPRI-935

Impossible d'ajouter des utilisateurs à une souscription sur un Server configuré pour l'authentification Windows.

2022.3.1.430

Résolu

Résolu

Version mineure/correctif 2 2022.3.1.450

ID

Description

Version

Statut du problème

TGAL-7053

Les utilisateurs Server peuvent exécuter des workflows dans Server lorsque ces workflows utilisent des connexions aux données Server qui ne sont pas explicitement partagées avec eux pour une autre utilisation dans Designer. Il s'agit d'un paramètre global pour tous les workflows d'une instance de Server. Les administrateurs peuvent contrôler ce paramètre dans  Administrateur  >  Paramètres  > Configuration  > Ressources .

2022.3.1.450

Résolu

TGAL-7199

Toutes les versions des workflows publiés à partir de Designer s'affichent en tant que version 1 dans Server et les versions antérieures ne sont pas accessibles.

2022.3.1.450

Résolu

Résolu

Version mineure/correctif 3 2022.3.1.486

ID

Description

Version

Statut du problème

GDCM-2765

Un workflow avec une information d'identification contenant un nom d'utilisateur et aucun mot de passe ne s'exécute pas après la migration vers la version 2022.3.

2022.3.1.486

Résolu

TGAL-6769

La connexion est uniquement partagée avec les membres directs du groupe d'utilisateurs sur Alteryx Server et non avec les membres du groupe AD qui fait partie de ce groupe d'utilisateurs sur Alteryx Server.

2022.3.1.486

Résolu

TGAL-7247

Les administrateurs de Server doivent pouvoir utiliser une connexion configurable sur le worker pour leur permettre d'utiliser des informations d'identification de connexion uniques lors de la connexion directe à MongoDB.

2022.3.1.486

Résolu

TGAL-7291

GCSE-1121

L'interface d'administration Server ne peut pas ajouter de connexion aux données pour Microsoft SQL Server avec l'authentification Windows.

2022.3.1.486

Résolu

TPRI-972

Fenêtre contextuelle de l'historique des versions du workflow : toutes les versions du workflow ne sont pas visibles lorsqu'il existe plus de 5 versions.

2022.3.1.486

Résolu

TPRI-1071

Lorsque vous tentez d'exécuter une version d'un workflow autre que la dernière version (version la plus récente), le workflow n'est pas exécuté correctement. Server n'envoie pas la version correcte à exécuter.

2022.3.1.486

Résolu

Résolu

Version mineure 2022.3.1.508

ID

Description

Version

Statut du problème

TGAL-7785

TCPE-587

GCSE-1149

Designer ne peut pas se connecter directement à un contrôleur à distance pour créer ou gérer des planifications (Desktop Automation/Planificateur).

2022.3.1.508

Résolu

TPRI-1487

Lorsque les propriétaires d'un workflow ou d'une application exécutent manuellement un workflow dans Server immédiatement après avoir modifié la version publiée pour une version différente de la dernière (ou plus récente) version de ce workflow, Server exécute la version publiée lors de la première exécution manuelle au lieu de la dernière version. Les exécutions manuelles suivantes exécuteront la dernière version comme prévu.

2022.3.1.508

Résolu

Résolu

Version mineure 2022.3.1.532

ID

Description

Version

Statut du problème

TCPE-618

GCSE-1210

Les workflows chargés via le point de terminaison d'API admin/v1/workflows ne se chargent pas dans Server après la mise à niveau vers 2021.4 - 2022.3, ce qui entraîne une erreur 404 dans l'onglet réseau et une erreur « Page introuvable » avec une redirection vers Mon espace de travail.

2022.3.1.532

Résolu

TGAL-8397

Après la mise à niveau vers Alteryx Server 2022.3, de nombreuses révisions du workflow s'affichent en tant que version 0 dans l'interface utilisateur Alteryx Server.

2022.3.1.532

Résolu

TPRI-1135

GBETA-362

Lors de la planification d'un Workflow dans Server, l'utilisateur n'a pas la possibilité de sélectionner un jour calendaire.

2022.3.1.532

Résolu

Résolu

Version mineure 2022.3.1.553

ID

Description

Version

Statut du problème

TCPE-597

GCSE-1178

Une exception a été levée lors de l'affirmation de la réponse SAML depuis le fournisseur d'identité (lors de l'utilisation de Meta ou x509).

2022.3.1.553

Résolu

TGAL-8569

Le transfert de la clé DCM via la CLI ne fonctionne pas sur toutes les clés.

2022.3.1.553

Résolu

TPRI-1077

GCSE-1135

Les messages d'exécution n'ont pas de retour à la ligne dans les résultats du workflow de l'interface utilisateur Server et ne peuvent pas être copiés complètement.

2022.3.1.553

Résolu

TPRI-2273

Les utilisateurs ne peuvent pas copier le texte des messages des Résultats de tâches.

2022.3.1.553

Résolu

Fixed

Minor Release Version 2022.3.1.573

ID

Description

Version

Issues Status

TCPE-648

GCSE-1295

Telemetry XML generated for unsaved workflow runs picks up the WorkflowFilePath of a previously run, saved workflow in customer managed Telemetry XML.

2022.3.1.573

Fixed

TGAL-8184

TCPE-740

Certain CredentialPasswordID values are causing MongoDB migration to schema 42 to fail and preventing successful upgrade to 2022.3+.

2022.3.1.573

Fixed

Fixed

Minor Release Version 2022.3.1.590

ID

Description

Version

Issue Status

TCPE-921

GCSE-1888

The POST /admin/v1/workflows endpoint is returning "An item with the same key has already been added." exception message for specific YXZP files.

2022.3.1.590

Fixed

TGAL-9760

GCSE-1830

Controller token and MongoDB password is intermittently becoming corrupt causing service issues as a result.

2022.3.1.590

Fixed

Connu

Version 2022.3.1.395 en disponibilité limitée

ID

Description

Version

Statut du problème

TGAL-6264

GCSE-339

Les utilisateurs ne sont pas affichés dans la liste déroulante Ajouter un utilisateur dans « Connexions aux données » lorsque le nom d'utilisateur est en caractères japonais uniquement.

2022.3.1.395

Connu

TGAL-6357

GCSE-412

L'ouverture du workflow à partir de la fenêtre de l'interface utilisateur Server entraîne une fermeture immédiate.

2022.3.1.395

Connu

TGAL-6394

GS-610

L'heure d'été modifie les intervalles de planification ultérieurs des tâches/workflows. Ils sont envoyés au début de l'heure lorsqu'ils sont planifiés pendant la fenêtre d'heure d'été comprise entre 2 h et 2 h 59. Pour plus d'informations sur le passage à l'heure d'été, consultez Planifications : prise en charge des fuseaux horaires.

2022.3.1.395

Connu

TGAL-6467

GCSE-464

L'heure d'été entraîne l'exécution des planifications à une heure incorrecte dans Server : les planifications avancent ou reculent d'une heure lors du passage à l'heure d'été. Pour plus d'informations sur le passage à l'heure d'été, consultez Planifications : prise en charge des fuseaux horaires.

2022.3.1.395

Connu

TGAL-6743

Selon votre configuration, les cartes de référence peuvent ne pas s'afficher dans les applications qui utilisent l'outil Entrée de carte. Consultez Les ensembles de cartes ne s'affichent pas dans l'interface utilisateur Server (article de la communauté) pour obtenir plus d'informations et pour savoir comment résoudre ce problème.

2022.3.1.395

Connu

TGAL-6745

GCSE-723

API Server V3 : la définition de « application/xml » ou de « text/xml » dans l'en-tête Accepter de la requête d'API renvoie une erreur ou ne renvoie pas les résultats au format XML.

2022.3.1.395

Connu

TGAL-6751

La page de connexion d'administrateur qui utilise SAML n'affiche pas l'écran de connexion SAML.

2022.3.1.395

Connu

TGAL-6756

Erreur renvoyée lorsqu'un administrateur utilise le bouton Remplacer les workflows pour remplacer un workflow chargé par Designer via l'API ou l'interface utilisateur Server.

2022.3.1.395

Connu

TGAL-6825

L'outil Préparation à la migration accepte plusieurs entrées à l'invite initiale et les lit dans l'ordre. Ainsi, « yy » peut approuver plusieurs commandes à l'insu de l'utilisateur.

2022.3.1.395

Connu

TGAL-6848

GCSE-946

Problèmes intermittents d'accès à Server pour les collections et d'autres pages après la mise à niveau vers 2022.1.

2022.3.1.395

Connu

TGAL-6990

GCSE-1027

La migration du schéma de la base de données échoue si l'environnement contient des connexions aux données de Server avec des mots de passe NULL ou vides.

2022.3.1.395

Connu

TMEE-713

GCSE-637

Les messages de sortie des applications analytiques exécutées sur Server ne s'affichent pas correctement.

2022.3.1.395

Connu

TMEE-772

GCSE-726

Lorsque vous modifiez une planification hebdomadaire dans la version 2022.1, celle-ci sélectionne tous les jours au lieu des jours que vous aviez précédemment sélectionnés. De plus, la case « Aucune date de fin » n'est pas préremplie.

2022.3.1.395

Connu

TMEE-845

GBETA-326

Améliorations de l'interface utilisateur/expérience utilisateur Server : la zone de texte de la nouvelle page de l'interface d'administration Server ne peut pas traiter la saisie de texte en japonais.

2022.3.1.395

Connu

TMEE-859

GBETA-342

Améliorations de l'interface utilisateur/expérience utilisateur Server : le message « Gestion des ressources » n'est pas traduit.

2022.3.1.395

Connu

TMEE-860

GBETA-343

Améliorations de l'interface utilisateur/expérience utilisateur Server : le texte d'extrait dans Catégories et  Créer une catégorie présente un problème de modification. Lorsque vous ajoutez un caractère au milieu du texte, le curseur revient automatiquement à la fin du texte.

2022.3.1.395

Connu

GSCE-1329

Erreur de l'interface utilisateur Server sur les systèmes d'exploitation japonais, chinois, français et italien : une erreur HTTP 500 s'affiche lorsque vous ouvrez l'interface utilisateur Server (par exemple, Erreur de serveur interne HTTP500 : impossible d'afficher cette page Web.) Pour résoudre ce problème, remplacez le paramètre de langue sur le système d'exploitation non anglais par Anglais et installez Alteryx Server. Après l'installation, vous pourrez rétablir la langue de votre choix.

2022.3.1.395

Connu

TCPE-618

GCSE-1210

Les workflows chargés via le point de terminaison d'API admin/v1/workflows ne se chargent pas dans Server après la mise à niveau vers 2021.4 - 2022.3, ce qui entraîne une erreur 404 dans l'onglet réseau et une erreur « Page introuvable » avec une redirection vers Mon espace de travail.

2022.3.1.395

Connu

Connu

Version majeure 2022.3.1.430

ID

Description

Version

Statut du problème

TGAL-7017

Les utilisateurs anonymes ne peuvent pas exécuter de workflows publics, même lorsque le paramètre « Les utilisateurs non enregistrés peuvent exécuter des workflows sur la page d'accueil » a été activé.

2022.3.1.430

Connu

TINST-503

TDES-4841

Après avoir installé le correctif de Server sur la version GA complète de Server, la version du correctif ne s'affiche pas dans la fenêtre À propos d'Alteryx dans Designer. Seule la version de Server s'affiche à la place.

2022.3.1.430

Connu

TPRI-1487

Lorsque les propriétaires d'un workflow ou d'une application exécutent manuellement un workflow dans Server immédiatement après avoir modifié la version publiée pour une version différente de la dernière (ou plus récente) version de ce workflow, Server exécute la version publiée lors de la première exécution manuelle au lieu de la dernière version. Les exécutions manuelles suivantes exécuteront la dernière version comme prévu.

2022.3.1.430

Connu

GSCE-1329

Erreur de l'interface utilisateur Server sur les systèmes d'exploitation japonais, chinois, français et italien : une erreur HTTP 500 s'affiche lorsque vous ouvrez l'interface utilisateur Server (par exemple, Erreur de serveur interne HTTP500 : impossible d'afficher cette page Web.) Pour résoudre ce problème, remplacez le paramètre de langue sur le système d'exploitation non anglais par Anglais et installez Alteryx Server. Après l'installation, vous pourrez rétablir la langue de votre choix.

2022.3.1.430

Connu

Mises à jour de sécurité

Connu

ID

Description

Version

Statut du problème

TGAL-2207

À communiquer.*

Toutes les versions 2022.x

Connu

TGAL-6764

À communiquer.*

Toutes les versions 2022.x

Connu

TGAL-6772

GCSE-822

À communiquer.*

Toutes les versions 2022.x

Connu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. À partir de 2022.3, les versions et mises à jour seront disponibles et cela se poursuivra jusqu'à ce que le correctif soit fourni pour toutes les versions prises en charge. Afin de garantir que toutes les versions que vous utilisez sont rapidement corrigées, nous vous recommandons d'effectuer régulièrement les mises à jour. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge concernées.

Résolu

Version mineure/correctif 3 2022.3.1.486

ID

Description

Version

Statut du problème

TGAL-2207

À communiquer.*

2022.3.1.486

Résolu

TVULC-1373

À communiquer.*

2022.3.1.486

Résolu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge qui sont concernées.

Résolu

Version mineure/correctif 5 2022.3.1.532

ID

Description

Version

Statut du problème

TGAL-8405

GCSE-1571

À communiquer.*

2022.3.1.532

Résolu

*Conformément aux meilleures pratiques en matière de sécurité et afin d'éviter toute manipulation potentielle par des personnes malveillantes, Alteryx ne divulgue pas les détails d'une vulnérabilité en cours tant que toutes les versions prises en charge n'ont pas fait l'objet d'une mise à jour corrective. Des informations supplémentaires seront disponibles une fois la vulnérabilité corrigée pour toutes les versions prises en charge qui sont concernées.

Résolu

Version mineure/correctif 6 2022.3.1.553

ID

Description

Version

Statut du problème

TCUD-423

Mise à jour de la bibliothèque Chromium Embedded Framework (CEF) pour traiter le vecteur potentiel de CVE-2023-4863 (libwebp).

2022.3.1.553

Résolu

TGAL-8498

GVM-584

À communiquer.*

2022.3.1.553

Résolu