Skip to main content

Modalità scura

Alteryx Designer ora consente di selezionare un'opzione Modalità scura come tema. La modalità scura aiuta l'usabilità generale di Designer: riduce l'affaticamento degli occhi, migliora il contrasto dei colori e offre più opzioni di personalizzazione per la tua esperienza di sviluppo.

Suggerimento

Some Windows dialogs aren't converted to the Dark Mode theme. They are controlled by your system/computer settings and you need to set them outside of Designer. Go to Change colors in Windows for information on how to update these settings.

Release beta

La funzionalità Modalità scura è ancora in versione beta al momento. Ciò significa che solo alcuni componenti dell'interfaccia di Designer sono stati convertiti in modalità scura. Inoltre, potresti notare alcuni componenti (incluse molte configurazioni degli strumenti) attualmente convertiti solo parzialmente in modalità scura. Nelle release future, continueremo a includere altri elementi per la modalità scura.

Attivazione della modalità scura

Il tema predefinito di Designer è la modalità chiara ma puoi attivare rapidamente la modalità scura tramite le impostazioni utente. Per attivare la modalità scura in Designer…

  1. Vai a Opzioni  >  Impostazioni utente  > Modifica impostazioni utente .

  2. Seleziona la scheda Personalizzazione .

  3. Seleziona Modalità scura . Seleziona Modalità chiara per tornare al tema predefinito di Designer.

Image that shows the Designer Theme User Settings with Light Mode selected.

Avanzamento dell'implementazione della modalità scura

La release iniziale della modalità scura è una release beta. Ciò significa che al momento la modalità scura è implementata solo per alcuni componenti dell'interfaccia di Designer. Continueremo a implementare le funzionalità nelle release future.

Area di disegno del flusso di lavoro

L'area di disegno del flusso di lavoro di Designer non è inclusa nella release beta della modalità scura. Tuttavia, come per le versioni precedenti, puoi continuare a personalizzare il colore di sfondo dell'area di disegno tramite la scheda Area di disegno in Impostazioni utente .

Tieni presente che le icone degli strumenti sono ottimizzate sia per la modalità chiara sia per quella scura. Se utilizzi la modalità scura con un'area di disegno con sfondo chiaro (o la modalità chiara con un'area di disegno scura), alcune icone degli strumenti potrebbero risultare invisibili quando le posizioni sull'area di disegno. Per evitare che ciò accada, personalizza il colore dell'area di disegno in modo che corrisponda al tema di Designer.

Intestazione app, menu App e Ricerca globale

Parte di Alteryx Designer in cui sono presenti la barra degli strumenti di Designer, dove puoi salvare, aprire, copiare, annullare operazioni e altro, i menu principali (File, Modifica, Opzioni, ecc.), il campo Ricerca globale e i risultati della ricerca. Anche le voci del menu principale e i sottomenu associati sono compatibili con la modalità scura.

dark-mode-sub-menus.png

Tavolozza degli strumenti

La tavolozza degli strumenti che contiene le varie categorie di strumenti di Designer e gli strumenti associati (incluse le relative icone) è compatibile con la modalità scura.

dark-mode-tool-palette.png

Finestra Flusso di lavoro - Configurazione

La finestra Flusso di lavoro - Configurazione , in cui puoi personalizzare Area di disegno, Flusso di lavoro, Runtime e molte altre impostazioni, è compatibile con la modalità scura. La scheda Visualizzazione XML non è compatibile con la modalità scura nella release beta.

dark-mode-workflow-config.png

Schede dell'area di disegno del flusso di lavoro

Le schede del flusso di lavoro (e i pulsanti e le icone associati) nella parte superiore dell'area di disegno del flusso di lavoro sono compatibili con la modalità scura.

L'area di disegno del flusso di lavoro di Designer non è inclusa nella release beta della modalità scura. Tuttavia, come per le versioni precedenti, puoi continuare a personalizzare il colore di sfondo dell'area di disegno tramite la scheda Area di disegno in Impostazioni utente .

Tieni presente che le icone degli strumenti sono ottimizzate sia per la modalità chiara sia per quella scura. Se utilizzi la modalità scura con un'area di disegno con sfondo chiaro (o la modalità chiara con un'area di disegno scura), alcune icone degli strumenti potrebbero risultare invisibili quando le posizioni sull'area di disegno. Per evitare che ciò accada, personalizza il colore dell'area di disegno in modo che corrisponda al tema di Designer.

dark-mode-workflow-tabs.png

Finestra Risultati

La finestra Risultati , in cui puoi visualizzare i dati che attraversano il flusso di lavoro e interagire con gli stessi, è compatibile con la modalità scura.

dark-mode-results-window.png

Impostazioni utente

La finestra Impostazioni utente e le schede associate sono compatibili con la modalità scura, ad eccezione della barra del titolo della finestra.

dark-mode-user-settings.png

Finestra Trova Sostituisci

La finestra Trova Sostituisci è compatibile con la modalità scura.

dark-mode-find-replace.png

Finestra Esporta flusso di lavoro

La finestra Esporta flusso di lavoro ( Opzioni > Esporta flusso di lavoro ) è ora compatibile con la modalità scura.

export-workflow-dark-mode.png

Interfaccia Designer

La finestra Interfaccia di Designer è parzialmente convertita in modalità scura. I bordi e i pulsanti della finestra vengono convertiti, mentre il contenuto della finestra è ancora in modalità luce.

interface-designer-dark-mode.png

Configura la tavolozza degli strumenti

La finestra Configura tavolozza strumenti (accessibile tramite l'icona a forma di ingranaggio nella tavolozza degli strumenti) è compatibile con la modalità scura.

configure-tool-palette-dark-mode.png

Messaggi di salvataggio su Server

L'esperienza di salvataggio su Server ( File > Salva come > Alteryx Server > Server della mia azienda ) è compatibile con la modalità scura. Inoltre, l'esperienza di Aggiunta di un nuovo Server è compatibile con la modalità oscura.

server-save-as.png

Finestre di dialogo Apri e Salva di Alteryx Analytics Cloud

Le esperienze Salva in Alteryx Analytics Cloud Platform ( File > Salva con nome > Alteryx Analytics Cloud ) e Apri da AACP ( File > Apri flusso di lavoro > Alteryx Analytics Cloud ) sono compatibili con la Modalità scura.

save-to-aacp.png

Finestra Panoramica

La finestra Panoramica ( Visualizza > Panoramica ) è compatibile con la modalità scura.

overview-dark-mode.png

Finestra Dipendenze - Flusso di lavoro

La finestra Dipendenze flusso di lavoro  ( Opzioni > Opzioni avanzate > Dipendenze flusso di lavoro ) è compatibile con la modalità scura.

workflow-dependencies-dark-mode.png

Confronto tra flussi di lavoro

La finestra Confronta flussi di lavoro  ( Opzioni > Opzioni avanzate > Confronta flussi di lavoro ) è compatibile con la modalità scura.

compare-workflows.png

Messaggi di Impostazioni utente

Le finestre di dialogo all'interno della finestra Impostazioni utente  ( Opzioni > Impostazioni utente > Modifica impostazioni utente ) sono compatibili con la modalità scura.

Messaggio a comparsa dopo l'esecuzione del flusso di lavoro

Il messaggio di conferma visualizzato al termine dell'esecuzione del flusso di lavoro è compatibile con la modalità scura.

finished-running-workflow-dark-mode.png

Finestra Informazioni

La finestra Informazioni accessibile tramite Aiuto > Informazioni è compatibile con la Modalità scura.

Configurazioni degli strumenti

Abbiamo iniziato ad aggiornare diversi componenti di configurazione degli strumenti per renderli compatibili con la Modalità scura. Ciò include gli strumenti con funzionalità di selezione e ID record.