Skip to main content

Macros

Una macro es un flujo de trabajo o un grupo de herramientas integradas en una sola herramienta que puedes insertar en otro flujo de trabajo. Crea una macro para guardar un proceso analítico que realices reiteradamente. Utiliza la macro dentro de un flujo de trabajo sin tener que volver a crear el proceso analítico cada vez.

Guarda una macro como un archivo .yxmc para usarlo en Designer o compartirlo con otros usuarios a través de la Alteryx Community Gallery  o el Server de tu empresa.

Tipos de macros

  • Macro estándar: esta macro está diseñada para empaquetar un proceso en un flujo de trabajo como una herramienta que se puede insertar en un flujo de trabajo.

  • Macro de lotes : esta macro se ejecuta varias veces en un flujo de trabajo y crea una salida después de cada ejecución. La macro se ejecuta una vez para cada registro o grupo seleccionado de registros en los datos. La macro requiere una herramienta Parámetro de control como entrada.

  • Macro iterativa : esta macro se ejecuta en el flujo de trabajo la cantidad de veces establecida en la configuración o de manera continua hasta que se cumple una condición.

  • Macro del optimizador de ubicación : esta macro es una macro iterativa que se puede utilizar en el análisis de red para identificar una o varias ubicaciones óptimas.

Crear una macro

Una macro consiste en un flujo de trabajo y una interfaz de usuario creados mediante herramientas de Interfaz. Consulta Diseñador de interfaz y Ventana de Diseñador de interfaz para obtener más información. Como alternativa, se puede crear una interfaz de usuario personalizada con la herramienta HTML: biblioteca de la GUI .

Para crear una macro:

Si estás utilizando un flujo de trabajo existente, selecciona la parte del flujo de trabajo que deseas guardar como macro y, a continuación, cópiala y pégala en una nueva pestaña de flujo de trabajo.

  1. Crea un nuevo flujo de trabajo o abre uno existente.

  2. Agregar una entrada de macro:

    • Si el flujo de trabajo no contiene una entrada, agrega una herramienta Entrada de macro.

    • Si el flujo de trabajo contiene una herramienta de entrada (como una herramienta Datos de entrada o Entrada de texto), haz clic con el botón derecho en la herramienta y selecciona Convertir en entrada de macro .

  3. Configura la herramienta Entrada de macro .

  4. Agrega y configura una herramienta Salida de macro .

De forma predeterminada, el tipo de flujo de trabajo cambia a Macro estándar cuando se agrega una herramienta Entrada de macro a un flujo de trabajo. El tipo de macro predeterminado es Macro de lotes cuando se agrega una herramienta Parámetro de control al flujo de trabajo. Para crear una macro iterativa, establece el tipo de macro en Iterativo.

Para establecer el tipo de macro:

  1. Selecciona el lienzo y, a continuación, la pestaña Flujo de trabajo en la ventana Configuración del flujo de trabajo.

  2. En Tipo , junto a Macro , selecciona un tipo de macro.

Convertir en macro

Además de crear una macro desde cero, tienes la opción de convertir un flujo de trabajo existente (o una parte del flujo de trabajo) en una macro. Antes de convertirlo en una macro, revisa estos requisitos y limitaciones:

  • Primero debes ejecutar el flujo de trabajo y explorar todos los lugares donde haya datos disponibles.

  • Debes guardar el flujo de trabajo antes de convertirlo en una macro.

  • Las herramientas que selecciones deben estar en una ruta continua y conectadas entre sí (Comentarios, Cuadros del explorador y Contenedores de herramientas están exentos de esto).

  • Las herramientas que selecciones no deben contener errores.

  • Las herramientas que selecciones no deben contener ninguna herramienta En-BD.

  • Las herramientas que selecciones no deben estar conectadas a ninguna herramienta de acción.

  • Las herramientas que selecciones no deben contener ninguna herramienta Python.

  • Las herramientas que selecciones no deben incluir datos que contengan tipos de datos espaciales, Blob o de informe.

Para convertir en una macro:

  1. Selecciona al menos una herramienta en un flujo de trabajo. Haz clic y arrastra las herramientas en el lienzo del flujo de trabajo para seleccionar varias herramientas.

  2. Haz clic con el botón derecho en una de las herramientas seleccionadas para abrir el menú de herramientas.

  3. Selecciona Convertir en macro en el menú desplegable para abrir la ventana Crear macro .

  4. En la ventana Crear macro...

    • Ingresa un nombre de archivo para la macro.

    • Elige una ubicación para guardar la macro.

    • Elige un ícono para la macro.

  5. Selecciona Aceptar para convertir el flujo de trabajo o una parte de este en una macro. Selecciona Cancelar para abandonar este proceso.

  6. El archivo de macro recién creado se abre en una nueva pestaña de Alteryx Designer, mientras que en el flujo de trabajo original se muestra que las herramientas seleccionadas se convirtieron en una macro.

Guardar la macro

Guarda una macro para utilizarla y compartirla en el futuro. Guarda macros con un nombre único en una ubicación específica. En Alteryx Designer, puedes crear un repositorio de macros asignado a una ubicación en la computadora o la red para guardar macros fácilmente y utilizarlas en un flujo de trabajo.

Para guardar una macro:

  1. Selecciona Archivo > Guardar como .

  2. Busca una carpeta en la computadora o red donde guardas las macros.

  3. Ingresa un nombre único para la macro y selecciona Guardar .

Para compartir los flujos de trabajo que utilizan macros personalizadas, exporta el flujo de trabajo para asegurarte de que todas las dependencias del flujo de trabajo, incluida la macro, se guardan con el flujo de trabajo. El flujo de trabajo debe incluir una ruta relativa a la macro. Visita Administración de flujos de trabajo y Dependencias de flujo de trabajo para obtener información adicional.

Actualizar una macro ausente

Históricamente, cuando importabas o abrías un flujo de trabajo con una macro existente, si dicha macro no estaba presente en el flujo de trabajo (debido a un cambio de nombre o de ubicación, un empaquetado incorrecto, etc.), esta mostraba un ícono de signo de interrogación negro ( UnknownTool_71x71.png) en el lienzo del flujo de trabajo.

Luego, tenías que pasar por un molesto proceso en el que debías volver a agregar manualmente la macro y reconfigurar el flujo de trabajo para todo funcionara bien.

Ahora tienes la opción de identificar las ubicaciones de las macros correctas antes de que se abra el flujo de trabajo para evitar por completo el error de macros ausentes.

Sugerencia

Consulta Actualizar macros ausentes para obtener más detalles y casos de uso.

Actualizar macros ausentes en un flujo de trabajo

Cuando intentas abrir un flujo de trabajo (archivo YXMD, YXMC o YXWZ) con una macro ausente, aparece la ventana emergente Actualizar macros ausentes en Designer para avisarte del problema.

update-missing-macros-1.png

La ventana Actualizar macros ausentes comunica que el flujo de trabajo hace referencia al menos a una macro ausente o inaccesible. El mensaje proporciona detalles sobre estas macros. Ten en cuenta en que la ventana se muestra un máximo de tres macros ausentes (aunque podrían ser más).

Tienes 2 opciones:

  • Actualizar : selecciona Actualizar para efectuar la actualización de las rutas de archivos de las macros ausentes. Esto abre el flujo de trabajo original donde puedes realizar cambios. Sin embargo, Designer no guarda automáticamente el flujo de trabajo. Después de realizar las actualizaciones, puedes ir a Archivo > Guardar como , o bien presionar el atajo de teclado Ctrl+S (Guardar) para guardar una nueva versión del flujo de trabajo o reescribir el flujo de trabajo original, si es necesario. Ten en cuenta que necesitas acceder a los archivos de macros ausentes para poder navegar a sus ubicaciones. Si recibiste el flujo de trabajo de alguien que no incluyó las macros, es probable que tengas que comunicarte con esa persona y pedirle que te proporcione los archivos. Si elegiste no actualizar las rutas del archivo, el flujo de trabajo se abrirá con los íconos de las herramientas ausentes.

  • Cerrar (no actualizar): selecciona Cerrar . Esto abre el flujo de trabajo original sin las macros actualizadas. Las macros tendrán el ícono de la herramienta ausente ( UnknownTool_71x71.png) y, si deseas corregir estas macros ausentes más adelante, deberás agregarlas y reconfigurarlas manualmente.

Actualizar una macro

Para actualizar las macros, sigue estos pasos:

  1. En la ventana Actualizar macros ausentes, selecciona Actualizar .

  2. Esto abre la ventana Actualizar macros ausentes , similar a la experiencia de Dependencias del flujo de trabajo. Aquí, puedes editar la ruta de archivo de cada macro ausente y actualizar su ubicación. Ten en cuenta que no puedes editar dependencias que no sean de macro a través de esta ventana.

    update-missing-macros-2.png
  3. Selecciona el ícono de edición de lápiz asociado a la macro ausente. Esto abre el Explorador de archivos, en donde puedes buscar la ubicación correcta de la macro. Selecciona la macro y, luego, Designer actualiza la ruta de macro y cambia su color a verde.

  4. Haz esto para cualquier macro adicional y selecciona Aceptar cuando termines. También puedes seleccionar Cancelar en este punto, lo que abre el flujo de trabajo original con rutas de archivo rotas (íconos de signo de interrogación de herramienta ausente).

  5. Si actualizaste las rutas de macros y seleccionaste Aceptar en el paso anterior, tu flujo de trabajo se abrirá con las macros actualizadas y sin íconos de herramienta ausente.

Si la macro es la misma y la cantidad de conexiones de entrada y salida de las rutas de macro nuevas coincide con la cantidad en el flujo de trabajo, Designer intenta realizar las conexiones automáticamente. Sin embargo, en algunos casos (por ejemplo, si conectas una macro diferente con la misma cantidad de entradas y salidas), Designer no puede realizar las conexiones. Si este es el caso, debes revisarlas y configurarlas manualmente. 

Importante

Cuando utilizas la característica Actualizar macros ausentes, Designer actualiza el flujo de trabajo original, aunque el flujo de trabajo no se guarda automáticamente. Puedes usar Archivo > Guardar como o el atajo de teclado Ctrl+S (Guardar) para guardar una nueva versión del flujo de trabajo o sobrescribir el flujo de trabajo original si es necesario. Si cierras el flujo de trabajo sin guardar, se perderán las actualizaciones.

Cerrar (no actualizar)

Si deseas abrir el flujo de trabajo y no actualizar las macros, sigue estos pasos:

  1. Cuando intentas abrir un flujo de trabajo con macros ausentes, aparece la ventana Actualizar macros ausentes .

  2. Para abrir el flujo de trabajo sin actualizar las ubicaciones de macros, selecciona Cerrar .

  3. Se abrirá tu flujo de trabajo y las macros ausentes mostrarán el ícono de herramienta ausente ( UnknownTool_71x71.png). Si deseas actualizar las macros ausentes, debes agregar las macros y volver a configurarlas manualmente.

Crear repositorio de macros

En Alteryx Designer, puedes asignar la ubicación en la que guardaste las macros y crear un repositorio de macros para guardar macros y utilizarlas fácilmente en un flujo de trabajo. Cualquier archivo .yxmc de macro que se encuentre en la ubicación seleccionada se muestra en la categoría de herramientas de la Paleta de herramientas.

Para crear un repositorio de macros:

  1. Ve a Opciones > Configuración de usuario > Editar configuración de usuario > Macros .

  2. Selecciona el botón “+”.

  3. En Nombre de la categoría , escribe un nombre. El nombre predeterminado es Macros.

  4. Selecciona el botón “...” para navegar a la ubicación en la que guardas las macros en la computadora o en una red.

Las subcarpetas de una ruta de búsqueda no se pueden agregar individualmente si su carpeta principal ya existe en el repositorio de macros.

Para establecer una ubicación de repositorio predeterminada:

  1. Selecciona la ruta de búsqueda del repositorio en la lista.

  2. Selecciona Establecer como predeterminado . Aparece un asterisco ( * ) junto al repositorio predeterminado.

Utilizar una macro en un flujo de trabajo

Para utilizar una macro guardada en el repositorio de macros, busca la macro en la Paleta de herramientas o usa Buscar.

Para utilizar una macro que no esté en la paleta de herramientas, haz clic con el botón derecho en el lienzo del flujo de trabajo y selecciona Insertar > Macro . Puedes seleccionar cualquier macro que esté abierta actualmente en Lienzo de esta lista o puedes buscar la ubicación de otro archivo *.yxmc de macro.

Para utilizar una versión de macro específica en el flujo de trabajo, haz clic con el botón derecho en la macro y, luego, selecciona la versión que deseas ejecutar. Todas las versiones de macros deben estar almacenadas en el mismo directorio. Puedes configurar esta ubicación en Configuración del usuario .

Para diferenciar una macro de una herramienta dentro de un flujo de trabajo, selecciona la opción Mostrar indicadores de macro en las herramientas para ver el ícono + en Configuración del usuario > Lienzo . Consulta Configuración del usuario para obtener más información.

Para ver el flujo de trabajo de una macro, haz clic con el botón derecho en la macro en un flujo de trabajo y selecciona Abrir macro . Una macro en un flujo de trabajo se actualiza de manera automática cuando se guardan los cambios que se realizaron en esa macro.

Para compartir los flujos de trabajo que utilizan macros personalizadas, exporta el flujo de trabajo para asegurarte de que todas las dependencias del flujo de trabajo, incluida la macro, se guardan con el flujo de trabajo. El flujo de trabajo debe incluir una ruta relativa a la macro. Visita Administración de flujos de trabajo y Dependencias de flujo de trabajo para obtener información adicional.

Plantillas de macros

Si descubres que reutilizas muchos componentes y configuraciones en tus macros, es recomendable que crees plantillas para ahorrar tiempo. Ve a Plantillas para aprender a guardar tu macro como plantilla.

Macros de muestra

En Alteryx Designer, se incluyen macros para ayudarte a aprender a usarlas y crearlas. Para acceder a las macros:

  • En archivos de programa en la computadora, ve a  \Archivos de programa\Alteryx\bin\RuntimeData\Macros .

  • En Alteryx Designer:

    • Dirígete a Ayuda > Flujos de trabajo de muestra > Usar herramientas de scripting y automatización > Crear una macro .

    • Algunas herramientas de la Paleta de herramientas son macros. Por ejemplo, la herramienta Crear muestras y la herramienta Limpieza de datos . Haz clic con el botón derecho en una herramienta y selecciona Abrir macro , si está disponible, para ver el flujo de trabajo de la macro.

  • Accede a las apps publicadas en Alteryx Community Gallery .