Skip to main content

DCM - Designer

データ接続マネージャー(DCM)は、データベースとクラウドの相互運用可能な接続(データソースにリンクされた資格情報)のための集約ストレージで、Alteryx製品間のワークフロー接続管理とコラボレーションを促進します。DCMを使用して、ツールとワークフロー間で接続と資格情報を入力および使用します。

DCM を使用すると、データソース、認証情報、接続を管理できます。

  • データソースオブジェクトは、データベース、クラウドサービスなどを表します。

  • 資格情報オブジェクトは、ユーザー名とパスワードの組み合わせと OAuthトークンを表します。

  • 接続オブジェクトは、データソースを資格情報に結合し、ワークフローの1つ以上のツールで使用されます。

詳細については、 サポートされているコネクタとツール を参照してください。

データ接続マネージャーの設定

管理者設定

DCMモード の変更と、 SDKのアクセスモード の選択のオプションがあります。

資格情報の処理と保存について設定する際に、 DCMモード から次のオプションを使用できます。

  • DCM Optional : 接続(パスワードを含む)は既定でワークフローに保存されます。DCMに接続を保存して管理することを選択できます。

  • DCM as Default : 接続(パスワードを含む)は既定でDCMに保存され、管理されます。ワークフロー内に保存を選択できます。

  • DCM Only  : ワークフローに接続を設定することはできません。DCMに保存された接続を選択することのみ可能です。パスワードが埋め込まれたワークフローは実行できます。

  • DCM Enforced : パスワードが埋め込まれたワークフローは動作しません。

SDK (Gallery)ツール のサポートを目的として、次の管理オプションが用意されています。

  • [拒否] – SDKツールはサポートされておらず、資格情報UIに [SDKツールの資格情報を許可] チェックボックスは表示されません。

  • [許可] - SDKツールがサポートされており、UIには [SDKツールの資格情報を許可] チェックボックスと各資格情報を手動で選択するためのオプションが表示されます。

  • [すべて許可] – SDKツールがサポートされており、資格情報UIに [SDKツールの資格情報を許可] チェックボックスは表示されません。

ユーザー設定

ユーザーは、[ オプション ] > [ ユーザー設定 ] > [ ユーザー設定の編集 ] > [ DCM ] で [ DCMモード ] を変更し、[ SDKのアクセスモード ] を選択できます。

資格情報の処理と保存について設定する際に、 DCMモード から次のオプションを使用できます。

  • DCM Optional : 接続(パスワードを含む)は既定でワークフローに保存されます。DCMに接続を保存して管理することを選択できます。

  • DCM as Default : 接続(パスワードを含む)は既定でDCMに保存され、管理されます。ワークフロー内に保存を選択できます。

  • DCM Only  : ワークフローに接続を設定することはできません。DCMに保存された接続を選択することのみ可能です。パスワードが埋め込まれたワークフローは実行できます。

  • DCM Enforced : パスワードが埋め込まれたワークフローは動作しません。

SDKのアクセスモードには、次のオプションを使用できます。

  • [拒否] – SDKツールはサポートされておらず、資格情報UIに [SDKツールの資格情報を許可] チェックボックスは表示されません。

  • [許可] - SDKツールがサポートされており、UIには [SDKツールの資格情報を許可] チェックボックスと各資格情報を手動で選択するためのオプションが表示されます。

  • [すべて許可] – SDKツールがサポートされており、資格情報UIに [SDKツールの資格情報を許可] チェックボックスは表示されません。

接続マネージャー

接続マネージャーでデータソースを認証するデータソースと資格情報を制御できます。また、Designer DesktopをAlteryx Analytics Cloud Platform (AACP)にリンクすることもできます。これらの機能にアクセスするには、[ ファイル ] > [ 接続を管理 ] を開きます。

データソースを管理

接続マネージャーでデータソースを追加するには、次の手順に従います。

  1. データソース に移動します。

  2. [ +新規 ] を選択します。

  3. [テクノロジー] を選択します。

  4. 接続するテクノロジーに必要な情報を入力します。必要に応じて [接続テスト] ができます。

  5. [保存] を選択します。

データソースと資格情報を組み合わせて接続を作成できます。 [データソース] > [接続] セクションで、接続用に関連付けられている資格情報のリストを確認したり、新しい資格情報を関連付けたりできます。

  1. [ + 資格情報の接続 ] を選択します。

  2. 認証方法 を選択します。

  3. 資格情報を入力します。

  4. オプションで、 [SDK への接続を許可] を選択できます。

  5. 接続テスト または 作成とリンク を選択して終了します。

資格情報を管理

接続マネージャーで資格情報を追加するには、 [資格情報] セクションに移動します。以下のオプションを使用できます。

  • 資格情報の追加 : + 新規 を選択します。 [資格情報名] を入力します。 方法 を選択します。選択した方法に必要な情報(クライアントID、シークレットキー、ユーザー名、パスワードなど)を入力します。 [保存] を選択します。

  • 資格情報の表示 : リストから、表示する資格情報を選択します。

  • 資格情報の編集 : 接続マネージャーで資格情報を編集するには、リストから編集する資格情報を選択します。 [編集] を選択します。 [保存] を選択します。

  • 資格情報の削除: 接続マネージャーで削除する資格情報を選択します。 ごみ箱 アイコンを選択します。 [削除] を選択します。

保存されたデータ接続に接続するには、ツールをDesignerワークフローキャンバスに配置し、 [接続を設定] を選択します。[接続マネージャー] ウィンドウで、接続を選択し、 [接続] ボタンを選択してリンクされた資格情報を使用します。

Alteryx リンクを管理

Alteryxリンクを使用すると、Designer DesktopをAlteryx Analytics Cloud Platform (AACP)ワークスペースにリンクして、Desktopで構築したワークフローをクラウドに保存して実行できます。これらの機能の詳細については、 Cloud Execution for Desktop を参照してください。

Alteryxリンクの作成

Designer DesktopとAACPをリンクするには、次の手順に従ってください。

  1. Designer Desktopで、[ ファイル ] > [ 接続を管理 ] の順に選択し、DCMを開きます。

  2. 左側のメニューで Alteryxリンクを選択し、 [+新規] ボタンを選択します。

  3. Analytics Cloudが既定の テクノロジー として選択されています。必要な情報を入力します。

    • データソース名 : このリンクの表示名(ラベル)です。表示名は [名前を付けて保存] および [開く] メニューに表示され、接続先の確認に役立ちます。

    • ベースURL : Alteryx Analytics Cloudへのアクセスに使用するURL (例、https://company.alteryxcloud.com/)です。この情報については、AACP管理者にお問い合わせください。

    • ワークスペース名 : Analytics Cloudワークスペースの名前で、URL (Base URLの後)に表示されます。たとえば、Analytics CloudにアクセスするURLがhttps://company.alteryxcloud.com/?workspace=my-workspaceだとします。この場合、 [ワークスペース名] のフィールドにはmy-workspaceと入力します。この情報については、AACP管理者にお問い合わせください。

  4. 保存 を選択します。次に、資格情報をリンクする必要があります。

  5. まず [+ 接続資格情報] を選択します。

  6. Cloud Execution for Desktopでは、OpenID Connect (OIDC)を使った認証方法に対応しています。このオプションは [認証方法] ドロップダウンで事前選択されています。

  7. [OIDCトークン] セクションで、 [資格情報] ドロップダウンを使用して既存の資格情報を選択するか、 [新しい資格情報の作成] を選択します。

  8. 新しい資格情報を作成する必要がある場合は、 [資格情報名] を入力します。このラベルは、今後この資格情報を識別するのに役立ちます。

  9. 既定ではDCMが 保管庫 に設定されます。

  10. 必要に応じて、 [接続テスト] [作成とリンク] を選択して終了します。

    重要

    接続に失敗した場合は、AACP接続のベースURLとワークスペース名が正しいことを確認してください。

Designer DesktopをAACPワークスペースに正常に接続すると、[ ファイル ] > [ 接続を管理 ] > [ Alteryxリンク ] から接続の詳細が確認できます。名前列でデータソース名を選択して、接続の詳細の表示、接続の編集や、接続の削除ができます。

既存のAlteryxリンクの表示、編集、同期

既存のAlteryxリンクを表示するには、Designerで次の手順に従います。

  1. [ ファイル ] > [ 接続を管理 ] > [ Alteryxリンク ]の順に移動します。

  2. 既存のリンクの名前を選択して開き、詳細を表示します。

  3. リンクを更新するには、[編集] ボタンを選択します。必要な編集を行い、 [保存] を選択するか、 [キャンセル] を選択して前の画面に戻ります。

  4. [接続] セクションで [同期] を選択して、Designer DesktopとAACP間の資格情報を同期することもできます。

Alteryxリンクの削除

既存のAlteryxリンクを削除するには、Designer Desktopで次の手順に従います。

  1. [ ファイル ] > [ 接続を管理 ] > [ Alteryxリンク ]の順に移動します。

  2. 削除するAlteryxリンクに関連付けられている ごみ箱 アイコンを選択します。これにより [削除] ダイアログが表示されます。 [削除] *ボタンを選択して削除を確定するか、[キャンセル] を選択して前の画面に戻ります。

*削除は恒久的です。この操作は元に戻せません。

資格情報の同期

DCMを使用すると、Alteryx製品スイート間で資格情報を同期できます。

Designer と Server 間で資格情報を同期する

  1. [ファイル] > [接続を管理] を順に選択して、接続マネージャーを開きます。

  2. [同期] を選択します。

  3. 新しいServer接続の場合:

    1. [ +新規 ] を選択します。

    2. Server インスタンスURL を入力し、 [接続] を選択します。

    3. [Eメール] [パスワード] を入力し、 [サインイン] を選択します。

  4. 同期するServerインスタンスを選択します。

  5. [同期] を選択します。

  6. [完了]  を選択します。

同期する資格情報を追加する

  1. [ファイル] > [接続を管理] を順に選択して、接続マネージャーを開きます。

  2. [資格情報] に移動します。

  3. [+ 資格情報の追加] を選択します。

  4. 資格情報の詳細を入力します。

  5. [保存] を選択します。

  6. DesignerとServer間で資格情報を同期する 」セクションの手順2から5を実行します。

同期する資格情報を編集する

  1. [ファイル] > [接続を管理] を順に選択して、接続マネージャーを開きます。

  2. [資格情報] に移動します。

  3. 更新する資格情報を選択します。

  4. [編集] を選択します。

  5. 資格情報の詳細を更新します。

  6. [保存] を選択します。

  7. DesignerとServer間で資格情報を同期する 」セクションの手順2から5を実行します。

同期する資格情報を削除する

  1. [ファイル] > [接続を管理] を順に選択して、接続マネージャーを開きます。

  2. [資格情報] に移動します。

  3. 削除する資格情報を選択します。

  4. ごみ箱 アイコンを選択します。

  5. [ 削除 ]を選択して確定します。

  6. DesignerとServer間で資格情報を同期する 」セクションの手順2から5を実行します。

ワークフローを DCM資格情報と同期する

  1. ワークフロー 」の記事に従って、ワークフローのアップロードまたはダウンロードを実行します。

  2. DesignerとServer間で資格情報を同期する 」セクションの手順2から5を実行します。

バックアップと復元

DCMストレージをバックアップし、バックアップファイルから復元できます。

重要

この機能は、Designerライセンスに基づいています。同じ組織内で購入された2つの異なるライセンス間でのリストアは動作しますが、その場合、同じ組織内の2つの異なるライセンスでバックアップとリストアを実行するには、異なるDesignerのインスタンスである必要があります。バックアップとリストアは、Designerの1つのインスタンス内の試用版または複数のアクティブなライセンスでは機能しません。

バックアップ

  1. [ファイル] > [接続を管理] を順に選択して、接続マネージャーを開きます。

  2. [ バックアップ ] を選択します。

  3. バックアップファイルのパスワードを入力します。

  4. [バックアップ] を選択します。

  5. バックアップファイルの場所と、オプションで名前を選択します。

  6. [保存] を選択します。

復元

  1. [ファイル] > [接続を管理] を順に選択して、接続マネージャーを開きます。

  2. [復元] を選択します。

  3. バックアップファイルのパスワードを入力します。

  4. [復元] を選択します。

ServerとDesigner間でのDCMの同期

次の3つの同期設定を使用できます。

  • 同期なし - DCM接続の同期は両方向でブロックされます。

  • Designerへの一方向 - DCM接続の同期は、ServerからDesignerへのみ有効です。

  • 完全同期 - DCM接続の同期は、ServerからDesigner、DesignerからServerの両方向で有効です。

ServerとDesigner間でDCMを同期するには、次の手順に従います。

  1. [ Designer ] > [ ファイル ] > [ 接続を管理 ]を順に選択して、 [接続マネージャー] を開きます。次に、メニューで [ 同期 ] を選択します。

  2. リストから同期するServerを選択します。

  3. [同期] を選択します。

ServerとDesignerの間でDCMを同期すると、所有している資格情報とアクセス権を持つすべてのデータソースが表示され、接続マネージャーで使用できるようになります。

サポートされているコネクターとツール

DCMでサポートされているツールとコネクタのリストについては、「 DCMでサポートされているコネクタとツール 」を参照してください。