Skip to main content

drop box input Dropbox Input Tool

Use the Dropbox Input tool to read the data stored in your Dropbox workspace.

Tool Configuration

To install the Dropbox Input tool

  1. Download the tool from Alteryx Community.

  2. In Designer,  go to File > Open Workflow.

  3. Open the  Dropbox Input YXI file. 

  4. Select Install.

Note

To install the Dropbox Input tool for all users, open Designer with administrator credentials.

To add the Dropbox Input tool into the workflow

  1. Go to the Connectors tab, and select Dropbox Input. Drag the tool to the canvas. Note: If you don't have the Connectors tab in your tool palette, you can add it via the Plus icon at the end of the tool palette.

  2. Select the Dropbox Input tool to open the configuration panel.

  3. Choose an authentication method:

    1. Sign in via Internet Browser – A popup window appears to grant access to Dropbox.

    2. Get files from URL – You Provide URL of your files.

    3. Access Token – Authenticate with an access token generated to call for your account without going through the authorization flow. With this authentication method, you also decide whether to log in to a Personal or Business account.

    4. You can also choose to Connect through your own Dropbox application with the client ID and secret.

  4. Select Connect.

  5. Select Site andDocument Library.

  6. To select your file, browse the folders  or use Search to find your Site, Library, and File. Note that File Path for the selected file is modified according to the selection made.

  7. In the Options tab, you can check File Format, Max Field Length, Field Delimiter  (Comma by default). Also, you can check  Quote Characters (None by default), Attach Metadata, and page coding. For unsupported file format (other than CSV, XLSX, and YXDB) you will get an error message.

  8. The tree view is populated according to the site selected. Based on the selected file format there are multiple options present in the Options tab.

  9. For the XLSX file format, in the Data tab, you can select Data range options: All Sheets, Sheet Names, Sheet Numbers along with a particular range, Named Range, or to Import only the list of sheet names.

    TIP

    You can choose also a folder with all subfolders (a file format is set manually), or you can define the file path using wildcards (for example, “.../*2020.xlsx” for all .xlsx files ending with '2020').

  10. Select Run to execute the workflow.