Skip to main content

Macros

Um macro é um fluxo de trabalho ou um grupo de ferramentas integrado em uma única ferramenta que você pode ser inserir em outro fluxo de trabalho. Crie uma macro para salvar e automatizar um processo analítico que você executa repetidamente. Use a macro em um fluxo de trabalho sem ter que recriar o processo de análise de dados todas as vezes.

Salve uma macro como um arquivo .yxmc para uso no Designer ou compartilhe-a com outros usuários através da Galeria da Comunidade Alteryx ou do Server da sua empresa.

Tipos de macros

  • Macro padrão: esta macro foi projetada para empacotar um processo em um fluxo de trabalho como uma ferramenta que pode ser inserida em outro fluxo de trabalho.

  • Macro de lote : esta macro é executada várias vezes em um fluxo de trabalho e cria uma saída após cada execução. A macro é executada uma vez para cada registro ou grupo selecionado de registros nos dados. A macro requer uma ferramenta Parâmetro de Controle como entrada.

  • Macro iterativa : esta macro é executada no fluxo de trabalho quantas vezes estiver definido na configuração ou continuamente até que uma condição seja atendida.

  • Macro otimizadora de localização : esta é uma macro iterativa que pode ser usada em análises de rede para identificar uma ou mais localizações ideais.

Criar uma macro

Uma macro consiste em um fluxo de trabalho e uma interface de usuário criada usando ferramentas de interface. Acesse Designer de interface e Janela do designer de interface para obter mais informações. Alternativamente, uma interface de usuário personalizada pode ser criada usando a ferramenta HTML - Biblioteca GUI .

Para criar uma macro...

Se você estiver usando um fluxo de trabalho existente, selecione a parte do fluxo que deseja salvar como uma macro e, em seguida, copie-a e cole-a em uma nova guia.

  1. Crie um novo fluxo de trabalho ou abra um existente.

  2. Adicione uma entrada de macro:

    • Se o fluxo de trabalho não contiver uma entrada, adicione uma ferramenta Entrada de Macro.

    • Se o fluxo de trabalho contiver uma ferramenta de entrada (como Dados de Entrada ou Entrada de Texto), clique com o botão direito do mouse na ferramenta e selecione Converter para Entrada de Macro .

  3. Configure a ferramenta Entrada de Macro .

  4. Adicione e configure uma ferramenta Saída de Macro .

Por padrão, o tipo do fluxo de trabalho muda para "Macro padrão" quando uma ferramenta Entrada de Macro é adicionada a ele. A macro assume o tipo "Macro de lote" quando uma ferramenta Parâmetro de Controle é adicionada ao fluxo. Para criar uma macro iterativa, defina o tipo de macro como tal.

Para definir o tipo de macro:

  1. Clique sobre a tela e selecione a guia Fluxo de trabalho na janela de configuração do fluxo.

  2. Em Tipo , ao lado de Macro , selecione um tipo de macro.

Converter para macro

Além de criar uma macro do zero, você tem a opção de converter um fluxo de trabalho existente (ou uma parte dele) para uma macro. Antes de converter para uma macro, verifique estes requisitos e limitações:

  • Você precisa executar o fluxo de trabalho primeiro e navegar de qualquer lugar em que os dados estejam disponíveis.

  • Você precisa salvar o fluxo de trabalho antes de convertê-lo para uma macro.

  • As ferramentas selecionadas devem estar em um caminho contínuo e conectadas entre si (as ferramentas Comentário, Caixas de Navegação e Contêiner de Ferramentas estão isentas dessa condição).

  • As ferramentas selecionadas não devem conter erros.

  • As ferramentas selecionadas não devem ser da categoria No Banco de Dados.

  • As ferramentas selecionadas não devem estar conectadas a nenhuma ferramenta Ação.

  • As ferramentas selecionadas não devem conter uma ferramenta Python.

  • As ferramentas selecionadas não devem incluir dados que sejam do tipo BLOB, dados espaciais ou de relatório.

Para converter para uma macro...

  1. Selecione pelo menos uma ferramenta em um fluxo de trabalho. Clique na tela do fluxo de trabalho e arraste para selecionar várias ferramentas.

  2. Clique com o botão direito do mouse em uma das ferramentas selecionadas para abrir o menu de ferramentas.

  3. Selecione Converter para macro no menu suspenso para abrir a janela Criar macro .

  4. Na janela "Criar Macro"...

    • Insira o Nome do arquivo para a macro.

    • Escolha um Local para salvar a macro.

    • Escolha um Ícone para a macro.

  5. Clique em OK para converter seu fluxo de trabalho ou uma parte dele em uma macro. Clique em Cancelar para abandonar esse processo.

  6. O arquivo de macro recém-criado é aberto em uma nova guia no Designer, enquanto o fluxo de trabalho original mostra que as ferramentas selecionadas foram convertidas em uma macro.

Salvar macro

Salve uma macro para uso e compartilhamento futuros. Salve macros com um nome exclusivo em um local específico. No Designer, você pode criar um repositório de macros mapeado para um local no computador ou na rede para salvá-las facilmente e usá-las em um fluxo de trabalho.

Para salvar uma macro...

  1. Selecione Arquivo > Salvar como .

  2. Localize uma pasta no computador ou na rede onde você salva as macros.

  3. Digite um nome exclusivo para a macro e selecione Salvar .

Para compartilhar fluxos que usam macros personalizadas, exporte o fluxo de trabalho para garantir que todas as dependências dele, incluindo a macro, sejam salvas junto com o fluxo. O fluxo de trabalho deve incluir um caminho relativo para a macro. Acesse Gerenciamento de fluxos de trabalho e Dependências do fluxo de trabalho para obter mais informações.

Atualizar macro ausente

Historicamente, quando um fluxo de trabalho com uma macro era importado ou aberto, se essa macro estava ausente nele (devido a uma alteração de nome, mudança de local, empacotamento incorreto etc.), ela apresentava um ícone de ponto de interrogação preto ( UnknownTool_71x71.png) na tela do fluxo de trabalho.

Você então tinha que passar por um processo difícil de adicioná-la novamente de forma manual e reconfigurar o fluxo de trabalho para que tudo funcionasse corretamente.

Agora, você tem a opção de identificar os locais corretos das macros antes que o fluxo de trabalho seja aberto e evitar completamente o erro de macro ausente!

Dica

Vá para Atualizar macros ausentes para obter detalhes adicionais e casos de uso.

Atualizar macros ausentes em fluxos de trabalho

Quando você tenta abrir um fluxo de trabalho (arquivo YXMD, YXMC ou YXWZ) com uma macro ausente, a janela pop-up Atualizar macros ausentes aparece no Designer para alertar sobre o problema.

update-missing-macros-1.png

A janela Atualizar macros ausentes  comunica que o fluxo de trabalho faz referência a pelo menos uma macro que está ausente ou inacessível. A mensagem fornece detalhes para essas macros. Observe que a janela lista um máximo de três macros ausentes (embora possa haver mais).

Você tem duas opções:

  • Atualizar : clique em Atualizar para atualizar os caminhos de arquivo para as macros ausentes. Isso abre o fluxo de trabalho original onde você pode fazer alterações. No entanto, o Designer não salva o fluxo de trabalho automaticamente. Depois de fazer as atualizações, você pode ir para Arquivo  > Salvar como ou usar o atalho de teclado Ctrl+S (Salvar) para salvar uma nova versão do fluxo de trabalho ou substituir o fluxo original, se necessário. Observe que é necessário ter acesso aos arquivos de macros ausentes e ser capaz de navegar até seus locais. Se você recebeu o fluxo de trabalho de alguém que não incluiu as macros, provavelmente será necessário entrar em contato e pedir que forneçam os arquivos. Se optar por não atualizar os caminhos de arquivo neste ponto, o fluxo de trabalho será aberto com os ícones de ferramenta ausente.

  • Fechar (não atualizar): clique em Fechar . Isso abre o fluxo de trabalho original sem as macros atualizadas. As macros apresentarão o ícone de ferramenta ausente ( UnknownTool_71x71.png). Se você quiser corrigir essas macros ausentes mais tarde, precisará adicionar as macros e reconfigurá-las manualmente.

Atualizar macro

Para atualizar as macros, siga estes passos:

  1. Na janela "Atualizar macros ausentes", clique em Atualizar .

  2. Isso abre a janela Atualizar macros ausentes , semelhante à janela "Dependências do fluxo de trabalho". Aqui, você pode editar o caminho de cada arquivo de macro ausente e atualizar seus locais. Observe que não é possível editar dependências que não são de macros por meio dessa janela.

    update-missing-macros-2.png
  3. Clique no ícone de lápis de edição associado a uma macro ausente. Isso abre o Explorador de Arquivos, onde você pode navegar até o local correto da macro. Ao selecionar a macro, o Designer atualiza o caminho dela e altera a cor do caminho para verde.

  4. Faça isso para quaisquer macros adicionais e clique em OK quando terminar. Você também pode selecionar Cancelar neste ponto, o que abre o fluxo de trabalho original com os caminhos de arquivo quebrados (ícones de ponto de interrogação indicando ferramentas ausentes).

  5. Se você atualizou os caminhos de macro e selecionou OK no passo anterior, o fluxo de trabalho será aberto com as macros atualizadas e sem os ícones de ferramentas ausentes.

Se a macro for a mesma e o número de conexões de entrada e saída dos novos caminhos de macro corresponder ao número no fluxo de trabalho, o Designer tentará fazer as conexões automaticamente. No entanto, em alguns casos (por exemplo, ao conectar uma macro diferente com o mesmo número de entradas e saídas) o Designer não é capaz de fazer as conexões. Se esse for o caso, você precisa revisá-las e configurá-las manualmente. 

Importante

Ao usar o recurso "Atualizar macros ausentes", o Designer atualiza o fluxo de trabalho original, porém, ele não é salvo automaticamente. Você pode ir para Arquivo > Salvar como ou usar o atalho de teclado Ctrl+S (Salvar) para salvar uma nova versão do fluxo de trabalho ou substituir o fluxo original, se necessário. Se você fechar o fluxo sem salvar, suas atualizações serão perdidas.

Fechar (não atualizar)

Se você quiser abrir o fluxo de trabalho e não atualizar as macros, siga estas etapas:

  1. Ao tentar abrir um fluxo de trabalho com macros ausentes, a janela Atualizar macros ausentes é exibida.

  2. Para abrir o fluxo de trabalho sem atualizar os locais das macros, clique em Fechar .

  3. O fluxo de trabalho é aberto e as macros ausentes exibem o ícone de ferramenta ausente ( UnknownTool_71x71.png). Se você quiser atualizar as macros ausentes, é preciso adicionar as macros e reconfigurá-las manualmente.

Criar repositório de macros

No Designer, você pode mapear para o local onde deseja salvar macros e criar um repositório para salvá-las facilmente e usá-las em um fluxo de trabalho. Qualquer arquivo de macro .yxmc no local selecionado é exibido na respectiva categoria na paleta de ferramentas.

Para criar um repositório de macros...

  1. Acesse Opções > Configurações de usuário > Editar configurações de usuário > Macros .

  2. Selecione o botão “+”.

  3. Em Nome da categoria , digite um nome. O nome padrão é "Macros".

  4. Selecione o botão “...” para navegar até o local onde você salva macros no seu computador ou em uma rede.

As subpastas em um caminho de pesquisa não podem ser adicionadas individualmente se sua pasta pai já existir no repositório de macros.

Para definir um local de repositório padrão...

  1. Selecione o caminho de pesquisa do repositório na lista.

  2. Clique em Definir como padrão . Um asterisco ( * ) é exibido ao lado do repositório padrão.

Usar macros em fluxos de trabalho

Para usar uma macro salva em seu repositório, localize-a na paleta de ferramentas ou utilize a barra de pesquisa.

Para usar uma macro que não esteja na paleta, clique com o botão direito do mouse na tela do fluxo de trabalho e selecione Inserir > Macro . Você pode selecionar qualquer macro que esteja atualmente aberta na tela a partir dessa lista ou navegar até o local de um arquivo de macro *.yxmc diferente.

Para usar uma versão de macro específica em seu fluxo de trabalho, clique com o botão direito do mouse na macro e selecione a versão que deseja executar. Todas as versões de macro devem ser armazenadas no mesmo diretório. Você pode configurar esse local em Configurações de usuário .

Para diferenciar uma macro de uma ferramenta comum em um fluxo de trabalho, marque a opção Exibir indicadores de macro em ferramentas em Configurações de usuário > Tela  para exibir o ícone + . Acesse Configurações de usuário para obter mais informações.

Para exibir o fluxo de trabalho de uma macro, clique com o botão direito do mouse na macro em um fluxo de trabalho e selecione Abrir macro . Uma macro em um fluxo de trabalho é atualizada automaticamente quando as alterações feitas na macro são salvas.

Para compartilhar fluxos que usam macros personalizadas, exporte o fluxo de trabalho para garantir que todas as dependências dele, incluindo a macro, sejam salvas junto com o fluxo. O fluxo de trabalho deve incluir um caminho relativo para a macro. Acesse Gerenciamento de fluxos de trabalho e Dependências do fluxo de trabalho para obter mais informações.

Modelos de macro

Se você reutiliza muitos componentes e configurações em suas macros, pode ser interessante criar modelos para economizar tempo. Vá para Modelos para saber como salvar sua macro como um modelo.

Macros de exemplo

Há macros que vêm incluídas no Designer para ajudar você a aprender a usar e criar macros. Para acessar as macros...

  • Em "Arquivos de programas" no seu computador, acesse \Arquivos de Programas\Alteryx\bin\RuntimeData\Macros .

  • No Designer...

    • Vá para Ajuda  > Exemplos de fluxos de trabalho  > Usar ferramentas de script e automação  > Criar uma macro .

    • Algumas ferramentas da paleta são macros. Por exemplo, a ferramenta Criar Amostras e a ferramenta Limpeza de Dados . Clique com o botão direito do mouse em uma ferramenta e selecione Abrir macro , se disponível, para visualizar o fluxo de trabalho da macro.

  • Acesse aplicativos publicados na Galeria da Comunidade Alteryx .