Skip to main content

Macro

Una macro è un flusso di lavoro o un gruppo di strumenti combinati in un unico strumento che può essere inserito in un altro flusso di lavoro. Crea una macro per salvare e automatizzare un processo analitico che esegui ripetutamente. Puoi utilizzare la macro all'interno di un flusso di lavoro senza dover ricreare ogni volta il processo analitico.

Salva una macro come file .yxmc da utilizzare in Designer o condividerla con altri utenti tramite la Galleria Community Alteryx o il Server aziendale.

Tipi di macro

  • Macro standard: questa macro è progettata per inserire un processo in un flusso di lavoro sotto forma di strumento integrabile.

  • Macro batch : questa macro viene eseguita più volte in un flusso di lavoro e crea un output dopo ogni esecuzione. La macro viene eseguita una volta per ogni record o gruppo di record selezionato nei dati. La macro richiede uno strumento Parametro di controllo come input.

  • Macro iterativa : questa macro viene eseguita nel flusso di lavoro il numero di volte impostato in fase di configurazione o continuativamente finché non viene soddisfatta una condizione.

  • Macro Location Optimizer : questa macro iterativa può essere utilizzata nell'analisi della rete per identificare una o più posizioni ottimali.

Creazione delle macro

Una macro è costituita da un flusso di lavoro e da un'interfaccia utente creata tramite gli appositi strumenti. Per ulteriori informazioni, consulta le sezioni Strumenti Interfaccia e finestra Interfaccia Designer . In alternativa, puoi creare un'interfaccia utente personalizzata utilizzando lo strumento HTML - Libreria GUI .

Per creare una macro...

Se utilizzi un flusso di lavoro esistente, seleziona la parte che desideri salvare come macro, quindi copiala e incollala in una nuova scheda del flusso di lavoro.

  1. Crea un nuovo flusso di lavoro o aprine uno esistente.

  2. Aggiungi un input macro:

    • Se il flusso di lavoro non contiene un input, aggiungi uno strumento Input macro.

    • Se il flusso di lavoro contiene uno strumento di input (ad esempio Dati di input o Input di testo), fai clic con il pulsante destro del mouse sullo strumento e seleziona Converti in Input macro .

  3. Configura lo strumento Input macro .

  4. Aggiungi e configura uno strumento Output macro .

Per impostazione predefinita, il tipo di flusso di lavoro cambia in Macro standard quando si aggiunge uno strumento Input macro a un flusso di lavoro. Quando aggiungi uno strumento Parametro di controllo al flusso di lavoro, Macro batch diventa il tipo di macro predefinito. Per creare una macro iterativa, imposta il tipo di macro su Iterativa.

Per impostare il tipo di macro:

  1. Seleziona l'area di disegno, quindi scegli la scheda Flusso di lavoro nella finestra Configurazione flusso di lavoro.

  2. In Tipo , accanto a Macro , seleziona un tipo di macro.

Conversione in macro

Oltre a creare una macro da zero, hai la possibilità di convertire un flusso di lavoro (o una parte dello stesso) in una macro. Prima di eseguire la conversione in una macro, rivedi i requisiti e le limitazioni di seguito:

  • Devi eseguire prima il flusso di lavoro e cercare ovunque siano disponibili i dati.

  • Devi salvare il flusso di lavoro prima di eseguire la conversione in una macro.

  • Gli strumenti selezionati devono trovarsi in un percorso continuo ed essere collegati tra loro (a eccezione di Commenti, Scatole di navigazione e Contenitori strumenti).

  • Gli strumenti selezionati non devono contenere errori.

  • Gli strumenti selezionati non devono contenere strumenti In-DB.

  • Gli strumenti selezionati non devono essere collegati a strumenti di azione.

  • Gli strumenti selezionati non devono contenere uno strumento Python.

  • Gli strumenti selezionati non devono includere dati che contengono dati di tipo spaziale, BLOB o Report.

Per eseguire la conversione in macro...

  1. Seleziona almeno uno strumento in un flusso di lavoro. Fai clic e trascina sull'area di disegno per selezionare più strumenti.

  2. Fai clic con il pulsante destro del mouse su uno degli strumenti selezionati per aprire il menu corrispondente.

  3. Seleziona Converti in macro nel menu a discesa per aprire la finestra Crea in macro .

  4. Nella finestra Crea macro...

    • Specifica un Nome file per la macro.

    • Scegli una Posizione in cui salvare la macro.

    • Scegli un' icona per la macro.

  5. Seleziona OK per convertire il flusso di lavoro o una parte dello stesso in una macro. Seleziona Annulla per abbandonare la procedura.

  6. Il nuovo file macro creato si apre in una nuova scheda in Designer, mentre il flusso di lavoro originale mostra che gli strumenti selezionati sono stati convertiti in una macro.

Salvataggio della macro

Puoi salvare una macro per utilizzarla e condividerla in futuro. Salva le macro con un nome unico in una posizione specifica. In Designer, puoi creare un repository delle macro mappato a una posizione sul computer o sulla rete per salvare facilmente le macro e utilizzarle in un flusso di lavoro.

Per salvare una macro...

  1. Seleziona File > Salva con nome .

  2. Individua la cartella in cui salvare le macro sul computer o sulla rete.

  3. Immetti un nome univoco per la macro e seleziona Salva .

Per condividere flussi di lavoro che utilizzano macro personalizzate, esporta il flusso di lavoro per garantire che vengano salvate anche tutte le relative dipendenze, inclusa la macro. Il flusso di lavoro deve includere un percorso relativo alla macro. Per ulteriori informazioni, consulta le sezioni Gestione del flusso di lavoro  e  Dipendenze del flusso di lavoro .

Aggiornamento della macro mancante

Di solito, quando dovevi importare o aprire un flusso di lavoro con una macro esistente, se la macro non era presente nel flusso di lavoro (a causa di una modifica del nome, un cambiamento di posizione, un impacchettamento errato, ecc.), la macro presentava un punto interrogativo ( UnknownTool_71x71.png) sull'area di disegno del flusso di lavoro.

Era quindi necessario eseguire una seccante procedura per riaggiungere manualmente la macro e riconfigurare il flusso di lavoro in modo che funzionasse correttamente.

Ora puoi identificare le posizioni corrette delle macro prima dell'apertura del flusso di lavoro ed evitare del tutto l'errore legato alla macro mancante!

Suggerimento

Per ulteriori dettagli e casi d'uso, consulta la sezione Aggiornamento delle macro mancanti .

Aggiornamento delle macro mancanti nel flusso di lavoro

Quando tenti di aprire un flusso di lavoro (file YXMD, YXMC o YXWZ) con una macro mancante, in Designer appare la finestra a comparsa Aggiorna macro mancanti per segnalare il problema.

update-missing-macros-1.png

La finestra Aggiorna macro mancanti comunica che il flusso di lavoro fa riferimento ad almeno una macro mancante o inaccessibile. Il messaggio fornisce dettagli su queste macro. Tieni presente che la finestra indica un massimo di 3 macro mancanti (anche se potrebbero mancarne altre).

Sono disponibili 2 opzioni:

  • Aggiorna : seleziona Aggiorna per aggiornare i percorsi dei file per le macro mancanti. Viene visualizzato il flusso di lavoro originale, in cui è possibile apportare modifiche. Tuttavia, Designer non salva automaticamente il flusso di lavoro. Dopo aver effettuato gli aggiornamenti, puoi selezionare File > Salva con nome o il tasto di scelta rapida Ctrl+S (Salva) per salvare una nuova versione del flusso di lavoro o sovrascrivere il flusso originale se necessario. È necessario poter accedere ai file delle macro mancanti e alle relative posizioni. Se il flusso di lavoro ti è stato inviato da un utente che non ha incluso le macro, è probabile che dovrai contattarlo e chiedergli di fornirti i file. Se scegli di non aggiornare i percorsi dei file qui, il flusso di lavoro si aprirà con le icone degli strumenti mancanti.

  • Chiudi (senza aggiornare): seleziona Chiudi . Viene visualizzato il flusso di lavoro originale senza le macro aggiornate. Le macro avranno l'icona dello strumento mancante ( UnknownTool_71x71.png) e se desideri risolvere il problema in un secondo momento, dovrai aggiungerle e riconfigurarle manualmente.

Aggiornamento delle macro

Per aggiornare le macro, attieniti alla seguente procedura:

  1. Nella finestra Aggiorna macro mancanti, seleziona Aggiorna .

  2. Viene visualizzata la finestra Aggiorna macro mancanti , simile a Dipendenze del flusso di lavoro. Qui puoi modificare il percorso del file di ogni macro mancante e aggiornarne la posizione. Non puoi modificare le dipendenze non macro tramite questa finestra.

    update-missing-macros-2.png
  3. Seleziona l'icona di modifica a forma di matita associata a una macro mancante. Viene visualizzato File Explorer, dove puoi selezionare la posizione corretta della macro. Una volta selezionata la macro, Designer aggiorna il relativo percorso e ne modifica il colore in verde.

  4. Esegui questa procedura per eventuali macro aggiuntive e seleziona OK al termine dell'operazione. A questo punto, puoi anche selezionare Annulla per aprire il flusso di lavoro originale con i percorsi dei file interrotti (icone di strumenti mancanti con i punti interrogativi).

  5. Se hai aggiornato i percorsi delle macro e hai selezionato OK nel passaggio precedente, il flusso di lavoro si aprirà con le macro aggiornate e non saranno presenti icone di strumenti mancanti.

Se la macro è la stessa e il numero di connessioni di input e output dai nuovi percorsi macro corrisponde a quello indicato nel flusso di lavoro, Designer tenta di stabilire le connessioni automaticamente. Tuttavia, in alcuni casi (ad esempio, se colleghi una macro diversa con lo stesso numero di input e output), Designer non è in grado di effettuare le connessioni. In questo caso, dovrai eseguire un controllo e una configurazione manuali. 

Importante

Quando utilizzi la funzionalità Aggiorna macro mancanti, Designer aggiorna il flusso di lavoro originale ma non lo salva automaticamente. Puoi selezionare File > Salva con nome o utilizzare la combinazione di tasti Ctrl+S (Salva) per salvare una nuova versione del flusso di lavoro o sovrascrivere il flusso originale se necessario. Se chiudi il flusso di lavoro senza salvare, gli aggiornamenti andranno persi.

Chiudi (senza aggiornare)

Se desideri aprire il flusso di lavoro e non aggiornare le macro, attieniti alla seguente procedura:

  1. Quando tenti di aprire un flusso di lavoro con macro mancanti, viene visualizzata la finestra Aggiorna macro mancanti .

  2. Per aprire il flusso di lavoro senza aggiornare le posizioni delle macro, seleziona Chiudi .

  3. Il flusso di lavoro si apre e le macro mancanti mostrano l'icona di strumento mancante ( UnknownTool_71x71.png). Se desideri aggiornare le macro mancanti, devi aggiungerle e riconfigurarle manualmente.

Creazione del repository delle macro

In Designer, puoi eseguire il mapping alla posizione scelta per salvare le macro e creare un repository per salvare facilmente le macro e utilizzarle in un flusso di lavoro. Qualsiasi file macro .yxmc nella posizione selezionata viene visualizzato nella categoria degli strumenti sulla tavolozza.

Per creare un repository delle macro...

  1. Seleziona  Opzioni  >  Impostazioni utente  >  Modifica impostazioni utente  >  Macro .

  2. Seleziona il pulsante "+".

  3. In Nome categoria , specifica un nome. Il nome predefinito è Macro.

  4. Seleziona il pulsante "..." per scegliere la posizione in cui salvare le macro sul computer o in rete.

Le sottocartelle in un percorso di ricerca non possono essere aggiunte singolarmente se la cartella superiore esiste già nel repository delle macro.

Per impostare una posizione predefinita per il repository...

  1. Seleziona il percorso di ricerca del repository nell'elenco.

  2. Seleziona Imposta come predefinito . Accanto al repository predefinito viene visualizzato un asterisco ( * ).

Uso della macro nel flusso di lavoro

Per utilizzare una macro salvata nel repository, individuala nella tavolozza degli strumenti o utilizza l'opzione Cerca.

Per utilizzare una macro che non si trova nella tavolozza degli strumenti, fai clic con il pulsante destro del mouse sull'area di disegno del flusso di lavoro e seleziona Inserisci > Macro . Da questo elenco puoi selezionare qualsiasi macro attualmente aperta sull'area di disegno oppure accedere alla posizione di un file macro *.yxmc diverso.

Per utilizzare una versione specifica della macro nel flusso di lavoro, fai clic con il pulsante destro del mouse sulla macro e seleziona la versione che desideri eseguire. Tutte le versioni della macro devono essere archiviate nella stessa directory. Puoi configurare questa posizione in Impostazioni utente .

Per differenziare una macro da uno strumento all'interno di un flusso di lavoro, seleziona l'opzione Mostra indicatori macro sugli strumenti per visualizzare l'icona + in Impostazioni utente > Area di disegno . Per ulteriori informazioni, consulta la sezione Impostazioni utente .

Per visualizzare il flusso di lavoro di una macro, fai clic con il pulsante destro del mouse sulla macro in un flusso di lavoro e seleziona Apri macro . Una macro in un flusso di lavoro viene aggiornata automaticamente quando vengono salvate le modifiche eseguite al suo interno.

Per condividere flussi di lavoro che utilizzano macro personalizzate, esporta il flusso di lavoro per garantire che vengano salvate anche tutte le relative dipendenze, inclusa la macro. Il flusso di lavoro deve includere un percorso relativo alla macro. Per ulteriori informazioni, consulta le sezioni Gestione del flusso di lavoro e Dipendenze del flusso di lavoro.

Modelli delle macro

Se ritieni di riutilizzare molti componenti e configurazioni nelle macro, puoi pensare di creare modelli per risparmiare tempo. Consulta la sezione Modelli per scoprire come salvare la macro come modello.

Macro di esempio

Le macro sono incluse in Designer per aiutati a imparare come crearle e utilizzarle. Per accedere alle macro...

  • Nella cartella Programmi sul computer, accedi a \Program Files\Alteryx\bin\RuntimeData\Macros .

  • In Designer...

    • Vai su Aiuto > Esempi flussi di lavoro > Usa strumenti di script e automazione > Crea una macro .

    • Alcuni strumenti della tavolozza sono macro. Ad esempio, lo strumento Campionatore e lo strumento Pulizia dei dati . Fai clic con il pulsante destro del mouse su uno strumento e seleziona Apri macro , se disponibile, per visualizzare il flusso di lavoro della macro.

  • Accedi alle app pubblicate nella Galleria Community Alteryx .