Skip to main content

Macros

Une macro est un workflow ou un groupe d'outils combiné dans un outil unique qui peut être inséré dans un autre workflow. Créez une macro pour enregistrer et automatiser un processus analytique que vous exécutez régulièrement. Utilisez la macro créée dans un workflow sans avoir à recréer à chaque fois le processus analytique.

Enregistrez une macro sous forme de fichier .yxmc pour l'utiliser dans Designer ou partagez-la avec d'autres utilisateurs via la Galerie de la communauté Alteryx ou le Server de votre entreprise.

Types de macros

  • Macro standard : cette macro permet d'inclure dans un package un processus d'un workflow en tant qu'outil afin de l'insérer dans un workflow.

  • Macro batch  : cette macro s'exécute à plusieurs reprises dans un workflow, créant un résultat après chaque exécution. La macro s'exécute une fois pour chaque enregistrement ou groupe d'enregistrements de données sélectionné. La macro exige un outil Paramètre de contrôle en tant qu’entrée.

  • Macro itérative  : cette macro s'exécute dans le workflow autant de fois que défini dans la configuration ou de façon continue jusqu'à ce qu'une condition soit satisfaite.

  • Macro Optimiseur d'emplacement  : cette macro est une macro itérative qui peut être utilisée dans l'analyse du réseau pour identifier un ou plusieurs emplacements optimaux.

Construire une macro

Une macro consiste en un workflow et une interface utilisateur créée à l’aide d’outils Interface. Pour plus d'informations, rendez-vous sur Outils Interface et Fenêtre Concepteur d'interface . Vous pouvez également créer une interface utilisateur personnalisée à l'aide de l' outil Bibliothèque GUI - HTML .

Pour construire une macro...

Si vous utilisez un workflow existant, sélectionnez la partie du workflow que vous voulez enregistrer en tant que macro, puis copiez-la et collez-la dans un nouvel onglet de workflow.

  1. Créez un nouveau workflow ou ouvrez un workflow existant.

  2. Ajouter une entrée de macro :

    • Si le workflow ne contient pas d'entrée, ajoutez un outil Entrée de macro.

    • Si le workflow contient un outil d'entrée (comme un outil Entrée de données ou Saisie de texte), cliquez avec le bouton droit de la souris sur l'outil, puis sélectionnez Convertir en Entrée de macro .

  3. Configurez l' outil Entrée de macro .

  4. Ajoutez et configurez un outil Sortie de macro .

Par défaut, le type de workflow devient Macro standard quand un outil Entrée de macro est ajouté dans un workflow. Le type de macro est renseigné par défaut par Macro batch lorsque vous ajoutez un outil Paramètre de contrôle au workflow. Pour créer une macro itérative, réglez le type de macro sur Itérative.

Pour définir le type de macro :

  1. Sélectionnez le canevas, puis cliquez sur l'onglet Workflow dans la fenêtre Configuration du workflow.

  2. Dans le champ Type , près de Macro , sélectionnez un type de macro.

Convertir en macro

En plus de créer une macro à partir de zéro, vous avez la possibilité de convertir un workflow existant en macro, dans sa totalité ou en partie. Avant de convertir une macro, vérifiez les exigences et limitations suivantes :

  • Vous devez d'abord exécuter le workflow et parcourir partout où les données sont disponibles.

  • Vous devez enregistrer le workflow avant de convertir en macro.

  • Les outils sélectionnés doivent se trouver dans un chemin continu et être connectés les uns aux autres (hormis les commentaires, navigateurs et conteneurs d'outils qui ne sont pas concernés).

  • Les outils sélectionnés ne doivent pas contenir d'erreurs.

  • Les outils sélectionnés ne doivent pas contenir d'outils BDD.

  • Les outils sélectionnés ne doivent pas être connectés à des outils Action.

  • Les outils sélectionnés ne doivent pas contenir un outil Python.

  • Les outils sélectionnés ne doivent pas inclure de données contenant des types de données spatiales, BLOB ou Rapport.

Pour convertir en macro...

  1. Sélectionnez au moins un outil dans un workflow. Cliquez sur le canevas du workflow et faites-le glisser pour sélectionner plusieurs outils.

  2. Cliquez avec le bouton droit de la souris sur l'un des outils sélectionnés pour ouvrir le menu des outils.

  3. Sélectionnez Convertir en macro dans la liste déroulante pour ouvrir la fenêtre Créer une macro .

  4. Dans la fenêtre Créer une macro…

    • Entrez un nom de fichier pour la macro.

    • Choisissez un emplacement où enregistrer la macro.

    • Choisissez une icône pour la macro.

  5. Sélectionnez Ok pour convertir votre workflow en macro, dans sa totalité ou en partie. Sélectionnez Annuler pour abandonner le processus.

  6. Le fichier de macro nouvellement créé s'ouvre dans un nouvel onglet de Designer et le workflow d'origine indique que les outils sélectionnés ont été convertis en macro.

Enregistrer la macro

Enregistrez une macro en vue de son utilisation et de son partage ultérieurs. Enregistrez les macros sous un nom unique à un emplacement spécifique. Dans Designer, vous pouvez créer un répertoire de macro associé à un emplacement sur votre ordinateur ou votre réseau afin d’y enregistrer facilement des macros et les utiliser dans un workflow.

Pour enregistrer une macro...

  1. Sélectionnez Fichier > Enregistrer sous .

  2. Identifiez le dossier dans lequel enregistrer les macros sur votre ordinateur ou votre réseau.

  3. Entrez le nom unique de la macro, puis sélectionnez Enregistrer .

Pour partager un workflow utilisant des macros personnalisées, exportez le workflow pour vous assurer que toutes ses dépendances, y compris la macro, sont enregistrées avec le workflow. Le workflow doit inclure le chemin relatif de la macro. Consultez les pages Gestion de workflow et Dépendances du workflow pour plus d'informations.

Mettre à jour une macro manquante

Dans le passé, lorsque vous importiez ou ouvriez un workflow avec une macro existante, si cette macro était absente du workflow (en raison d'un changement de nom, d'une modification d'emplacement, d'un package incorrect, etc.), la macro présentait une icône en forme de point d'interrogation noir ( UnknownTool_71x71.png) sur le canevas du workflow.

Vous deviez ensuite passer par un processus fastidieux afin de rajouter manuellement la macro et de reconfigurer le workflow pour que les choses fonctionnent correctement.

Vous avez désormais la possibilité d'identifier les emplacements de macro corrects avant l'ouverture du workflow et d'éviter l'erreur de macro manquante !

Astuce

Consultez la page Mettre à jour les macros manquantes pour plus d'informations et découvrir des cas d'usage.

Mettre à jour les macros manquantes dans les workflows

Lorsque vous tentez d'ouvrir un workflow (fichier YXMD, YXMC ou YXWZ) avec une macro manquante, une fenêtre contextuelle Mettre à jour les macros manquantes apparaît dans Designer pour vous avertir du problème.

update-missing-macros-1.png

La fenêtre Mettre à jour les macros manquantes indique que le workflow référence au moins une macro manquante ou inaccessible. Le message fournit des détails sur ces macros. Notez que la fenêtre répertorie un maximum de 3 macros manquantes (bien qu'il en manque peut-être davantage).

Vous avez 2 options :

  • Mettre à jour  : sélectionnez l'option Mettre à jour pour mettre à jour les chemins de fichiers des macros manquantes. Cela ouvre le workflow d'origine où vous pouvez apporter des modifications. Cependant, Designer n'enregistre pas automatiquement le workflow. Une fois les mises à jour effectuées, vous pouvez utiliser Fichier > Enregistrer sous ou le raccourci clavier Ctrl+S (Enregistrer) pour enregistrer une nouvelle version du workflow ou remplacer le workflow d'origine si nécessaire. Notez que vous devez accéder aux fichiers de macros manquantes et pouvoir naviguer jusqu'à leurs emplacements. Si vous avez reçu le workflow de quelqu'un qui n'a pas inclus les macros, vous devrez probablement le contacter et lui demander de vous fournir les fichiers. Si vous choisissez de ne pas mettre à jour les chemins de fichiers ici, le workflow s'ouvrira avec les icônes d'outils manquants.

  • Fermer (ne pas mettre à jour) : sélectionnez l'option Fermer . Cela ouvre le workflow d'origine sans les macros mises à jour. Les macros auront l'icône d'outil manquant ( UnknownTool_71x71.png) et, si vous souhaitez corriger ces macros manquantes ultérieurement, vous devrez ajouter les macros et les reconfigurer manuellement.

Mettre à jour la macro

Pour mettre à jour les macros, procédez comme suit :

  1. Dans la fenêtre Mettre à jour les macros manquantes, sélectionnez l'option Mettre à jour .

  2. Une fenêtre Mettre à jour les macros manquantes s'ouvre, similaire à l'expérience Dépendances du workflow. Ici, vous pouvez modifier le chemin de fichier de chaque macro manquante et mettre à jour son emplacement. Notez que vous ne pouvez pas modifier les dépendances non macro via cette fenêtre.

    update-missing-macros-2.png
  3. Sélectionnez l'icône de crayon de modification associée à une macro manquante. Cette opération ouvre l'explorateur de fichiers dans lequel vous pouvez naviguer jusqu'à l'emplacement correct de la macro. Sélectionnez la macro pour que Designer mette à jour le chemin de la macro et passe la couleur du chemin en vert.

  4. Effectuez cette opération pour les macros supplémentaires et sélectionnez OK lorsque vous avez terminé. Vous pouvez également sélectionner Annuler à ce stade, ce qui ouvre le workflow d'origine avec des chemins de fichiers rompus (icônes de point d'interrogation d'outil manquant).

  5. Si vous avez mis à jour les chemins de macro et sélectionné OK à l'étape précédente, votre workflow s'ouvre avec les macros mises à jour et aucune icône d'outil manquant.

Si la macro est la même et que le nombre de connexions d'entrée et de sortie des nouveaux chemins de macro correspond au nombre indiqué dans le workflow, Designer tente d'établir les connexions automatiquement. Cependant, dans certains cas (par exemple, si vous connectez une macro différente avec le même nombre d'entrées et de sorties), Designer n'est pas en mesure d'effectuer les connexions. Si c'est le cas, vous devez les vérifier et les configurer manuellement. 

Important

Lorsque vous utilisez la fonctionnalité Mettre à jour les macros manquantes, Designer met à jour le workflow d'origine, mais le workflow n'est pas automatiquement enregistré. Vous pouvez utiliser Fichier > Enregistrer sous ou le raccourci clavier Ctrl+S (Enregistrer) pour enregistrer une nouvelle version du workflow ou remplacer le workflow d'origine si nécessaire. Si vous fermez le workflow sans enregistrer, vos mises à jour seront perdues.

Fermer (ne pas mettre à jour)

Si vous souhaitez ouvrir le workflow sans mettre à jour les macros, procédez comme suit :

  1. Lorsque vous tentez d'ouvrir un workflow avec des macros manquantes, la fenêtre Mettre à jour les macros manquantes s'affiche.

  2. Pour ouvrir le workflow sans mettre à jour les emplacements des macros, sélectionnez l'option Fermer .

  3. Votre workflow s'ouvre et les macros manquantes affichent l'icône d'outil manquant ( UnknownTool_71x71.png). Si vous souhaitez mettre à jour les macros manquantes, vous devez ajouter les macros et les reconfigurer manuellement.

Créer un référentiel de macro

Dans Designer, vous pouvez associer l’emplacement où enregistrer les macros et créez un répertoire de macro afin d’y enregistrer facilement les macros et les utiliser dans un workflow. Tout fichier .yxmc de macro à l’emplacement sélectionné apparaît dans la catégorie de l’outil dans la palette d’outils.

Pour créer un référentiel de macro...

  1. Sélectionnez Options > Paramètres utilisateur > Modifier les paramètres utilisateur > Macros .

  2. Sélectionnez le bouton « + ».

  3. Dans Nom de catégorie , entrez un nom. Le nom par défaut est Macros.

  4. Sélectionnez le bouton « ... » pour accéder à l'emplacement où vous enregistrez les macros sur votre ordinateur ou sur un réseau.

Les sous-dossiers d'un chemin de recherche ne peuvent pas être ajoutés de manière individuelle si leur dossier parent existe déjà dans le référentiel de macros.

Pour définir un emplacement de référentiel par défaut...

  1. Sélectionnez le chemin de recherche du référentiel dans la liste.

  2. Sélectionnez Définir par défaut . Le référentiel par défaut est signalé par un astérisque ( * ).

Utiliser une macro dans un workflow

Pour utiliser une macro enregistrée dans votre répertoire de macro, recherchez la macro dans la palette d’outils ou utilisez l’option Rechercher.

Pour utiliser une macro qui n'apparaît pas dans la palette d'outils, cliquez avec le bouton droit de la souris sur le canevas du workflow, puis sélectionnez Insérer > Macro . Vous pouvez sélectionner n'importe quelle macro actuellement ouverte sur le canevas dans cette liste, ou accéder à l'emplacement du fichier *.yxmc d'une autre macro.

Pour utiliser une version de macro spécifique dans votre workflow, cliquez sur la macro avec le bouton droit de votre souris et sélectionnez la version que vous voulez exécuter. Les versions de macro doivent toutes être stockées dans le même répertoire. Vous pouvez configurer cet emplacement dans Paramètres utilisateur .

Pour distinguer une macro d'un outil dans un workflow, sélectionnez l'option Afficher les indicateurs de macro sur les outils pour afficher l'icône + dans Paramètres utilisateur > Canevas . Rendez-vous sur Paramètres utilisateur pour plus d'informations.

Pour afficher le workflow d'une macro, cliquez avec le bouton droit de la souris sur la macro dans un workflow, puis sélectionnez Ouvrir la macro . Une macro dans un workflow est automatiquement mise à jour lorsque les modifications apportées à cette macro sont enregistrées.

Pour partager un workflow utilisant des macros personnalisées, exportez le workflow pour vous assurer que toutes ses dépendances, y compris la macro, sont enregistrées avec le workflow. Le workflow doit inclure le chemin relatif de la macro. Consultez les pages Gestion de workflow et Dépendances du workflow pour plus d'informations.

Modèles de macros

Si vous réutilisez de nombreux composants et configurations dans vos macros, vous souhaiterez peut-être créer des modèles pour gagner du temps. Consultez la page Modèles pour savoir comment enregistrer votre macro en tant que modèle.

Échantillons de macros

Designer propose des macros qui vous aideront à apprendre leur création et leur utilisation. Pour accéder aux macros...

  • Dans Fichiers de programme de votre ordinateur, allez dans \Program Files\Alteryx\bin\RuntimeData\Macros .

  • Dans Designer...

    • Accédez à Aide > Exemples de workflows > Utiliser des outils de script et d'automatisation > Créer une macro .

    • Certains outils de la palette d’outils sont des macros. Par exemple, les outils Créer des échantillons et Nettoyage des données . Cliquez avec le bouton droit de la souris sur un outil, puis sélectionnez Ouvrir la macro , si cette option est disponible, pour afficher le workflow de macro.

  • Accédez aux applications publiées dans la Galerie de la communauté Alteryx .